www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Entladezeit LED


Autor: Tommy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen ich habe eine Frage. Bastel gerade etwas hier mit einem 
FPGA und ein paar LED's herum. Ich habe LED's ohne Vorwiderstand an 
einer Konstantstromquelle. Es kommt ab und an zu lustigen effekten. Da 
habe ich mir die Frage gestellt, wie lange ist eigentlich die 
Entladezeit einer LED?
Bzw. die Reaktionszeit.

lieben gruß und danke

: Verschoben durch Admin
Autor: Andreas K. (ergoproxy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich will dir nicht zu nahe treten aber die Antwort ist 42 falls dir das 
nicht reicht:

1. Schaltplan
2. Bauteilbezeichnungen (LEDs & KS-Quellen gibts wie Sand am Meer)
3. Layout / Leitungslängen
4. WELCHE lustigen Effekte meinst du?

Wenn du das zumindest eingrenzt müsste man da genaueres sagen können 
ansonnsten bleib es bei 42.

Gruß ErgoProxy

Autor: ymmoT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sau Schnell...

Autor: Reni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus nochmals,
naja ich bastel an einer led - matrix. und habe dort bei höheren 
Frequenzen ein überleuchten.

Daher denke ich das LEDs wohl eine kapazität und auch eine entlade zeit 
haben.

Kann dies sein? Wie gesagt ich habe keinen vorwiderstand. sodass der 
darin enthaltene strom nicht schnell genug verschwindet.

Autor: Flux Kompensator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde erstmal ein wenig die Grundlagen der Elektrik und Elektronik 
pauken, bevor ich mich an einen FPGA wage...

Autor: Reni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Flux Kompensator,

ich habe mir mal ein paar datenblätter reingezogen.
und es steht dort etwas von einer kapaziztät drin.
Diese liegt bei 50 pF würde also passen. t1 = 4 * 10 ^-8 (25 mhz) und 
die entlade zeit  beträgt 5  c  r  = 4.1 * 10 ^-8.

oder ist der ansatz nicht zu gebrauchen?

Beste grüße

Tommy R.

Autor: T. B. (bri)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem wird wohl nicht die LED sein, sondern der Transistor in 
Emitterschaltung in deiner Stromquelle.

Autor: Reni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo bri,

dass kann natürlich auch sein. Das werde ich morgenfrüh mal checken.

Danke

Autor: Heiko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich hab etwas ähnliches was ich nicht versteht.

Ich habe ein paar LEDs (siehe Anhang). Es soll immer nur eine LED 
leuchten. Bei geringen Verschiebungs-geschwindigkeiten klappt alles 
super. Aber sobald ich die Geschwindigkeit hochsetze sieht es so aus als 
ob zwei leds leuchten würden. Hat jemand ein solches Problem gehabt und 
beseitigt?

Autor: Heiko (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier auch mal der Anhang -.-

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heiko schrieb:
> Aber sobald ich die Geschwindigkeit hochsetze sieht es so aus als
> ob zwei leds leuchten würden.

Traegheit des Menschlichen Auges ?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sieht es so aus als ob zwei leds leuchten würden.
Ist es tatsächlich so, oder sieht es nur so aus?   ;-)

> sieht es so aus als ob zwei leds leuchten würden.
Welche 2 Leds? Immer benachbarte?
Auf welchem IC? Auf allen 3?

Autor: Route_66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@helmil
> Traegheit des Menschlichen Auges ?

Genau!

>sobald ich die Geschwindigkeit hochsetze sieht es so aus als
>ob zwei leds leuchten würden.

Wenn Du schnell genug wirst, leuchten sogar (scheinbar) ALLE!

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sieht es so aus als ob zwei leds leuchten würden.
Welchen Wert gibst du da aus? Einen konstanten?

> Aber sobald ich die Geschwindigkeit hochsetze...
Wie hoch?

Autor: Heiko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

also Trägheit des Auges, denke ich nicht.

Ich habe immer nur eine LED an, eine art Lauflicht. Es sieht wirklich 
nur so aus. Das Osca.-Bild zeigt eine Perfekte Durchschaltung.

Der Punkt läuft vier mal pro. Sekunde durch das Bild.

Und es ist immer der Punkt neben an, also der zuletzt an war.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Da habe ich mir die Frage gestellt, wie lange ist eigentlich die
> Entladezeit einer LED?
Das Licht der Led ist ein paar Nanosekunden nach Abschalten des Stromes 
aus. Mit LEDs werden ja auch schnelle digitale Signale (z.B. in 
Optokopplern, Fernbedienungen und optischen Sendern) übertragen.

> ... also Trägheit des Auges, denke ich nicht.
> Es sieht wirklich nur so aus.
Wenn es nur so aussieht, aber immer nur 1 LED leuchtet, dann muß es ja 
am Auge liegen :-o
Rechnen wir mal nach:
11 LEDs hintereinander, 4 mal pro Sekunde angesteuert ergibt eine 
Frequenz von 44 Hz. Das menschliche Auge kann maximal ca. 20 Hz. Du hast 
die doppelte Frequenz, also mußt du immer 2 LEDs sehen.

Zum Test: Nimm doch einfach mal eine Kamera und mach ein Bild vom 
Lauflicht. Wieviele LEDs leuchten? Achtung: Belichtungszeit sehr kurz 
halten (<< 1/200 sec)!

Autor: Heiko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Lothar,

ich denke ich habe mich etwas undeutlich ausgedrückt.

Die LED's werden mit einer Freq. von mehr als 1 Mhz angesteuert.

Wenn der Punkt aber 4 mal pro. sek. durch die Matrix läuft, habe ich 
eine "Bewegungsfrequenz" von 4Hz.

Was mich wundert, kommt GENAU JETZT:

Wenn ich einmal alle Register bespiele und dann um eines Verschiebe, 
sehe ich einen Punkt.

Wenn ich die Register 2 mal (und mehr) bespiele, dann sieht es so aus 
als seien zwei punkte an.

Ich besorge mir mal ne Cam und zeichne dass auf.

Desweiteren, wenn ich die Verschiebungsfrequenz auf 6 oder 10 mal pro 
sek. setze, sehe ich trotzdem nur 2 Punkte.

Schon seltsam oder?

Autor: matrix-men (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Hinweis mit den Transistoren ist schon der Richtige..., den gleichen 
Effekt hatte ich auch mal in einer LED-Matrix.

Deshalb sollte man, bevor man die nächste LED anschaltet, die 
vorhergehende LED explizit ausschalten (Betonung liegt auf explizit!).

Autor: Heiko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo matrix-men,

ich mache jetzt 1 mal eine led (in der kette) an und 5 alles LEDs aus.

NÜX... selber Effekt.

Autor: matrix-men (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
in welcher Reihenfolge/Programmierschritt? So bin ich zum Erfolg 
gekommen:

1.wirklich alles ausschalten
2.nächste LED anschalten
3.weiter mit 1.

und wirklich als Einzelschritte!

Und wenn es Schieberegister sind, wirklich erst den "Auszustand" 
reinschieben/durchschalten und dann erst wieder das nächste Bitmuster.

Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tipp: Schieberegister über den Enable "abschalten", dann schieben, 
latchen und wie enablen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.