www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Stepdown kann Nokia nicht laden? warum?


Autor: Heinz O. (styx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle!

Ich hab ein Problem mit dem "MC34063".
Ich benutze dieses Bauteil als Stepdown (siehe Anhang) und will damit 
mein Nokiahandy laden, aber das handy sagt nur, dass der Akku nicht 
geladen wird. Dabei hab ich doch eh die Spannung auf 5 Volt eingestellt 
und es kommen auch 5 Volt raus, auch den Strom hab ich auf 700mA 
begrenzt, aber das Handy will einfach nicht.

Wenn ich das selbe Handy aber über mein Netzgerät speisen will (mit den 
selben Spannungs- und Stromwerten) funktionierts, habt ihr eine Ahnung 
warum das mit dem Stepdown nicht geht.

Danke im Vorhinein

lg styx

: Verschoben durch Admin
Autor: hvwehb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vermutlich, weil das Nokia-Netzteil dem Handy was erzaehlt.

Gast

Autor: Tajas R. (tony)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nö, also die Nokia-Netzteile die ich kenne reden nicht. Die spannen nur 
^^ Bei dem bei mir vorhandenen sind allerdings 3,7V und 350mA 
gefordert...

Autor: Heinz O. (styx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tajas R. schrieb:
> Nö, also die Nokia-Netzteile die ich kenne reden nicht. Die spannen nur
> ^^ Bei dem bei mir vorhandenen sind allerdings 3,7V und 350mA
> gefordert...

Da geb ich dir recht, es hat ja schließlich auch mit einen stinknormalen 
Labornetzteil funktioniert.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,
wie hast du das mit den 5V Ausgangsspannung denn gemessen? Unter Last, 
mit einem Oszi? ich könnt mir vorstellen das du da noch ziemlich heftige 
Störungen drauf hast. Mach da eventuell mal noch den ein oder anderen 
kleinen Kondensator dran.
Und warum hast du überhaupt einen Schaltregler benutzt? ist deine 
Eingangsspannung so hoch? Wenn ja, würd ich empfehlen zwei regler zu 
benutzen; einen schaltregler von ??V auf 7-8V und dann mit einem 
Linearregler auf 5V. Verbraucher direkt an einen Schaltregler hängen ist 
immer riskant, bzw ich hab damit schlechte erfahrungen gemacht...

Grüße Basti

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Nokias scheinen da in der Tat etwas pingelig zu sein.

Die Spannung ist zwar recht egal, alles zwischen 3,7V und xx V 
(angeblich 32V bei den Neueren... ich tests nicht) wird direkt als 
Ladespannung akzeptiert, aber die Spannung muss konstant bleiben.

Das Nokia misst scheinbar wieweit die Spannung bei Belastung einbricht, 
und wenn das zuviel ist => "Läd nicht"

Autor: spice (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

ich meine, dass ich das damals mit einem niederohmigen serienwiderstand 
in der ladeleitung bewerkstelligt bekommen hab. Versuch mal so um die 
100ohm...
gruß spice

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In dem mit vorliegenden Nokia-Netzteil ist eine Strombegrenzung drinnen. 
Vielleicht fahren die Handys zumindest probeweise eine Lastkurve durch. 
Vielleicht um dem Akku zu schützen, vielleicht auch um gefakete oder 
defekte Netzteile zu erkennen und die Ladung zu verhindern. Prinzipiell 
sind es aber Spannungsquellen. Gemessen habe ich das Verhalten nicht.

Die 5V-Varianten liegen zumindest im Leerlauf auch etwas über 5V! (Ws 
für ein Schaltnetzteil völlig normal ist, die brauchen alle eine 
Mindestlast)

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
5V ist OK. Probiere wirklich mal ein Serienwiderstand. Aber nicht 100 
Ohm, sondern eher 0,47 bis 2 Ohm. Bei Überstrom schalten Nokia Handys 
sehr schnell ab. Bist du sicher dass das Netzteil nicht mehr wie 700mA 
bringt? Versuchs mal mit 500mA.

Autor: ... ... (docean) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
guck mal ins Datenblatt da sind Ausgangsfilter vorgeschlagen

C2 macht im Layout nix (jedenfalls nicht viel), der Strom wird einen 
Teufel tun den Umweg zu laufen...

Autor: Heinz O. (styx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Also erst mal danke für eure tollen Ideen und raschen Antworten, ich 
werd mal ein bisschen herumbasteln und euch dann Bericht erstatten obs 
funktioniert.

MFG Michi

Autor: Heinz O. (styx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias schrieb:
> 5V ist OK. Probiere wirklich mal ein Serienwiderstand. Aber nicht 100
> Ohm, sondern eher 0,47 bis 2 Ohm. Bei Überstrom schalten Nokia Handys
> sehr schnell ab. Bist du sicher dass das Netzteil nicht mehr wie 700mA
> bringt? Versuchs mal mit 500mA.

Also ja ich bin mir sicher, und das Handy sollt sich mit dem Strom auch 
wohl fühlen, das Originalladegerät ladet schließlich auch mit 800mA.


So ich hab jzt einiges ausprobiert, also Serienwiderstand (hab 0,22 Ohm 
genommen weil ich den gerade herumliegen hatte) hat nicht funktioniert.
Auch ein zusätzlicher Kondensator hat nichts gebracht... und Oszi hab 
ich leider keins damit ich mir die Spannung vom Schaltregler genauer 
anschauen kann, aber das Nokialadegerät ist doch auch ein Schaltregler 
warum funktionierts mit dem und mit meinem nicht?

mfg Michael

Autor: H. Triti (triti)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Ich hab gerade ein Ladegerät für ein Nokia gebastelt. Eingang: 13.8V, 
Serienwiderstand 30R/>2W, 7805+1N4007 auf Masse --> Volt: 5,6.
Funktioniert 1A. Begrenz mal deinen Ladestrom auf 250-350(400)mA, dann 
sollte es...
lg
Triti

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0,22 Ohm ist doch völlig unrealistisch! Messe mal allein den 
Kabelwiderstand. Du mußt noch viel lernen.

Autor: Michi s. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Abdul K. schrieb:
> 0,22 Ohm ist doch völlig unrealistisch! Messe mal allein den
> Kabelwiderstand. Du mußt noch viel lernen.

Vielen Dank für deinen unnötigen Komentar.


An alle anderen, es funktioniert jetzt, das Handy hat einfach 5,3 Volt 
gebraucht... und mein Schaltregler hat ca. 5,1 erzeugt.

Also noch mals danke für eure Hilfe.

Mfg Michi

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> das Handy hat einfach 5,3 Volt gebraucht...
> und mein Schaltregler hat ca. 5,1 erzeugt.
Ich tippe mal eher, dein Schaltregler erzeugt soviel Ripple, dass das 
Handy etwas ins Kotzen gekommen ist. Denn das Layout für die Ladephase 
der Spule ist extrem suboptimal...
Zeichne dir mal in dein Layout die Strompfade für die Freilaufphase 
(rot, recht kompakt) und die Ladephase (gelb A bzw. weiß B) ein. Die 
beiden letzeren (eigentlich sollte das nur 1 schön definierter sein) 
sind unterirdisch :-/
Auch die Anbindung des Feedbackspannungsteilers ist ungeschickt.

> das Handy hat einfach 5,3 Volt gebraucht...
Du hast vermutlich Störungen auf der Ausgangsspannung und das Handy 
kommt erst ab einer höheren Mindestspannung damit klar.

Auch wenn du ein anderes IC hast, sieh dir als Grundlage mal das an:
http://www.lothar-miller.de/s9y/categories/40-Layo...

Autor: nokian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nicht raten - spec lesen!:
Tolle Spec...
4.65 V – 5.20 V is identified as a special charger 
and 5.5 V – 9.3 V is identified as a standard charger
Und das bei erlaubten 800mVpp Ripple :-o

>>> 0,22 Ohm ist doch völlig unrealistisch!
>>> Messe mal allein den Kabelwiderstand. Du mußt noch viel lernen.
Dazu die Spec:
Ground lead resistance with contacts   max. 0.05 Ω

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
>> Nicht raten - spec lesen!:
> Tolle Spec...

Immerhin, man fand eine. Hätte ich nicht erwartet.


>
> 4.65 V – 5.20 V is identified as a special charger
> and 5.5 V – 9.3 V is identified as a standard charger
> 
> Und das bei erlaubten 800mVpp Ripple :-o

Also auf dem ACP-8E original Nokia steht: 5.3V 500mA


>
>>>> 0,22 Ohm ist doch völlig unrealistisch!
>>>> Messe mal allein den Kabelwiderstand. Du mußt noch viel lernen.
> Dazu die Spec:
>
> Ground lead resistance with contacts   max. 0.05 Ω
> 

Das Anschlukabel ist hauchdünn. Wenn denn ein künstlicher Widerstand als 
Stromquellensimulation eingebaut wäre, hätte ich den schon Faktor 10 
größer als den Kabelwiderstand gemacht. Daher meine Annahme (ins Blaue).

Autor: Michi s. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Auch wenn du ein anderes IC hast, sieh dir als Grundlage mal das an:
> http://www.lothar-miller.de/s9y/categories/40-Layo...

Also das Layout wäre doch auch mit ein paar kleinen Änderungen einseitig 
gegangen...

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also das Layout wäre doch auch mit ein paar kleinen Änderungen einseitig
> gegangen...
Vielleicht schon, aber ich mache solche Sachen schon lange nicht mehr 
einseitig, weil einseitig und SMD einfach nicht kompatibel sind.

Und zudem wären dann die schönen Stromschleifen wieder versaut worden... 
:-/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.