www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Schaltnetzteil stört


Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi zusammen!

Ich habe einen Audio-Recorder mit einem ISD1016 (uralt, ich weiß) 
aufgebaut. Zwischen Ausgang und Lautsprecher hängt noch ein 
Verstärker-IC TDA2822 (uralt, ich weiß).

Betrieben wird das Ganze aus einem Steckernetzteil (Schaltnetzteil, war 
mal zum laden eines Handys). Das Netzteil ist über ein ca 1,5m langes 
Kabel mit der (Lochraster-)Platine verbunden und geht nochmal in einen 
1000uF- und 100nF-Kondensator zum sieben und dann ohne weiteren Filter 
direkt zu den ICs.

Nehme ich Ton auf, brummt die Wiedergabe (irgendwo untere Frequenz, 
nichts Hochfrequentes). Bei Betrieb aus einem Labornetzteil ist der Ton 
gut. Es liegt auch nur an der Aufnahme und nicht an der Wiedergabe durch 
den Verstärker.

Beobachtung: Klemme ich die Masse der Schaltung auf die Erde der 
Steckdose, ist das Brummen weg. Das habe ich von ganz alleine 
rausgefunden, indem ich die Spannung mit dem Oszi gemessen habe.

Das Brummen ist nun Ursache von? Und das Anklemmen der Masse an die Erde 
bewirkt was? Und was tu ich dauerhaft dagegen?

Danke für eure Hilfe!
Daniel

: Verschoben durch Moderator
Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel schrieb:
> Und was tu ich dauerhaft dagegen?

Die Schaltungsmasse an Erde klemmen vielleicht?

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Schaltungsmasse an Erde klemmen vielleicht?

Ich hab aber keine Erde in dem Gehäuse. Da gehen NUR die zwei 
spannungsführenden Adern des Schaltnetzteils rein.

Ist das außerdem nicht ziemlicher Pfusch? Einfach irgendwas auf Erde 
klemmen, nur damit's klappt ohne zu wissen, was ich eigentlich mache? 
Hört sich so nach türkischem Workaround an...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel schrieb:

> Ich hab aber keine Erde in dem Gehäuse. Da gehen NUR die zwei
> spannungsführenden Adern des Schaltnetzteils rein.

Fehldesign. ;-)

Dann musst du halt einen Netzteil suchen, der die Masse der
Ausgangsseite selbst auf Erde klemmt.

> Ist das außerdem nicht ziemlicher Pfusch? Einfach irgendwas auf Erde
> klemmen, nur damit's klappt ohne zu wissen, was ich eigentlich mache?

Der Schaltnetzteil ist "frei schwebend", damit nimmt er irgendein
Potenzial gegen Erde ein, und du koppelst dir (vermutlich kapazitiv)
einen Teil der Netzspannung als Brummspannung auf die Schaltungsmasse.
Wenn du Pech hast, hat er noch zwei (kleine) Entstörkondensatoren im
Eingangsbereich, deren Mittelpunkt (an dem hochohmig 110 V ~ gegen
Erde liegen) an der Masse der Ausgangsseite klemmt.  Das Teil war
halt nicht als Universalnetzteil für x-beliebige Geräte konzipiert.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel schrieb:
> Einfach irgendwas auf Erde
>
> klemmen, nur damit's klappt ohne zu wissen, was ich eigentlich mache?

wieso, Du weißt doch EXAKT was Du machst: Schaltungsmasse mit PE 
verklemmen .-)


so what....

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat übrigens nichts mit irgendwelchen HF-Störungen zu tun, daher
schiebe ich das mal ins Analogforum.

Autor: Daniel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Hat übrigens nichts mit irgendwelchen HF-Störungen zu tun, daher
> schiebe ich das mal ins Analogforum.

Auch recht, du bist der Boss, Boss ;-) Dacht nur: Felder, da passts. Im 
nachhinein betrachet...

Zum Thema:
Aber wo soll denn die Erde auch herkommen? Das Steckernetzteil selbst 
ist doch in einem schutzisoliertem Gehäuse. An dem Eurostecker sind gar 
keine Erdungsbügel dran.

Heißt im Klartext: Keine Chance außer anderes Netzteil nehmen? Oder mit 
größerem Aufwand: Notchfilter basteln und die 50Hz filtern? Oder mit ner 
LC-Kombination die entsprechende Frequenz dämpfen?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Heißt im Klartext: Keine Chance außer anderes Netzteil nehmen?
Ich habe diesen Schaltnetzteilstöreffekt auch schon gehabt (bei einem 
Boss BR-600) und den dann so umgangen, dass ich jetzt ein "normales" 
Trafo-Steckernetzteil verwende...   :-o

Autor: Besserwisser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht nach einer Common-Mode Störung aus.
würde mal einen Ferrit auf das Niederspannungskabel klemmen oder
die Leitung ein paar mal um einen Ferrit-Ringkern schlingen.
Vielleicht hilfts.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Experiment mit Filtern ist schade um die Zeit.

Ursache des Übels könnte wie oben schon zu lesen, die Entstörkombination 
sein, auf die Du beim Schaltnetzteil nicht verzichten kannst.
http://de.wikipedia.org/wiki/Entst%C3%B6rkondensator

Nimm z.B. ein Netzteil mit Schukostecker oder erde Dein Gerät.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daniel schrieb:
> Heißt im Klartext: Keine Chance außer anderes Netzteil nehmen?

Wenn du weißt, was du tust (und du es ordentlich machst), kannst
du natürlich das bestehende Netzteil in ein anderes Gehäuse klemmen,
bei dem du PE dann ordentlich mit anklemmst.

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Besserwisser schrieb:
> würde mal einen Ferrit auf das Niederspannungskabel klemmen oder
> die Leitung ein paar mal um einen Ferrit-Ringkern schlingen.

...bei einer 50/100Hz Störung??  LOL!

Lies mal ein Datenblatt über Ferrithülsen (z.B. bei Würth - 
http://katalog.we-online.de/kataloge/eisos/index.p...) 
und sieh' Dir die dort angegebenen Impedanzverläufe an. Achte dabei 
besonders bei welchen Frequenzen die Angaben überhaupt beginnen.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@BESSERWISSER
Dein Ferrit bei 50 Hz ist so wirksam wie Hustensaft gegen 
Rückenschmerzen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.