www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT232RL - Schaltungsprobleme?


Autor: Philipp H. (tdk29)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe mit der oben genannten Schaltung ein Problem.
Ein Schaltung mit dem FT232R hat bereits funktioniert, bei dieser 
Schaltung, mit dem FT232RL (gibts da überhaupt einen nennenswerten 
unterschied? die Datenblätter sehen ziemlich gleich aus) funktioniert 
nichts. Windows 7 meldet Code 43 bei der Geräteerkennung (Gerät wurde 
wegen eines Fehlers angehalten o.ä.) - keine Vendor ID etc.
Könnte vllt einer mal über den Schaltplan drüber schaun?
Der Pic und der IC wurde zu den Testzwecken nicht angelötet.

Danke schon mal

Mit freundlichen Grüßen

Autor: dummy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh man, der PIC kann doch USB. Wozu der FT232?
Naja, was solls;) DP,DM vertauscht?
Irgendeine Leitung vergessen oder Kurzschluß?

Autor: M. W. (hobbyloet)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reset vom RL an +5V, was soll das?.

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
M. W. schrieb:
> Reset vom RL an +5V, was soll das?.

Active low reset pin. This can be used by an external device to reset 
the FT232R. If not required can be left unconnected, or pulled up to 
VCC.

Autor: M. W. (hobbyloet)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das meine ich ja, das ist schonmal ein Fehler!
Entweder mit Pullup oder garnicht.

Autor: Sönke O. (soenio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach mal ein Bild. Wenn wirklich nur bis jetzt der FT232RL, L1, L2, R2, 
R3, C4 und X1 angeschlossen sind sollte es theoretisch gehen. Reset 
wurde schon gesagt, denke aber nicht das das der Grund ist. 
USB-Anschluss korrekt? Nachgemessen? Sind die Widerstände ausreichend 
dimensioniert? Liegt die Spannung zwischen 4 und 5,25V auch direkt am IC 
an? Mal an einem anderen PC probiert? Allgemein sind sehr wenige 
Entstörmaßnahmen vorhanden. Foto vom aufbau? Was zeigen die LEDs beim 
anstecken an den PC an? Strom(verbrauch) mal gemessen? Wird der IC warm?

Kenn mich zwar mit PIC's nicht aus aber glaube auch dort müssen 
Abblockkondensatoren an den µC...
SDA und SCl brauchen glaube ich ein PullUp, wenn nicht extern vorhanden. 
Noch ein Tipp: niemals durch Bauteile durchzeichnen!

Schönen Abend noch.

Autor: M. W. (hobbyloet)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dummy schrieb:
> Oh man, der PIC kann doch USB. Wozu der FT232?

Genau!
Siehe hier:
http://www.datasheetcatalog.com/datasheets_pdf/P/I...

Autor: Philipp H. (tdk29)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sönke O. schrieb:
> Mach mal ein Bild. Wenn wirklich nur bis jetzt der FT232RL, L1, L2, R2,
> R3, C4 und X1 angeschlossen sind sollte es theoretisch gehen. Reset
> wurde schon gesagt, denke aber nicht das das der Grund ist.
> USB-Anschluss korrekt? Nachgemessen? Sind die Widerstände ausreichend
> dimensioniert? Liegt die Spannung zwischen 4 und 5,25V auch direkt am IC
> an? Mal an einem anderen PC probiert? Allgemein sind sehr wenige
> Entstörmaßnahmen vorhanden. Foto vom aufbau? Was zeigen die LEDs beim
> anstecken an den PC an? Strom(verbrauch) mal gemessen? Wird der IC warm?
>
> Kenn mich zwar mit PIC's nicht aus aber glaube auch dort müssen
> Abblockkondensatoren an den µC...
> SDA und SCl brauchen glaube ich ein PullUp, wenn nicht extern vorhanden.
> Noch ein Tipp: niemals durch Bauteile durchzeichnen!
>
> Schönen Abend noch.

Alle Passiven Bauteile sind korrekt angeschlossen.
USB Anschluss wurde 2 mal kontrolliert - nachgemessen und an 
verschiedenen PC's mit verschiedenen Betriebssystemem getestet.
Weder die RX noch die TX Led leuchten beim einstecken. Jedoch liegt an 
#PWEN eine Spannung von 5V an. Laut Datenblatt wäre der IC somit im 
Suspend Mode. dies kann ich aber nicht verstehen da der IC eigentlich 
dauernd Verbindungen aufbaut.
"Output is low after the device has been configured
by USB, then high during USB suspend mode." Die Data+ Leitung vom IC 
liegt gemessen auf +3,3V.

Über die Abblockkondensatoren werde ich mich mal informieren. Genauso 
wie über den Pull Up - wobei es auch ohne Funktioniert - zumindest bei 
dem Testboard.

M. W. schrieb:
> dummy schrieb:
>> Oh man, der PIC kann doch USB. Wozu der FT232?
> Genau#1
> Siehe hier:
> http://www.datasheetcatalog.com/datasheets_pdf/P/I...

Aufgabenstellung war anders. Ich sollte diesen IC verwenden.

M. W. schrieb:
> Das meine ich ja, das ist schonmal ein Fehler!
> Entweder mit Pullup oder garnicht.

Werd ich im nächsten Layout ändern.

mfg

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp H. schrieb:
>
> ich habe mit der oben genannten Schaltung ein Problem.
> Ein Schaltung mit dem FT232R hat bereits funktioniert, bei dieser
> Schaltung, mit dem FT232RL (gibts da überhaupt einen nennenswerten
> unterschied? die Datenblätter sehen ziemlich gleich aus)

FT232R ist der 'Überbegriff' für die beiden Gehäusevarianten FT232RL und 
FT232RQ, mehr nicht

> Könnte vllt einer mal über den Schaltplan drüber schaun?

> Über die Abblockkondensatoren werde ich mich mal informieren. Genauso
> wie über den Pull Up - wobei es auch ohne Funktioniert - zumindest bei
> dem Testboard.

wo sind denn die Stütz/Blockkondesatoren vom FT232? Oder die 
Ferritperle? Oder der C am USB-Port?

Autor: Thilo M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In die Datenleitungen Plus und Minus vom FT232 zur USB-Buchse sollten 27 
Ohm - Widerstände 'rein.
Den 6MHz-Quarz vermisse ich auch, läuft der auch ohne?
 ;-)

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thilo M. schrieb:
> In die Datenleitungen Plus und Minus vom FT232 zur USB-Buchse sollten 27
> Ohm - Widerstände 'rein.

Unnoetig.

> Den 6MHz-Quarz vermisse ich auch, läuft der auch ohne?
>  ;-)

Braucht man ebenfalls nicht.

Autor: maxi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum funktioniert die gleiche Schaltung nicht mit dem FT232RL, aber mit 
dem FT232R schon?
Kann es sein, dass der eine FT232 die Paralelle Version ist und der 
FT232R nur seriell ?

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Warum funktioniert die gleiche Schaltung nicht mit dem FT232RL, aber mit
> dem FT232R schon?
> Kann es sein, dass der eine FT232 die Paralelle Version ist und der
> FT232R nur seriell ?
FT232RL = Seriell, SSOP-Gehäuse
FT232RQ = Seriell, QFN-Gehäuse
FT245RL = Parallel, SSOP-Gehäuse
FT245RQ = Parallel, QFN-Gehäuse

Raschelt es nun? :)
Wie kommst du auf "mit FT232R gehts, mit RL nicht" ?

Ralf

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.