www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 74 HC 595 Defekt feststellen?


Autor: groca (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
habe ein Problem mit einem Multieffektgerät "VoxToneLab SE". Die LED´s
sind alle AUS und werden normalerweise über Fußtaster EIN/AUS 
geschaltet.
Die Bänke-LED (LED15) sowie Tuner-LED sind alle AUS.
Auf dem Schaltplan sind drei 74HC595 zu erkennen. Ist es möglich mit 
einem Strommessgerät einen Defekt des 74HC595 zu messen bzw.feststellen?
Bei einem 74HC595 ist (IC4 im Schaltplan KOD-A30583)der Pin QA bis QE 
ohne Spannung? Bei dem daneben liegenden IC5- 74HC595 steht an QA bis QH 
5V an. Oder der Quarz für die Frequenz defekt?

Bin leider kein Elekroniker.....

Bitte um Hife!!!

Autor: Anja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wie kommst du denn auf die Idee daß die HC595 defekt sind?
Die Wahrscheinlichkeit ist viel höher daß der Defekt entweder im 
Netzteil ist oder daß die Reset-Leitung dauernd aktiv ist.

Gruß Anja

Autor: ichhhhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum sollten genau diese Schieberegister defekt sein? Mess mal die 
Pegel an den eingängen und vergleiche im Datenblatt ob das passt was 
reinkommt und rausgeht

Autor: cargro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
das mit dem dem Reset kann auch gut möglich sein. Die Idee mit dem
Schieberegister ist durchdas Messen Q1-Q8 entstanden.War einfach nur 
eine Vermutung.Wie kann ich das mit dem Reset den testen?
Komischerweise sind heute einige LED´s AN jedoch wenn ein Fusstaster 
gedrückt
wird gehen einige wieder aus. Die Bänke für die gespeicherten 
Einstellugen
funktionieren auch nicht.
Kannst Du mir ein paar Tip´s geben?
Das Netzteil ist Extern, wobei die Gleichrichterplatine im Effektgerät 
ist.
Die Spannungen sind alle soweit OK.

Gruss Carsten

Autor: cargro (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
können die Pegel mit einem Spannungsmessgerät gemessen werden?
Wo soll ich genau Messen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier geht es nicht nur ums Messen, sondern ums Verstehen der Schaltung, 
um die Meßergebnisse interpretieren zu können. So klein ist die 
Schaltung nun auch wieder nicht, so daß man nicht einfach so mal 
Empfehlungen geben kann.
Vielleicht ist "nur" IC3 hinüber - in dem Falle kannste das Gerät 
vermutlich wegschmeissen, weil das ist vermutlich die Intelligenz des 
Kastens.

Autor: Anja (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
cargro schrieb:
> Komischerweise sind heute einige LED´s AN jedoch wenn ein Fusstaster
> gedrückt
> wird gehen einige wieder aus.

Spricht umso mehr für einen Fehler in der Stromversorgung.

cargro schrieb:
> Die Spannungen sind alle soweit OK.
glaube ich nicht: wahrscheinlich gibt es kurze Spannungseinbrüche 
verursacht durch eingetrocknete Elko's auf der 5V-Leitung.

Du brauchst entweder ein Oszilloskop oder ein ESR-Meßgerät um weiter zu 
kommen.
Versuchsweise kannst Du ja mal zu C1 einen entsprechenden Elko parallel 
schalten.

Normalerweise fallen in einem Gerät zuerst die mechanischen Bauelemente 
aus, dann die Elkos, danach Leistungshalbleiter die an der 
Belastungsgrenze bzw. mit hoher Temperatur betrieben werden und erst zum 
Schluß die ganzen Logik-Bauelemente.

Gruß Anja

Autor: cargo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Anja,
erst einmal Danke für deine Information bzw. Bemühungen mir zu helfen.

Anja schrieb:
Du brauchst entweder ein Oszilloskop oder ein ESR-Meßgerät um weiter zu
kommen.
cargo schrieb:
Leider habe ich die o.g Geräte nicht und kann Diese auch nicht bedienen.
Anja schrieb:
Versuchsweise kannst Du ja mal zu C1 einen entsprechenden Elko parallel
schalten.
cargo schrieb:
Ist das der Elko vom POWER-CB Board?
Denn muss ich dann noch besorgen...
Anja schrieb:
Normalerweise fallen in einem Gerät zuerst die mechanischen Bauelemente
aus, dann die Elkos, danach Leistungshalbleiter die an der
Belastungsgrenze bzw. mit hoher Temperatur betrieben werden und erst zum
Schluß die ganzen Logik-Bauelemente.

Gruß Carsten

Autor: cargo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,Jens
auch Dank für Deine Info!

Jens.G schrieb:
Hier geht es nicht nur ums Messen, sondern ums Verstehen der Schaltung,
um die Meßergebnisse interpretieren zu können. So klein ist die
Schaltung nun auch wieder nicht, so daß man nicht einfach so mal
Empfehlungen geben kann.
Vielleicht ist "nur" IC3 hinüber - in dem Falle kannste das Gerät
vermutlich wegschmeissen, weil das ist vermutlich die Intelligenz des
Kastens.

cargo schrieb:
das ist halt mein Problem!!
Ich möchte auf keinen Fall das Gerät entsorgen, da es ein Ideellen
Wert für mich besitzt.
Die Schaltung kann ich nur in Teilen verstehen....
Mit den Messwerten hast Du auch Recht..
Ich werde mal den ELKO C1 (POWER-PCB)tauschen "Tip von Anja".
Dann mal weiter sehen.

Gruß Carsten

Autor: cargo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Anja,
mit dem ELKO C1 kann Problem nicht gelöst werden.
Habe C1 und C7 erneuert (POWER-PCB). Jedoch ist noch das Problem mit dem 
LED´s vorhanden.Was könnte man noch testen?

Gruß Carsten

Autor: macaronlu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo
 Da hatte ich in 595 JAL von purogram geschrieben hilft, wenn Sie durch 
einen Blick in Ich danke haben

Autor: kolabier (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PCB zu PCB Verbindungen prüfen. Wenn das gesteckte Kabel sind, dann 
rosten die Kontakte gerne. Einfach mal abziehen und wieder aufstecken. 
Evtl. mit feinem Schmirgelpapier Korrosion wegmachen (nur oberflächlich, 
nicht die ganze Verzinnung runterhobeln).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.