www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Metallgehäuse


Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich habe ein Problem mit meiner Elektronik. Und zwar habe ich einen 
LED-Treiber in Verbindung mit einem ATMega328p aufgebaut. An einem 
AD-Pin lese ich ein Poti ein, welches die Helligkeit mittels PWM 
einstellt. Auf dem Tisch funktioniert alles wunderbar - alles ohne 
Probleme.
Nur: Wenn ich nun das ganze Ding in mein Metallgehäuse einbaue und ich 
es zuschraube, fängt die LED leicht zu flackern an sobald ich das 
Gehäuse berühre. Außerdem ist mir aufgefallen, dass sich der µC komplett 
aufhängt, wenn ich das Gehäuse mit der Erde (PE) verbinde. Dann hilft 
nur mehr ein Neustart der Elektronik. Manchmal verschwinden dadurch auch 
Daten aus dem EEPROM bzw. sind nicht mehr richtig. Als Versorgung nehmen 
ich ein Schaltnetzteil von 230V auf 24V (zugekauft).
Was kann da sein? Bin gespannt auf eure Antworten.
Vielen Dank im Voraus für eure Hilfe!

mfg
Andy

Autor: Charly B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da ist irgendwo eine kalte Lötstelle oder du hast die Isolierung zum 
Metallgehäuse vergessen =)

Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich beides verneinen. Das passiert bei mehreren (gleichen) 
Elektroniken. Und die Elektronik ist mit einem elektrisch isolierenden, 
doppelseitig klebenden Tape auf die innere Metallfläche geklebt. Auch 
diese Klebefolie hab ich schon zigmal gewechselt und auf "Lecks" 
untersucht. Vergeblich...

Autor: Randomize ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du evtl. offene/unbeschaltete Eingänge? Die könnten "Schmutz" aus 
der (abgeschirmten) Umgebung innerhalb des Gehäuses einfangen...

Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Offene Eingänge hab ich schon. Die hab ich alle als Eingang definiert 
und PullUps aktiviert... Kann das ein Problem sein??

Autor: Randomize ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setz' die doch spasseshalber mal auf Ausgang und probiers dann noch mal. 
Ansonsten ist meine Glaskugel vom Vulkan mit Staub bedeckt.

Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werd ich dann gleich mal probieren. Was ich noch beobachtet habe: Wenn 
ich zwischen Elektronik und Metallfläche ein Abstand von ca. 5mm mache, 
dann ist das Phänomen auch weg. Nur muss ich aus Platzgründen direkt 
aufliegen. Vielleicht hilft diese Info ein bisschen weiter...

lg

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schalte mal einen Kondensator (4.7 .. 10nF) zwischen Gehauese und GND 
deiner Schaltung.

Gruss Helmi

Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Helumt: Du bist mein Held. Diese Maßnahme scheint wirklich zu 
funktionieren. Sowohl das Flackern, als auch der Ausfall bei Berührung 
mit PE ist weg. Kannst du mir noch bitte erklären, was dieser C 
bewirkt??
THX!

lg

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem dürfte an kapazitiven Einstreuungen liegen (Indiz: Abstand 
Platine - Gehäuse spielt eine Rolle).

Beim Aufbau des Gerätes ist mir eins nicht ganz klar: Besitzt das Gerät 
ein internes oder ein externes Netzteil? In beiden Fällen sind die 
einschlägigen Richtlinien (VDE) zu berücksichtigen.

Die einfachste Lösung wäre (falls zulässig): Gehäuse mit Gerätemasse 
verbinden.

Bernhard

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Posch schrieb:
> Kannst du mir noch bitte erklären, was dieser C
> bewirkt??

Damit hast du HF-Maessig das gleiche Potential auf dem Gehauese und 
deinem GND. Damit koennen die Stoerungen nicht in deine Schaltung 
einstreuen.

Aber Achtung! VDE schreibt dazu einen Y-Kondensator vor. Also einen 
Kondensator der eine erhoehte Spannungsfestigkeit hat.

Suche mal nach Y-Kondensatoren.

Autor: Andreas Posch (andyp17)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, danke für eure Erklärungen. Habe gesehen, dass es verschiedene 
Klassen bei den Y-Kondensatoren gibt. Nun, mein Gerät wird mit 24V 
betrieben (über externes EVG - EVG hängt an 230V). Welche Klasse muss 
ich dann nehmen? Die kleinste, oder?? (<150V).

lg

Autor: Guest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sagt dir die Prüfstelle bei der CE-Konformitätsprüfung...

Autor: Christian H. (netzwanze) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guest schrieb:
> Das sagt dir die Prüfstelle bei der CE-Konformitätsprüfung...

Oh, ich wusste nicht, dass man Selbstbaugeräte (Einzelgeräte) auf 
CE-Konformität prüfen lassen muss.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian H. schrieb:
> Oh, ich wusste nicht, dass man Selbstbaugeräte (Einzelgeräte) auf
> CE-Konformität prüfen lassen muss.

Wenn nur fuer deinen persoenlichen Gebrauch ist nicht. Ansonsten darfst 
du auch selber pruefen.

Mach 250V Y Kondensatoren dran und gut ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.