www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Brauche Hilfe bei DCF77 Wecker Spannungsversorgung


Autor: C. S. (chrisdask8)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hey Leute,

bin momentan dabei einen DCF Funkwecker zu bauen. (aktueller Stand s. 
Bild)
Das ist erst mein 2. Projekt, ich bitte daher um Nachsicht ;-)

Problem ist folgendes:

Nachdem ich bisher immer mit 9V Blöcken und einer 7805 Schaltung 
gearbeitet habe, ist dies das erste Projekt das ich mit einem Netzteil 
betreiben will.

Dazu fand ich ein altes Handynetzteil von Samsung das 5V 
Ausgangsspannung hat. Alternativ besitze ich noch ein 
Multifunktionsnetzteil von Hama das auch auf 5V eingestellt werden kann.
Das Netzteil wird an die Schaltung angeschlossen (s. Bild), allerdings 
scheint die Spannung nicht schön glatt zu sein.
Der DCF Empfang will einfach nicht klappen. Die Led blinkt mal schnell 
mal dauerhaft, mal garnicht.
Mir ist bewusst, dass dies auch an den LED Anzeigen liegt, die mit 
multiplex-Verfahren angesteuert werden. Allerdings selbst wenn ich die 
Anzeige über das 34polige Kabel abziehe, klappt der Emfang nicht.
Ein Test mit einem 9V Block brauchte wesentlich bessere Ergebnisse, das 
DCF- Signal schien gut empfangbar zu sein.

Daraus schließe ich, dass die Versorgungsspannung über das Netzteil 
nicht so optimal ist.
Habe die Spannung versucht durch einen Elko mit 10uF und 100nF 
Kondensator zu glätten, direkt auf der DCF- Empfängerplatine (die 
kleine) nochmal das selbe (vgl. Bild).
Die Beschaltung des Moduls habe ich auch mal mit angehangen.

Jemand ne Idee wie ich das Modul mit dem Netzteil zum laufen kriege?
Geht da vllt. noch was mit Spulen etc.?
Hätte noch eine 10uH Spule hier ;-)

Bin dankbar für jeden Tipp!!

mfg
Christian

Autor: Düsendieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die DCF Empfänger sind recht zickig bei Störungen. Ist Dein Netzteil 
vielleicht ein Schaltnetzteil?

Besser ein Netzteil mit 8V DC -> min. 100µF Glättung -> 7805 mit jeweils 
100nF am Ein- und Ausgang.



Axel

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Axel,

Das eine Netzteil ist ein Handyladegerät, das feste 5V (gemessen ca. 
5,3V) liefert.
Das andere lässt sich einstellen 3,0 - 4,5 - 5,0 - 6,0 - 9,0 - 12 Volt
Meinst du es wäre besser dieses zu nehmen, auf 9V einzustellen, mit Elko 
zu glätten (hätte 470uF und 1000uF da für deine genannte Größenordnung 
(mindestens 100uF)) und danach trotzdem eine 7805 Schalung zu verwenden?

danke für deine Antwort

Gruß Christian

Autor: Dirk W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Das eine Netzteil ist ein Handyladegerät ...

... und solche sind heutzutage Schaltnetzteile, was den DCF-Empfang 
extrem stört. Da kannst Du auch mit Glättung nix verbessern.

> Das andere lässt sich einstellen 3,0 - 4,5 - 5,0 - 6,0 - 9,0 - 12 Volt

Das kann ein Schaltnetzteil sein, oder ein herkömmliches mit Trafo. 
Die herkömmlichen sind deutlich größer und schwerer als ein 
Schaltnetzteil mit vergleichbarer Leistung.

> Meinst du es wäre besser dieses zu nehmen, auf 9V einzustellen, mit Elko
> zu glätten (hätte 470uF und 1000uF da für deine genannte Größenordnung
> (mindestens 100uF)) und danach trotzdem eine 7805 Schalung zu verwenden?

Das ist ein guter Ansatz, bringt aber nix mit einem Schaltnetzteil.

Gruss, Dirk

Autor: ichhhhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DCF77 läuft mit viel Experimentieren an Schaltnetzteilen. Sobald du aber 
auch noch deine LEDs anschaltest und damit relativ große Lasten 
zuschaltest und abschaltest, wirds noch mehr gestört!

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch mal eine Schaltung aufgebaut, in der mehrere Treiber für 
die Anzeige mir die Versorgungsspannung so ziemlich verhagelt haben. Da 
ein DCF-Empfänger normalerweise nur sehr kleine Ströme benötigt kann man 
hier ein RC-Glied direkt vor dessen Versorgungsspannung setzen. Mit 1k 
und 1uF Keramik funktioniert das wunderbar.

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Chris schrieb:
> Da
> ein DCF-Empfänger normalerweise nur sehr kleine Ströme benötigt kann man
> hier ein RC-Glied direkt vor dessen Versorgungsspannung setzen. Mit 1k
> und 1uF Keramik funktioniert das wunderbar.

s. Beschaltung des DCF- Emfängers, 1kOhm sowie 100n Kerko sind als RC- 
Gleid bereits verbaut.

Düsendieb schrieb:
> Besser ein Netzteil mit 8V DC -> min. 100µF Glättung -> 7805 mit jeweils
> 100nF am Ein- und Ausgang.

Habe gerade ein altes 9,6V Netzteil verwendet (sah klobig aus => daher 
vermutung auf kein Schaltnetzteil). Dann habe ich die besagte 7805 
Schaltung mit 470uF Elko für die Versogrungsspannung aufgebaut.
Der Elko war keine so gute Idee, glaube ich habe mir da grade einige 
Bauteile zerschossen :D
Beim Nachmessen sah ich dass die Spannung nach dem 7805 kontinuierlich 
gestiegen ist, von 5,3 ....... 6V. Bei 6V habe ich dann abgesteckt..

Wie ist das nun wieder passiert??

EDIT: Doch nix passiert :-) ein Kabel war lose..

---

Hat jemand noch nen guten Tipp für mich?

Ganz schön verzwickt aus dem Netz ne passable Gleichspannung zu holen...

Da lobe ich mir die 9V Blöcke ;-)

mfg und danke für die bisherigen Antworten!!

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C. S. schrieb:
> s. Beschaltung des DCF- Emfängers, 1kOhm sowie 100n Kerko sind als RC-
> Gleid bereits verbaut.

Wieso versorgst Du das DCF-Modul denn bitte über einen Portpin des 
ATmega? Bau die Spannungsversorgung sternförmig auf! Also GND und VCC 
des Moduls direkt hinter dem Regler entnehmen und nichts anderes an 
diese Leitungen anschließen.

Autor: Düsendieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was tut das gute Stück denn nun mit dem Traftnetzteil?

Bei mir läuft das DCF77 Modul vom großen C an so einem Trafo problemlos. 
Sobald aber ein Schrittmotor in der Nähe läuft, ist es vorbei mit den 
Empfang und es läuft nur interne Zeit bei ungültigem DCF Empfang.

Benutzt Du auch das Programm von Ulrich Rading?


Axel

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Chris schrieb:
> Wieso versorgst Du das DCF-Modul denn bitte über einen Portpin des
> ATmega? Bau die Spannungsversorgung sternförmig auf! Also GND und VCC
> des Moduls direkt hinter dem Regler entnehmen und nichts anderes an
> diese Leitungen anschließen.

Ich dachte so könnte ich das Modul bequem per Pin aus und einschalten. 
Habs mal so aufgebaut wie du gesagt hast, leider keine Besserung 
eingetreten...

Düsendieb schrieb:
> Benutzt Du auch das Programm von Ulrich Rading?

Ja, noch ein wenig erweitert, am Programm liegt es auch nicht soweit...

Kann es sein, dass der 7805 den DCF-77 Emfang stört?
Bei meinem jetztigen Aufbau ist dieser nur ca. 10cm von der 
Emfängerspule entfernt. Gibt das Probleme??
Der Empfang mit der 7805 Schaltung scheint mir noch schlechter zu sein, 
als mit dem 5V Netzteil am Anfang...
Momentan funktioniert es nicht einmal wenn alle uC aus dem Sockel 
entfernt sind, die Led Anzeigen aus bleiben, und sozusagen nur der DCF - 
Empfänger empfangen soll/ will ...

Kann es am 7805 liegen, der evtl durch magnetische Abstrahlungen o.Ä. 
die 10cm entfernte DCF- Spule beeinflusst?

danke schonmal

Gruß Christian

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C. S. schrieb:
> Ich dachte so könnte ich das Modul bequem per Pin aus und einschalten.

Genau dafür ist PON vorgesehen :-)

Was mir noch einfällt: Manche Module fangen erst bei einer fallenden 
Flanke an PON an zu arbeiten. Du legst es lediglich an GND. Schließe PON 
mal an den AVR an und wechsel dann von einem High auf Low.

Autor: C. S. (chrisdask8)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Chris schrieb:
> Was mir noch einfällt: Manche Module fangen erst bei einer fallenden
> Flanke an PON an zu arbeiten. Du legst es lediglich an GND. Schließe PON
> mal an den AVR an und wechsel dann von einem High auf Low.

Daran liegt es nicht.

Habe das ganze grade mit nem 9V Block auch auf Lochraster zum Laufen 
gebracht und bin richtig STolz auf mich ;) (s. Bild)
Hab einfach das Programm geändert, die Anzeigen werden erst angesteuert, 
wenn das DCF-Signal empfangen ist :-P
Die DCF Platine hab ich auch nochmal überarbeitet.

Mit Netzteil läuft das ganze weiterhin leider immer noch nicht :-(

Das ganze wird nen 9V Block schnell die Puste ausgehen lassen oder??
Ich muss es früher oder später noch schaffen, das mit Netzteil zum 
laufen zu kriegen ..
Hat jemand vllt. ne Empfehlung worauf ich bei den Netzteilen achten 
muss??
Und reicht für die gängigen Netzteile wirklich ein 470uF Elko und eine 
Standard-7805 Schaltung danach??

Drosseln, Spulen etc?? Würde das was helfen?

ich danke jeden der versucht mir Tipps zu geben!!

Schönen Abend euch

Christian

Autor: Lukas T. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, hatte mal nen ähnliches Problem.
Versuche es mal mit Abschirmen.
Leg' testweise 'nen Kochtopf über Anzeige und Netzteil und schau' dann 
mal nach, ob der Empfang sauberer ist ... okay, da ist der Kochtopf über 
der Anzeige doch eher hinderlich.
Aber das Prinzip passt.
Probier's aus.
Wenn's dann trotzdem nicht klappt, dann liegt es wohl an der unsauberen 
Spannung und du musst deine Siebung verbessern.

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lukas T. schrieb:
> Wenn's dann trotzdem nicht klappt, dann liegt es wohl an der unsauberen
> Spannung und du musst deine Siebung verbessern.

Hi,
ja es liegt definitiv an der unsauberen Versogrungsspannung.
Weil: Schließe ich einen 9V-Block an funktioniert alles wunderbar.

Hat jemand nen Tipp für ein Netzteil, das:
*kein Schatnetzteil ist.
*eine saubere Gleichspannung von ca. 8VDC liefert.
*nicht allzu teuer ist.
*eine Leerlaufspannung in akzeptablen Bereichen hat.
(nicht z.b. 15V Leerlaufspannung statt "9,6VDC Bezeichnung")


Hoffe jemand hat nen Tipp

schönen Abend an euch

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Falk,

der Artikel ist mir schon bekannt.
Spielst du auf den R-C Filter an, der dort verwendet wurde?

Habe grade eine (für mich) sehr komische Entdeckung gemacht:

Ich Testete meine Funkuhr mit meinem Universal- Schaltnetzteil.
Es war wie immer kein DCF-77 Empfang festzustellen (anders wie mit 9V 
Block).
Durch einen dummen Zufall berührte ich mit meinem Finger die Pins im 
Bereich der Vcc und GnD Anschlüsse des Atmega32.
Genau in diesem Augenblick (bzw. kurz danach) begann der DCF-77 Empfang 
zu funktionieren.
(EDIT: DCF Empfang nur solange meine Finger die Pins berühren)
Wie ist das möglich? Dieses Verhalten ist auch reproduzierbar. Hat jetzt 
3mal in Folge grade funktioniert mit dieser "Finger an Pins halten - 
Technik".

Habe ich dadurch meinen Finger als "Verbraucher" zwischen Vcc und GnD 
geschalten, was die Versorgung geglättet hat? :D

Wenn ja, würde evtl. ein Widerstand ~ 1MOhm den selben Effekt bewirken?

Nur mal theoretisch? Testen werde ich es dann so oder so :-)

mfg

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

also habe mal ein par Tests gemacht.

Für die, die nicht erst alles lesen wollen:

Ich versuche herauszufinden, wie ich meine Schaltung auch mit einem 
Netzteil zum laufen kriege.

Folgende Versuche brachten Erfolg:
*den Vcc Anschluss mit dem Finger berühren
*den Gnd Anschluss mit dem Finger berühren
*den Vcc Anschluss über einen 10 kOhm Widerstand berühren
*Eine Prüfspitze des Multimeters (auf Strommessung eingestellt) mit Vcc 
verbunden, die andere frei in der Luft.
*Messen der Spannung zwischen Vcc und Gnd mit dem Multimeter

Erfolg bedeutet hier, dass durch diese "Versuche" der DCF-77 Empfang 
plötzlich möglich ist.

Ein 10kOhm Widerstand zwischen Vcc und Gnd zeigte keine Wirkung, wenn 
ich ihn nicht berührt hatte.

Ich kann mir das nicht erklären.

Hat jemand eine Idee??

Bin um jeden Tipp dankbar, oder Vermutungen

EDIT: selbst ein Berühren des Quarzoszillators von oben genügt

????? wie ist das möglich

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  C. S. (chrisdask8)

>Spielst du auf den R-C Filter an, der dort verwendet wurde?

Ja. Bau ihn ein. Oder hack dir den Finger ab und kleb ihn in die 
Schaltung ;-)

MFG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  C. S. (chrisdask8)

>EDIT: selbst ein Berühren des Quarzoszillators von oben genügt

>????? wie ist das möglich

Ich tippe mal auf Gleichtaktstörungen, verursacht durch das 
Schaltnetzteil. Die koppeln symetrisch in VCC/GND ein und fliessen dann 
über die immer vorhandenen Erdkapazitäten gegen Schutzerde im Haus. Den 
Effekt könnte man mit einem Kondensator zwischen GND deiner Schaltung 
und Schutzerde in der Steckdose wegbekommen.

ACHTUNG!!!! Nicht einfach an der Steckdose rumfummeln!!!

MFG
Falk

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Falk,

danke für deine Hilfe erstmal!!!!

Falk Brunner schrieb:
> Oder hack dir den Finger ab und kleb ihn in die
> Schaltung ;-)

:-D denke dann wäre die Wirkung auch weg

Falk Brunner schrieb:
> Ich tippe mal auf Gleichtaktstörungen, verursacht durch das
> Schaltnetzteil. Die koppeln symetrisch in VCC/GND ein und fliessen dann
> über die immer vorhandenen Erdkapazitäten gegen Schutzerde im Haus. Den
> Effekt könnte man mit einem Kondensator zwischen GND deiner Schaltung
> und Schutzerde in der Steckdose wegbekommen.


Klingt interessant was du da schreibst, meinst du in einem solchen Fall 
Hilft der R-C Filter?
Ich frage nur nocheinmal nach, weil ich bereits mal einen verbaut hatte 
direkt vor dem DCF- Modul, ohne Wirkung.. und desswegen wieder ausgebaut 
hatte.
Die Dimensionierung mit 1kOhm und 100nF Kerko wäre ok?
Diese Dimensionierung hatte mein R-C Filter zuvor gehabt.

Hoffe du kannst mir weiterhelfen

danke

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch mal 1k/10µF am DCF Modul.

MFG
Falk

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:
> Versuch mal 1k/10µF am DCF Modul.

Hey Falk,
konnte mich nun nach langer Pause mal wieder mit meiner DCF-Uhr 
beschäftigen.
Bin z.Z. mit Schule ausgelastet (Abitur).

Leider konnte der genannte R-C Filter auch keine Besserung herbeiführen.

Ich fasse nochmal zusammen:

Die Spannungsversorgung wird mit einem 470uF Elko geglättet, und dann 
mit einem 7805 Spannunsregler auf +5V geregelt (100nF Kerko am Eingang 
und Ausgang wie üblich).

Die Versorgungsleitungen für den DCF- Empfänger habe ich direkt nach dem 
7805 angeschlossen.

Bislang funktioniert der DCF-Empfang nur bei einem angeschlossenen 
9V-Block (und abgeschalteter Anzeigeeinheit).
Unter Verwendung meines Netzteils mit Einstellung 9V:
http://www.reichelt.de/?ACTION=3;GROUP=D411;GROUPI...
ist kein Epfang feststellbar.
Liegt das jetzt dadran, dass es ein Schaltnetzteil ist oder kann ich 
duch bessere Filterung / Siebung (vgl. oben) auch mit diesem Netzteil 
ans Ziel kommen?

Wenn nein, auf was muss ich bei einem Neukauf eines Netzteils achten??


Hoffe jemand hat nen Tipp

Gruß
Christian

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C. S. schrieb:
> Die Spannungsversorgung wird mit einem 470uF Elko geglättet, und dann
> mit einem 7805 Spannunsregler auf +5V geregelt (100nF Kerko am Eingang
> und Ausgang wie üblich).

Das ist zu mager, wenn da noch LEDs getrieben werden sollen.
Manche Wandwarzen haben nur eine Diode drinn, dann mußt Du 20ms 
überbrücken.
Nimm einen 2200µF vor dem 7805 und einen 470µF dahinter.


Peter

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  C. S. (chrisdask8)

>Unter Verwendung meines Netzteils mit Einstellung 9V:
>http://www.reichelt.de/?ACTION=3;GROUP=D411;GROUPI...
>ist kein Epfang feststellbar.

Naja, das Ding ist ein billiges Schaltnetzteil, wahrscheinlich spuckt es 
ordentlich Dreck.

>Liegt das jetzt dadran, dass es ein Schaltnetzteil ist oder kann ich
>duch bessere Filterung / Siebung (vgl. oben) auch mit diesem Netzteil
>ans Ziel kommen?

Möglicherweise.

>Wenn nein, auf was muss ich bei einem Neukauf eines Netzteils achten??

Mit Glück ein störarmes Erwischen :-0
Oder ein klassische mit normalem 50 HZ Trafo verwenden.

MFG
Falk

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke euch beiden für die Antworten.

Habe es grade mit obiger Anordnung zum laufen gebracht.

Ich habe ein 4,5V Netzteil ausgebraben, das nicht wie ein Schaltnetzteil 
ausgesehen hat.
Beim Nachmessen lieferte es 9,2VDC.
Testweise hängte ich also dieses "4,5V" Netzteil an die Schaltung und es 
funktionierte auf Anhieb problemlos :-)


Danke nochmal für alle Antworten

DCF Empfang läuft jetzt auch ohne überflüssigen Batterieverbrauch ;)

schönen Abend noch

Christian

Autor: Alex Chili (habanero)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe hier momentan auch so meine Probleme, eine Funkuhr mit einem 
Traco oder Recom SNT zu betreiben. Grob gesagt wird die Uhr durch die 
SNT so gestört, dass sie keinen Empfang bekommt. Daher interessiert mich 
mal, ob es mittlerweile jemand geschafft, eine Selbstbau-Uhr an einem 
SNT zu betreiben? Falls ja, mit welchen Maßnahmen?

Ich würde mich über eure Antworten sehr freuen!

Grüße,
Alex

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.