www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Multiplex: LED flackert


Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe ein kleines Problem mit einem Würfel aus LEDs.
Die fahre ich (logischerweise) über Multiplex, was auch klappte.

Ich hatte (um eine gesamte Ebene gegen masse zu ziehen) einen BC337, und 
pro LED noch je einen BC337, die über Schieberegister am Atmega hängen. 
Damit konnte jede LED ansteuern.

Jetzt hab ich die Transistoren, die gegen Masse ziehen, gegen FETs 
ausgetauscht, und den LEDs einen etwas größeren Vorwiderstand verpasst, 
damit insgesamt weniger Leistung am Transistor und mehr an den LEDs 
verbraten werden kann.

Jetzt flackern aber manche LEDs leicht.
Mein Timing für den Mutliplex ist dasselbe wie vor dem Umbau, daran 
liegt es also nicht. Es sind auch nicht alle LEDs, die flackern, sondern 
nur manche.
Die LEDS können bis zu 1A Peak ab (Dauerstrich 100 mA), ich betreibe sie 
mit 75mA.

Meine Vermutung ist, dass es irgendwie am FET liegt. Ich habe aber keine 
Ahnung, was es sein könnte.

Das Gate hängt direkt am Ausgang des Atmega und hat einen 10k Pulldown 
gegen Masse. Ohne den Pulldown flackern sie aber auch leicht.

Schwingt da irgendwas? Kann er sich nicht schnell genug entladen?

Mfg
Jens

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klingt so, als ob du die Ausgänge nicht wirklich aus Ausgänge geschalter 
hast, Stichwort DDRx Register. Damit schaltest du nur die internen 
Pull-Ups ein und aus. Der Bipolar funktioniert dabei "normal", der Fet 
hat ein floatendes Gate.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch, das sind Ausgänge.

Ich habe es vielleicht etwas schlecht formuliert:
Die LEDs leuchten so, wie ich es erwarte (und gehen auch aus, wenn ich 
es will ;)

Aber manche LEDs haben ein leichtes Flackern, wenn sie an sind.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann auch ein Softwarefehler sein.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, kann sein.
Aber ich verstehe nicht so ganz, warum sich FETs dann an der Stelle 
anders verhalten als die ehemaligen Bipolar. Und mir ist auch nicht ganz 
klar, warum es nur manche LEDs trifft.

Autor: AVRuser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

sind die Basis-Widerstände von den BC337 noch in der Schaltung (als 
Gate-Widerstand)? Wenn ja, wie gross sind sie?
Welchen FET verwendest du?

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, die Basis-Widerstände sind raus.
Das Gate hängt direkt am Pin des Atmega und hat einen 10k Pulldown.
Ohne Pulldown flackerte es aber auch.

FETs sind FDN327N.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens schrieb:
> Mein Timing für den Mutliplex ist dasselbe wie vor dem Umbau, daran
> liegt es also nicht.

Das heißt also, das Programm ist exakt das gleiche?

Anfänger versuchen oft, Multiplex ohne Timerinterrupt zu machen und 
erleiden natürlich Schiffbruch.


Peter

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, die Software ist exakt gleich.
Ich hab nur die Vorwiderstände der LEDs vergrößert, Bipolar gegen FET 
getauscht, den ehemaligen Basiswiderstand rausgenommen und dafür einen 
Pulldown am Gate angebracht.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens schrieb:
> Aber ich verstehe nicht so ganz, warum sich FETs dann an der Stelle
> anders verhalten als die ehemaligen Bipolar.

Wie hoch ist denn die Frequenz Deines Timerinterrupts zum Multiplexen?

Bipolar in Emitterschaltung haben ne deutlich größere Sperrverzögerung.
Es kann durchaus ein SW-Fehler sein, der durch die unterschiedliche 
Reaktionszeit deutlicher auffällt.


Peter

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Timer hat knapp 100 us.
Was bedeutet Sperrverzögerung?
Bedeutet das einfach, dass der FET schneller schaltet als der Bipolar?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Jens (Gast)

>Der Timer hat knapp 100 us.

Alle 100µs ein Interrupt? Wozu das, das sind 10kHz?
Selbst für eine 8:1 MUX braucht man gerade mal 800 Hz, also 1250 µs.
Siehe LED-Matrix.

>Was bedeutet Sperrverzögerung?
>Bedeutet das einfach, dass der FET schneller schaltet als der Bipolar?

Vereinfacht gesagt, ja.

MFg
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.