www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit Gegentaktwandler


Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Hab hier ein paar Probleme mit so 'nem Ding. Daten: 12V auf 10..20V, 
Ferritkern ohne Spalt, 9 Wdg. Primär, 2mal 40 Wdg. Sekundär (380uH 
primär und 3800uH auf jeder Sekundärwicklung, auf der Primärseite mit 
einer kurzgeschlossenen Sekundärwicklung 2.8uH Streuinduktivität).

Die Sekundärwicklung wird als 80 Wdg. mit Mittelanzapfung verwendet, der 
Sekundärteil schaut so aus:

http://www.mikrocontroller.net/attachment/37660/Ge...


Die Primärseite funktioniert einwandfrei (Halbbrücke), mit'm Oszi alles 
angeguckt, sehr schönes Rechteck an der Spule, das andere Ende wird von 
Kondensatoren schön auf 6V gehalten - alles perfekt.

Sekundärseitig kommen aber sehr komische Sachen zustande. Zum einen 
bleibt die Spulenspannung (noch vor'm Gleichrichter gemessen, Masse ist 
die Mittelanzapfung) nach dem Umschalten der FETs eine Weile auf 0V 
stehen. Damit kann ich überhauptnix anfangen.
Danach springt die Spannung zwar in etwa auf den Wert den sie haben 
sollte, aber mit etwa 50% AC Anteil.
An den beiden Enden der Wicklung kann ich das schön einmal im positiven 
und dann im negativen messen, das wird soweit auch ordentlich 
gleichgerichtet.

Erhöhe ich die Last verlängert sich die "Totzeit" am Anfang, in der die 
Spule auf 0V rumdümpelt (bei 3A sind es dann etwa 50% in denen über die 
Spule einfach keine Spannung abfällt, obwohl auf der Primärseite keine 
Totzeit vorhanden ist).
Wenn ich die Frequenz hochdrehe bleibt die Totzeit konstant, der Anteil 
wird aber größer und die Ausgangsspannung sinkt dadurch ebenfalls.


Heut Nachmittag stell ich mal ein paar Bilder ein. Hat irgendjemand eine 
Idee warum die Spulenspannung einfach auf 0V rumdümpelt?

Autor: Jörg Rehrmann (Firma: Rehrmann Elektronik) (j_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jfu schrieb:

> Erhöhe ich die Last verlängert sich die "Totzeit" am Anfang, in der die
> Spule auf 0V rumdümpelt (bei 3A sind es dann etwa 50% in denen über die
> Spule einfach keine Spannung abfällt, obwohl auf der Primärseite keine
> Totzeit vorhanden ist).

Woher weisst Du das ? Bei einer Vollbrücke ist es nicht ganz so einfach, 
die Primärspannung darzustellen.

> Wenn ich die Frequenz hochdrehe bleibt die Totzeit konstant, der Anteil
> wird aber größer und die Ausgangsspannung sinkt dadurch ebenfalls.
>
>
> Heut Nachmittag stell ich mal ein paar Bilder ein. Hat irgendjemand eine
> Idee warum die Spulenspannung einfach auf 0V rumdümpelt?

Ich würde mal stark vermuten, dass sich die Rechteckspannungen der 
beiden Brückenzweige nicht exakt in Gegenphase befinden. Ein Schaltplan 
der Ansteuerung würde hier sicher Klarheit schaffen. Das wird übrigens 
auch gezielt zur PWM-Modulation genutzt, Stichwort "Phase-Shift-PWM". 
Schau mal hier ganz unten: 
http://www.joretronik.de/Web_NT_Buch/Kap8_3/Kapitel8_3.html

Jörg

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm... also es ist nur eine Halbbrücke, die Ansteuerung macht ein TL494. 
Ich mach mal Bilder...

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aaaalso...


http://ih.doesntexist.org/snt/sch.png

So schaut die Sache aus, die Spule und den C im Sekundärteil hab ich 
weggelassen, irgendwie mochte Kicad das nicht grml.



http://ih.doesntexist.org/snt/NewFile5.bmp.png

Unten gelb ist die Spannung zwischen den FETs, also Trafo Pin 1. Blau 
ist Trafo Pin 2, bleibt bei 6V schön konstant. Auffällig sind nur die 
etwas hohen Spannungswerte bei Gelb direkt nach dem Schalten.


http://ih.doesntexist.org/snt/NewFile3.bmp.png
http://ih.doesntexist.org/snt/NewFile4.bmp.png

Erstes ist Gatespannung von den P-FETs, zweites von dem N-FET.


(darf nur max. 5 links posten, 2. Teil folgt)

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit schauts net schlecht aus. Aaabber:

http://ih.doesntexist.org/snt/NewFile1.bmp.png
http://ih.doesntexist.org/snt/NewFile2.bmp.png

Das erste ist die Spannung zwischen Trafo 3 und 4, das zweite zwischen 
Trafo 6 und 4. Nach dem Gleichrichter kommt auch genau das selbe raus:

http://ih.doesntexist.org/snt/NewFile0.bmp.png


Wär super wenn jemand eine Idee hätte, was das sein könnte.

Autor: Jörg Rehrmann (Firma: Rehrmann Elektronik) (j_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jfu schrieb:
> Hmm... also es ist nur eine Halbbrücke, die Ansteuerung macht ein TL494.
> Ich mach mal Bilder...

Aha ! Der TL494 macht doch selbst eine Totzeit. Dass Du die Totzeit u.U. 
primärseitig nicht sehen kannst, liegt an der Streuinduktivität. Die 
sorgt dafür, das die Primärspannung nach dem Abschalten eines 
Transistors sofort umschwingt. Das hat mit dem beobachteten Effekt aber 
vermutlich  nichts zu tun.
Durch die Speicherdrossel hinter dem Gleichrichter fließt i.d.R. immer 
ein Gleichstrom, sodass immer eine der Dioden leitend ist. Eine 
Sekundärspannung kann sich erst aufbauen, wenn die Sekundärspule mehr 
Strom liefert als durch die Speicherdrossel fließt. Auch wenn die 
Spannung auf der Primärseite sehr schnell umschwingt, sorgt die 
Streuinduktivität dafür, dass sich der sekundäre Spulenstrom nur mit 
begrenzter Geschwindigkeit abbauen kann, um sich dann mit umgekehrter 
Polarität wieder aufbauen zu können. In dem Zeitraum, in dem der 
Spulenstrom kleiner ist als der Drosselstrom, bricht die 
Sekundärspannung auf null zusammen.
Weiterhin sind durch die Sperrverzugszeit der Dioden, sofern es keine 
Schottky-Dioden sind, während der Umschaltphase kurzzeitig beide Dioden 
Leitend. Diesen Kurzschluß der Sekundärspule federt die Steuinduktivität 
ebenfalls ab.

Jörg

Autor: Jörg Rehrmann (Firma: Rehrmann Elektronik) (j_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jfu schrieb:

> Unten gelb ist die Spannung zwischen den FETs, also Trafo Pin 1. Blau
> ist Trafo Pin 2, bleibt bei 6V schön konstant. Auffällig sind nur die
> etwas hohen Spannungswerte bei Gelb direkt nach dem Schalten.

Die Spannungsspitzen sind eine Folge der Streuinduktivität der geteilten 
Sekundärspule. Nach dem Umschalten muß der Strom sehr schnell von einer 
zur anderen Spule wechseln. Nach der jeweiligen Stromflußphase sind die 
Spulen dann relativ plötzlich offen und ohne jegliche Last. Die in der 
Streuinduktivität noch gespeicherte Energie entlädt sich dann in einer 
Spannungsspitze, die sehr leicht die Dioden zerstören kann. Abhilfe 
schafft ein RC-Dämpfungsglied, ebenfalls hier zu sehen:
http://www.joretronik.de/Web_NT_Buch/Kap8_3/Kapitel8_3.html
in Bild 8.4 b oder eine einfache Sekundärspule mit Brückengleichrichter

Jörg

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm.... also ich hab es geschafft die Leistung mit dem RC-Glied über die 
Trafo Pins 3 und 6 etwas zu steigern (47nF, 6 Ohm), aber so besonders 
viel war es nicht (bei 26kHz stieg die Ausgangsleistung bei 10 Ohm Last 
von 18.5W auf 23.8W).
Der Wirkungsgrad ist damit allerdings von 74.4% auf 67.5% gefallen.

Wenn ich bei den Bedingungen einen 100nF direkt dranhalte gibt's 1.8mal 
soviel Leistung, aber auch bei bescheidenem Wirkungsgrad.

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab testweise mal beiden Sekundärwicklungen kurzgeschlossen, aber 
irgendwie sind da trotzdem nur so etwa 2A in's Netzteil reingeflossen.

Hat jemand eine Idee woran das liegt? Magnetische Kopplung vom Trafo zu 
schwach? Aber eigentlich hat der ja nur <1% Streuinduktivität. Geht mir 
grad nicht so ganz in den Kopf.

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, ich glaub langsam hab ich es. Ich hab wohl den Trafo falsch 
gewickelt, die Primärwicklung geht, weil sie so kurz ist, nicht einmal 
komplett rum, sondern ist nur auf einem Ausschnitt von etwa 45° vom 
Ringkern aufgewickelt.

Dadurch tut die Sache scheinbar nicht, ich hab mit ein paar anderen 
Ringkernen mal Tests gemacht, da trat das selbe Phänomen auf.

Autor: jfu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jep, ist erledigt. Direkt nach dem Umwickeln vom Trafo ist mir der 
erstmal in Sättigung gerannt, hab mal kurz einen 
Vollbrückengleichrichter drangehäkelt und nun kamen recht problemlos 65W 
raus. Mehr wollte ich noch nicht probieren, die Sache sitzt auf dem 
Steckbrett, die Gleichrichter sind 2 Nummern kleiner als die auf der 
Platine, und die Siebspule ist glaub für 3A spezifiziert (waren 4.3A).


Also merken: Ringkerne gehören gleichmäßig von Anfang bis Ende 
bewickelt, auch wenn's bei 9 Windungen doof aussieht.

Autor: Jörg Rehrmann (Firma: Rehrmann Elektronik) (j_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jfu schrieb:

> Also merken: Ringkerne gehören gleichmäßig von Anfang bis Ende
> bewickelt, auch wenn's bei 9 Windungen doof aussieht.

Das ist keine Besonderheit von Ringkernen und gilt für alle 
Trafobauformen: Zur Vermeidung von Streuinduktivitäten muß die zur 
Verfügung stehende Wicklungsbreite von allen Spulen möglichst 
gleichmäßig und vollständig genutzt werden. Am besten sollten die Drähte 
aller Spulen möglichst dicht ineinander bzw. nebeneinander gelegt 
werden.

Jörg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.