www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Bandpass 5kHz


Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:
  • preview image for BP.jpg
    BP.jpg
    86,2 KB, 615 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
habe einen 5kHz Bandpass laut Bild mit einem LM358N aufgebaut. Geb ich 
jetzt ein Signal mit 5V mit 10μs hight und 190μs low auf die Bandpass, 
kommt am Ausgang so gut wie nichts mehr raus.

: Verschoben durch Admin
Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>habe einen 5kHz Bandpass laut Bild mit einem LM358N aufgebaut. Geb ich
>jetzt ein Signal mit 5V mit 10μs hight und 190μs low auf die Bandpass,
>kommt am Ausgang so gut wie nichts mehr raus.

Dann funktioniert er super!

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja falls dein Signal ein Rechteck ist, enthält es in der Konstellation 
10us an, 190us aus auch viele Anteile höherer Frequenzen als 5 kHz.
(->Fourier)

Autor: Albert ... (albert-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was heißt so gut wie nichts mehr? Wie hoch ist denn die Amplitude deines 
Rechtecksignales? 5V? Bei einem 5V Signal wirst du nur ein paar 100mV 
Signalamplitude rausbekommen.

Autor: Martin R. (herki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schließe mich meinen Vorrednern an.

Da kann niemals was rauskommen. Rechne Dir doch mal die 
Fourier-Koeffizienten aus.

VG

Herki

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Eingang ist ein Rechtecksignal 5V mit 10μs hight und 190μs low.
Damit der Bandpass funktioniert müsste ich also ein Sinussignal auf den 
Bandpass geben, oder wie?

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch eine +/- Stromversorgung, z. B. +12V/-12V ?
Die brauchst du mit deiner Schaltung, wenn dein Eingangssignal von 0 
nach 5V geht.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Am Eingang ist ein Rechtecksignal 5V mit 10μs hight und 190μs low.
> Damit der Bandpass funktioniert müsste ich also ein Sinussignal auf den
> Bandpass geben, oder wie?

Was du probieren kannst ist das Tastverhältnis auf 50% zu setzen, also 
100us an und 100us aus. Dann hast du nämlich 5kHz als Grundschwingung im 
Signal.

Wahrscheinlich wird das Signal dann hinten ein bisschen abgerundet 
rauskommen, da höhere Frequenzen wegefiltert werden.

Für Filter solltest du dich mal in Fourierreihe / Fouriertransformation 
einlesen. :D

Autor: Martin R. (herki)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Am Eingang ist ein Rechtecksignal 5V mit 10μs hight und 190μs low.
> Damit der Bandpass funktioniert müsste ich also ein Sinussignal auf den
> Bandpass geben, oder wie?

Hi

Die Funktion eines Bandpasses kannst DU am leichtesten Testen indem Du 
am Eingang ein weißes Rauschen (Frequenzgemenge in dem unteranderem auch 
ein Signal mit 5kHz ist) anlegst. Am Ausgang kannst Du dann ein 
5kHz-Signalgemenge (+- ein paar Hertz (abhängig von der Steilheit deines 
Bandpasses)) rausmessen.

Alternativ kannst Du ja mal ein Sinussignal mit 1kHz, 4kHz, 5kHz, 6kHz 
und 10kHz auf den Bandpass geben und am Ausgang messen was rauskommt.

Wie wolltest Du denn Deinen Bandpass prüfen?

VG

Herki

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier erst einmal ein paar Infos zu meinem Vorhaben.
Ich habe eine Bewässerungsanlage mit vielen Düsen welche ich gerne mit
Sende- und Empfangsdiode(IR 880nm oder 950nm) überwachen möchte.
Anhang: Projekt

Damit die Schaltung gegen Fremdlicht unempfindlich ist, wollte ich die 
IR-Sendediode mit z.B. 5kHz pulsen und auf der Empfangsseite einen 
Bandpass aufbauen. Das gefilterte Signal würde ich dann mit einem 
Mikrocontroller auswerten.

Ich habe mal mit Filter Pro von Texas Instruments einen 5kHz Filter 
erstellt.
Anhang: 5kHz-filter

Anschließend mit OrCAD Capture simuliert. Simu1 zeigt die Schaltung,
Simu2 den Phasenfrequenzgang und Amplitudenfrequenzgang
Anhang: Simu1, Simu2

Kann ich den Filter (den ganzen Rest)so aufbauen oder muss der Filter 
komplexer sein?
Sonst irgendwelche Tips, Anregungen?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal den Tonedecoder LM/NE 567 an.  Damit kannst du deine 
Frequenz rausfiltern.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst auch mal nach Infrarot-Empfängern schaun, die bereits den Filter 
intergriert haben (meist 38 oder 40 kHz).
Dann müsstest du dich nur noch um die Senderseite kümmern.

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flo schrieb:
> Kannst auch mal nach Infrarot-Empfängern schaun, die bereits den Filter
> intergriert haben (meist 38 oder 40 kHz).

Meinst du TSOP17xx? Geben die nicht einen RC5 Code oder so aus?
Wenn es geht würde ich gerne Abstufungen machen(Wasserstrahlt bei 100% - 
75% - 50% - 25% - aus)

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sind halt digitale Sensoren, sagen dir also nur, dass Signal ist da 
oder nicht.

Das einzige, was man für Abstufungen tun könnte, wäre die Sendestärke 
der IR-Dioden linear nach oben zu fahren.
Sobald dann die Sensoren schalten, weis man ja die Senderintensität und 
kann so die "Durchstrahldämpfung" errechnen.

Du willst mit der Lichtschranke (praktisch ist es ja eine) die Menge an 
Wasser, das durch die Düsen kommt abschätzen?

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flo schrieb:
> Du willst mit der Lichtschranke (praktisch ist es ja eine) die Menge an
> Wasser, das durch die Düsen kommt abschätzen?

Ja. Die Düsen können teilweise oder ganz verstopfen und dann habe ich in 
meinem Gewächshaus ein Problem.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ob da eine Lichtschranke so ideal ist bei der üblichen Verschmutzung ?
Da sollte es noch andere Lösungen geben ?

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Ob da eine Lichtschranke so ideal ist bei der üblichen Verschmutzung ?
> Da sollte es noch andere Lösungen geben ?

Die da wären?

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Ich habe mal mit Filter Pro von Texas Instruments einen 5kHz Filter
> erstellt.
> Anhang: 5kHz-filter

Habe den Bandpass (Anhang: 5kHz-filter)aufgebaut und die Sendediode mit 
einer 5kHz Rechteckspannung gespeist.
Bildanhang Kurver unten
Am Ausgang meines Filters erhalte ich diesen Verlauf.
Bildanhang Kurver oben
Außerdem sinkt die Eingansspannung von 5V auf 4V.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die da wären?
z.B. über Verbrauchsmessung: schwebender Magnet in sekrechtem Rohr und 
induktive Auswertung/ Reedkontakt sobald normales Level verlassen wird?
Wenn Düsen verstopfen erhöht sich der Druck.

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Hans Bernd schrieb:
>> Ich habe mal mit Filter Pro von Texas Instruments einen 5kHz Filter
>> erstellt.
>> Anhang: 5kHz-filter
>
> Habe den Bandpass (Anhang: 5kHz-filter)aufgebaut und die Sendediode mit
> einer 5kHz Rechteckspannung gespeist.
> Bildanhang Kurver unten
> Am Ausgang meines Filters erhalte ich diesen Verlauf.
> Bildanhang Kurver oben
> Außerdem sinkt die Eingansspannung von 5V auf 4V.

Und hier die Messung noch einmal mit einem anderen OP, einem TS912.
Von einer Rechteckspannung weit entfernt.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeig doch mal den Schaltplan.
Ich vermute deine Schaltung stimmt nicht.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein langsamer OPV ist ja auch kein schnelles Logikgatter.
Immerhin ist noch ein Impuls übrig, den man durch einen nachgeschalteten 
Schmitt-Trigger verschönern könnte.
http://en.wikipedia.org/wiki/Schmitt_trigger

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Zeig doch mal den Schaltplan.
> Ich vermute deine Schaltung stimmt nicht.

Schaltplan ist von oben die
Datei: simu1.png
aber mit Rechteckspannung als Quelle und als OP ein TS912

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Schaltplan ist von oben die
> Datei: simu1.png

Wenn du das ganze so aufgebaut hast wundert es mich nicht das da nichts 
rauskommt. Entweder das ganze mit +-5V speissen und den + Eingang auf 0 
legen oder unsymetrisch speissen und den +Eingang auf halbe 
Betriebsspannung legen. Sonst kann der OP nicht richtig arbeiten.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich hab es befürchtet.
Diese erwähnte Schaltung kann ja nie funktionieren. Ich sehe ein 
schwimmendes 5V Supply. Das geht niemals! Der Minus-Anschluss muss auf 
Masse(GND).
Angenommen du hättest Minus vom Supply in Wirklichkeit auf GND 
angeschlossen, dann hast du den Arbeitsunkt bei 0V. Das geht erstmal 
nicht. Bei Single Supply Versorgung muss du den Ausgang auf Ub/2 
einstellen.
Die Alternative wäre +5V und -5V Supply. Das hast du aber vermutlich 
nicht verfügbar.

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Angenommen du hättest Minus vom Supply in Wirklichkeit auf GND
> angeschlossen

Sorry Minus vom Supply ist doch auf GND angeschlossen (siehe neue 
Zeichnung).

> muss du den Ausgang auf Ub/2 einstellen

Wie meinst du das?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
>> muss du den Ausgang auf Ub/2 einstellen
>
> Wie meinst du das?

+Versorgung auf einen Spannungsteiler  10K 10K  in der Mitte hast du 
dann 2.5V also UB/2 . Und die kommen jetzt an den + Eingang vom OP. 
Damit ist der OP in der Mitte der Versorgungsspannung.

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So wie im Schaltbid müsste deine Schaltung aussehen.

Du hast ein Filter mit hoher Güte gerechnet. Damit gehen die 
Grenzfrequenzen deiner Opamps schon stark in die Mittenfrequenz ein. 
Deshalb musst du R3 so abstimmen, dass du bei 5KHz am Eingang die 
maximale Amplitude bekommst (Abgleich der Mittenfrequenz)
Beim LM358 werden es wohl ca. 150kOhm sein, beim TS912 ca. 180kOhm.
Das Filter wäre unkritischer, wenn du es mit weniger Güte berechnet 
hättest.

Das lässt sich übrigens alles mit LTspice wunderbar simulieren. Vor 
allem auch der Effekt endlicher Bandbreite des Opamp, wodurch die 
Mittenfrequenz nicht genau der berechneten Frequenz entspricht. Das 
zweite Bild zeigt das Einschwingen auf Rechteckimpulse mit 20mVpp. Bei 
mehr als 50mVpp kommt man schon langsam in die Begrenzung beim LM358. 
Beim TS912 kannst du weiter aussteuern. Deshalb ist der die bessere 
Wahl. Außerdem hat der auch mehr Bandbreite was hier ein großer Vorteil 
ist.

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja so sieht die Schaltung aus. Mit Ub/2 habe ich folgendes Signal wenn 
ich eine Recheckspannung Pulse(0V 5V 0 0 0 100us 200us) anlege(habe vom 
uC leider nur diese Rechteckspannung, viel zu groß).
Anhang: TS912 ub0.5.JPG

Würde nun gerne die Schaltung erweitern:
Anhang: projekt_neu.png
Doch sobald die Rechteckspannung anliegt, habe ich eine Rechteckspannung 
auf der gesamten Speisespannung.
Anhang: störung.jpg

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
8,5 Ohm ist recht wenig für die Sendediode.

Was hast du denn als Versorgung für deine Schaltung?

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flo schrieb:
> 8,5 Ohm ist recht wenig für die Sendediode.
>
> Was hast du denn als Versorgung für deine Schaltung?

eine Rechteckspannung Pulse(0V 5V 0 0 0 100us 200us)

5V(UB) - 0,7V(Transistor)- 2,6V(LED)=1,7V
R=U/I =1,7V/0,2A=8,5Ohm

Müsste passen, oder?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
8,5 Ohm ist recht wenig für die Sendediode? I=?
Stützkondensatoren/Elkos sehe ich auch nicht für die 5V.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls das ein Phototransistor sein soll, dann ist der falsch 
angeschlossen.

Dein Filter setzt eine Spannungsquelle mit kleinem Innewiderstand 
voraus.
Dein Transistor ist aber eine Stromquelle.
Deshalb linker Anchluss von R4 nach Masse.
Kollektor an +5V.
Emitter an den Knoten R4oR5. Emitter ist der mit dem Pfeil.

Autor: Flo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> 8,5 Ohm ist recht wenig für die Sendediode? I=?
> Stützkondensatoren/Elkos sehe ich auch nicht für die 5V.

Das meinte ich, mit 8,5 Ohm wird deine Versorgungsspannung einbrechen, 
falls du keine Pufferelkos oder ein Netzteil betreibst.
In deinem Schaltplan sieht das sehr nach Batterien aus.
Was benutzt du jetzt genau als Stromversorgung?

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Falls das ein Phototransistor sein soll, dann ist der falsch
> angeschlossen.

Soll eine Photodiode sein, also die Schaltung wie für den 
Phototransistor beschrieben ändern?!

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Flo schrieb:
> Was benutzt du jetzt genau als Stromversorgung?

Spannung kommt von einem ATMEL Evaluations-Board.
Also 7805 mit ein wenig Beschaltung.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Helmut S. schrieb:
>> Falls das ein Phototransistor sein soll, dann ist der falsch
>> angeschlossen.
>
> Soll eine Photodiode sein, also die Schaltung wie für den
> Phototransistor beschrieben ändern?!


Warum zeichnest du dann einen Phototransistor?
Bist du sicher?
Ich habe hier schon soviel Fehler gesehen, da glaub ich gar nichts mehr.
Link auf Datenlatt?


> Dein Transistor ist aber eine Stromquelle.
> Deshalb linker Anchluss von R4 nach Masse.
> Kollektor an +5V.
> Emitter an den Knoten R4oR5. Emitter ist der mit dem Pfeil.

Eine Photodiode in Sperrichtung ist eine Stromquelle.
Deshalb linker Anchluss von R4 nach Masse.
Kathode an +5V. Kathode ist da wo der Querstrich ist.
Anode an den Knoten R4oR5.

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Warum zeichnest du dann einen Phototransistor?

Habe die Zeichnung verbessert.
Ist eine Photodiode(SFH203).

Die Sendediode möchte ich mit einem 8,5Ohm Vorwiderstand betreiben 
(größer geht nicht, sonst bekommt die Sendediode zu wenig Strom), wie 
kann ich dann verhindern, das auf meiner Spannungsquelle ein 
Rechtecksignal erscheint(siehe st_rung.jpg). Elko zwischen +5V unf GND?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Habe die Zeichnung verbessert.
> Ist eine Photodiode(SFH203).

Meinst du Photodiode bringt an einem Arbeitswiderstand von 97 Ohm viel 
Signal ?

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut Lenzen schrieb:
> Meinst du Photodiode bringt an einem Arbeitswiderstand von 97 Ohm viel
> Signal ?

Normal müsste man bei Photodioden 1MOhm nehmen.
Die 97,5Ohm stammen aus der Berechnung vom Bandpass. Wenn ich nun R5 
ändere, stimmt doch mein ganzer Filter nicht mehr, oder?

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Normal müsste man bei Photodioden 1MOhm nehmen.
> Die 97,5Ohm stammen aus der Berechnung vom Bandpass. Wenn ich nun R5
> ändere, stimmt doch mein ganzer Filter nicht mehr, oder?

Richtig. Da muss noch ein Buffer OP zwischen um den Ausgang niederohmig 
zu machen. Die ganzen Filterschaltungen gehen von einer niederigen 
Generatorimpedanz aus.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Wo ist der Link zu Deinem Optokoppler-Datenblatt ?
2. Das Fotosignal könnte man z.B. mit einem OPV verstärken/entkopplen.

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der Link zum Datenblatt der Photodiode/Koppler fehlt immer noch.
Wieviel Strom bekommst du maximal von der Photodiode? 10uA?

Mit der Schaltung im Anhang ist die Empfindlichkeit um Faktor 40 höher 
wegen RF=100kOhm. Den musst du so einstellen, dass auch bei maximaler 
Umgebungshelligkeit der Transistor nicht am oberen Anschlag hängt.
Probiers mal mit dieser Schaltung.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Es macht keinen Sinn, die LED mit einem unsymmetrischen Rechteck 
anzusteuern, wenn du das Signal später mit einem Bandpaß herausfiltern 
willst. Herr Fourier läßt grüßen. Nimm ein symmetrisches Rechteck.

2. Die LED erhält höchstwahrscheinlich viel zu viel Strom. Das macht 
riesige Störungen in deiner Schaltung.

3. Der Basiswiderstand von Q1 ist viel zu klein.

4. Das Signal von der Photodiode mußt du erst mit einem Opamp aufpäppeln 
(Stichwort: "Transimpedanzverstärker"):

http://www.mikrocontroller.net/articles/Lichtsenso...

5. Der Bandpaß hat eine viel zu hohe Güte. Das quält nicht nur den 
OPamp, sondern es kann gut sein, daß du aufgrund der Bauteiletoleranzen 
der Filterbauteile die 5kHz garnicht triffst, sondern daneben liegst.

6. Warum teilst du denn im Bandpaßfilter das Eingangssignal mit R5 
herunter?? Ist dein Signal von der Fotodiode so groß, daß du das tun 
mußt?

7. Einfach den analogen Ausgang des Bandpaßfilters auf den 
Mikrocontroller zu geben, ist vielleicht keine gute Idee. Eventuell 
solltest du da noch einen Komparator mit Hysterese zwischenschalten, 
also einen Schmitt-Trigger.

Kai Klaas

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> Wo ist der Link zu Deinem Optokoppler-Datenblatt ?

Wie gesagt, ist eine SFH203FA
http://www.datasheetcatalog.org/datasheets/228/486465_DS.pdf

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke fürs Datenblatt.
Habe den Widerstand ganz links auf 10k reduziert.
Den Widerstand RF solltest du so wählen, dass die Spannung oben am Rf 
auch bei maximaler Umgebungshelligkeit unter 5V bleibt.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hhm, Hans fährt vielleicht einfacher mit einer OPamp-Schaltung...

Kai Klaas

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
OK, wenn er noch einen OPA übrig hat. :-)

Autor: Hans Bernd (baggy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die folgende Schaltung nun aufgebaut.
Problem ist immer noch, dass meine Versorgungsspanung durch die 
Sendediode einbricht.
Schalte ich ein weiteres Netzteil parallel bricht die 
Versorgungsspannung immer noch ein. Nur wenn ich die Sendediode mit 
einem separatem Netzteil betreibe, bleibt die Spannung stabil.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Problem ist immer noch, dass meine Versorgungsspanung durch die
> Sendediode einbricht.

Warum nimmst du die Stromversorgung für die Sendediode nicht direkt an 
V1 ab, sondern nach R7?
Wenn das unbedingt sein muss, dann vergrößere mal C4 deutlich (-> 
4700µF).

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich immer noch 8,5 Ohm lese und R7=100 Ohm, dann ist das ein 
wunderbarer Spannungsteiler. Dann kann für den Rest nicht viel übrig 
bleiben.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bevor Du Hildes Tip mit "Batterie anschließen" verwirklichst, schau rein 
vorsorglich nochmals ins LED-Datenblatt ob Deine LED für 200mA 
Dauerbetrieb bei >45 Grad zugelassen ist. Würde mich wundern.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Ich habe die folgende Schaltung nun aufgebaut.
> Problem ist immer noch, dass meine Versorgungsspanung durch die
> Sendediode einbricht.
> Schalte ich ein weiteres Netzteil parallel bricht die
> Versorgungsspannung immer noch ein. Nur wenn ich die Sendediode mit
> einem separatem Netzteil betreibe, bleibt die Spannung stabil.

Ich spring gleich an die Decke.
Da filtere ich extra die Spannung für die Auswerteschaltung damit die 
nichts von den Spannunsgeinbrüchen mitkriegt und die schließt genau da 
die Sendediode an. Muss man denn alles erklären?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich spring gleich an die Decke.
>Da filtere ich extra die Spannung für die Auswerteschaltung damit die
>nichts von den Spannunsgeinbrüchen mitkriegt und die schließt genau da
>die Sendediode an. Muss man denn alles erklären?

Von den sieben Punkten meines obigen Posts wurde nur ein einziger 
aufgegriffen und dieser auch nur von dir. Da Hans offenbar nicht gewillt 
ist, sein Vorgehen irgendwie näher zu erläutern, verabschiede ich mich 
aus diesem Thread und wünsche ihm viel Glück...

Kai Klaas

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> 1. Es macht keinen Sinn, die LED mit einem unsymmetrischen Rechteck
> anzusteuern, wenn du das Signal später mit einem Bandpaß herausfiltern
> willst. Herr Fourier läßt grüßen. Nimm ein symmetrisches Rechteck.

nehm ich doch 5kHz mit 100us hight und 100us low

> 2. Die LED erhält höchstwahrscheinlich viel zu viel Strom. Das macht
> riesige Störungen in deiner Schaltung.

laut Datenblatt kann die LED I=200mA bei tp=100us und D=0,5



> 6. Warum teilst du denn im Bandpaßfilter das Eingangssignal mit R5
> herunter?? Ist dein Signal von der Fotodiode so groß, daß du das tun
> mußt?

Habe den Filter mit FilterPro von TI konstruiert.
Siehe Beitrag 10.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans Bernd,

funktioniert es nachdem du die Photodiode direkt an die 
Spannunsgversorgung gelegt hast?

Falls du zuviel Photostrom hast, Widerstand RF verkleinern.

Gruß
Helmut

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
>> 6. Warum teilst du denn im Bandpaßfilter das Eingangssignal mit R5
>> herunter?? Ist dein Signal von der Fotodiode so groß, daß du das tun
>> mußt?

Das ist deshalb noetig damit man Guete und Resonanzfrequenz des 
Bandpasses getrennt einstellen kann.  Ohne den R5 ist die Guete von der 
Mittenfrequenz abhaengig.

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> funktioniert es nachdem du die Photodiode direkt an die
> Spannunsgversorgung gelegt hast?

Du meinst die Sendediode?!
Ja funktioniert super.

Geh gerade mal in die Sonne um die Empfindlichkeit gegen Fremdlicht zu 
testen.

Autor: Kai Klaas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>nehm ich doch 5kHz mit 100us hight und 100us low

Gut.

>Das ist deshalb noetig damit man Guete und Resonanzfrequenz des
>Bandpasses getrennt einstellen kann.  Ohne den R5 ist die Guete von der
>Mittenfrequenz abhaengig.

Das mag ja sein, daß man dann besser was verstellen kann. Hanses Problem 
ist aber nicht nur die Detektion der 5kHz, sondern auch noch die 
Verstärkung dieses Signals, da es wohl sehr schwach ist, nach der 
Reflektion am Wasserstrahl. Darauf läßt ja auch der utopisch hoch 
gewählte LED-Strom schließen. Wenn er im Bandpaßfilter das 
Eingangssignal so stark herunterteilt ((2,3k + 98) / 98 = 24) steht er 
doch mit leeren Händen da und muß woanders wieder verstärken.

Ein Herunterteilen ist ja nur notwendig, wenn neben den 5kHz noch andere 
AC-Komponenten im Signal vorhanden sind, die sonst das Bandpaßfilter 
übersteuern würden. Oder wenn das 5kHz schon sehr groß ist. Aber dann 
braucht er nicht den sehr hohen LED-Strom.
Vor einem Gleichanteil braucht er sich dagegen keine Sorgen zu machen, 
den blockt das Bandpaßfilter ja ganz von selbst.

Noch etwas:
Du solltest die Schaltung im Anhang verwenden, da du sonst kein 
positives Ausgangssignal erhälst.

Und noch mal zum Basiswiderstand R7. Ist dir bewußt, daß mit 100R dem 
Mikrocontroller ein Strom von (5V - 0,7V) / 100R = 43mA abverlangt 
wird???

Kai Klaas

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Bernd schrieb:
> Helmut S. schrieb:
>> funktioniert es nachdem du die Photodiode direkt an die
>> Spannunsgversorgung gelegt hast?
>
> Du meinst die Sendediode?!
> Ja funktioniert super.

Sorry, sollte natürlich Sendediode heißen.

> Geh gerade mal in die Sonne um die Empfindlichkeit gegen Fremdlicht
> zu testen.

Hoffentlch musst du dann den Widerstandswert nicht zu stark reduzieren
wegen Fremdlichtübersteuerung.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hoffentlch musst du dann den Widerstandswert nicht zu stark reduzieren
>wegen Fremdlichtübersteuerung.

Mit der SFH203 dürfte der Widerstand in der Gegenkopplung des 
Transimpedanzverstärkers bei 100000lux und 80nA/lux unter 1k liegen 
müssen, wenn die Photodiode direktes Sonnenlicht abbekommt.

Kai Klaas

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn da direkte Sonneninstrahlung möglich ist, dann muss da natürlich 
konstruktiv etwas dagegen getan werden, z. B. die Photodiode an das Ende 
eines kurzen Rohres setzen. Das Rohr muss natürlich waagrecht montiert 
sein, damit die Sonne nicht direkt einstrahlen kann.
Ansonsten bleibt noch die Möglichkeit den Widerstand RF durch eine 1H 
Spule zu ersetzen.

Autor: Hans Bernd (baggy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Ansonsten bleibt noch die Möglichkeit den Widerstand RF durch eine 1H
> Spule zu ersetzen.

Um wieviel würde dann denn mehr verstärkt?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Um wieviel würde dann denn mehr verstärkt?

Das Entscheidende ist, daß DC und damit der Gleichlichtanteil des 
Sonnenlichts nur relativ gering wird, im Gegensatz zu deinem Meßlicht.

Das kannst du ja selbst ausrechnen, wenn du weißt, daß die Impedanz 
einer Spule 2 x pi x f x L ist und bei DC f ja 0 ist. Lediglich der 
enldiche Wicklungswiderstand der 1H Induktivität kommt dann zum Tragen.

Allerdings ist eine Induktivität in der Gegenkopplung eines OPamps eine 
recht kritische Angelegenheit und kann erhebliche Stabilitätsprobleme 
zur Folge haben kann...

Kai Klaas

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das vom Wasserstrahl reflektierte Signal ist ziemlich klein.
Ist es möglich einen OP nach dem Bandpass zu schalten?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.