www.mikrocontroller.net

Forum: PC Hard- und Software RS485 Loopback


Autor: Rengglian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag Mikrocontroller Gemeinde,
ich habe hier (für mich) ein unerklärliches Problem mit einem RS323 /
RS485 Konverter. Der Konverter war bis zum gestrigen Tag erfolgreich im
Einsatz, aber nun ist keine Kommunikation mit dem Endgerät (nur
9600baud) mehr möglich.

Bei der Fehleranalyse ist mir beim Loopback Test, mit Docklight als
Terminal, folgendes aufgefallen:
Baud   TX           RX
9600   hello world  heþ
14400  hello world  helüû
19200  hello world  helloü
28800  hello world  hello woò
38400  hello world  hello worlä
56000  hello world  hello world

Der selbe Test mit den selben Einstellungen/Kabel mit einem Ersatzgerät
ergab:
Baud   TX           RX
9600   hello world  hello world
14400  hello world  hello world
19200  hello world  hello world
28800  hello world  hello world
38400  hello world  hello world
56000  hello world  hello world

Der funktioniert wie gewünscht.

Meine Feststellung ist nun, je länger der String ist desto höher muss
die Baudrate beim "defekten" Gerät sein.
Beim Ersatzgerät ist keine solche Abhängigkeit feststellbar.

Beim Konverter handelt es sich um Best.-Nr.: 981290 - 62 (Conrad)

Weiss jemand von euch eine Erklärung für dieses Verhalten und ev. sogar
eine Lösung?
Oder liegt wirklich ein Defekt am Konverter vor...

Gruss
Rengglian

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit separater Stromversorgung getestet?

Autor: Rengglian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Mit separater Stromversorgung getestet?

Nein noch nicht. Werde ich aber mal Testen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wäre nämlich denkbar, dass ein Elko an der parasitären Stromversorgung 
mau ist und die rasch zusammenbricht. Es scheint ja so zu sein, dass das 
Teil in ungefähr konstanter Zeit aufgibt.

Autor: Rengglian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe soeben den Test gemacht mit externer Versorgung.

Baud  TX           RX
9600  hello world  helloü×Kýý
14400  hello world  helloð×?Kùý
19200  hello world  hello worlþ
28800  hello world  hello world
38400  hello world  hello world
56000  hello world  hello world

Eine Veränderung ist sichtbar, funktioniert aber immer noch nicht 
annährend so gut wie das Ersatzgerät.

Da das Gerät ev. noch umgetauscht werden kann, werde ich keinen Blick 
ins innere des Gerätes werfen.

A. K. schrieb:
> Wäre nämlich denkbar, dass ein Elko an der parasitären Stromversorgung
> mau ist und die rasch zusammenbricht.

Könnte das auf Spikes / Störimpulse im System hinweisen? Momentan habe 
ich leider kaum die Mittel für eine genauere Analyse. Fakt ist einfach, 
es funktionierte mehrere Wochen.

Aber schon mal Danke für die Unterstützung

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.