www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Code Composer Essentials - Geschwindigkeit beim Code-Aufspielen


Autor: Hersbach (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi zusammen,

sagt mal, arbeitet wer von euch ebenfalls mit dem ode Composer und kann 
mir sagen, ob das Code-Laden bei euch auch etwas länger dauert?

Der rödelt da immer erstmal noch herum - bei IAR war alles ruck-zuck 
fertig.

Ist das bei euch auch so?

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun wissen wir ja praktischerweise nicht, welchen Controller Du 
verwendest, aber Du könntest mal die Einstellungen des 
Programmiererteils überprüfen. Wenn Du einen µC mit sehr viel Flash 
verwendest, dann kann es geschwindigkeitssteigernd sein, nur die 
verwendeten Bereiche zu löschen und zu programmieren, und nicht alles.

Autor: Hersbach (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, stimmt, die Info sollte ich euch nicht voenthalten:

Ich benutze einen MSP430F2418

8k   RAM
116k Flash

Ich wundere mich nur, wieso es dagegen beim IAR so schnell ging.

Leider bin ich über die 8k Code hinaus, daher arbeite ich nun bis zu den 
16k mit dem CCE weiter...

Autor: Jens A. (micro)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hast du die Frequqnzen des Flash tools richtig eingestellt.
Hatte mal mit dem C2000 das Problem.
Nach dem richtigen einstellungen ging es dann auch wieder schneller

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hersbach schrieb:
> 116k Flash
>
> Ich wundere mich nur, wieso es dagegen beim IAR so schnell ging.

Na, da wird wohl das komplette Flash gelöscht statt nur die von Deinem 
Programm benötigte Menge. Das sollte konfigurierbar sein.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nutzt du den LPT-Debugger? Der ist wirklich nur bei IAR schnell, bei 
mspgcc oder CCE ist der absolut lahm. Wieso weiß ich auch nicht, 
einstellen kann man da leider nix. Ich nutze seit Vista prinzipbedingt 
nur noch USB, der Olimex ist wahnsinnig schnell, das macht richtig Spaß.

Autor: Hersbach (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens A. schrieb:
> hast du die Frequqnzen des Flash tools richtig eingestellt

Was genau meinst du damit? Wo kann ih da was einstellen?

Rufus t. Firefly schrieb:
> Na, da wird wohl das komplette Flash gelöscht statt nur die von Deinem
> Programm benötigte Menge

Wo finde ich dazu was? Ich benutze CCS erst gerade zwei Tage, wolche 
Einstellungen habe ich noch nicht gefunden.

Christian R. schrieb:
> Nutzt du den LPT-Debugger?

Ja, ich benutze den LPT-Debugger.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.