www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR NET IO - uC Flashen


Autor: Philipp R. (philipp_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mikrocontroller Community,

ich habe mir vor kurzer Zeit das AVR NET IO Board von Pollin zugelegt.
Wie hier im Forum steht 'n Kühlbleck auf den Spannungswandler drauf und 
eingeschaltet. Ping funktioniert, Board scheint in Ordnung zu sein, also 
auf zum Selberprogrammieren.

Leider habe ich es bis dato noch nicht geschafft meine eigenen 
Anwendungen auf den ATMega32 zu flashen. Ich verwende den AVR ISP MKII, 
der leider keine Spannungsversorgung auf dem VCC Pin hat. Ich habe 
deshalb die Spannung am Board gelassen.

Beim Anstecken des ISP Kabels leuchtete sofort die SCK Led meines 6->10 
Adapters. Was bei näherer Betrachtung logisch ist, da dies auch der SCK 
der SPI schnittstelle zum ENC28J60 ist. Egal, auf Flashen gedrückt aber 
alles was ich bekomme ist
Setting mode and device parameters.. OK!
Entering programming mode.. FAILED!
Leaving programming mode.. OK!

Am ATMega liegst nicht, den habe ich gegen andere funktionierende 
getauscht.
Leider steht mir das STK500 zeitweise nicht zur Verfügung.

Mache ich grundsätzlich einen Fehler, oder ist irgendeine Hardware 
defekt?

freundliche Grüße
Philipp Reitter

Autor: Joachim K. (minifloat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm mal den ENCdingsbums aus der Fassung, der stört vielleicht die SPI- 
Kommunikation mit deinem AVRISP. Hast du die 10Pin Molex-Buchse auch 
richtig herum eingelötet?
mf

Autor: Philipp R. (philipp_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Board nicht selber gelötet, aber die Komponenten sind 
richtig rum eingebaut. (Widerstands- und Kondensatorenwerte habe ich 
nicht nachüberprüft).

Aber ich habe ein paar interessante Entdeckungen gemacht:
-Mit ENC28J60 und verbundenem Ethernet Kabel:
 Entering Programm Mode FAILED! SCK leuchtet.

-Mit ENC28J60 ohne Ethernet Kabel:
 Studio4 meldet kurzschluss zwischen MOSI, SCK und RESET

-Ohne ENC28J0 und verbundenem Ethernet Kabel:
 Entering Programm Mode FAILED! SCK leuchtet nur bis zum ersten versuch.

-Ohne ENC28J60 ohne Ethernet Kabel:
 Target Device hat scheinbar keine Power, Spannung 0.1V


Der ISP Stecker sitzt richtig.
Der Computer hängt sowie das Netzgerät im Stromnetz.

Handelt es sich hier um einen Fehler im Uusammenbau?
Ich glaub ich werd wohl doch wieder auf das STK warten müssen ...

Autor: Wichtel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp R. schrieb:
> -Ohne ENC28J60 ohne Ethernet Kabel:
>  Target Device hat scheinbar keine Power, Spannung 0.1V

Laut Schaltplan des AVRNETIO darf das nicht sein, da die Schnittstelle 
direkt mit dem 5V-Ausgang des Netzteil verbunden ist.

Hast schonmal manuell nachgemessen ob Spannung kommt?
Ist evtl. die ISP-Buchse verkehrtherum eingebaut sodass der Anschluss 
nur noch verkehrt passt?

Autor: Marcus B. (raketenfred)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich habe das stk 500 hier neben mir liegen und kann problemlos mit 
dem 10Pin ISP Stecker flashen

Spannung kommt über das stk500 auch, denke aber das macht keinen 
unterschied, wenn man das board selbstständig betreiben würde

der schlitz von der buchse für isp, zeigt von der lan buchse weg
lankabel und enc ist bei mir drin eingesteckt

habe aber das vor fertig gelötetes board

Autor: Philipp R. (philipp_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wichtel schrieb:
> Philipp R. schrieb:
>> -Ohne ENC28J60 ohne Ethernet Kabel:
>>  Target Device hat scheinbar keine Power, Spannung 0.1V
>
> Laut Schaltplan des AVRNETIO darf das nicht sein, da die Schnittstelle
> direkt mit dem 5V-Ausgang des Netzteil verbunden ist.
>

Ich habe die Kabel und den Adapter mal nachgemessen und habe entdeckt 
dass bei dem 6->10 PIN Adapter zumindest die GND Leitung getrennt war, 
obwohl er bis dato immer einwandfrei funktioniert hat, keine schäden 
erlitten hat und äußerlich auch einwandfrei aussieht.

Proforma nen neuen gebastelt und der uC lässt problemlos mit sich 
arbeiten.

Vielen Dank an Euch!
freundliche Grüße
Philipp Reitter

Autor: Wichtel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitteschön, danke für Rückmeldung!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.