www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Verstärkung funktioniert nicht


Autor: Matthias O. (oesema)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen.

Ich lasse mir über einen d/a- Wandler eine Spannung von 0-5V ausgeben.

Nun versuche uch diese mittels eines lm358n auf 0-15V zu verstärken( nur 
testweise, zumal ich später -5-20V brauche).

Ich dachte mir kein Problem, 2 Widerstände an den OP und gut ist, habe 
ihn an 15V und GND als Versorgung, und ich wäre ja schon glücklich wenn 
er bis 12 Volt verstärkt hätte, nun aber das Problem.

Wären ich die Spannung an dem + Eingang langsam von 0V bis 5V linear 
hochfahre, kriege ich am Ausgang bis ca 800mV Eingangsspannung ca 0,003 
Volt und ab dann 12,7 im Ausgang.

Verwende einen ad 420 und habe auch schon das ic (Wandler wie auch OP 
getauscht)

Als Widerstände habe ich 5k und 10k gewählt.

Wäre spitze wenn jm Anregungen zur Fehlerbeseitigung hat, da ich echt 
noch keinen Lösungsansatz habe.

Danke schon mal

Oesema

Autor: Marius Wensing (mw1987)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan?

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat da jemand einen Trigger gebaut?

Autor: Fred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan her!

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fred schrieb:
> Schaltplan her!

lol

Autor: Fred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja was denn? :)

Autor: Matthias O. (oesema)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan kommt, existiert zur Zeit nur auf dem Papier.

Die Sache ist, wenn ich auf den Eingang des OP´s 3V von nem 
Steckernetzteil gebe funktioniert die verstärkung, hab mir dann 12V über 
nen Spannungsteiler aufgeteilt um die Eingangsspannnung über ein Poti 
etwas zu variieren und auch das läuft. Nur wenn ich 0V bis 5V von dem 
DAC Ausgang drann lege nicht mehr. Den Ausgang des DAC hab ich mit nem 
Oszilloskop und mit nem Multimeter gemessen, das sieht gut aus. Wenn ich 
den OP als Impedanzwandler schalte geht es auch, nur nicht als 
Verstärker..

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias Oeselke schrieb:
> Schaltplan kommt, existiert zur Zeit nur auf dem Papier.

Dann scan den doch ein oder mach ein Foto davon.

Autor: Michael Roek (mexman) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
"2 Widerstände an den OP und gut ist"

Tja, der Trick besteht darin, diese Widerstaende an die richtigen OP 
Beinchen zu legen!
Nicht an den nichtinvertierenden sondern den invertierenden Eingang!
Und den nichtinvertierenden auf Masse legen geht nicht!

Da Du sowieso spaeter eine negative Ausgangsspannung haben willst, 
solltest Du schon jetzt mal eine +/- Versorgung bereitstellen. Dann wird 
das Ganze auch was


Gruss

Michael

Autor: Bersch (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also erstmal nur mit positiver Verstärkung geht es in der Simulation ja 
auch auf jeden Fall.

Autor: Bersch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthias Oeselke schrieb:
> Wenn ich
> den OP als Impedanzwandler schalte geht es auch

Mach doch mal einen Impedanzwandler vor den Verstärker

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Mach doch mal einen Impedanzwandler vor den Verstärker
Wozu? Er hat doch gemessen:
>>>> Wären ich die Spannung an dem + Eingang langsam von 0V bis 5V
>>>> linear hochfahre
Da brauchts keinen Impedanzwandler. Der Fehler liegt woanders.

Autor: Matthias O. (oesema)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So hier ist der Schaltplan.

Hab die Widerstände in Rot eingezeichnet. Nimmt man den gegen Masse raus 
und brückt den anderen ( also Impedanzwandler), dann funktioniert es, 
mache ich es aber so wie gezeichnet klappt nix mehr.

Autor: Bersch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mal Figure7 aus dem Datenblatt probiert, ob er dann macht, was 
er soll - da ist ja der bipolare Ausgang beschrieben.

Autor: Matthias O. (oesema)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja hab ich, die Dimensionierung der Widerstände ist da ja auch 
beschrieben, habe den OP dann für +/- 10 Volt am Ausgang beschaltet.
Läuft aber auch nicht, hatte dann am Ausgang entweder annährend 0V oder 
dann Sprunghaft ca 28V..
Die beiden 10k parallel hab ich nur genommen weil ich keinen 5k mehr 
hatte.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du es mal nur probehalber mit nem anderen OP versucht?

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> So hier ist der Schaltplan.

Sieht richtig aus.

Vermutung: Widerstände falsch abgelesen oder kontaktiert.

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank schrieb:
> Hast du es mal nur probehalber mit nem anderen OP versucht?
Ja, schreibt er oben.

Autor: Matthias O. (oesema)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kaum macht man alles richtig, funktioniert es:-)

Hab die OP- Schaltung noch mal seperat aufgebaut und siehe da die 
Spannung steigt parallel zu meinen 0V-5V vom DAC von - 10 bis + 10 Volt.

Ich glaube ich hatte bei der vorherigen Schaltung den ein oder anderen 
falschen Kontakt was GND und - 15 Volt betrifft. Irgendwann ist die 
Konzentration vorbei.. oh man ich freu mich:-)

Ich danke euch für eure Anregungen und vor allem für euer Interesse!!!!

Ach, mal noch was anderes, hat jm ne Idee wie ich die Potentiale so 
verschieben kann das ich daraus -5V - +15V bekomme? Besser neuen Thread 
auf machen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Indem man einen R von exakt 30k gegen +15V schaltet. Da damit aber der 
30k quasi parallel zum 5k liegt (verstärkungstechnisch betrachtet), 
erhöht sich die Verstärkung etwas (was Du ja eigentlich auch willst, 
weil die Ausgangsspanne ja jetzt 20V überstreicht, also v=4 nötig). Den 
5k mußt Du also noch mal neu berechnen, um mit 30k parallel auf zusammen 
3,3k zu kommen, weil dann der resultierende 3,3k und der 10k 
(Rückkopplung) v=4 ergibt für das Eingangssignal

Autor: Matthias O. (oesema)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> weil die Ausgangsspanne ja jetzt 20V überstreicht, also v=4 nötig)

Die Spanne zwischen -10V bis +10V, ist doch die gleiche wie zwischen -5V 
und +15V oder? Meine Verstärkung bleibt ja gleich oder nicht? Nur halt 
nicht mehr mit GND als bezug sondern +5V. Kann man das so sagen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ging es nicht erst um die Spanne zw. 0 und 15V? Vielleicht habe ich auch 
nur den Faden verloren in diesem thread

Autor: Matthias O. (oesema)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja in meiner ersten Testschaltung.

Im Datenblatt des ad 420 ist aber u.a. die Beschaltung für -10V bis+10V 
beschrieben, die für mich noch besser ist, da ich real -5V bis +15V 
benötige.

Hatte das nur am Anfang nicht mit aufgeführt da ich ja schon mit einer 
simplen Verstärkung zu kämpfen hatte und das ganze nicht unnötig 
kompliziert darstellen wollte.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.