www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik NAND Gatter funktioniert nicht


Autor: Theo H. (theovention)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorweg schonmal:
Einen Beitrag mit identischem Titel gab es schon einmal. In diesem 
Beitrag ging es allerdings um einen SN74LS01. Ich weiß nicht, wie weit 
die Lösung dieses Beitrags auch auf den SN7400 zutrifft.

Ich habe ein Problem mit einem SN7400 NAND-Gatter. Wenn ich VCC und zwei 
Eingänge anschließe, dann sollte ja aus dem zugehörigen Anschluss kein 
Strom herauskommen. Das tut er aber.

Es kommt dabei also folgende Wahrheitstabelle heraus:
A B Y
0 0 1
1 0 1
0 1 1
1 1 1
Sobald ich VCC angeschlossen habe ist Y immer 1.

Weiß jemand, woran das liegen könnte?

Autor: Hallo011 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle offene Eingänge auf GND legen.
Vielleicht mal einen Kondensator zwischen Plus
und Minus vom IC legen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Alle offene Eingänge auf GND legen.
Nicht unbedingt nötig, denn ein nicht angeschlossener Pin ist bei TTL 
(SN7400) automatisch ein High-Pegel.

Theo H. schrieb:
> Einen Beitrag mit identischem Titel gab es schon einmal.
Ein Link zum erwähnten Beitrag wäre da nicht schlecht gewesen...  :-/

> Sobald ich VCC angeschlossen habe ist Y immer 1.
Aber GND schliesst du schon auch an?

> Ich habe ein Problem mit einem SN7400 NAND-Gatter.
Mach doch mal ein Foto von deinem Versuchsaufbau.

Autor: Theo H. (theovention)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Aber GND schliesst du schon auch an?

Nein. Ich wusste nicht, wo ich das anschließen soll, deswegen habe ich 
es gelassen. Ich bin noch nicht so erfahren in elektronischen Dingen, 
deshalb wusste ich es micht.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GND kommt an - deiner Stromquelle

GND - Masse - Minus

sind alles nur verschiedene Bezeichnungen für immer dasselbe: Das 
Bezugspotential, im Regelfall das Minus der Stromquelle.

Autor: Hallo011 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GND ist dein Minus. Mußt du auch anschließen.
Und die Eingänge die du benutzt, nicht offen lassen.
Also über einen Widerstand an GND legen. Sag mal 10K oder höher.

Autor: Hc Zimmerer (mizch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Er nannte den SN7400, also Standard-TTL.  Da ist es völlig in Ordnung, 
Eingänge offen zu lassen.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo011 schrieb:

> Und die Eingänge die du benutzt, nicht offen lassen.
> Also über einen Widerstand an GND legen. Sag mal 10K oder höher.

Wie schon gesagt, ist das bei TTL nicht notwendig. Ein Gatter eines 7400 
stört sich nicht daran, wenn andere Gatter offene Eingänge haben (die 
bei TTL als High gewertet werden).
Zum Basteln auf dem Steckbrett ist es bei TTL ok, wenn man nur das eine 
Gatter beschaltet, welches man benutzt.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Da ist es völlig in Ordnung, Eingänge offen zu lassen.

Allerdings nicht, wenn er eine 0 am Eingang haben will.
Und da er schon GND nicht angeschlossen hat,
ist er vielleicht der Meinung, daß ein Eingang, der
ebenfalls einfach nicht angeschlossen ist, 0 sei.

Ist er aber nicht, er muss an Masse=GND gelegt werden.

Ist er offen, gilt er als (schlechte) 1.

Autor: Theo H. (theovention)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich die Erdung an das Minus mit einer einfachen Drahtbrücke 
anschließe, kommt immer 0 dabei heraus, wenn ich stattdessen einen 
Widerstand nehme, dann ist wieder alles so wie bisher.
Kann es vielleicht sein, das die Spannung zu stark oder zu schwach ist? 
Ich habe eine einfache 9V-Blockbatterie benutzt, daran einen Widerstand 
angeschlossen und an diesen VCC und alle Eingänge.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Theo H. schrieb:
> Wenn ich die Erdung

Das heisst Ground oder Masse.
Sag bitte nicht Erdung (auch wenn das die scheinbare Übersetzung von 
Ground ist). Eine Erdung ist etwas anderes.

> an das Minus mit einer einfachen Drahtbrücke

> Ich habe eine einfache 9V-Blockbatterie benutzt,

Autsch.
Gratuliere: Du hast deinen IC höchst wahrscheinlich von seinen Leiden 
erlöst.
TTL will 5V! Und die sollten auch noch ziemlich gut stimmen. Das einzige 
was dich jetzt noch retten könnte ist, wenn die Batterie schon so 
ausgelutscht war, dass die Spannung sofort zusammengebrochen ist.

Vergiss diese Batterie/Notlösung/Zehner Diode/Spannungsteiler/sonstige 
Behelfe.
Damit hab ich mir in meinen Anfangszeiten auch den einen oder anderen 
74... gegrillt, bis ich es dann endlich geglaubt habe:
Steckernetzteil mit 8V oder 9V Gleichspannung, dahinter ein 7805 (+2 
Stück 100nF) und du hast Ruhe.


> daran einen Widerstand
> angeschlossen und an diesen VCC und alle Eingänge.

Mach mal ein Photo von deinem Aufbau

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Kann es vielleicht sein, das die Spannung zu stark oder zu schwach ist?
> Ich habe eine einfache 9V-Blockbatterie benutzt,

Troll ?

Vielleicht vorher mal in das Datenblatt (=die offizielle Beschreibung) 
zu dem Chip gucken, den du gerade kaputtmachen willst ?

http://focus.ti.com/lit/ds/symlink/sn74ls00.pdf

Und dir Gedanken darüber machen, was ASOLUTE MAXIMUM RATINGS bedeutet ?

Kauf dir halt einen neuen Chip.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Troll ?
Schon sehr trollig, bisher...

> was ASOLUTE MAXIMUM RATINGS bedeutet ?
Was bedeutet ASOLUTE?  ;-)


Karl heinz Buchegger schrieb:
> Damit hab ich mir in meinen Anfangszeiten auch den einen oder anderen
> 74... gegrillt
Ach, DU warst das... ;-)

> Mach mal ein Photo von deinem Aufbau
Und wenn das nicht kommt: Troll!

Autor: Jakob B. (teddynator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Theo H. schrieb:
> Ich habe eine einfache 9V-Blockbatterie benutzt, daran einen Widerstand
>
> angeschlossen und an diesen VCC und alle Eingänge.

Leute lest den Text mal fertig.
Er hat vor VCC einen Widerstand. Wenn dieser groß genug ist muss das IC 
nicht zwnagsweise kaputt gehen (Auch wenn ich absolut nicht der Meinung 
bin dass das eine angebrachte lösung ist um ein TTL IC zu versorgen.) 
Also lieber 7805 und zwei 100n.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.