www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik rand() und Atxmega32A4


Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Habe gerade feststellen müssen, dass die rand()-Funktion beim xmega32A4 
nicht funktioniert. Stimmt das, oder bin ich zu doof sie einzusetzen?

lg
Andy

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich wüsste keinen Grund warum die bei einem bestimmten Prozessor nicht 
wie vorgesehen funktionieren sollte.

Ist doch nur eine Formel, die aus einem Wert den nächsten Wert 
berechnet.

Autor: Floh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andy schrieb:
> Habe gerade feststellen müssen, dass die rand()-Funktion beim xmega32A4
> nicht funktioniert. Stimmt das, oder bin ich zu doof sie einzusetzen?

Da du weder Code zeigst noch erklärst, warum die WErte nicht stimmen 
können, denke ich letzteres.
:-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.