www.mikrocontroller.net

Forum: Digitale Signalverarbeitung / DSP Von Laplace zu Z transformieren


Autor: Dibo Dibo (Firma: FH) (duspol)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fo(s)=(1+s) / (1+2s) -->muss diskretisiert werden für die Abtastzeit 
Ta=1.

G(z)=(0.5 - 0.1065z^-1)/(1 - 0.6065z^-1)-->die Lösung.

ich ersetze s=1/Ta(z-1) oder 2/Ta*(z-1)/(z+1) Aber es funktioniert 
nicht.

Mach ich was falsch?

Autor: blubb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weißt du wie die Lösung hergeleitet wurde?

Ich nehme in der Regel immer eine Korrespodenztabelle (s Funktion 
zerlegen, so dass sie in der Tabelle kommt, entsprechende z Funktionen 
auswählen, z Funktion auf einen Nenner schreiben.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ich ersetze s=1/Ta(z-1) oder 2/Ta*(z-1)/(z+1) Aber es funktioniert
>nicht.
>Mach ich was falsch?

Ist schon ein Weilchen her, aber ich kann mich erinnern, dass sowas 
immer auf folgendes herauslief:

- Sprungantwort des System H(s) ermitteln.
- H(s) diskretisieren,
- das Ganze mit (z+1)/z multiplizieren, dadurch entsteht H_null_G(z)
- geeignet umformen.

Hm.. ich müsste mal nachsehen

Autor: Dibo Dibo (Firma: FH) (duspol)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
blubb schrieb:
> Weißt du wie die Lösung hergeleitet wurde?
>
> Ich nehme in der Regel immer eine Korrespodenztabelle (s Funktion
> zerlegen, so dass sie in der Tabelle kommt, entsprechende z Funktionen
> auswählen, z Funktion auf einen Nenner schreiben.

Ja so wird es gemacht.ich glaub was ich mache ist,Näherungsweise 
Z-Transformation.Aber mein G(Regler)[--->Nur Regler 
Übertragunsfuntion]ist
Zähler 2.Ordnung und Nenner 3.Ordnung.

Die Übertragungfunktion habe ich mit Tustin_Formel diskretisiert.Das 
problem ist,dass ich kein Ek bei der reglergleichung habe 
(Yk=Yk-1..+Ek-1...).

Autor: Duspol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mit Tustin mein regler diskretisiert.

Dann habe ich mit step Befehl 10 sec simulieren lassen und das gleiche 
mit simulink gemacht.Die Sprungantworten sind bisschen anders.Da mein 
Verhält sich wie I Anteil und mit Matlab(Workspace Step-Befehl)geht er 
von 0 bis 9(in 10 Sekunden).Aber bei Simulink geht er von 0 bis 8.Woran 
könnte es liegen?

Autor: Duspol (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Sprungantworten sind im Dateianhang.ich habe alles probiert aber es 
geht leider nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.