www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Problem, Einseitiges PCB, usbprog->mkII


Autor: Alex -- (wing)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin moin,

vor einigen Wochen ist mir eine Idee zu einem kleinen Projekt gekommen.
Das wurde dann auch fix gebaut. PCB gebügelt und geäzt. Program 
raufgespielt. Die einzelnen Komponenten, also das Relay und der Treiber 
funktionieren. (Auch wenn in der Schaltung im Anhang die 
Versorgungsleitungen Fehlen, die habe ich später nachgelötet aus Sorge 
um einen etwas zu hohen Strom bei zu schmalen Leitungen.)

Rein Funktional wäre das Board bereit zum Einsatz, allerdings kann ich 
es nicht über den ISP programmieren. Das wird/würde die Entwicklungszeit 
(abgesehen davon das es übel nervt wenn man den Kontroller andauernd 
raus und wieder reinstecken muss) enorm erhöhen.
Ich benutzte den usbprog (http://www.embedded-projects.net/usbprog/)
Die Pinbelegung (Website oder Anhang) habe ich schon mehrfach auf 
Richtigkeit und Durchgang überprüft.

Die Versorgungsspannung ist glatt (gemessen direkt an den beiden 
Versorgungspins des atmega8, hab das Glück ein Oszilloskop zu besitzen)

Der Kontroller lässt sich wunderbar auf meinem Breadboard programmieren 
(Minimalbelegung: MISO MOSI SCK RST, Versorgung: kleines 
Computernetzteil).

Wenns dann aber ans PCB geht (richtig rum eingesteckt, TreiberIC 
entfernt)
bekomme ich folgende Fehlermeldung:

-------------
C:\>avrdude -p m8 -P usb -c avrispmkII

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: stk500v2_program_enable(): bad STK600 connection status: 
Unknown (0x64)

avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.
--------------

Das ist nicht das erste mal das ich so eine Fehlermeldung sehe, aber 
mitlerweile hab ich alle Fehlerquellen die mir eingefallen sind 
abgearbeitet. Jemand ne Idee?

Autor: chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm hast du auch den GND verbunden mit deinem ISP stecker? Sehe ich im 
Schaltplan jetzt nicht heraus.

Autor: Alex -- (wing)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
chris schrieb:
> hmm hast du auch den GND verbunden mit deinem ISP stecker? Sehe ich im
> Schaltplan jetzt nicht heraus.

Die hatte ich komplett übersehen ... auf meinem Breadboard ist sie dann 
natürlich vorhanden >_>... und siehe da, es geht.

Einer der größeren Vorteile wenn man in nem Büro arbeitet... es 
funktioniert nicht! es geht nicht! zu stönen ... und dann kommt ein 
Kollege vorbei guckt dir eben über die Schulter und sagt : Haste auch 
GND verbunden ^__^...
(Erstmal bloated alles andere durchmessen au man ... ~_~)

Dankeschön!!! Es geht...es geht ^__^

Autor: chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gerne doch :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.