www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pollin Net-IO Port C Problem


Autor: Dennis J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich habe ein Pollin AVR Net-IO und folgendes Problem:

Vom Port C kann ich nicht alle Pins ansteuern!

PC0 --- geht        --- Named Pin
PC1 --- geht        --- Named Pin
PC3 --- geht nicht  --- Named Pin
PC4 --- geht nicht  --- Stella Light
PC5 --- geht nicht  --- Stella Light
PC6 --- geht        --- Stella Light
PC7 --- geht        --- Stella Light

Was kann das sein?

LG

Autor: Timmo H. (masterfx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast wahrscheinlich noch den JTAG aktiviert (siehe S. 60 Handbuch 
ATmega32). Kannst du in den Fuse-Bits ausschalten (JTAGEN).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.