www.mikrocontroller.net

Forum: PC Hard- und Software Schwerwiegendes Bluescreen Problem


Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

mich verfolgt seit Wochen dieser Bluescrrenwahn. Am Anfang trat er ganz 
sporadisch auf und mittlerweile tritt er jede 5 Min auf.

Fehlercode und verursachender Treiber ca. 10 + x verschiedene. Das geht 
von Fehlercode 7F, 8e...D1 etc pp und vom verursachenden Treiber 
notskrnl.exe, atapi.sys, ataport.sys etc pp. Buck Check String ist 
meistens der DRIVER_IRQL_Not_LESS_OR_EQUAL aber auch nur 
IRQL_NOT_LESS_OR_EQUAL und auch UNEXPECTED_KERNEL_MODE_TRAP

Selbstverständlich habe ich mich im Internet nach solchen Problemen 
umgesehen und ein paar Sachen versucht.
Folgendes habe ich bisher gemacht:

- CPU und Festplatten - Test mittels Software. Keine Fehler

- Arbeitsspeichertest mit MemTest. Keine Fehler

- Habe gelesen MemTest kann anzeigen, dass es keine Fehler gibt aber 
trotzdem welche besitzen. Ich habe 2 RAM-Module, von denen ich jeweiles 
einen alleine laufen haben lasse und Steckplatz gewechselt. Hab daher 
Arbeitsspeicher ausgeschlossen.

- Meine Festplatte macht derzeit extreme "Piepgeräusche" z.B beim Daten 
übertragen auf einen USB-Stick, so dass ich davon ausgegangen bin, dass 
sie kaputt ist, obwohl der Test positiv verlief. Habe daher eine andere 
Festplatte eingebaut und versucht Windows 7, mittels CD, auf diese zu 
installieren. Sobald ich die zu dem Menü komme, wo ich die Sprache 
auswählen kann, kommt jedes Mal ein weiterer Bluescreen. Fehlercode F7 
und D1.

- DVD-Laufwerk habe ich auch schon abgestöpselt.

- CPU Temperatur 50 Grad und Spannungen sind auch korrekt.

Jetzt habe ich einen "Trick" herausgefunden, wie ich kein Bluescreen 
bekomme. Ich lasse einfach Memtest laufen. Starte ich also MemTest, dann 
kommt in der Regel kein Bluescreen. So habe ich meinen Computer schon 
dazu gebracht 15 Stunden und mehr keinen Bluescreen zu bekommen. Beende 
ich MemTest, dann habe ich meistens sofort nach Beendigung einen 
Bluescreen, wenn nciht sofort dann anch 5 Minuten. Mittlerweile benötige 
ich auch ca. 5 + x Bootvorgänge, damit ich MemTest starten kann, bevor 
ein Bluescreen kommt. Ganz selten kommt ein Bluescreen, obwohl ich 
MemTest laufen habe. Das kommt allerdings relativ selten vor. Ohne hält 
er wiegesagt nicht mehr 5 Minuten aus. Anfangs lief er auch mal mehrere 
Stunden.

Was könnte nun das Problem sein? MotherBoard? Bios? Windows 7 lief auf 
meinem PC ca. 1 Jahr ohne einen einzigen Bluescreen. Ich hab auch keine 
Hardware installiert, als da sProblem auftrat. Es kam aus dem nichts. 
Ich glaub einen Tag vorher hat mir Win7 ein Update automatisch 
aufgespielt.

Habe einen Intel P. 4 mit 3GHz
1GB Ram
Windows 32 - Bit
ATI Radeon 9200, ich weiss, es gibt dazu keinen Win7-Treiber, aber 
vorher liefs auch ein Jahr.
P4P800 SE Asus Board

Autor: Ronny Minow (hobby-coder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

versuche mal bitte folgendes:

* windows live cd/ dvd nutzen (ggf. auf 2. pc eine erstellen)
* linux live cd laufen lassen

laufen beide live systeme ohne probleme? wenn ja, windows 7 neu 
einrichten.
wenn nein, netzteil tauschen und system checken. läuft es? wenn ja, 
netzteil defekt -> austauschen. wenn nein -> mainboard checken.

das sollte erst einmal helfen...

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ich würde auf Speicher tippen (oder einfach irgendwo 
Kontaktprobleme).

Speicher lässt sich doch eigentlich einfach bestätigen oder 
ausschließen,
indem man mal ein paar andere Riegel einsetzt.
Vielleicht kannst du mal aus einem anderen Rechner welche leihen, muß ja 
nicht der eigene sein.

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was auch sein könnte: irgendein Problem mit Stromsparmodi etc.;
vielleicht mal sicherheitshalber im BIOS alles in dieser Richtung 
abschalten.
Das würde auch zur Beobachtung passen, daß es mit laufendem memtest 
besser geht.

Mal eine Live-CD ist auch eine gute Idee, sehe ich ebenfalls so.

Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal Danke für die Antworten.

Es zeichnet sich schon seit Wochen, die Suche nach der berühmten 
Stecknadel im Heuhaufen ab.

Software dürfte nicht das Problem sein, wie ich geschrieben habe, habe 
ich versucht auf einer ganz anderen Festplatte Windows 7 zu 
installieren. Daher verstehe ich den Ansatz von einer Live CD nicht 
ganz.

Zum Thema Arbeitsspeicher schrieb ich, dass ich einen Test gemacht habe 
(MemTest) allerdings über Windows, und da dieser Test wohl sowieso zum 
Knicken ist, habe ich mal nur dne Riegel laufen lassen und dann mal nur 
den. Sind beide kaputt?

Im Bios sind die Spannungen richtig, Vcore 1,3 V usw. Kann es trotzdem 
daran liegen?

Das Problem ist auch, dass ich nicht Teile einfach ersetzen kann, da sie 
nicht vorliegen, wie z.B. weiteres Netzteil. Weitere Riegel.

Deswegen dachte ich der Hinweis, dass wenn ich MemTest über windows 
laufen lasse, kein Bluescreen kommt, würde eine nahe Vermutung zulassen. 
Ich bekam ja einen Hinweis mit den Stromsparmodi im Bios. Das werd ich 
mal prüfen müssen, allerdings kenne ich mich im Bios noch nicht so aus, 
und weiss jetzt spontan ohne zu gucken nicht, wo ich diese Einstellungen 
dort vornehme.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mögliche Ursache: Elkos auf dem Mobo, welche für die RAM-Spannung 
zuständig sind. Oder/ auch CPU. Mit Memtest im Hintergrund fallen die 
Lastwechsel kleiner aus, deshalb läuft er da (noch) ohne BlueScreen.

Autor: User (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum nicht auch Elkos im Netzteil? Der Durchschnitt der Spannung mag ja 
noch stimmen ;)

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
User schrieb:
> Warum nicht auch Elkos im Netzteil? Der Durchschnitt der Spannung mag ja
> noch stimmen ;)

Wäre auch möglich, aber da würde memtest im hintergrund keine Änderung 
des Verhaltens bewirken.

Autor: User (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der ESR der Netzteil-Elkos kann unvorteilhafte Auswirkungen auf den 
Regelkreis des Netzteils haben.

Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry Leute, ich verstehe nur Bahnhof.

Elkos für Mobo? Ich schätze Mobo steht für Motherboard?
ESR im Netzteil-Elko?
Und für Laien?

Sehe ich das also richtig, Probleme könnten z.B. sein Motherboard oder 
Netzteil.
Um das rausfinden zu können, wird man dann wohl leider zu einem Ersatz 
greifen müssen, ohne wirklich zu wissen, obs daran liegt.
Ob ein neuer PC dann nicht die bessere Lösung wäre, mhh

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jojo schrieb:
>
> Zum Thema Arbeitsspeicher schrieb ich, dass ich einen Test gemacht habe
> (MemTest) allerdings über Windows, und da dieser Test wohl sowieso zum
> Knicken ist

Richtig erkannt. Da Windows keinen Zugriff auf bestimmte, vom System 
belegte Speicherbereiche zuläßt, kann das Tool gar nicht alles 
überprüfen. Check das nochmal mit dem "richtigen" memtest86+:

http://www.memtest.org/

Das startet man von Diskette oder CD, so hat es den kompletten PC für 
sich.

> Sehe ich das also richtig, Probleme könnten z.B. sein Motherboard oder
> Netzteil.

Schau dir die Elkos erstmal an, ob welche aufgebläht oder gar 
ausgelaufen sind.

Autor: Berni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alle BIOSeinstellungen zurücksetzen, kein Übertakten !

Speicherzugriffe auf "langsam" einstellen. "Fail Save" wählen, wenn 
möglich.

Andere Speichermodule prüfen.

Tritt der Fehler vorwiegend morgens auf?
Dann ist es ein thermisches Problem. das sind Haarrisse oder kalte 
Lötstellen. Dann kannst du den PC wegwerfen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.