www.mikrocontroller.net

Forum: PC Hard- und Software PC per RCT automatisch starten lassen


Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das BIOS der PCs hat üblicherweise eine über die RTC steuerbare 
Startfunktion: man stellt den Starzeitpunkt ein und fährt die Mühle 
herunter. Ist der Zeitpunkt erreicht, dann startet sie, ohne daß das 
Betriebsystem irgendwas dazu tun müßte. Insbesondere muß der Rechner 
nicht - wie bei der Windows-Bordfunktion üblich - im Hybenate Modus 
sein.

Früher - vor Jahren - hatte ich mit dem RTC-Start keine Probleme; das 
hat völlig sicher funktioniert.

Dann habe ich auf Basis eines ASUS P5E Mainboards einen Rechner 
zusammengeschraubt und bei dem ist die schöne RTC-Funktion zwar im BIOS 
vorhanden, aber sie funktioniert nicht. Warum weiß der Teufel.

Ich hatte dann den Technischen Service von ASUS angeschrieben und 
erhielt die Antwort, das Netzteil sei zu schwach, ich bräuchte ein knapp 
3-mal so starkes. Blödsinn, denn die Kiste läuft problemlos hoch, wenn 
ich sie im BIOS so einstelle, daß sei nach einem Power-Failure starten 
soll und über die Steckerleiste der Strom eingeschaltet wird - oder 
funktioniert das so völlig anders, als ein RTC-Start?

Nun habe ich einen alten Rechner mit einem ASUS P3B-F Mainboard 
reaktiviert. Bei der Kiste funktionierte der RTC-Start, nachdem ich ihr 
eine neue Pufferbatterie spendiert hatte.

Die ist jetzt mit Debian Lenny als Kommandozeilensystem konfiguriert und 
läuft ganz ordentlich - nur der verdammte RTC-Start funktioniert 
plötzlich nicht mehr.

Hat jemand eine Idee, woran das liegen könnte?
Sind bei der Startfunktion irgend welche Hardware-Besonderheiten im 
Spiel?

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steuerst du die Aufweckzeit per Programm oder per manuellem Eintrag ins 
BIOS? Programmgesteuert gibt's da eine Falle, weil viele BIOSe die 
Aufweckzeit nur beim Start des Rechners in die RTC kopieren. Ziemlich 
dämlich, weil man das i.d.R. vor dem Shutdown setzt, aber so ist es 
leider oft.

Tipps zu diesem Thema findet man im Umfeld vom VDR: 
http://www.vdr-wiki.de/wiki/index.php/NVRAM_WakeUp

Bei neueren Rechnern funktioniert nicht selten der ACPI Wakeup: 
http://www.vdr-wiki.de/wiki/index.php/ACPI_Wakeup

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Steuerst du die Aufweckzeit per Programm oder per manuellem Eintrag ins
> BIOS?

Ich machs im BIOS und der Wert ist nach dem Shutdown unverändert.

Danke für die Links. Besonders der zweite sieht interessant aus.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:

> Ich machs im BIOS und der Wert ist nach dem Shutdown unverändert.

Der sollte dadurch auch nicht verändert werden. Aber dieser Wert steht 
zunächst nur im NVRAM drin, nicht zwangsläufig auch in den 
entsprechenden Alarm-Registern der RTC.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, ich hab die verfluchte Hütte nicht dazu bewegen können, die Mühle 
unter Debian Lenny per RTC gestartet zu bekommen.

Jetzt hab ich mal probeweise DSL von der CD gebootet, und siehe da, der 
RTC-Start funktioniert wieder. Nach einem Boot mit Lenny geht es wieder 
nicht mehr.

HWCLOCKACCESS=no ist in rcS gesetzt. Es wird von zwei Skripten 
abgefragt, aber das scheint nicht zu reichen.

Offenbar hat Lenny auch mit Kernel 2.6.26-2-686 noch Probleme mit der 
RTC.

Vielleicht sollte ich mal versuchen, ACPI bei Start abzuschalten.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Boot-Parameter pci=noacpi hat auch nichts geändert...

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erklär mir jetzt bloss mal, wie du dir diesen Zusammenhang vorstellst. 
Die RTC ist ein Stück Hardware, die den Rechner einschaltet, kein 
kleiner 4-Bit Microcontroller unter debian. Das Betriebssystem hat nur 
dann damit zu tun, wenn die oben verlinkten Mechanismen diesen Zeitpunkt 
definieren, was dich aber sowieso nicht wirklich interessiert.

Wenn das BIOS korrekt eingestellt wurde und der Wecktermin aktiv ist und 
zuschlägt, dann kann das Betriebssystem auf den Aufweckvorgang selbst 
keinerlei Einfluss haben. Ein Betriebssystem kann allenfalls den 
Abschaltvorgang beeinflussen, aber nicht den Einschaltvorgang.

Ist ja nicht so, dass in den Paar Transistoren des (ehemaligen) MC6818 
ein kleiner Gnom hockt, der debian für Bäh hält.

Autor: Andreas Ferber (aferber)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: kruemeltee (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du nicht willst, dass der Kernel in der RTC rumpfuscht, dann 
schmeiss nicht ACPI, sondern die RTC Treiber raus.

Du kannst dir auch ein eigenes Wakeupmodul baun, is gar nicht schwierig. 
Die Logik an sich hat höchstens 50 Zeilen.

http://bochs.sourceforge.net/techspec/PORTS.LST
RTC - 0071

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Erklär mir jetzt bloss mal, wie du dir diesen Zusammenhang vorstellst.

Es war ein fehlgeschlagener Versuch, Lenny daran zu hindern, irgendwas 
mit der RTC zu veranstalten. (Der Alarmmechanismus läuft über ACPI.) Die 
Tricks mit rcS haben leider nichts bewirkt und auch die ISA-Option für 
hwclock nicht.

kruemeltee schrieb:
> Du kannst dir auch ein eigenes Wakeupmodul baun, is gar nicht schwierig.

Na ja, man kann auch das Rad neu erfinden...

Aber eine interessante Neuigkeit habe ich entdeckt: Der Rechner, der 
unter Ubuntu 7.10 den Restart vergeigt hat, kanns jetzt mit 10.04.

Ich werde also auf der alten Kiste eine Xubuntu 10.04 installieren und 
dann wird man sehen.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, mit xubuntu 10.04 funktioniert der RTC-Start, ohne daß irgend welche 
weiteren Eingriffe notwendig wären.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Toll: xubuntu ermöglicht zwar den RTC-gesteuerten Start der Möhre, aber 
das nur genau ein mal, weil es hinterher die Kiste nicht mehr abschalten 
kann...

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem Bootparameter acpi=force läßt sich das Problem beheben.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist verhext:
Ohne den Bootparameter acpi=force startet der Rechner RTC-gesteuert, 
aber schaltet beim Shutdown nicht ab; und damit fährt er natürlich auch 
nicht mehr hoch.

Mit dem Bootparameter acpi=force schaltet er beim Shutdown ab, bootet 
aber nicht mehr RTC-gesteuert.

Und Abschalten mit apm funktioniert nicht. Auch das Unterbinden von 
RTC-Zugriffen in rcS bewirkt nichts.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.