www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannungsfolger folgt nicht.


Autor: Reto H. (huberret)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein kleines Problem mit dem Spannungsfolger im Anhang. Und zwar
folgt die Spannung am Ausgang nur ca. bis 3.9V der Spannung am Eingang,
dann geht sie nicht mehr weiter rauf.

Was ich habe:

Versorgung: 5V asymmetrisch
Ausgang: unbelastet, offen
negativer Eingang: bleibt auch bei 3.9V stehen wenn der Ausgang 3.9V hat

Ich habe diverse Typen von OPs mit selbem Pinout durchprobiert, das
Resultat ist bis auf ein paar Millivolt immer dasselbe, im unteren
Bereich funktioniert der Spannungsfolger, im oberen nicht mehr. Alle OPs
sind Rail-to-rail... da sollte ich doch schon auf annähernd 5V
Ausgangsspannung kommen, oder?

Hat wer eine Idee wo das Problem liegen könnte?

Vielen Dank!

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die OPVs müssen Input und Output-RailToRail haben, nicht nur eins von 
beiden!

Autor: Michael Förtsch (the_new_number_2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simpel: An C16. Lies dir einmal das Datenblatt deines OpAmps durch oder 
häng' ein Oszi an den OpAmp-Ausgang...

Autor: Simulator (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
simulieren geht, trotz C(100nF) am Ausgang (Electronic Workbench)

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Alle OPs sind Rail-to-rail

Also ein LM358 ist zumindest kein Rail-To-Rail,
weder am Eingang noch am Ausgang (hier beides nötig).

Da du aber meinst, faul wie du bist, keine
Typennummern angeben zu müssen, die Hornhaut auf
den Fingern die beim vielen Tippen entsteht,
ich weiss, die ist nicht hübsch, gibt es bei dir
auch nichts zu helfen.

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, leider sind Simulation und Realität oft nicht sehr nahe beieinander.

Also wie schon gesagt wurde...Kondensator am Ausgang von einem OP ist 
i.d.R. schlecht - und die Sache mit dem Rail-2-Rail. Lass einfach ein 
bisschen Luft nach oben - selbst R-2-R-OPs schaffen es nicht 100% an die 
Grenzen.

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Reto,

> ich habe ein kleines Problem mit dem Spannungsfolger im Anhang. Und zwar
> folgt die Spannung am Ausgang nur ca. bis 3.9V der Spannung am Eingang,
> dann geht sie nicht mehr weiter rauf.

> Versorgung: 5V asymmetrisch
> Ausgang: unbelastet, offen
> negativer Eingang: bleibt auch bei 3.9V stehen wenn der Ausgang 3.9V hat
nimm einen echten Rail-to-Rail-Operationsverstärker. Der folgt der 
Spannung besser. Der LM358 kommt kommt bekanntermaßen nur an die untere 
Spannungsversorgung heran, von daher sind Deine Ergebnisse nicht 
überraschend.

Hier eine Übersicht
http://www.mikrocontroller.net/articles/Standardba...



Gruß,
  Michael

Autor: Michael Förtsch (the_new_number_2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simulator schrieb:
> simulieren geht, trotz C(100nF) am Ausgang (Electronic Workbench)

Ich kenne "Electronic Workbench" nicht. Daher meine Fragen: War das eine 
DC-Simuation? Wie sieht der DC-Anteil am Ausgang bei einer 
Transienten-Analyse aus? Wie war der OpAmp in deiner Simulation 
versorgt?

Der LM358 verträgt keine kapazitive Last - schon garnicht 100nF. Und 
wenn der OpAmp schwingt, kann er bei V+=5V natürlich keine 
DC-Ausgangsspannung von 5V erreichen...

Lösung: C16 entfernen oder mit einem Widerstand entkoppeln.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simulator schrieb:
> simulieren geht, trotz C(100nF) am Ausgang (Electronic Workbench)

Scherzkeks. Du kannst mit deinem OPAMP Modell gar nicht die Sättigung 
erreichen.

Das Problem ist halt, dass der OPAMP nicht weiter an die positive 
Versorgungsgrenze rankommt. Mit den Kondensatoren hat das nichts zu tun.

Autor: Simulator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michael Förtsch
Bei einem Spannungfolger interessiert mich erst einmal nur die 
DC-Betrachtung. Eine Transienten Analyse habe ich nicht gemacht. 
Versorgt habe ich sowohl symetrisch(-15V/+15V) als auch 
asymetrisch(0V/+5V). Beides lieferte mir die gleiche Spannung am Ausgang 
(bis auf die 2mV mehr). Es ist richtig, dass der LM358 keine kapazitive 
Last verträgt, aber ich war davon ausgegangen, dass er die Schaltung im 
LF-Bereich nutzen will (PID-Regler etc.). Mag sein, dass EWB etwas 
veraltet ist - Ich müsste mich nach einem besseren Simulator umsehen.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simulator schrieb:
> simulieren geht, trotz C(100nF) am Ausgang (Electronic Workbench)

Die Opamp-Modelle von Electronic Workbench bzw. Multisim scheinen
teilweise stark zu idealisieren. Das Thema hatten wir hier im Forum erst
vor kurzem. Der LM358, der in der Simulation verwendet wurde, hat nicht
einmal Versorgungsspannungsanschlüsse. Folglich können die Begrenzungen
der Ausgangsspannung nicht modelliert sein. Dieser simulierte Opamp
würde wahrscheinlich auch 1000V am Ausgang liefern, wenn man einen
entsprechenden Verstärkungsfaktor einstellt.

Viele Hersteller schreiben zu ihren Spice-Modellen dazu, was genau
simuliert wird und was nicht. Diese Informationen sollte man sich zu
Gemüte führen, bevor man einer Simulation glaubt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dennis schrieb:
> Ja, leider sind Simulation und Realität oft nicht sehr nahe beieinander.
Gerade Grenzbereiche und Überlastungen werden oft gar nicht simuliert. 
Oder hat schon mal einer einen 1/8 Widerstand oder einen BC547 in der 
Simulation abgeraucht?

Autor: Simulator (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Yalu
Den Verdacht hatte ich schon lange. Aber ich kann (wie im Bild) die 
Versorgungsspannung bzw. "Voltage Swing" vorgeben. Aber das scheint doch 
mit Vorsicht zu genießen zu sein.
Welchen Simulator (der auch die Specs abdeckt) könnt ihr empfehlen?

Autor: Εrnst B✶ (ernst)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ltspice (mit dem LM358-Model von der National Website) macht das 
halbwegs richtig.

Autor: Simulator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Εrnst B✶
DANKE!

Autor: Andreas K. (derandi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin mir fast sicher, das das alles im Datenblatt steht...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.