www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PGA2311 Lautstärke IC - Knacks beim Abschalten


Autor: Simon K. (simon) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich baue gerade einen kleinen Vorverstärker für meine Endstufenmodule, 
bin aber leider auf ein Problem gestoßen:

Die Schaltung des Vorverstärkers mit dem PGA2311 habe ich angehangen.
Die Spannungen wird von einem(!) bipolaren Netzteil bereitgestellt. 
Sprich Trafo mit 3 Abgriffen, Gleichrichter, zwei Filter-Kondensatoren.
Analog und Digitalteil werden von dem gleichen Netzteil aus gespeist.
Die Verbindung von Analog- und Digitalmasse findet somit direkt am Trafo 
statt.

Jetzt bin ich darauf gestoßen, dass, wenn ich die Spannung hart wegnehme 
(Also die 230V vom Netzteil) ich nach ca. 1 Sekunde einen dicken 
Transienten am Ausgang kriege. Habe noch nicht gemessen, ob er positiv 
oder negativ ist, aber er ist da und lässt meinen Schrott-Test 
Lautsprecher mit der Membran locker anschlagen ;-)

Habe nun mal rumgesucht im Internet und herausgefunden, dass es Probleme 
geben kann, wenn Digital-5V und Analog-5V unterschiedlich schnell 
abfallen.
Allerdings steht dazu nichts im Datenblatt und da ich ja sowieso für 
beides ein und das selbe Netzteil benutze wüsste ich nicht, wie ich das 
ganze NOCH synchroner hinkriegen sollte.
Eventuell weitere Beschaltung?

Bin daher etwas ratlos, woran das noch liegen kann. Ich habe noch den 
Kondensator am /MUTE Eingang im Auge. Möglicherweise hält der noch eine 
Weile lang die Spannung am /MUTE Eingang oben. Würde ich den weglassen, 
würde die Spannung am /MUTE Eingang (durch den Pullup) genau der 
Versorgungsspannung entsprechen. Somit würde sich der Chip automatisch 
beim Power-Down muten.
Ist aber nur eine Vermutung. Das werde ich morgen direkt mal 
ausprobieren.

Ich wollte mich nur umhören, ob jemand, der den Chip einsetzt (Ich 
glaube TravelRec. setzt den oft ein?) schon auf derartige Probleme 
gestoßen ist.

Ich bedanke mich im Voraus!

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deshalb hatten Verstärker früher eine Einschaltverzögerung für die 
Lautsprecher in Form eines Relais, welches dann auch beim Ausschalten 
eher wieder trennte als die Betriebsspannung sich auf null zu bewegte.

Du musst den Abfall der Betriebsspannung also auswerten und für 
Mute-Eingänge an der Endstufe oder Trenn- und Schaltvorgänge nutzbar 
machen.

Es ist ein "natürliches Phänomen" in der Elektronik, und kein Problem. 
:)

Autor: Hans W. (stampede)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe auch ne nette Schaltung mit dem PGA2311 gebaut ( www.picplayer.de 
), jedoch habe ich das Problem da nicht.
Versuche mal:
1. Widerstand (100k) nach Masse am Eingang.
2. Vor dem Ausschalten den PGA in den MUTE Modus schalten. Wenn da über 
die Software nicht geht, nimm ein Spannungsüberwachungs-IC und häng das 
an den MUTE Pin.
Ob dieses RC Netzwerk so zielführend ist, wage ich zu bezweifeln, denn 
der PGA ist beim Start immer gemutet, also warum das verzögern?

Gruß
Stefan

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhh schrieb:
> Deshalb hatten Verstärker früher eine Einschaltverzögerung für die
> Lautsprecher in Form eines Relais, welches dann auch beim Ausschalten
> eher wieder trennte als die Betriebsspannung sich auf null zu bewegte.

Eigentlich gehe ich davon aus, dass das früher war ;-)

> Du musst den Abfall der Betriebsspannung also auswerten und für
> Mute-Eingänge an der Endstufe oder Trenn- und Schaltvorgänge nutzbar
> machen.

Im Datenblatt vom PGA2311 steht, dass der Chip in den Mute Zustand geht, 
wenn +/-VA unter +/-3.2V sinkt.

Je mehr ich über die RC Beschaltung nachdenke, desto fragwürdiger ist 
die. Immerhin könnte die für ein Latchup sorgen am /MUTE Pin.

Hier schreibt jemand, dass das Problem auftaucht, wenn VD+ früher als 
VA+ fällt. Dann wird ein negativer Spike beim Ausschalten erzeugt. Genau 
das ist bei mir im Moment der Fall.
http://www.diyaudio.com/forums/digital-source/1244...

Wie auch immer, ich habe jetzt folgendes gemacht:

An VD+ den 10µF am 7805 rausgemacht.
Gesamtkapazität an VD+: ca 10µF, an VA+/-: je ca. 20µF.
VD+ hat einen 1k Widerstand als Belastung, damit es schneller sinkt.
VA+/- hat jetzt keinen Belastungswiderstand mehr.
Zwischen VA+/- einen 100nF Kondensator gesetzt (Aus der 
Elektor-Schaltung übernommen).

Der Transient ist leider immer noch vorhanden. Und zwar negativ. Jetzt 
werde ich mal nachprüfen, wie VD+/VA+ sich verhalten.

Autor: Simon K. (simon) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke das Problem ist klar. Beim Ausschalten stirbt +5V viel 
schneller als -5V (laaangsame e-Kurve).

Ich sollte dazu sagen, dass ich die Primärseite des Netztels (Trafo, 
Gleichrichter, Elkos) per Relais vom Netz nehme.

Wenn ich den Stecker für +/-5V direkt abziehe, sinken die quasi 
gleichzeitig.

Demnach wird das Problem wohl eher im Netzteil zu suchen sein, wo die 
Spannung an den Elkos langsam ungleichmäßig "wegstirbt".

Deswegen im Anhang mal das Netzteil.

So wie es aussieht geht das gar nicht so ohne weiteres, wie ich mir das 
gedacht habe (Relais trennt Primärspannung).

PS: Natürlich kann ich den PGA2311 vor dem Ausschalten per Software in 
den Mute Zustand versetzen. Aber was ist, wenn jemand den Stecker zieht? 
Oder der Strom ausfällt? Dann gehen die Lautsprecher kaputt.

Jetzt bin ich etwas ratlos. Digitaltechnik ist eh viel besser als 
analoger Kram! ;-)

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wär´s, wenn Du -5V für den PGA und die Op-Amps mit einem Inverter 
von den 5V erzeugst? Dann sterben beide Spannungen gleichzeitig. Oder 
nimm gleich einen DC/DC-Konverter mit 5V ´rein und +-5V ´raus.

Simon K. schrieb:
> Aber was ist, wenn jemand den Stecker zieht?
> Oder der Strom ausfällt? Dann gehen die Lautsprecher kaputt.

Eher selten gehen die kaputt, es klingt nur sackig.

Simon K. schrieb:
> Jetzt bin ich etwas ratlos. Digitaltechnik ist eh viel besser als
> analoger Kram! ;-)

Sagen wir mal anders.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt durch ein, zwei Widerstände die Entlade-Geschwindigkeiten 
von +/-5V angepasst, jetzt knackt es nicht mehr.
Komische Sache ist das!

Allerdings habe ich ein weiteres Problem. Und zwar geht der PGA2311 in 
einen Latchup, wenn das Eingangsspannungssignal groß genug ist (ca 
1Vamp) und wenn die Stromversorgung abgeschaltet wurde.
Komischerweise mutet er dann nicht, sondern leitet es sehr verzerrt und 
mit kleiner Amplitude an den Ausgang.

Muss ich also zwangsläufig an die Mute-Funktion der Verstärker Boards 
heran.

Ich dachte immer der PGA2311 wäre so einfach zu handhaben ;-)

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simon K. schrieb:
> Und zwar geht der PGA2311 in
> einen Latchup, wenn das Eingangsspannungssignal groß genug ist (ca
> 1Vamp) und wenn die Stromversorgung abgeschaltet wurde.

Begrenze den Strom mit Serienwiderständen und schalte Dioden nach Vcc 
und GND. Kein IC mag Spannungen mit genügend Strom dahinter am Eingang, 
wenn die Versorgung aus ist.

Simon K. schrieb:
> Muss ich also zwangsläufig an die Mute-Funktion der Verstärker Boards
> heran.
>
> Ich dachte immer der PGA2311 wäre so einfach zu handhaben ;-)

Betreibe ihn innerhalb der Spezifikationen. Lies das Datenblatt 
aufmerksam und schau Dir die Kennwerte und Tipps genau an.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Knut Ballhause schrieb:
> Simon K. schrieb:
>> Und zwar geht der PGA2311 in
>> einen Latchup, wenn das Eingangsspannungssignal groß genug ist (ca
>> 1Vamp) und wenn die Stromversorgung abgeschaltet wurde.
>
> Begrenze den Strom mit Serienwiderständen und schalte Dioden nach Vcc
> und GND. Kein IC mag Spannungen mit genügend Strom dahinter am Eingang,
> wenn die Versorgung aus ist.
Im Datenblatt steht, dass die Signalquelle am besten 600 Ohm 
Innenwiderstand haben soll. Wie soll ich das mit nem 1kΩ Widerstand noch 
gewährleisten?
Deswegen verstehe ich es ja nicht. Wie man sich vor Latch Ups generell 
schützt ist mir natürlich klar.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch zur Aufklärung, da ich demnächst weitermachen werde an den Projekt:
Ich werde das Relais, was ursprünglich zwischen zwei Quellen auswählen 
sollte (Und vor dem PGA2311 liegt) nun dazu benutzen um bei 
ausgeschalteter Versorgungsspannung das Eingangssignal zu trennen.
Denke das ist die beste Methode.

Würde ich das Layout noch mal neu machen, würde ich vor den PGA2311 
einen Operationsverstärker schalten, die Eingangsquelle mit 10kOhm gegen 
Masse belasten, dahinter vor Latchup schützen und dann hochohmig mit dem 
Operationsverstärker aufnehmen.

EDIT: Ach so, kleine Frage noch:

Hinter dem PGA2311 liegt ein "normaler" Audioverstärker. Also ein 
Endstufenmodul mit 26dB Verstärkung (20fache Spannungsverstärkung).
Der PGA2311 soll dann das digitale Poti davor sein.

Habe für den PGA2311 dann ein Stellbereichsmaximum von 0dB eingestellt, 
wo ich aber bei angeschlossenem Rechner mit "normallauter" Lautstärke 
schon fast bis an das Maximum von 0dB gekommen bin.
Ist es ratsam/üblich/normal dass ich im Vorverstärker (Also der PGA2311) 
auch ruhig beim Stellbereichs-Endwert bis +6dB oder +12dB bei normalen 
Line-Pegel gehen könnte? Erfahrungswerte irgendjemand?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.