www.mikrocontroller.net

Forum: PC Hard- und Software gnome unter debian squezze hängt sich auf


Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seit heute (besser gesagt seit ich den PC heute Nachmittag um einzukaufe 
ausgeschaltet habe) hängt sich der gdm3/Gnome auf, mit der Folge, dass 
direkt nach dem Start der Monitor schwarz bleibt (kein Loginscreen) und 
auch ein Wechsel auf die Textkonsole nicht mehr möglich ist.
Habe nun im save-mode den automatischen Start erstmal deaktiviert, und 
er fährt wieder "normal" hoch natürlich nur bis zur Textkonsole.

Was ich shcon probiert habe:
- fsck ausgeführt
- geprüft das noch genug Festplattenspeicher zur Verfügung steht.
- Soundkarte im Bios deaktiviert (hatte da eine Warnung im log gesehen 
auch wenn ich mir nicht wirklich besserung vom deaktiviern versprochen 
habe...)

nun bin ich ein wenig ratlos wo man nun schauen könnte was da schief 
läuft... unter var/log/gdm3 wird aufjedenfall nix angelegt (hatte mal 
testweise die Logfiles gelöscht) wenn es zum absturz kommt.

Ich weiß nurnoch das ich wohl heute mal über das automatische Update was 
reingekommen ist, kann mir aber garnicht vorstellen das ich dann der 
einzige sein sollte der Probleme hat... hab aber auch schon rausgefunden 
das man so ein Update nicht "einfach" zurücknehmen kann (sonst hätte ich 
es einfach mal probiert...)

Autor: Norbert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst Du denn, nachdem Du Dich als root auf der Konsole angemeldet 
hast, den gdm mit '/etc/init.d/gdm start' normal starten?

Ansonsten würde ich eher ein Grafikkartenproblem bzw. das dazugehörige 
kernelmodule vermuten.
Was isses denn,ATI nVidia oder Anderes?

xserver könnte man auch mit 'dpkg-reconfigure -pHigh xserver-xorg' oder 
so ähnlich neu konfigurieren.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Norbert schrieb:
> Kannst Du denn, nachdem Du Dich als root auf der Konsole angemeldet
> hast, den gdm mit '/etc/init.d/gdm start' normal starten?
Werde ich gleich mal testen, mache gerade noch ein Backup vor weiteren 
Experimenten.

Norbert schrieb:
> Was isses denn,ATI nVidia oder Anderes?
ATI mit zugehörigem Treiber, kann das sein das der auf einmal Amok 
läuft?

Norbert schrieb:
> xserver könnte man auch mit 'dpkg-reconfigure -pHigh xserver-xorg'
Würde das dann erstmal nur den Grafiktreiber schachmatt setzen oder hat 
das noch weitere Auswirkungen?

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> '/etc/init.d/gdm start'
Bildschirm wird schwarz und System friert ein. Kann danach weder auf 
eine andere Konsole wechseln nocht den PC per Power-Schalter 
runterfahren.

Autor: Norbert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab' hier noch ein Lenny laufen, aber zu Squeeze sollte kein großer 
Unterschied sein.

ATI, mit proprietärem Treiber vermutlich...

Sinnvollerweise kann man /etc/X11/xorg.conf sichern (in gleiches Verz. 
mit fortlaufender Nummer kopieren)

dpkg-reconfigure führt einfach nur die erneute Konfiguration aus so wie 
sie bereits bei der Einrichtung des Systems vorgenommen wurde.

-pHigh stellt aber evtl. mehr Fragen die nützlich sein könnten.


Gibt's denn in /var/log/syslog bzw. mit dmesg|less keine Einträge zu 
eventuellem Fehlverhalten der Grafik?

Autor: Norbert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahh, hab' gerade die Info gesehen.
Wenn der PC derart einfriert, dann könnte das evtl am ATI Treiber und 
KMS (kernel mode switching) liegen.

Ansonsten, wenn auch die Magic keys nicht mehr gehen:
http://en.wikipedia.org/wiki/Magic_SysRq_key

dann würde ich per aptitude den proprietären ATI Treiber rausschmeissen 
und mit dem freien kernel module radeon.ko testen.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Norbert schrieb:
> Hab' hier noch ein Lenny laufen, aber zu Squeeze sollte kein großer
> Unterschied sein.
Scheinbar schon... auf jedenfall geht das "resetten" jetzt wohl einfach 
durch löschen der xorg.conf (oder halt umbenenne), nun fährt gnome auch 
wieder hoch!
Hätte man auch selbst drauf kommen können so im nach hinein.
Auf jedenfall schon mal danke!

Norbert schrieb:
> dann würde ich [...] den proprietären ATI Treiber rausschmeissen
jo ich lass das jetzt auf dem default treiber laufen, 3D brauch ich 
eigentlich nicht dringend und so wirkliche Verbesserung einiger 
Unschönheiten konnte ich jetzt auch nicht feststellen...

Autor: Robin H. (Firma: vkl) (4klee)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest den Treiber ATI nativ von der Homepage pprobieren von 
AMD/ATI!
Beim Grub wenn er startet kannst du mal probieren einen alten kernel zu 
verwenden.
was ist deine eigentl. version "uname -a"

Debian squeeze und lenny sind riesen unterschied zwar nicht vom system 
aber von der aktuellität.
squeeze ist zwar im frozen status aber bei mir zum beispiel lies sich 
mit der squeeze version von 2 monaten raid ohne probleme installieren 
und mit dem release candidate 1 von squeeze funktioniert dass nicht 
mehr.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir hatte squeeze noch vor einigen Tagen ein paar nette Verdreher in der 
manuellen LVM-Partitionierung verbrochen. Das LV vom Swap-Space hiess 
var, /var hiess tmp und /tmp hiess swap. Liess sich aber mühelos zurecht 
drehen, da man die LVs im gemounteten Zustand umbenennen kann.

Wenn man von lenny auf squeeze updated, dann macht sich das z.B. im 
Startup-Verfahren deutlich bemerkbar. Das alte sequentielle /etc/rc* 
Verfahren wurde von einem abhängikeitsorientierten Verfahren abgelöst. 
Auch grub wurde auf den Kopf gestellt (V2 hat wenig Ähnlichkeit mit dem 
Vorgänger).

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robin Hatzl schrieb:
> Du solltest den Treiber ATI nativ von der Homepage pprobieren von
> AMD/ATI!
Genau den hatte ich...

Robin Hatzl schrieb:
> Debian squeeze und lenny sind riesen unterschied zwar nicht vom system
> aber von der aktuellität
Naja ich bin auch nur auf Squezze gewechselt weil unter lenny meine 
Grafikkarte gar nicht im Standardmodus funktionierte und der Treiber 
sich immer mit merkwürdigen Abhängigkeitsproblemen verabschiedete.

A. K. schrieb:
> Auch grub wurde auf den Kopf gestellt
Und der gdm3 Anmeldemanager läßt sich nicht mehr um-konfigurieren auf 
eine einfache Ansicht :-\

Robin Hatzl schrieb:
> was ist deine eigentl. version "uname -a"
>> Linux laeubi4core 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011
>> x86_64 GNU/Linux

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:

> Und der gdm3 Anmeldemanager läßt sich nicht mehr um-konfigurieren auf
> eine einfache Ansicht :-\

Die von mir in solcher Umgebung üblicherweise verwendete Anmeldung hat 
sich optisch seit 4 Jahrzehnten nicht wesentlich verändert. ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.