www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR ISP MKR II nur oranges Blinken, obwohl alles stimmt


Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

zur Zeit plagt mich ein Problem: mein AVRISP MK II blinkt bei meiner 
neuen Schaltung nur noch Orange. Das Problem, die neue Schaltung basiert 
auf von mir schon zigfach benutzten alten Schaltungen. Die werden halt 
schön immer auf neue Platine übernommen, wenn eine neue Version erstellt 
wird.

Was bisher getestet wurde
1. Der Programmer geht wunderbar an den vorhandenen alten Schaltungen
2. Überall liegt sauber und rein 5V und GND an, über 4,7k auch PullUp 
bei
   Reset. Oszi bestätigt das
3. Alle Leitungen durchgepiept, überall Verbindungen
4. Alles getestet und überprüft, kein Kurzschluß oder so.

Jetzt habe ich nur 3 Pins zum Programmer geführt. 5V, Masse und Reset. 
Und es blinkt weiter Orange. Nun habe ich denn 4,7k Pullup ausgelötet: 
Orange. Neuen 4,7k ran: Orange.....die 4,7k mal um 1k, 2k und 4,7k 
erhöht: Orange.
Alte Schaltung genommen: grün....also Programmer kann es nicht sein.
Dann habe ich sogar 100N zwischen Reset und VCC gemacht, auch kein 
Erfolg

Mir fällt leider nichts mehr ein, ich ahne, daß es da was ganz dämliches 
ist, aber mir fällt es nicht ein. Ob es daran liegt, daß Sonntag ist und 
man was anderes als sein Hobby machen sollte?;)

Wer hat eine Idee?

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zieht deine Schaltung vielleicht Versorgung des mk2 runter?

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mh, keine Ahnung, mein Ampermeter ist auch gerade futsch...geht das 
denn? Ich meine, es liegen ja nur die 5V, GND und reset an, da kann doch 
eigentlich keine Last zum Programmer zur Stande kommen, oder?

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>da kann doch eigentlich keine Last zum Programmer zur Stande kommen, oder?

Kann auch nicht. VTG wird lediglich für die Pegelwandler des MKII 
benutzt.

MfG Spess

Autor: Thomas Eckmann (Firma: Thomas Eckmann Informationst.) (thomase)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Max schrieb:
> Jetzt habe ich nur 3 Pins zum Programmer geführt. 5V, Masse und Reset.

Schliess' den doch erstmal richtig an.

mfg.

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Thomas Eckmann, was meinst du mit richtig anschließen? Die 3 Pins 
reichen doch aus um den Programmer in Breitschaft zu setzen....


So, habe jetzt einfach von einer alten, funktionierenden Schaltung 5V 
und GND zur neuen Schaltung gezogen, damit die 7805-Schaltung umgangen 
wird. Aber immer noch Orange....dann habe ich den Resetpullup der neuen 
Schaltung abgelötet und noch eine Leitung von Reset Alt-Schaltung zu 
Reset-Neu-Schaltung gelegt: auch Orange ABER die alte Schaltung geht 
auch nicht mehr. Ergo muß es mit dem Reset-Pin des AVR der neuen 
Schaltung zu tun haben, da es sonst keine Verbindung zu irgendwas gibt 
(Kurzschluß etc)

Leider ist der AVR ein Mega32 TQFP, schnell mal tauschen ist da nicht. 
Jetzt meien Frage, kennt einer es, daß der Reset-Pin vom AVR rumspinnt?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Max schrieb:
> Leider ist der AVR ein Mega32 TQFP

Dann ist es bestimmt ne Lötbrücke von nem anderen Pin zum Reset-Pin.
Hast Du auch sämtliche VCC, AVCC, GND angeschlossen?


Peter

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter hat mal wieder 100Punkte! Es war keine Lötbrücke, das hatte ich 
auch vermutet und getestet. Vielmehr war der Masse-Strang zu den 
GND-Kontakten des AVR unterbrochen. Bein einer Durchkontaktierung muß 
wohl die eine Seite (natürlich nicht sichtbar unter dem Chip) keinen 
Kontakt haben. Masse per Hand an die 100N's rangelötet, dabei noch ein 
paar dieser schlechten Durchkontaktierungen gefunden und schon ist die 
Lampe grün!

Vielen Dank, Peter!!! :):):):)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.