www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik OP als Stromverstärkerschaltung OPA 548


Autor: Sebastian Murck (basteldieter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich bin momentan mit einem Projekt an der FH beschäftigt. 
Prinzipiell geht es darum mit einer NationalInstruments-Messkarte 
(NI6009)Wechselspannungen zwischen mit rund 4V Offset und 300mV 
Amplitude zu erzeugen. Das Ganze sollte in einem Bereich zwischen 
0,001HZ und 10kHz geschehen. Ströme können ggf. bis zu 2A Auftreten.

Das soll auf einen LiIonen Akku gehen und wir wollen den Impedanzgang 
aufnehmen. Leider gibt die Messkarte bei 5V nur 1-3mA her. Da wir als 
Energietechniker leider nicht über das ausgeprägteste Elektronikwissen 
verfügen haben wir uns gedacht, dass wir uns einfach einen einen OPA 548 
( http://focus.ti.com/lit/ds/symlink/opa548.pdf ) bestellen und diesen 
als Impedanzwandler einsetzen, da unsere Spannung ok ist, wir allerdings 
größere Ströme benötigen.( http://de.wikipedia.org/wiki/Impedanzwandler 
)

Nachdem die Teile angekommen sind haben wir natürlich sofort losgelegt, 
allerdings kam schnell die Ernüchterung. Wir konnten zwar die Spannung 1 
zu 1 (mit kleinem Offset) durchgeben. Jeodoch brach die Spannung auf 
wenige mV zusammen sobald wir eine Last angehängt haben. Als 
Versorgungsspannung haben wir alles zwischen 0 und +-25V ausprobiert

Da wir alle uns bekannten Möglichkeiten ausprobiert haben den OP zu 
beschalten sind wir nach endloser Zeit leider kein Stück weiter 
gekommen. Wenn also jemand eine Idee oder einen Ansatz hat wie wir das 
Ziel mit den gegebenen Mitteln erreichen können wäre das super.
Für andere Vorschläge wäre ich auch dankbar (anderer OP oder sonstiges).


Vielen Dank schonmal für die zahlreichen Antworten ;-)

Basteldieter


Ps: ich habe ähnliche Threads gefunden, bin aber leider aus diesen nicht 
schlau geworden...

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

wie ist der OP beschaltet?

Autor: Sebastian Murck (basteldieter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0-5V an Vin+ (erstmal von seperatem Netzgerät)
0 bis +-25V an V+ und V- Versorgungsspannung
Vo einfach auf Vin- zurück

Dann haben wir noch den Ilim Pin versuchsweise mit V- gebrückt ,weil wir 
sowas im Dateblatt gelesen bzw interpretiert hatten um bis zu 5A am 
Ausgang zuzulassen. Hat allerdings nichts gebracht ;-)

Ach ja, wir haben alles erstmal mit Gleichspannung betrieben um hinter 
die funktion zu kommen...

Autor: Basteldieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem fängt eigentlich auch schon viel früher an....
wir bekommen keinerlei Ampere aus diesem OP heraus.
Selbst wenn wir eine Bsp-Schaltung aus dem Datenblatt aufbauen (Seite 16 
ist ein Parallel Output angegeben von dem wir nur die obere hälfte 
aufgabut haben, die parallelität ist nur dazu da, die max Stromstärke zu 
verdoppeln). Wenn wir die Schaltung im Leerlauf betreiben kommt da die 
geforderte Spannung heraus! Yiha haben wir uns gedacht. Schließen wir 
nun eine leichte Last von 10 Ohm an bricht die Spannung in den 
mV-Bereich und wir messen eine Stromstärke von etwa 5mA. Das ist nicht 
grade die Leistung die wir uns von einem Leistungs-OP erwartet haben. 
Machen wir irgendwas Dämliches falsch?
Danke schon mal für die HIlfe

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OP defekt?

Mal mit einem 2ten probiert?

Kondensatoren nah am OP?

Autor: Peer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieviel Strom kann den das Netzteil liefern, mit dem ihr den OP 
versorgt?

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sebastian Murck schrieb:
> 0-5V an Vin+ (erstmal von seperatem Netzgerät)
> 0 bis +-25V an V+ und V- Versorgungsspannung
> Vo einfach auf Vin- zurück
>
> Dann haben wir noch den Ilim Pin versuchsweise mit V- gebrückt ,weil wir
> sowas im Dateblatt gelesen bzw interpretiert hatten um bis zu 5A am
> Ausgang zuzulassen. Hat allerdings nichts gebracht ;-)
>
> Ach ja, wir haben alles erstmal mit Gleichspannung betrieben um hinter
> die funktion zu kommen...

Schaltplan bitte aufmalen und hier posten.

Egal ob aus Schaltplaneditor File oder als Notizpapier Handskizzen Foto.

Einfach, weil wir hier im Forum beständig erleben das verbale 
Beschreibung und reale Schaltung um Welten auseinander liegen.

Autor: Basteldieter (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die oben beschriebenen Fehlerquellen kann ich ausschließen. Die 
Netzteile liefern mindestens 2A-3A mehr haben wir nicht ausprobiert.
Ich habe mal 2 Schaltungen angehängt die wir aufgebaut haben. Den 
Impedanzwandler habe ich oben bereits "verbal" beschrieben und die 
zweite Schaltung haben wir versuchsweise aufgebaut. Diese soll zwar die 
Spannung verstärken, jedoch auch "große" Ströme abgeben.

Das Ergebnis war jedoch immer das selbe. Im Leerlauf war die Spannung 
ok, mit Last ist diese jedoch eingebrochen auf einige mV und der Strom 
der geflossen ist betrug auch nur einige mA.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon geschrieben: da müssen Kondensatoren an die Versorgung!

Autor: Sebastian Murck (basteldieter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Momentan arbeiten wir doch nur mit DC. Was sollen die denn bringen. 
Wohin sollen die denn und hast du ne Ahnung wie gross die seien 
müssten?Naja, versuch macht klug

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seite 8 Figur 1 im Datenblatt.

Autor: Sebastian Murck (basteldieter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es denn sinnvoll möglichst kompliziert anmutende Schaltungen 
aufzubauen, wenn nichtmal einfache Schaltunge funktionieren? Probieren 
werden wirs auf jeden fall, aber ich steh der Sache eher skeptisch 
gegenüber. Aber schonmal danke ;-)

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sebastian Murck schrieb:
> Momentan arbeiten wir doch nur mit DC. Was sollen die denn bringen.
> Wohin sollen die denn und hast du ne Ahnung wie gross die seien
> müssten?Naja, versuch macht klug



Das ist schon korrekt, das die Schaltung OHNE Kondensatoren 
funktioniert.
Im Leerlauf halt.
Das Problem leigt aber darin, das Du einige 100...1000mA Last ahben 
willst.
Und eben da kommt der (richtige) Hinweis in den Fokus des Erbauers: Hier 
sind Kondensatoren sinnvoll und wichtig, da Dir jeder cm Zuleitung (== 
induktive Komponente) auch bei diesem (nur 1MHz GBW) langsamen OPV 
Schwingneigung bringen kann.

Ein Oszilloskop am Ausgang wäre sicher eine gute Idee, um mehr 
Informationen zu erhalten warum die Schaltung nicht so tut wie es soll.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.