www.mikrocontroller.net

Forum: Platinen Eagle - Schaltplanteile kopieren


Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

gibt es eine einfache Möglichkeit, bestimmte Teile aus einem Schaltplan
(also bspw. die Spannungsversorgung) in einen anderen Schaltplan zu
kopieren oder zu exportieren/importieren?

Jens

Autor: Peter Hofmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jens,

mit GROUP den Schaltplanteil markieren, mit CUT und Rechtsklick auf den
markierten Bereich und PASTE im neuen Schaltplan.

Gruß Peter

Autor: Pete77 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich bekomme immer die Meldung "Zwischenspeicher ist leer"

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du musst beide schaltpläne im gleichen Eagle aufgemacht haben! Wenn du 
einen schaltplan mit doppelklick öffnest geht ein neues Eagle auf!

Autor: Mario Hagen (djacme)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und du must CUT (AUSSCHNEIDEN) verwenden, nicht copy!

Autor: Pete77 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich markiere eine Gruppe, dann selektiere ich das CUT-Symbol und klicke 
mit der rechten Maustaste auf die Gruppe.
Die Gruppe verschwindet auch.
Ein Einfügen in einem zweitem Schaltplan schlägt mit o.a. Meldung fehl.

Ich benutze die Version 4.16r1 von eagle.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe es gerade mit der 4.16r1, allerdings in der Light Version, 
probiert-es funktioniert problemlos. Mit einem Unterschied: CUT löscht 
die selektierten Teile nicht, sondern kopiert sie nur. Das steht auch so 
in der "statuszeilenhilfe" wenn man mit der Maus über CUT geht.
Verwendest du vlt. versehentlich DELETE (das Kreuz)? ..man weiss ja nie 
;) ..schon mal versucht den Befehl über das Menü auszuführen, anstatt 
über die Symbole?

Autor: Pete77 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Kreuz ?? ... ---- Ähem, ...., ööhh ....

So isses, Problem gelöst :-)

DANKE !!!

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..is mir auch schon passiert g
Kein Problem

Autor: Karsten Donat (karstendonat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich versuch auch grad eine Schaltung aus einer anderen zu kopieren.

Wie kann ich im gleichen Eagle zwei Schaltungen öffnen? Bei mir schließt 
er die erste dann immer.

Ciao

Karsten

Autor: enwo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
etwas spät...
das das fenster sich schließt is kein problem, solange du nach der cut 
operation nochmal auf die gruppe geklickt hast (statuszeile lesen)
Mit paste taucht dann die schaltung in der neuen schematic auf.
(probiert mit eagle 4.16r2 light)

Autor: Jochen B. (jochen_b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte auch aus zwei fertig gerouteten Platinen-Layouts ein 
gemeinsames Layout erstellen und scheitere schon beim Erstellen der 
Gruppe.
Meine Vorgehensweise:
- erste .brd Datei öffnen
- alle Layer bis auf Bottom, Pads, Vias und Dimensions ausblenden
- Group-Befehl (Rechteck) aktivieren und mit der Maus ein Rechteck 
definieren. Dieses wird auch grau unterlegt
- Cut-Befehl (Schere) anklicken
- ein Mausklick in dieses Rechteck (definiert den Nullpunkt)
- das Ziel-Board öffnen
- Past-Befehl (Pinsel) anklicken
- tatsächlich erscheint jetzt die kopierte Gruppe ...
>>>NUR ES FEHLEN DIE PADS!

Das habe ich jetzt mehrmals probiert und dabei festgestellt, dass beim 
definierender Gruppe zwar die Leiterbahnen und Vias aufgehellt werden, 
nicht aber die Pads! Was zum Geier mache ich falsch?

Autor: Leo-andres H. (leoloewe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jochen B. schrieb:
> Das habe ich jetzt mehrmals probiert und dabei festgestellt, dass beim
> definierender Gruppe zwar die Leiterbahnen und Vias aufgehellt werden,
> nicht aber die Pads! Was zum Geier mache ich falsch?

Du wählst zu viele Layer ab.
Lasse mal tOrigins und bOrigins aktiviert. Das sind die Mittelpunkte 
(kleine Kreuze) an den Bauteilen, ohne diese kannst du die Teile weder 
auswählen noch kopieren, verschieben etc.

Wieso wählst du überhaupt die Layer ab? Ich würde eher alle Layer 
markieren, um wirklich alle Fräsdaten, Lötstoplack etc. zu kopieren.

Autor: Jochen B. (jochen_b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leo,
wenn ich keine Layer abwähle, dann sagt mir EAGLE beim Einfügen, dass 
dies in meiner (lizenzierten!) Standard-version 5.11 dies nicht möglich 
sei.

Ich glaube auch, dass mein Problem schon bei der Gruppendefinition 
liegt. Es werden die Leiterbahnen (in meinem Fall nur Bottom) 
"ge-high-lighted" nicht aber die Pads - obwohl deren Layer aktiv ist.

Beitrag #2220731 wurde vom Autor gelöscht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.