www.mikrocontroller.net

Forum: FPGA, VHDL & Co. CPLD zu klein ?


Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuche gerade diese Schaltung nachzubauen:
http://babelfish.altavista.com/babelfish/trurl_pag...
Allerdings bekomme ich die Software nicht in den CPLD (X95108). Ich
bekomme immer eine Fehlermeldung:

Mapping a total of 83 equations into 6 function
blocks.................................................................. 
.....ERROR:Cpld:892
- Cannot place signal sumlt<14>. Consider reducing the collapsing
   input limit or the product term limit to prevent the fitter from
creating
   high input and/or high product term functions.
See the fitter report for details.
..............
java.lang.ClassCastException:
org.apache.xalan.res.XSLTErrorResources_de
  at org.apache.xalan.xslt.Process.main(Unknown Source)
Exception in thread "main" ERROR:Cpld:868 - Cannot fit the design
into any of the specified devices with
   the selected implementation options.
ERROR: Fit failed
Reason:
Process "Fit" did not complete.

Bin ich zu dumm dazu, oder an was liegt das ?

Autor: OTobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Pins mit per "Hand" schon zugewiesen ? Versuch doch mal
das
"Pinassigment" von der Xilinx Software durchführen zu lassen.
Manchmal ist es besser erstmal die Software arbeiten zu lassen,
vielleicht passt dein Programm ja dann in dein CPLD

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe garnichts zugewiesen, also macht es die Software automatisch.
Dann habe ich die Pins mal so zugeordnet wie beim Orginal, auch ohne
Erfolg.
Laut Anleitung von Xilinx muss man bei den Fitter Einstellungen unter
Advanced die Product Term Einstellung ändern, dann geht es.
Nur bei mir gibts kein Advanced...

Autor: OTobias (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Versuche mal bei "Implement Design" mit den Einstellungen
herumzuoptimieren. Da gibt es ja eine Menge einzustellen, vielleicht
funktioniert es ja. Ich habe auch nicht bei meiner Webpack Version
diese Einstellung (Advanced Product Term)gefunden. Wenn du willst
schicke doch mal deinen VHDL File und ich kann bei mir heute Abend mal
ein bisschen mit Webpack ISE herumspielen.

Gruß Tobi

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich schon.
Alles auf Area, Minimum Size usw. gestellt.
Unter Fitting soll es ein Advanced Menü geben wo man Product Term
umstellen kann (wie gesagt, soll...)

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt rausgefunden wie es geht:
Unter Edit, Preferences..., Processes gibt es Property Display Level.
Hier muss Advanced stehen.
Dann kann man bei den Fitter Optionen Exhaustive Fit Mode aktivieren.
Jetzt probiert der Fitter alle Möglichkeiten durch, was einige Zeit
dauern kann (so eine halbe Stunde bei einem schnellen PC ist durchaus
möglich....)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.