www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MEGA162 LCD Probleme


Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen ich betreibe ein Display (128x64 KS0108)an einem mega162v
Daten werden an Porta übergeben die Steuerausgänge hatte ich zuerst an
Portc PC0..PC5 dummerweise kam dann der Text den ich ausgegeben habe
auf beiden Displayseiten habe dann mal nachgemessen PC5 waren immer 5V
(DDRC=0xFF ,Portc=0x00).Habe dann das Fusebit für JTAG ausgeschaltet
dann ging nichts mehr.
Jetzt betreibe ich die Steuerausgänge an Portb hier habe ich das
Problem das die rechte Hälfte schwarz ist was geht hier schief.

MFG Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.