www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Mode Error


Autor: noah (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein STK500 mit STK501 Erweiterung und ATmege128L.
Hatte bis jetzt keine Verbindungsprobleme.

Seit einiger Zeit versuche ich nun von einem anderen PC aus (seriell) zu 
programmieren. Habe mit AVR Studio 4 ein Firmware update erfolgreich 
durchgeführt.
Meine Board wird erkannt. Doch sobald ich irgendwie kommunizieren will 
erscheint das ISP Mode Error Fenster.
(A problem occured when executing command.)

STK 500 Osc: 3,686 MHz
ISP Frequ: 57,60 kHz

Das Problem muss wohl irgendwo am PC liegen, denn ich hatte das Board ja 
schon problemlos programmiert und seither unverändert gelassen.

Wäre froh über ein paar Tipps...

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Update hat funktioniert, also ist die serielle Verbindung ok.

Wurden von diesem Computer mit dem AVR-Studio schon andere AVR's 
programmiert, eventuell mit einem Debugger? Überprüfe mal die 
Einstellungen im AVR-Studio.

Autor: noah (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein ich programmiere zum ersten mal einen AVR mit diesem Computer.
Also hab auch keinen Debugger verwendet.

Kann es ev. mit dem Oscillator Calibration Byte zu tun haben?
Wenn ich hier bei Calibrate for Frequency einen Wert eintrage,
und anschließen das Callibration Byte lesen will, erscheint wieder
der ISP Mode Error.
d.h. ich kann auch keine Adresse schreiben.

Autor: Greisel (Gast) (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe har genau das gleiche Problem wie du blos Programmiere ich das 
Board zum erstenmal. Das ISP6PIN kabel ist auch richtig gesteckt. 
Firmware ist auch auf dem Aktuellen stand. ISP-Frequenzen hab ich schon 
alle ausprobiert. Jumper sind alle richtig gesteckt hab ich auch schon 
X-Mal nachgeschaut.

Hab anbei noch die Fehlermeldung

Währe froh über hilfe mein Latein ist am Ende

mfg

Autor: Daniel (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.JPG
    1.JPG
    129 KB, 141 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hi Greisel ich habe das selbe Problem. :-)
Dies taucht jedoch nicht bei jedem AVR Dragon auf.

Programmieren oder debuggen geht nicht mit meinem AVR Dragon im 
ISP-Mode.
Ich hab für dich ne Lösung.

Wenn du debuggen willst, dann musst du beim Programming Mode: anstatt 
ISP den PP/HVSP Mode wählen. Dies wird im Bild angezeigt.

Und wenn du deinen ATmega beschreiben willst, dann musst du den ATmega 
in den AVR Dragon einsetzen und im selben Mode: PP/HVSP machen.

Hier mal der Link für meinen Atmega: 
http://support.atmel.no/knowledgebase/avrstudiohel...

Es heißt dann beim Atmel Parallel Programming.
Nicht zu vergessen musst du mittels Parallel Programming den Fuse Bit: 
SPIEN aktivieren.

Autor: Neuling (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe derzeit dasselbe Problem wie Greisel.
Die "Lösung" von Daniel hilft mir nicht, da ich kein AVR Dragon habe.
Ich verwende den AVR-ISP-Stick. 
http://www.mikrocontroller.net/articles/AVR-ISP-Stick
Ich kann Fuse-Bits setzen, nur beim Flashen tritt der Fehler auf.
Wäre super, wenn ihr Tipps hättet, was ich noch machen könnte.
Vielen Danke im Vorraus!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.