www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bistabiles Relais "ansteuern"


Autor: Randy N. (huskynet)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir ein paar bistabile Relais gekauft, jedoch erst nach dem 
Kauf festgestellt, dass diese an der Spule nur zwei Kontakte besitzen - 
also für jedes Umschalten muss die Spannung daran umgepolt werden. Habt 
ihr eine Idee, wie man das Umpolen am einfachsten bewerkstelligen 
könnte? Die Ansteuerung müsste ein ULN2003A übernehmen. Ein weiteres 
Relais nur zum Wechseln möchte ich nicht verwenden. Die angehängte 
Möglichkeit würde zwar prinzipiell funktionieren (Basiswiderstände hab 
ich der Einfachheit halber weggelassen), jedoch fehlen da die zum Relais 
antiparallelen Dioden.

Grüße
Randy

Autor: Wolfgang Horn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, Randy,

die einfachste Schaltung ist eine Halbbrückenschaltung - Treiber ist 
eine pnp-npn-Entstufe, gekoppelt über einen genügend dicken Elko an die 
Relaisspule gegen Masse.

Den ULN brauchst Du dann nicht mehr.


Ciao
Wolfgang Horn

Autor: The Devil (devil_86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du dir sicher, dass das so (auf Dauer) funktioniert? Die 
Freilaufdioden des ULN willst du aber eh nicht verwenden, oder?

Autor: Jack Braun (jackbraun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>die einfachste Schaltung ist eine Halbbrückenschaltung - Treiber ist
>eine pnp-npn-Entstufe, gekoppelt über einen genügend dicken Elko an die
>Relaisspule gegen Masse.

Ganz genau.

Verwende ich seit Jahren.

Beitrag "Re: bistabiles relais umpolen"

Autor: Randy N. (huskynet)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm also ich hab mal bissl rumprobiert - das mit dem Elko ist für mich 
ungünstig, da das nur relativ niedrige Schaltfrequenzen erlaubt (maximal 
2Hz). Außerdem kann man nicht nur mit kurzen Impulsen schalten, da der 
Elko zum einen in zu kurzer Zeit noch nicht vollständig ge-/entladen 
ist, und sich dann nach dem Impuls auch wieder langsam entlädt.

Eigentlich wäre für mich die oben angehängte Schaltung perfekt, 
allerdings weiß ich nicht wie das mit der Induktionsspannung nach dem 
Abschalten ist. Genau so würde auch die Variante Widerstand-gegen-Plus 
funktionieren, aber auch hier hab ich keine Dioden.

Autor: tcfkat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich beziehe mich auf die Schaltung im ersten Posting... stimmt das mit 
den 24V? BC558 ist dann was knapp, der kann nur Uce(max)=30V, nimm 
besser BC556.
Schalte parallel zur Spule eine bidirektionale 30V-Suppressordiode, z.B. 
1.5KE30CA (die gibt es auch in kleiner, habe gerade nicht die 
Bezeichnung parat). Bedingung: Die Versorgungsspannung der Relais steigt 
nicht wesentlich über 24V an. Lege noch in die Collectorleitung der 
BC556 eine 1N4148, damit  wird verhindert, dass die 
Selbstinduktionsspannung die CB-Strecke in Vorwärtsrichtung treibt. 
Damit sollte es gehen.
Wenn Du aus Versehen mal beide Ausgänge einschaltest, knallt das, das 
ist klar?

Autor: pfuscher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

@ Randy N.
die obere Schaltung ist schon ok, aber bei Ausgabe BEIDER Signale 
raucht's wohl.
Als Pfuscher würde ich mal überlegen, die Transistoren durch Widerstände 
zu ersetzten. Man müsste nur ausprobieren (oder berechnen) wie groß.
Der Gesamtstrom (Relais + Widerstand) muss wohl kleiner 500mA sein, aber 
die Spannung Uversorgung-Uwiderstand muss ausreichen, um das Relais zu 
schalten; Vielleicht kann man die Versorgung erhöhen.

Ach ja: nach dem Schalten sollten die Ausgänge natürlich wieder 
ausgeschaltet (auf plus) werden (klappt ja, ist ja ein bistabiles 
Relais)


PS:
Ich hatte mal ein paar bistabile 3V-Relais. Die habe ich einfach 
zwischen 2 74138 gehängt. Das hat geklappert.

PPS. Oh noch 'ne Idee: einfach von dem ULN2003 einen decoder (sowas wie 
74138) schalten, dann KÖNNEN die Ausgänge gar nicht gleichzeitig kommen.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein paar bistabile 5V-Relais, die habe ich einfach über 100µF 
an den AVR-Portpin gelegt, das andere Spulenende auf GND. Geht 
wunderbar.

...

Autor: STS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
L293 von ST

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.