www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik bistabiles relais umpolen


Autor: Peter Peterson (kloud)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits
zu meiner verteidigung ich bin anfänger..
also ich hab ein bistabiles relai (dsp2a-l-dc3v)
das ich mit einem atmega8 schalten will.
Das relai hat eine spule die umgepolt werden muss
ich weiß nur nicht wie bzw. ob man das mit transitoren schalten kann
und wie man dann die freilaufdiode schalten muss

ich hab mir mal ein bischen was überlegt aber es könnte sein das ich da 
ziemlich auf dem holzweg bin (siehe Anhang)

bin für jede hilfe dankbar

Autor: Sebastian Arnd (seba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was du suchst ist eine H-Brücke

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
welchen strom+spg braucht das relais?

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
guten abend

@sebastian: danke für den tipp ich lese mich gerade ein

@ernst: das relai braucht 3V 50mA

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde es direkt an den AVR anschliessen. Je Relaisanschluss 2 Pins 
parallel (besser 3), falls du noch genug übrig hast, nicht mal Dioden 
brauchst du. Einen Widerstand noch in Reihe, falls der AVR mit 5V läuft 
(rechnerisch 40R, Relais ziehen auch mit weniger Strom als angegeben, 
mit ein paar mehr Ohm bist du auch auf der sicheren Seite mit nur je 
einem Pin).
Habe ich seit Jahren auf einer Modelleisenbahn so laufen, problemlos 
(5V, 40mA-Relais, Tiny12)
Ist es ein kommerzielles Projekt, solltest du allerdings etwas anders 
ran gehen.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
direkt an den AVR anschließen scheint mir doch etwas riskant
braucht man die diode nicht um eine von der spule induzierte spannung 
kurzzuschließen?
außerdem wie kann ich die spule dann umpolen?

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich würds so machen:
relais direkt an je ein avr-pin, der mega kann 50ma mit ca 1v verlust, 
dh es gibt recht genau 3v am relais; par zum relais 2x zf3,9 
antiparallel in reihe, um die spg.spitzen abzufangen; das sollte perfekt 
funktionieren; ansteuerung nur etwa 10ms lang, somit auch kein problem 
für den mega8.

Autor: Peter Peterson (kloud)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo ernst
mit zf3,9 meinst du z-dioden oder?
meinst du sowas (siehe Anhang)?

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
right

Autor: Peter Peterson (kloud)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so ich hab mir jetzt mal was gezeichnet
jetzt die entscheidende frage:
Funktioniert das??
ich werds morgen jedenfalls mal ausprobieren

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, das funktioniert nicht.
Und man braucht auch keine Dioden, weder einfache noch Z-Dioden oder was 
anderes, solange man nicht bei stromführendem Relais die Ausgänge 
hochohmig schaltet.
Jahrelang haben die Entwickler bei den IC-Hersteller gequängelt, doch 
endlich Ausgänge dranzupappen, die auch was Strom liefern können, und 
zwar sowohl sink als auch source. Und nun hat man die, und du willst 
trotzdem eine externe Brücke dranpappen, kopfschüttel....

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>so ich hab mir jetzt mal was gezeichnet

Schlimmer (d.h. komplizierter) geht's nimmer.

Einfach vom µ-Ausgang zu Relais+, Relais- an Elko+, Elko- an Masse.
47 bis 100µF sollten genügen.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@jack:
um das relai zu schalten muss man es umpolen aber das geht ja nicht mit 
dem elko oder?

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
deswegen mein vorschlag mit z-dioden...
im prinzip kannste die auch weglassen, die energie der spule wird auch 
von den schutzdioden im avr abgefangen, mit den z-dioden is nur "auf 
nummer sicher", weil bei relais-strom 50ma eben auch max 50ma 
zurückkommen, und der avr-schutz "nur" 40ma hat...vermutlich kann er 
schon mehr, aber ....sicher ist sicher.
wenn das rel immer so geschaltet wird:
--beide pins lo out
1. 10ms lang ein pin hi out (je nach richtung eben)
--beide pins lo out

brauchts keine z-dioden, sondern nur 2 (zb) 1n4148, von den rel.anschl. 
je 1 nach masse, in sperrichtung. das is alles.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab mir das datenblatt vom atmega8 genauer angeschaut und es scheint 
ja wirklich kein problem zu sein das relai daran zu betreiben
nur eins verwirrt mich noch ein wenig:
wenn source current gleich 50ma dann liefert der atmega 3,6V
und bei sink current gleich 50ma dann liegen 1,2V an
heißt das jetzt das dann an dem relai nur 3,6-1,2 also 2,4V anliegen
stimmt das so??

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jo, aber da das "min" angaben sind und dein relais wohl kaum erst bei 
genau 50ma anzieht passt das schon so...und mach lieber die 2 dioden 
ran, damit kein latch-up entsteht.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beitrag "Re: bistabiles relais umpolen"
So, wie Jack es gesagt hat, werden bistabile Relais umgepolt.
Bei ELV gibt es einen Akkuwächter-Bausatz. dort ist ein bistabiles 
Relais verbaut. Am Ausgang der Schaltung ist ein normaler Elko, der zum 
Relais führt.

Autor: ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mmm, jack hat recht. 1 pin. definitiv die einfachste variante.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok ich glaub ich versteh die schaltung mit dem elko
wenn ich den avr-pin auf high setze wird das relai durch den ladestrom 
des elkos geschalten
wenn ich dann auf low schalte wird das relai durch den entladestrom des 
elkos geschaltet richtig??

wie schauts bei dieser schaltung dann mit der induktionsspannung aus?
ich hab ja trotzdem eine änderung des stromes im magnetfeld oder?

gibt es irgendwelche standartwerte für die dauer des stromimpulses zum 
schalten von bistabilen relais im datenblatt hab ich nichts gefunden?

danke
thomas

Autor: Zwischenfrage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum verwendest Du kein bistabiles Relais mit 2 Spulen?

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wenn ich dann auf low schalte wird das relai durch den entladestrom des
>elkos geschaltet richtig??

Genau so.

Die Schaltung mit dem Elko habe ich seit Jahren im Einsatz, ohne Dioden.

Relais: 3V Relais von National (RHLD, uralt, aber sehr schön klein)
und 5V Relais von Matsushita (230V Schaltspannung). Funktioniert
bestens mit 15µF.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Zwischenfrage
weil ich das mit der einen spule gerade günstig bekommen habe
@jack
ok ich werds mal so ausprobieren vielen dank für die hilfe

Autor: p.j.weber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo! bin ebenfalls laie und mache solche elektronikspielchen nur für 
mein modellbahnhobby.

mögliche problemlösung:

nenne die beiden spulen-enden deines bistab. relais A und B.
löte an A und an B jeweils einen widerstand (wert sollte etwa so sein 
wie der widerstand der relaisspule)
lege die beide offenen enden der widerstände auf PLUS.
löte parallel zu den widerständen jeweils eine freilaufdiode (z.B. 
1N4001)
wenn du nun kurzzeitig mit masse auf A oder B tippst, schaltet das 
relais von hü nach hot und von hot nach hü.
wenns nicht tut, solltest du die spannung etwas erhöhen (die beiden 
zusätzlichen widerstände "verheizen" ja schließlich auch ein bisschen 
was.
wenn der manuelle test gut verläuft, ersetzt du das handantippen auf A 
oder B durch den kollektor von jeweils einem BC337 (zum beispiel). die 
beiden emitter legst du auf masse.
wenn du nun auf die basis einer der beiden transistoren ein HIGH signal 
gibst (also PLUS), dann schaltet der jeweilige trans. durch und schaltet 
das relais um.
fast vergessen: vor die basis der BC337 noch so runde 10 KOhm.
ich habe die schaltung mit hilfe eines astabilen multivibrators getestet 
(10 umschaltzyklen pro sekunde) und nach rund 250.000 zyklen 
abgebrochen. die schaltung funktioniert fehlerlos.
gruß: j. weber

Autor: Peter Peterson (kloud)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo j.weber
deine schaltung hat leider den nachteil das sie 2 pins am avr benötigt
im gegensatz zu der von jack beschriebene schaltung die mit einem pin 
auskommt

ich hab mir die schaltung von jack probeweise aufgebaut und sie 
funktioniert einwandfrei allerdings muss man darauf achten das man den 
elko groß genug wählt (wegen der impulszeit) ich hab jetzt 47uF da 
funktionierts mit 22uF schaltet das relai aber noch nicht.

ich hab die schaltung von jack noch um zwei transitoren erweitert 
(anhang) um das relai nicht direkt am atmega zu betreiben da ich mehrere 
relais anschließen möchte und dann bald den zulässigen gesamtstrom des 
atmegas (400ma) überschritten hätte.
und welch ein wunder es funktioniert juhuu :)

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ich hab die schaltung von jack noch um zwei transitoren erweitert
>(anhang) um das relai nicht direkt am atmega zu betreiben da ich mehrere
>relais anschließen möchte und dann bald den zulässigen gesamtstrom des
>atmegas (400ma) überschritten hätte.

Wie willst Du den auf einen so hohen Strom kommen?
Die bistabilen Relais brauchen doch nur zum Umschalten einen kurzen
Stromimpuls, dann wird kein Strom mehr verbraucht.

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Übrigens ist in dem Schaltbild der BC557 falsch herum gezeichnet:

Die beiden Emitter gehören zusammen, Collector an Masse.

Autor: Peter Peterson (kloud)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@jack
stimmt der transistor ist falsch eingezeichnet, ich habs aber richtig 
aufgebaut
mit dem stromverbrauch hast du auch recht man braucht ja nur kurzzeitig 
strom, nicht daran gedacht

Autor: maddin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hatte mit dieser schaltung immer das problem das sie nciht bei jedem 
puls den zustand wechselte... woran kann das liegen... auch nach dem 
umtausch von bc557..

anschluss 2 der klemme ist doch - oder?

gruß,
m.

Autor: kloud (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo maddin

klemme 2 ist gnd stimmt so
vll ist der kondensator zu klein dimensoniert
das war bei mir auch ein problem
einfach mal ausprobieren

lg kloud

Autor: maddin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hi,

ich habe das Schaltbild dieser Schaltung jetzt mal Korregiert, damit die 
Falsche Zeichnung endlich mal hier verschwindet. Sie wird von Beitrag zu 
Beitrag gereicht, und stiftet dann u.u. nur Verwirrung...

Gruß,
m.

Autor: Andrea (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

erstmal sorry, dass ich diesen alten Thread wieder hochhole, aber ich 
möchte die Schaltung, wie im Bild "relai_transitor_Corr.JPG" zu sehen 
ist, nachbauen.

Dazu ein paar Fragen:
1. Ist es erlaubt, dass nach dem Ansteuern (µC-Ausgang dauerhaft auf 
high) an der Spule jeweils an den Enden die gleiche Erregerspannung 
anliegt? Es fließt ja bekanntlich dann kein Strom durch die Spule, 
sollte also so ohne Probleme gehen, oder ist die Spule des bistabilen 
Relais' dadurch gefährdet?

2. Ich möchte zusätzlich eine LED an den µC-Ausgang legen, damit man den 
Status des Ausgangs auch optisch sieht.
Kann man parallel zur Spule vom µC-Ausgang zur gemeinsamen Masse eine 
LED anschließen, ohne dass die Funktion des Relais beeinträchtig wird?
Mein bistabiles Relais ist eine 5V-Version und hat nur einen 
Wechselkontakt.
Auf einen weiten µC-Ausgang möchte ich verzichten.

Freundliche Grüße,
Andrea

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was geschieht eigentlich, wenn man bei letzter Schaltung kein Signal an 
die Basis legt? Man stelle sich beispielsweise einen unprogrammierten µP 
vor. Besteht die Gefahr, dass beide Transistoren leicht öffnen und somit 
ordentlich Strom fließt oder wer kann mich da beruhigen? Wäre jeweils 
ein eigener Vorwiderstand für jede Basis besser?

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung ist in Ordnung. Es können nie beide Ts leitend werden, 
weil dazu deren Basen um ca. 1,4V auseinanderliegen müssten.
Beachte, der obere ist NPN, der untere PNP - eine klassische 
Gegentakt-Endstufe ohne Ruhestrom.
Die Versorgungsspannung für das Relais kann aber nicht höher sein als 
die Spannung des µC, bzw. wenn sie es ist, steuert der NPN nicht voll 
durch.
Um das zu umgehen, müsste noch ein NPN in Emitterschaltung davor.

Ich würde den Basiswiderstand sogar noch etwas kleiner machen, ca. 100 
Ohm. Ist eigentlich nur ein Schutzwiderstand, es würde auch ohne ihn 
gehen.

Ohne Signal an der Basis passiert einfach nichts, der C lädt sich auf 
die angelegte Spannung auf, es fließt kein (nennenswerter) Strom.

Autor: No Name (nohelp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir sollte es ein bistabilies Finder Relais (Reichelt FIN 40.52.6 
12V) werden. Aber mit dem angehängten Schaltplan und der Dimensionierung 
tut sich gar nichts. Vielleicht geht die Elkomethode mit diesem 
Relaistyp auch nicht, das laut Datenblatt einen Entregungswiderstand 
haben möchte. Oder hat doch jemand Erfolg mit dieser Methode?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  No Name (nohelp)

>tut sich gar nichts. Vielleicht geht die Elkomethode mit diesem
>Relaistyp auch nicht,

Doch. Aber C3 scheint mir zu klein, mach den mal 470uF oder größer.

MFG
Falk

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
470uF hatte ich auch schon erfolglos ausprobiert. Dass die Transistoren 
schalten, konnte ich am gemeinsamen Emitterausgang messen. Ich frag 
nochmal etwas unwissender: Wie steuert man das Relais per Software genau 
an? Bislang wechsel ich einfach per Schalter den Eingangspegel. Gut, 
dass ich die Ziel-Platine noch nicht weiter entwickelt habe.

Autor: No Name (nohelp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nach weiterem Fummeln hier nun die tasächlich funktionierende Lösung. 
Man darf aber nur alle 1-2 Sekunden schalten, sonst passiert nix. Leider 
spart man mit der Schaltung aber kaum Strom. Es fließen ca. 12mA im 
Ein-Zustand.

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Leider spart man mit der Schaltung aber kaum Strom.
>Es fließen ca. 12mA im Ein-Zustand.

Der Kollektorwiderstand vom 1.Transistor ist ja auch viel zu niedrig:

Mach mal R10 10k und R11 1k. Für die Gegentaktstufe kannst Du ja B oder
C-Typen nehmen, falls der Basisstrom für den A-Typ zu gering wird.

Und nimm diese Dioden hinter dem Relais raus, und natürlich auch
die 200 Ohm. Dann klappts auch mit einem kleineren C.

Autor: Bernhard M. (boregard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
No Name schrieb:
> Nach weiterem Fummeln hier nun die tasächlich funktionierende Lösung.
> Man darf aber nur alle 1-2 Sekunden schalten, sonst passiert nix. Leider
> spart man mit der Schaltung aber kaum Strom. Es fließen ca. 12mA im
> Ein-Zustand.

...wohl wegen R10. Braucht man R9 und R10 wirklich so klein?

[Edit] ...ich sollte wohl vor dem Antworten mal refreshen ;-)

Autor: Bernhard M. (boregard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jack schrieb:
>> Leider spart man mit der Schaltung aber kaum Strom.
>>Es fließen ca. 12mA im Ein-Zustand.
>
> Der Kollektorwiderstand vom 1.Transistor ist ja auch viel zu niedrig:
>
> Mach mal R10 10k und R11 1k. Für die Gegentaktstufe kannst Du ja B oder
> C-Typen nehmen, falls der Basisstrom für den A-Typ zu gering wird.
>
> Und nimm diese Dioden hinter dem Relais raus, und natürlich auch
> die 200 Ohm. Dann klappts auch mit einem kleineren C.

Ich denke, die Dioden und den 200 Ohm baucht man doch, weil die Finder 
Relais mit einem niedrigeren Strom abgeschaltet werden müssen (der 200 
Ohm steht meines Wissens so im Datenblatt)...

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich denke, die Dioden und den 200 Ohm baucht man doch, weil die Finder
>Relais mit einem niedrigeren Strom abgeschaltet werden müssen (der 200
>Ohm steht meines Wissens so im Datenblatt)...

Stimmt.
Dann würde ich aber ein anderes Relais nehmen, das außerdem mit 5V
betrieben wird, dann spart man 5-6 Bauteile.

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, die 12mA werden wohl durch R10 verursacht und R9 könnte auch größer 
sein. Da werd ich am Abend mal etwas >=10K hinpacken. Ich habe mich 
bewusst für ein 12V Relais entschieden, um es unabhängig vom 5V Zweig 
für den Mikrocontroller zu betreiben. Richtige 5V Relais bistabil, die 
in der Lage sind 16A/230V zu schalten gibt's eben nicht an jeder 
Reicheltecke ;-). Im Übrigen möcht ich mich nach dem Kauf dieser nicht 
grade billigen Relais (>5€) nicht nochmal umentscheiden wollen. Den 
Entregungswiderstand mit den beiden Dioden hatte ich zuerst weggelassen 
und (s.o.) es geschah gar nix. Dann sah ich diesen 
[Beitrag "bistabiles Relais ansteuern"] und hab mir das dort 
abgeschaut

Autor: No Name (nohelp)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Da es Rückfragen zur Dimensionierung gab, stelle ich nochmal meinen 
letzten Stand hier ein. Die Relais lassen sich sicher schalten, man darf 
aber nicht häufiger als alle 1,5 Sekunden die Spule erregen, sonst ist 
das vorherige Entregen der Spule noch nicht vollständig und zieht daher 
nicht wieder an.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wozu die Asymetrie? D7.2 ist überflüssig.

MFG
Falk

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon selber ausprobiert? Hab das so aus den diversen Beiträgen 
herausgelesen und funktioniert. Kann die Diode im Entregungszweig mal 
überbrücken und schauen, was passiert.

Autor: Frage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich mich auch für das bistabile Relais interessiere eine kurze Frage:
1. Wozu dient Transistor 7.1? - kann ich nicht den uc direkt (via R7.1) 
an die Basen von T7.2 und T7.3 schließen?
2. Kann es ein, dass die Dioden D7.1 und D7.2 falsch gepolt gezeichnet 
sind?
(Den Widerstand beim ausschalten)

Autor: Falk Brunner (falk)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@  Frage (Gast)

>1. Wozu dient Transistor 7.1?

Als Pegelwandler von 3/5V auf 12V.

> - kann ich nicht den uc direkt (via R7.1)
>an die Basen von T7.2 und T7.3 schließen?

Nur wenn dein Relais mit 3/5V arbeitet.

>2. Kann es ein, dass die Dioden D7.1 und D7.2 falsch gepolt gezeichnet
>sind? (Den Widerstand beim ausschalten)

Kommt drauf an wie das Relais angeschlossen ist.

MfG
Falk

P S so richtig verstehe ich die Funktion dieses "Entregungswidertandes" 
nicht. Vor allem bei DC?

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Frage (Gast)
(das waren aber zwei Fragen)

zu 2) da ich die Dioden antiparallel drin habe, sollte es meiner Meinung 
egal sein. Hab das Überbrücken von D7.2 noch nicht ausprobiert

Der Entregungswiderstand wird vermutlich mit den speziellen 
ferromagnetischen Eigenschaften des Spulenkerns zusammenhängen. Da 
dieser Kern anders beschaffen sein muss, als die der monostabilen Relais 
(die Spule als solche sieht ja genauso aus), macht das für mich nur so 
Sinn.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht sollte man mal eins oder zwei kaufen und messen. Hmm.

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meine D7.2 ist tatsächlich nicht notwendig

Autor: Aufpasser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Entregungswiderstand wird vermutlich mit den speziellen
 > ferromagnetischen Eigenschaften des Spulenkerns zusammenhängen.
 > Da dieser Kern anders beschaffen sein muss, als die der
 > monostabilen  Relais (die Spule als solche sieht ja genauso aus),
 > macht das für mich nur so Sinn.

Nein der Spulenkern ist so wie bei monostabilen.
Was anders ist sind die zusätzlichen Dauermagnete. Deren Haltekraft muss
beim Schaltwechsel überwunden werden.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Aufpasser (Gast)

>Was anders ist sind die zusätzlichen Dauermagnete. Deren Haltekraft muss
>beim Schaltwechsel überwunden werden.

Dazu muss man doch aber keinen Widerstand in Reihe schalten?!?

Autor: Frage (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Was ich an der deiner Schaltung schade finde ist:
- Du musst zum Schalten immer warten, bis der ELKO vollständig 
geladen/entladen ist. Wie bekommst du es mit, falls es nicht 
funktioniert hat?
- Wenn sich die Kapazität des Elkos sich über die Zeit/Temperatur ändert 
(ich weiß nicht in wiefern das Relevant ist). Reicht die Ladung in einem 
Jahr zum Ein/Ausschalten noch?
- Beim resetten des µc weißt du nicht, in welchem Zustand dein Relais 
ist -> du musst es "Ein"schalten, lange warten und wieder "Aus"schalten. 
Erst dann bist du sicher, dass das Relais aus ist -> du schaltest den 
Verbraucher einmal unnötig um. (Analog für Initialisierungszustand=an)

Mein Ziel:
Schalten von mind. 4 bistabilen Relais (die gleichen von vorhin, 12 V 
VSS) mit 4+1 Kontrollerausgängen. Beim Neustart will nicht alle Relais 
hin und herschalten müssen.

Deshalb hätte ich eine Frage (sind wieder ein paar mehr):
- Würde meine angehängte Skizze Diagramm1 funktionieren? (Grün = für 
jedes Relais, Schwarz = gemeinsame Leitung: Schalte Relais ein/aus)
- Kann die Schaltung noch optimiert werden (paar Transistoren/Inverter 
entfernen): so wie Diagramm2. Leider wäre hier T1.4 oder T1.5 im 
Inversbetrieb -> Der Transistor wird die 12 V nicht abkönnen.
- Muss man noch eine Freilaufdiode einfügen? (Wo?)
- Wie hoch würdet ihr Kenner den Stromverbrauch schätzen (alle µC-Pins 
LOW) - eigentlich sollte doch kein Strom fließen?

Vielen Dank und sorry wenn ich für jemanden dumme und zuviele Fragen 
stelle!

Autor: Frage (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier nocheinmal Diagram2

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
warum nehmt Ihr nicht ein bistabiles Relais mit 2 Spulen?

T.

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht hier eben nicht um 2-spulige Relais!

In meiner Schaltung wird tatsächlich nach einem Reset ausgeschaltet, was 
auch schon reicht. Ob das Relais tatsächlich angezogen hat, messe ich 
über einen im Verbraucherzweig hängenden Strommesser, was ich zur 
Bewertung weiterer Fälle sowieso benötige. Ich habe außerdem etliche 
Stunden im Testlauf überprüft, ob 1,5 Sekunden sicher schalten, was sie 
auch taten. Mir reicht das. Die zu schaltende Brunnenpumpe von 1,5 KW 
möchte ich außerdem gar nicht mit mehr als 0,5 Hz ein- und ausschalten.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  No Name (nohelp)

>Stunden im Testlauf überprüft, ob 1,5 Sekunden sicher schalten, was sie
>auch taten.

Das kann man einfach für 5*R*C ausrechnen, Spulenwiderstand * Kapazität 
* 5

> Mir reicht das. Die zu schaltende Brunnenpumpe von 1,5 KW
> möchte ich außerdem gar nicht mit mehr als 0,5 Hz ein- und ausschalten.

Besser ist das.

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine andere Möglichkeit (je nach Spannung und Strom) wäre ein IC, wie 
z.B. 7404, 7414, 7417 (ohne Open-Collector-Ausgänge). 3 Buffer parallel 
an den einen Spulenanschluss, die anderen 3 Buffer an den anderen. 
Braucht auf die Art zwei uC-Pins, mit einem kleinen Transistor-Inverter 
läuft es auch mit einem, dann fließt allerdings ständig Strom.

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Falk Brunner (falk)

Die Spule des 40.61.6.012 (12V bistabil) hat laut Datenblatt 130 Ohm
5 x 130 Ohm x 470µF = 305 ms
richtig gerechnet? Denn dann würde es nicht funktionieren

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  No Name (nohelp)

>Die Spule des 40.61.6.012 (12V bistabil) hat laut Datenblatt 130 Ohm
>5 x 130 Ohm x 470µF = 305 ms
>richtig gerechnet?

Sieht so aus.

> Denn dann würde es nicht funktionieren

??
Was meinst du? Hast das mal geprüft?

Was Probleme machen könnte ist deine suboptimale Halbbrücke. Die 20K 
(R7.2, was sollen eigentlich die komischen Namen?) Sind füh die 
Ausschaltphase strombegrenzend, grob überschlagen kommen da nur 10mA bei 
HIGH raus. Dein Relais hätte aber gern ~12V/130Ohm = 100mA.
Mach mal testweise den Widerstand 2k2 oder so.

MfG
Falk

Autor: No Name (nohelp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In meinem ersten Beitrag 
Beitrag "Re: bistabiles relais umpolen" zur Dimensionierung 
war der Dauerstrom noch deutlich höher und das Schaltverhalten das 
gleiche wie jetzt.

Die Namen rühren daher, dass ich das ganze mehrfach aufgebaut habe und 
gleiche Gruppeninhalte so eben benenne.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  No Name (nohelp)

>Beitrag "Re: bistabiles relais umpolen" zur Dimensionierung
>war der Dauerstrom noch deutlich höher und das Schaltverhalten das
>gleiche wie jetzt.

Hmm, komisch. Müsste man mal mit einem Oszi nachmessen.

Autor: Markus (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.PNG
    1.PNG
    1,14 KB, 1042 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend.
Kann das denn auch mit einen ULN2803 Treiber funktionieren. (S. Anhang)

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein. Es muss ein Push-Pull Ausgang sein, kein Open Kollektor.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verdang. Deswegen funktioniert das auch nicht . Hättest du ein Tip wie 
ich das lösen könnt ? Mit nur einem Ausgang ein bistabiles Relais zu 
schalten, umpolen?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ich das lösen könnt ? Mit nur einem Ausgang ein bistabiles Relais zu
>schalten, umpolen?

Ist doch hier schon tausendmal geschrieben worden. UNd auch DU bist dort 
vertreten!

Beitrag "Re: Stromstossrelais / bistabiles Relais"

Es reicht EIN Ausgang, dazu der Kondensator in Reihe, fertig. Somit 
reicht EIN L293 für VIER Relais.

MFG
Falk

Autor: Markus P. (sebastianwurst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ich weiss, ich werde jetzt hier auch nicht mehr schreiben. Ich wollte 
hier halt nur die Frage stellen ob das mit eine ULN2803 möglich ist.

>Es reicht EIN Ausgang, dazu der Kondensator in Reihe, fertig. Somit
>reicht EIN L293 für VIER Relais.

Der Kondensator geht doch nicht, wegen den ULN2803.

Das verwirt mich jetzt total:
"Somit reicht EIN L293 für VIER Relais"
Wie meinst Du das ?

Autor: Falk Brunner (falk)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Markus P. (sebastianwurst)

>hier halt nur die Frage stellen ob das mit eine ULN2803 möglich ist.

Ist es auch nicht.

>Der Kondensator geht doch nicht, wegen den ULN2803.

Von dem redet auch keiner. Es war vom L293 die Rede, auch in dem Link.

>Das verwirt mich jetzt total:
>Somit reicht EIN L293 für VIER Relais"
>Wie meinst Du das ?

Siehe Anhang! Die Kondensatoren muss man an die Relais anpassen. Pi mal 
Daumen sollte C mal Relaiswiderstand der Spule rund 3 mal so groß wie 
die Schaltzeit sein.

C * R_Spule ~ 3 * t_schalt

MfG
Falk

Autor: Markus P. (sebastianwurst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Falk, ich probiere das mal aus und hoffe das es geht .... Somit 
brauch ich dann ja wirklich nur 1 Ausgang für ein Relais. Genau das was 
ich wollte. Jetzt muss ich nur noch die Brücken bestellen.

Autor: Markus P. (sebastianwurst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch eine Frage zum Kondensator

Wenn die Spule 220 Ohm hat und ich eine Schaltzeit von 100ms mache, ist 
dann diese Rechnung richtig: (Schaltzeit = Aufladezeit des Kondensator, 
also ansteuerzeit des Relais ?!?)

3*100ms = 300

"C * R_Spule ~ 3 * t_schalt"

C = 300/220
C = 1.4 yF ?!?! Ist die Rechnung richtig ?


Vielen Dank

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Markus P. (sebastianwurst)

>Wenn die Spule 220 Ohm hat und ich eine Schaltzeit von 100ms mache,

Es geht nicht darum, 100ms "zu machen", sondern wie lange das Relais zum 
schalten braucht. Steht im Datenblatt, typische Relais haben um die 
10ms.

>3*100ms = 300

da fehlen die ms.

>C = 300/220
>C = 1.4 yF ?!?! Ist die Rechnung richtig ?

Nö, weil a) die ms fehlen und b) es keine 100ms Schaltzeit hat.

Ehr so.

10ms * 3 = 30ms.

30ms/220 = 136µF. Also ein 220µF Kondensator und gut.

MFG
Falk

Autor: Markus P. (sebastianwurst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne Worte, danke !

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.