www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Portierungsprobleme Mega32 -> Mega644


Autor: Thorsten Fritzke (thorsten)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

ich darf momentan ein bestehendes System von einem Mega32 auf einen 
Mega644 portieren. Dank Atmels Appnote ist das auch kein allzugroßes 
Problem.
Allerdings:
Am Controller ist ein 128x64 Grafikdisplay mit Datenleitungen an PortA 
und Steuerleitungen an PortC angebunden und eben jenes verweigert nun 
den Dienst.
Alle anderen Funktionen wie z.B. ein Keyboard, I²C oder die UART 
funktionieren normal.

Die Fuse fürs JTAG Interface habe ich schon deaktiviert. Das System 
läuft mit 16Mhz.
Da das System bis auf das Display sich normal verhält schliesse ich mal 
den Watchdog aus, zumal dieser sowieso per Software deaktiviert wird.

Fällt da irgendjemandem was ein, woran das liegen könnte?

Gruß
Thorsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.