mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pollin Addon-Board v1.0 und LCD TC1602A - wie befestigen?


Autor: Markus D. (daubsi)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

ich bin gerade dabei mir das Pollin Addon-Board (Nr. 810 053) für das 
Atmel Eval Board zusammenzulöten. Habe erst angefangen und die 
Buchsenleisten gesetzt und wollte nun auch die 2 Steckleisten für die 
Jumper und das LCD festlöten.
Da wo die 2x11 polige Leiste unten neben den Buttons hinkommt, habe ich 
die Leiste mit den Stiften der Länge ca. 0.7cm verlötet, jetzt habe ich 
noch 2x7 und 2x1 mit ca. 1,2cm längen Steck-Kontakten. Die 2x7er würde 
dann ja links in den Bereich passen wo das Display drüber ist (bei den 
jeweils 2x4 Buchsen), so wie es auch auf Seite 3 der Anleitung 
abgebildet ist und die 1x2 ist dann wohl einfach übrig...

Dann habe ich mir das mal genauer angesehen und mir ist jetzt irgendwie 
völlig unklar wie überhaupt das Display befestigt werden soll.
Bei meinem Bausatz hat das Display Nr. 120 420 gefehlt, es wurde mir 
aber kostenlos nachgeliefert.

Aber dieses Display hat links überhaupt keine Öffnungen/Kontakte für die 
2x7 Pins! Es hat lediglich am oberen Rand 16 Lötpunkte (wie auch im 
Produktphoto von Pollin sichtbar). Auf der Titelseite des 
Anleitungs-PDFs bzw. den Produktfotos für 810 053 sieht man auch, dass 
die Leisten an diese Lötpunkte gelötet werden. In der Anleitung wird 
aber darüber kein Wort verloren, dafür sieht man aber, dass in den 2x7 
Pin-Öffnungen Stecker verlötet sind...?

Heißt das dann, dass das Display nur an diesen 16 Punkte befestigt ist 
und ansonsten in der Luft hängt?? Oder soll das dann an den erwähnten 
2x7 Pins "aufliegen"?? Dann fehlen wir allerdings Stecker, obwohl laut 
Stückliste alles bei ist...

Ich habe gesehen, dass es anscheinend zwei verschiedene Varianten von 
dem Display gibt (http://img204.imageshack.us/i/dsc00098yk9.jpg/). Ist 
das dann einfach so gedacht, dass man schauen muß, welche Version man 
hat und die entsprechenden Leisten einlötet oder haben die mir evtl. ein 
falsches Display nachgeliefert?

Ich bin jetzt nicht wirklich der Leiterbahnspezialist, aber wenn ich das 
richtig interpretiere, geht die 2x11 polige Jumperleiste hoch zu der 
16-poligen Leiste, wie sie auf dem Titelbild sichtbar ist, während die 
2x7 polige Leiste links irgendwie mit gar nichts verbunden zu sein 
scheint??

Dann noch eine weitere Frage:

Wie ist das denn jetzt mit der 40 poligen Anschlußbuchse ganz links?
Kann ich da einfach das "Hauptboard" und dieses Board mittels 40-poligem 
IDE Kabel verbinden, so wie hier 
Beitrag "Re: Pollin Atmel Evaluations-Board & Co. - Fragen" ersichtlich oder muß 
ich jetzt da noch etwas beachten.
Ich habe den Artikel unter Beitrag "Pollin Atmel Evaluations-Board & Co. - Fragen" 
mal diesbezüglich überflogen, aber da scheint es im Wesentlichen ja nur 
um Fragen zur Programmierung der ATmegas zu gehen, und das funktioniert 
bei mir soweit problemlos...

Vielen Dank!

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pieps das 40-polige IDE Kabel zur Sicherheit mit dem Durchgangsprüfer 
durch. Dunkel erinnere ich mich an Beiträge mit einem nicht vollständig 
1:1 beschalteten Kabel (Hab's: 
Beitrag "Re: Pollin Evaluationsboard mit Add-On Board RS232 Fehler").

Zweites Problem möglicherweise zwischen dem Middle und dem End Connector 
am Kabel:
[zitat http://en.wikipedia.org/wiki/Parallel_ATA#Cable_select]
With the 40-wire cable it was very common to implement cable select by 
simply cutting the pin 28 wire between the two device connectors; 
putting the slave device at the end of the cable, and the master on the 
middle connector. This arrangement eventually was standardized in later 
versions. If there is just one device on the cable, this results in an 
unused stub of cable, which is undesirable for physical convenience and 
electrical reasons. The stub causes signal reflections, particularly at 
higher transfer rates.
[/zitat]

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, sagen wir so: Ich habe kein IDE Kabel (mehr) gehabt und hab mir bei 
Pollin noch die entsprechende "Rohware" bestellt um das Kabel selbst zu 
konfektionieren. Auch in diesem Fall ist dann Pin 1 zu entfernen wie es 
da heißt?

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muss ich mir die beiden Schaltpläne mal ansehen. Dauert etwas...

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, wieder da. Ich sehe kein Problem mit einem 1:1 IDE Kabel.

Aber die diversen Jumper auf dem Addon-Board müssen richtig gesetzt 
sein. Wenn da ein ungünstiger Jumper gesetzt ist, hat man in der Tat 
z.B. eine Verbindung von Px0 (Pin1) auf Px4 (Pin5) an J4.

x=A bei Atmega16 oder Atmega32
x=C bei Atmega8

Die von Markus im anderen Thread erwähnten PD0 und PD4 sind zumindest 
bei obigen AVR gaaannnz weit von Pin1 am IDE-Connector weg. Ich verstehe 
das Posting nicht bzw. man müsste wissen um welchen AVR es ging.

Du kannst aber das Kabel mal nur am Pollin-µC-Board einstecken und im 
Betrieb an Pin 1 bzw. Pin 5 mit dem Voltmeter messen, ob du dort +5V 
findest. Bzw. nur am Wannenstecker messen geht auch.

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, danke, das probiere ich dann mal!
Zum Thema LCD kannst Du mir nichts sagen, oder?

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Also" ich würde in die 2x7er Reihe die Stiftleiste reinlöten und in die 
1x16er Lochreihe auch Stifte reinsetzen. Auf mein LCD würde ich die 
passende Buchsenleiste einlöten, so dass ich das LCD einfach aufstecken 
kann. Das baut dann ca. 1cm höher, aber man kann so verschiedene LCDs 
einfach testen.

Die mechanische Stabilität kommt, wenn du Abstandsbolzen in die fetten 
Ecklöcher der im LCD1 Gebiet der Platine und in dem aufgesockelten bzw. 
aufgelöteten LCD montierst.

Ich weiss nicht ob dafür Bauteile im Kit sind. Ich sammele beim 
Schlachten alter Elektronik Schräubchen und Mütterchen im Gurkenglas und 
finde in diesem Fundus meist was passendes... bei metallischen 
Abstandshaltern wie Schrauben oder Gewindestangen aufpassen, ob man die 
ohne Bestrafung durch Hr. Ohm verwenden kann.

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm.. okay, sicher, flexibel kann ich es ja immer halten, das ist 
richtig.
Konkret sind aber keinerlei weitere Bauteile vorhanden, daher die Frage, 
wie das da wohl gemeint ist von Pollin.
Das mit den Abstandshaltern ist ne gute Idee, muss mal kucken, ob ich da 
auch noch was finde...

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo markus

ich habe selbiges board und bei mir kam auch keine befestigung fuer das 
display mit. das display, das bei mir mitkam, hat auf der einen schmalen 
seite 2x7 durchkontaktierungen und auf der anderen 2 einzelne. diese 
sind fuer die hintergrundbeleuchtung. zwecks flexibilitaet habe ich das 
LCD auch nicht angeloetet sondern mir steckerleisten und stiftleisten 
nachtraeglich gekauft. die gibts in verschiedenen groessen. das LCD hat 
jetzt einen abstand von ca 11 mm zum add-on board.
hatte das auch schon gebraucht, da ich die kondensatoren darunter wieder 
ausgeloetet habe. ( C11 bis C18 machen nur probleme ) mit M2x20 habe ich 
es noch zusaetzlich angeschraubt, waere aber nicht unbedingt notwendig.

> 2x7 polige Leiste links irgendwie mit gar nichts verbunden zu sein

doch ist es, geht ebenfalls zu der 2x11 leiste in der naehe der taste 
B4.

den IC2 habe ich uebrigens weggelassen und versorge das board vom 
basis-board ueber das flachband-kabel. alle 40 pins 1:1 verbunden.

gruesse
hans

--

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

Hans Mayer schrieb:
> hallo markus
>
> ich habe selbiges board und bei mir kam auch keine befestigung fuer das
> display mit. das display, das bei mir mitkam, hat auf der einen schmalen
> seite 2x7 durchkontaktierungen und auf der anderen 2 einzelne. diese

Ah, wie ich schon vermutete, da gab's zwei verschiedene Varianten... ich 
meine auch, ich hätte bei einer alten Bestellung von LCDs mal diese 
Variante gesehen...

> sind fuer die hintergrundbeleuchtung. zwecks flexibilitaet habe ich das
> LCD auch nicht angeloetet sondern mir steckerleisten und stiftleisten
> nachtraeglich gekauft. die gibts in verschiedenen groessen. das LCD hat
> jetzt einen abstand von ca 11 mm zum add-on board.
> hatte das auch schon gebraucht, da ich die kondensatoren darunter wieder
> ausgeloetet habe. ( C11 bis C18 machen nur probleme ) mit M2x20 habe ich
> es noch zusaetzlich angeschraubt, waere aber nicht unbedingt notwendig.
>
>> 2x7 polige Leiste links irgendwie mit gar nichts verbunden zu sein
>
> doch ist es, geht ebenfalls zu der 2x11 leiste in der naehe der taste
> B4.
>

Hmm... das heißt also eigentlich sind die beiden Pin-Leisten beide mehr 
oder weniger identisch beschaltet und kommen dann halt je nach 
verwendetem Display-Typ zum Einsatz? Inwiefern machen denn C11-C18 
Probleme?
(Und warum kommt es überhaupt zu Problemen?... testen die das denn nicht 
bevor die sowas produzieren??)
Ich möchte ja eigentlich nur ein Board, mit dem ich "rumspielen" kann. 
Aber funktionieren sollte es halt, damit ich weiß, dass ich Fehler bei 
mir suchen muß und nicht erst auf dem Board rumsuchen muß...

> den IC2 habe ich uebrigens weggelassen und versorge das board vom
> basis-board ueber das flachband-kabel. alle 40 pins 1:1 verbunden.
>

Ah, ok, ist also auch ne Möglichkeit?
Habe ich das richtig in Erinnerung, dass dann da auch ein Pin direkt von 
der Spannungsquelle auf dem Hauptboard durchgeschaltet war oder kamen 
die alle vom µC? Weil dann, sollte man ja nichts anschließen was viel 
Strom zieht, weil die µCs das ja nicht abkönnen, oder?

> gruesse
> hans
>
> --

grüße,
markus :-)

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo markus

> (Und warum kommt es überhaupt zu Problemen?...

sieh mal hier
Beitrag "design fehler am atmel evaluations-board - programm stuerzt ab"
es ist leider so. bzw hier
http://www.mikrocontroller.net/articles/Diskussion...

> Habe ich das richtig in Erinnerung, dass dann da auch ein Pin direkt

da kann ich dir nicht ganz folgen, was du meinst.
pin 35, 37 u 39 sind masse und die gegenuebeliegenden pins 36, 38 u 40 
sind +5V. die beiden 7805 sollte man tunlichst nicht so schalten, dass 
die beiden ausgaenge zusammen kommen. mit einem 40 poligen 1:1 kabel ist 
es aber so. ein 7805 liefert ca 1 A, wenn ich mich recht entsinne. 
hoffentlich schaffen das auch die leiterbahnen. bei mir nehmen alle 
platinen in summe ca 85 mA auf. wobei ich die LED fuer die "NETZ" 
anzeige am add-on deaktiviert habe. die blendet naemlich.

schoene gruesse
hans

--

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

Hans Mayer schrieb:
> hallo markus
>
>> (Und warum kommt es überhaupt zu Problemen?...
>
> sieh mal hier
> Beitrag "design fehler am atmel evaluations-board - programm stuerzt ab"
> es ist leider so. bzw hier
> 
http://www.mikrocontroller.net/articles/Diskussion...
>

Seufz.. ja, war auch mehr ne rhetorische Frage... :-/

>> Habe ich das richtig in Erinnerung, dass dann da auch ein Pin direkt
>
> da kann ich dir nicht ganz folgen, was du meinst.
> pin 35, 37 u 39 sind masse und die gegenuebeliegenden pins 36, 38 u 40
> sind +5V. die beiden 7805 sollte man tunlichst nicht so schalten, dass
> die beiden ausgaenge zusammen kommen. mit einem 40 poligen 1:1 kabel ist
> es aber so. ein 7805 liefert ca 1 A, wenn ich mich recht entsinne.

Das heißt, Du würdest also dem Beitrag 
Beitrag "Re: Pollin Addon-Board v1.0 und LCD TC1602A - wie befestigen?" weiter oben 
wiedersprechen, dass es keine Probleme gibt?

> hoffentlich schaffen das auch die leiterbahnen.

Du meinst: im Kurzschlußfall?

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich erinnere mich an einen Beitrag, in dem behauptet wurde, man müsse 
VCC und GND am Übergang zum Display vertauschen.

Weiß jemand, wo diese Behauptung zu finden ist?
Für welche Verbindung und welches Display trifft das zu?

> Bei meinem Bausatz hat das Display Nr. 120 420 gefehlt, es wurde
> mir aber kostenlos nachgeliefert.

> das display, das bei mir mitkam, hat auf der einen schmalen
> seite 2x7 durchkontaktierungen und auf der anderen 2 einzelne.
An Alle eine generelle Bitte:
Immer so exakt und ausführlich wie möglich schreiben:
Welches Display (Bezeichnung, Lieferant, BestNr.) ist gemeint.


Es gibt über 100 Beiträge zum Thema Pollin Addon / Add-on hier im Forum.
Es lohnt sich, zumindest 10 davon zu lesen.


> wobei ich die LED fuer die "NETZ" anzeige am add-on deaktiviert
> habe. die blendet naemlich.
Geht mir auch so, ich nehme statt der 270 einen höheren Wert (470-1k).
Ist auch besser für den Linearregler (weniger Erwärmung), falls er mit 
einer hohen Spannung versorgt wird.

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo markus

> Das heißt, Du würdest also dem Beitrag
> Beitrag "Re: Pollin Addon-Board v1.0 und LCD TC1602A - wie befestigen?"
> weiter oben
> wiedersprechen, dass es keine Probleme gibt?

hmm ?? jetzt wird's kompliziert.
ich habe keine probleme mit dem 40-poligen 1:1 kabel. die angesprochene 
problematik mit den jumpern kann ich jetzt nicht nachvollziehen, kein 
zugriff zu den pdf's momentan. generell muss man natuerlich bei jedem 
eval-board sich ueberlegen, wie man jumper setzt. um groesst moegliche 
flexibilitaet zu haben, wird es sicherlich kombinationen geben, die 
problematisch sind.

ich habe uebrigens das add-on mit distanzhuelsen am eval-board montiert. 
den abstand darf man nicht zu knapp bemessen, da man sonst den 
10-poligen stecker fuer ISP nicht an- bzw. abstecken kann. wenn man es 
so montiert, muss das flachbandkabel etwas laenger sein, da die stecker 
auf den gegenueberliegenden seiten zu liegen kommen. das layout ist 
leider nicht so, dass sie uebereinander montierbar waeren. dafuer 
braeuchte man kein flachbandkabel, sondern eines, das sich leicht um 180 
grad drehen laesst.

> > hoffentlich schaffen das auch die leiterbahnen.
> Du meinst: im Kurzschlußfall?

ja, z.b.
ich habe mir das layout nicht angesehen, aber ueblicher weise ist es 
kein problem bei den meisten prints 1 A ueber die leitungen zu ziehen. 
aber das braucht man ja ohnehin nicht.

schoene gruesse
hans

--

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo eProfi,

eProfi schrieb:

> An Alle eine generelle Bitte:
> Immer so exakt und ausführlich wie möglich schreiben:
> Welches Display (Bezeichnung, Lieferant, BestNr.) ist gemeint.
>

Hatte ich... siehe Titel des Threads und mein erster Beitrag ;-)

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

na ja, Du hattest geschrieben:

> hmm ?? jetzt wird's kompliziert.
> ich habe keine probleme mit dem 40-poligen 1:1 kabel. die angesprochene
> problematik mit den jumpern kann ich jetzt nicht nachvollziehen, kein

bzw.

> sind +5V. die beiden 7805 sollte man tunlichst nicht so schalten, dass
> die beiden ausgaenge zusammen kommen. mit einem 40 poligen 1:1 kabel ist
> es aber so. ein 7805 liefert ca 1 A, wenn ich mich recht entsinne.

Daher hatte ich das so interpretiert, dass wenn man ein 40 poliges 1:1 
Kabel nimmt, es eben genau einen Kurzen gibt. Oder wolltest Du damit 
sagen, dass es mit einem 40-poliges 1:1 Kabel eben genau -nicht- 
passiert?

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

> > das display, das bei mir mitkam, hat auf der einen schmalen
> > seite 2x7 durchkontaktierungen und auf der anderen 2 einzelne.
> An Alle eine generelle Bitte:
> Immer so exakt und ausführlich wie möglich schreiben:
> Welches Display (Bezeichnung, Lieferant, BestNr.) ist gemeint.

da gebe ich dir voellig recht. aber das ist leichter gesagt als getan. 
das display, das mir geliefert wurde, war in keiner weise bezeichnet. 
weder in den mitgelieferten unterlagen, noch war auf dem display irgend 
etwas aufgedruckt.

also ein echter noname.
vom aussehen sieht es diesem aehnlich
http://www.pollin.de/shop/dt/NDU0OTc4OTk-/Baueleme...
aber eben nur aehnlich


schoene gruesse
hans

--

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo markus

> Daher hatte ich das so interpretiert, dass wenn man ein 40 poliges 1:1
> Kabel nimmt, es eben genau einen Kurzen gibt. Oder wolltest Du damit
> sagen, dass es mit einem 40-poliges 1:1 Kabel eben genau -nicht-
> passiert?

es gibt keine probleme, wenn
- das kabel und die stecker richtig montiert sind, also pin 1 des einen 
steckers mit pin 1 des anderen, usw. verbunden sind. und auch die 
buchsen nicht falsch herum eingeloetet sind, sondern so wie 
aufgezeichnet.
- und du den spannungsregler 7805 (IC2) am add-on weg gelassen hast. und 
wenn nicht, dann ist es auch kein kurzschluss, sondern es liefern 2 
regler auf eine 5 V versorgung. ich denke, sie werden es aushalten.

schoene gruesse
hans

--

Autor: qwertzuiopü+ (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich habe zwei addon-boards von pollin. auf einem ist das display (noch) 
fest aufgelötet, das fristet allerdings meistens in einer "lagerkiste" 
sein dasein. beim anderen habe ich (abgesehen vom hühnerfutter und 
sonstigen bauteilen) nur die im anhang rot markierten anschlüsse 
bestückt (mit den "kontaktbuchsen").
das pollin-board verwende ich dann hauptsächlich als "verteiler" für das 
(bzw. die) breadboard(s). für diesplay-tests habe ich drei 
standard-modelle, an die ich flachbandkabel angebaut und mit passenden 
falchband-ic-sockel-anschlüssen (ähnl. reichelt KK08025C) bestückt habe.

da meine addon-baords mittlerweile mit einem stk500 ihren dienst 
versehen habe ich zusätzlich noch eine 40pol. pfostenbuchse mit fünf 
jeweils nicht voll bestückten 10 poligen pfostenbuchsen ausgestattet, 
mit denen ich die einzelnen pins vom stk500 einfach auf die anschlüsse 
am addon-baord legen kann.

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> vom aussehen sieht es diesem aehnlich
> 
http://www.pollin.de/shop/dt/NDU0OTc4OTk-/Baueleme...
> aber eben nur aehnlich
>
>
> schoene gruesse
> hans
>
> --

Ist es vlt. dieses hier, dass ich ganz oben verlinkt habe?
http://img204.imageshack.us/i/dsc00098yk9.jpg/

Autor: Markus D. (daubsi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Mayer schrieb:
> hallo markus
>

> - und du den spannungsregler 7805 (IC2) am add-on weg gelassen hast. und
> wenn nicht, dann ist es auch kein kurzschluss, sondern es liefern 2
> regler auf eine 5 V versorgung. ich denke, sie werden es aushalten.
>

Wenn ich aber eh nur die Spannungsversorgung beim Hauptboard nutze, dann 
ist es auch egal, und ich brauche den IC2 nicht ausbauen, weil er dann 
ja eh nicht aktiv ist, oder? Wenn man dann doch mal das Addon-Board 
alleine betreiben will, nutzt man ihn halt dann..

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo markus

> Ist es vlt. dieses hier, dass ich ganz oben verlinkt habe?
> http://img204.imageshack.us/i/dsc00098yk9.jpg/

ja, das kommt der sache schon sehr aehnlich.
welche typenbezeichnung hat dieser ?

> Wenn ich aber eh nur die Spannungsversorgung beim Hauptboard nutze, dann
> ist es auch egal, und ich brauche den IC2 nicht ausbauen, weil er dann
> ja eh nicht aktiv ist, oder? Wenn man dann doch mal das Addon-Board

dann lieferst aber die 5 V an den ausgang, der selbst keine 
ausgangsspannung liefert. also verkehrt rum betrieben.  ob ihm das trotz 
der schutzdioden gut tut ?
hast du ihn schon eingeloetet ?

> alleine betreiben will, nutzt man ihn halt dann..

alleine ? was willst damit machen ?


schoene gruesse
hans

--

Autor: Markus D. (daubsi)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans,

Hans Mayer schrieb:
> hallo markus
>
>> Ist es vlt. dieses hier, dass ich ganz oben verlinkt habe?
>> http://img204.imageshack.us/i/dsc00098yk9.jpg/
>
> ja, das kommt der sache schon sehr aehnlich.
> welche typenbezeichnung hat dieser ?


<such such> Ha, bei mir kommt halt nix weg... Wusste doch, dass ich mir 
so ein Teil auch mal bestellt hatte: Es ist ein TC1602A, Pollin 
120420...
Und dabei fällt mir auf, dass mir Pollin auf meine Reklamation hin kein 
120420 geliefert hatte, so wie es in dem Bausatz heißt, sondern ein 
120421 - TC1602E. Dieses hat eben nicht die Stiftleiste links, sondern 
die 16 Kontakte an der Oberkante.
Ich vermute jetzt aber einfach mal ganz stark, dass die beide kompatibel 
sind:

a) Die 2x7 Pins links und die kleineren Distanzhalter-Bohrungen passen 
fürs 120420/TC1602E
b) Die 1x16 Pins oben und die größeren Distanzhalter-Bohrungen passen 
fürs 120421/TC1602A

Das lässt die Variante mit der Flexibilität von oben nochmal positiver 
erscheinen. Ich habe mal bei Pollin nach Abstandshaltern gesucht. 
(http://www.pollin.de/shop/suchergebnis.html?S_TEXT...) 
Welche verwendet ihr hierfür?
Kann ich das Display dann einfach auf die Pins aufstecken (die Bohrungen 
in der Display-Platine scheinen klein genug zu sein, dass ein guter 
Kontakt besteht), oder muß ich da wirklich ein Gegenstück dranlöten?

>
>> Wenn ich aber eh nur die Spannungsversorgung beim Hauptboard nutze, dann
>> ist es auch egal, und ich brauche den IC2 nicht ausbauen, weil er dann
>> ja eh nicht aktiv ist, oder? Wenn man dann doch mal das Addon-Board
>
> dann lieferst aber die 5 V an den ausgang, der selbst keine
> ausgangsspannung liefert. also verkehrt rum betrieben.  ob ihm das trotz
> der schutzdioden gut tut ?
> hast du ihn schon eingeloetet ?

Nein, noch nicht. Das heißt, sowas darf man nicht machen?
--> Warum ist der denn dann überhaupt drin?? Dann macht das doch gar 
keinen Sinn??

>
>> alleine betreiben will, nutzt man ihn halt dann..
>
> alleine ? was willst damit machen ?
>

Öhm... hmm.. vlt. die IR Schnittstelle, das Funkmodul, ... auch mit 
einem anderen Board verwenden? Weiß noch nicht so genau... Ich hab hier 
noch ein myAvr Board rumliegen und MSP und STM Boards und dachte mir, da 
könnte ich dann auch die entsprechenden Bausteine mitnutzen indem ich 
das flexibel verkabel...

Grüße,
Markus

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Mayer schrieb:
> ich habe uebrigens das add-on mit distanzhuelsen am eval-board montiert.
> den abstand darf man nicht zu knapp bemessen, da man sonst den
> 10-poligen stecker fuer ISP nicht an- bzw. abstecken kann. wenn man es
> so montiert, muss das flachbandkabel etwas laenger sein, da die stecker
> auf den gegenueberliegenden seiten zu liegen kommen. das layout ist
> leider nicht so, dass sie uebereinander montierbar waeren. dafuer
> braeuchte man kein flachbandkabel, sondern eines, das sich leicht um 180
> grad drehen laesst.

Das passt aber optimal, wenn man die Lötseiten zueinander montiert.
Man kommt gut an alles ran, und braucht nur ein kurzes Kabel, das
nicht verdreht werden muß.

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo


> > hast du ihn schon eingeloetet ?
> Nein, noch nicht.

dann lasse ihn weg.

> Warum ist der denn dann überhaupt drin??

fuer leute, die das board alleine betreiben wollen :-)

> Das passt aber optimal, wenn man die Lötseiten zueinander montiert.

geniale idee von dir.


schoene gruesse
hans

--

Autor: Hans Mayer (Firma: mayer) (oe1smc) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

> oder muß ich da wirklich ein Gegenstück dranlöten?

wie ? einfach die stifleiste nur durch die durchkontaktierungen 
durchfuehren und hoffen, dass dann kontakte vorhanden sind.

das wird nix.

da brauchst schon passende kontaktleisten.


schoene gruesse
hans

--

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan B. schrieb:
> "Also" ich würde in die 2x7er Reihe die Stiftleiste reinlöten und in die
> 1x16er Lochreihe auch Stifte reinsetzen. Auf mein LCD würde ich die
> passende Buchsenleiste einlöten, so dass ich das LCD einfach aufstecken
> kann.

Ich mache es übrigens genau andersrum:
Stifte ins LCD und Buchse auf die Platine (auch bei anderen
Testschaltungen, nicht nur dem Pollin-Board).
Grund: mit den Stiften im LCD kann man das auch geschwind auf einem
Breadboard nehmen.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Markus,

ich habe 2 ADD-On-Boards bestückt.
In eine Bausatz war das eine und im andern das andere Display wie auf 
dem Foto in Deinem letzten Thread.

Das Board ist ja für beide Displays vorgesehen daher klappt deren 
ornungsgemäßer Berieb ohne weiteres. Man muß nur vor dem Anlöten schauen 
welches Display man hat und die Stiftleiste (Buschsenleiste, oder was 
auch immer) an entsprechender Stelle anlöten. Bei mir funtkionieren 
jedenfalls beide Displays am ADD-On-Board.

Um nicht immer mit eingeschalter Displaybeuchtung zu arbeiten habe ich 
in dessen Zuleitung eine kleine Modifikation eingebracht indem ich diese 
mit einem Jumnper bei Bedarf ein oder ausschalte. Sicher gibt es 
elegantere Lösungen.
Sollte ich nocheinmal ein Board dieser Art bauen werde ich mir übrigens 
einige hier genannte Tips zu Herzen nehmen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.