mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Attiny Probleme Relaisschaltung


Autor: Mike Cellar (Firma: MC) (badtiny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich hoffe Ihr könnt mir tips geben.
Ich probiere gerade mit dem Attiny 2313 und nem BB139(1000 Ohm 
Basiswideratsnd) ein 12V (265 Ohm Spule) Relais zu schalten.
Die 12Volt der Batterie regle ich mit einem 7805 runten.
100nF Kondensator parallel zu den 5Volt
330nF Kondnsator paralles zu den 12Volt.

Taster drücken = an
Taster 2 Sekunden drücken = Aus

Soweit so gut!
Trocken lüppt das auch einwandfrei.
Bei kleinen Lastströmen ist auch alles OK.

Hänge ich einen 55Watt ohmschen Verbraucher an meine Relaiskontakte, 
dann
taktet das Relais nur kontunierlich.
Ab und an zieht es mal an und bleibt an!

Ich denke das das mit der Stromversorgung zusammen hängt!!

Habt Ihr ne Idee, was ich machen kann??

Gruss
MC

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Berater ohne Honorar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Netzteil/Trafo überlastet? Spannungseinbruch? Reset des Tiny? Würde mal 
nen dicken Elko an die 5V klemmen, damit der Tiny stabiler versorgt 
wird.

Autor: Mike Cellar (Firma: MC) (badtiny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Info.

Naja, ein Netzteil gibt es nicht.
Nur die 12Volt Batterie und die Lichtmaschine.

Ich werde mal versuchen den Kondensatorwert zu erhöhen.
Die Basiswiderstände habe ich etwas verruntergesetzt, damit ich 
sichergehe
das die BD139 genug Basisstrom haben.

Wieviel Strom kann der Portausgang des Tiny´s liefern??

Gruss
MC

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Mike Cellar (Firma: MC) (badtiny)

>Ich werde mal versuchen den Kondensatorwert zu erhöhen.

Wird nichts bringen.

>Die Basiswiderstände habe ich etwas verruntergesetzt, damit ich
>sichergehe
>das die BD139 genug Basisstrom haben.

256 Ohm an 12V macht 47mA. Lächerlich. Mit 1K Basiswiderstand kricht 
dein BD139 ~4mA. Stromverstärkuing 10 hat der locker, eher Richtung 100.

>Wieviel Strom kann der Portausgang des Tiny´s liefern??

20mA

Neben einem fehlenden Snubber vermute ich Einkopplungen in dein IO-Pin 
mit dem Taster. Dort ist wahrscheinlich nur der interne Pull-Up aktiv. 
Ein RC-Filter wäre angesagt, siehe Schmitt-Trigger.

MFG
Falk

Autor: Floh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike Cellar schrieb:
> Ich denke das das mit der Stromversorgung zusammen hängt!!

> Nur die 12Volt Batterie und die Lichtmaschine.

KFZ? Ein Schaltplan wäre mal nett :-)

Autor: Mike Cellar (Firma: MC) (badtiny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Taster schaltet Masse auf den Eingang des Tiny´s.

Ich poste morgen mal den Schaltplan.

Gruss
MC

Autor: Bernd Stein (bernd_stein)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike Cellar schrieb:
> Hallo Leute,
>
> ich hoffe Ihr könnt mir tips geben.
...
> Trocken lüppt das auch einwandfrei.
> Bei kleinen Lastströmen ist auch alles OK.
>
> Hänge ich einen 55Watt ohmschen Verbraucher an meine Relaiskontakte,
> dann
> taktet das Relais nur kontunierlich.
> Ab und an zieht es mal an und bleibt an!
>
> Ich denke das das mit der Stromversorgung zusammen hängt!!
>
> Habt Ihr ne Idee, was ich machen kann??
>
> Gruss
> MC
>
Hast Du einen 100nF Kerko an Vcc und GND vom µC ?
Er sollte so nah wie möglich am µC positioniert werden.
Dieser erspart einem manchmal stundenlange Fehlersuche.


Bernd_Stein

Autor: Hauspapa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und sei so freundlich und sag mir das Du eine Sicherung in der Leitung 
hast.

Autor: Mike Cellar (Firma: MC) (badtiny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd Stein schrieb:
> Hast Du einen 100nF Kerko an Vcc und GND vom µC ?
> Er sollte so nah wie möglich am µC positioniert werden.
> Dieser erspart einem manchmal stundenlange Fehlersuche.
 Ja, ein 100nF ist direkt am Tiny.



Tja Leute,

ich geb Entwarnung.

So wie es aussieht scheint meine Testbatterie nicht mehr so frisch zu 
sein!!
Der Entschaltrush des 55W Verbrauchers muss die Spannung so beeinflusst 
haben,das die Versorgung des Tiny´s zusammenbrach.

Geladen und mit noch angeschlossenem Lader funzt es!!



Ich danke für Ihre Unterstützung!!!!!!!!!!!!!!!!!!

Gruss
MC

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Mike Cellar (Firma: MC) (badtiny)

>Der Entschaltrush

Was für ein Wort . . . 8-(

>des 55W Verbrauchers muss die Spannung so beeinflusst
>haben,das die Versorgung des Tiny´s zusammenbrach.

55W an 12V sind knapp 5A. Hmmmm.

MFG
Falk

Autor: Mike Cellar (Firma: MC) (badtiny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für das Kompliment!

Die Schaltung hängt an einer Motorradbatterie, die hat nicht ganz 
soviele Amperestunden.

Gruss
MC

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm einen 4060 und einen 4017 aus dem anderen Thread;)
Die funktionieren sicher, wie sich zeigt.
Beitrag "Astabiler Multivibrator mit langer Timerzeit"
Deine Schaltung kannst Du dann eintauschen. Du musst nichtmal was bauen.

Naja, versuch doch mal in die Zuleitung zum Tiny eine Diode reinzubauen 
und direkt über dem uC einen Kondensator. So bekommt der uC für sich 
alleine Strom, sozusagen...

Gruß

Axelr.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.