mikrocontroller.net

Forum: PC Hard- und Software Firefox ist plötzlich furchtbar träge


Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seit zwei Tagen habe ich zunehmende Probleme mit meinem FF 3.6.15 unter 
Ubuntu 10.04: das Anklicken eines Links läßt ich bis zu 12 Sekunden 
arbeiten, ohne daß sich was tut. Der Prozessorkern ist dabei zu 100% 
ausgelastet.

Ich habe mittlerweile den Cache gelöscht und FF im Safe Mode gestartet - 
alles hat nichts geholfen.

Gibt es eine Möglichkeit FF - der ja sein eigenes Updatesystem hat - neu 
zu installieren?

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier:
Beitrag "DNS-Routing: Firefox defekt, IE prima"
wird vorgeschlagen es einmal mit der "portable" Version zu probieren.

Ansonsten würde ich mal die Installierten Plugins durchforsten ob da 
eventuell etwas bei ist das ausbremst.

oder:
http://www.pcfreunde.de/forum/t48817/firefox-3-bei...
(4. Post) hast du Firefox den über die Paketverwaltung installiert oder 
manuell?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> Ansonsten würde ich mal die Installierten Plugins durchforsten ob da
> eventuell etwas bei ist das ausbremst.

Die werden im Safe Mode alle nicht geladen - hat nur nix gehlfen. 
Womöglich ist irgendwo in den Chrome-Skripten des FF der Wurm.

> hast du Firefox den über die Paketverwaltung installiert oder
> manuell?

Bei Ubuntu wird er bei der Systeminstallation automatisch 
mitinstalliert.

Ich versuche jetzt mal eine Neuinstallation über das System.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Die werden im Safe Mode alle nicht geladen
Ok, dann kann es das nicht sein...

Uhu Uhuhu schrieb:
> irgendwo in den Chrome-Skripten des FF
Was hat den FF seit neuestem mit Crome zu tun? grübel

Uhu Uhuhu schrieb:
> Ich versuche jetzt mal eine Neuinstallation über das System.
Nicht vergessen in home die Config/Cache Order ggf. manuell zu löschen

Autor: Guru (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du währenddessen die Chronik aufgehabt?

Dabei beobachte ich auch sehr starke Verzögerungen.

Autor: hp-freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal ein neues Profil anzulegen und Favoriten, Cookies, Plugins 
usw. einzeln zu installieren/kopieren. Dann Siehst Du evtl. wo das 
Problem liegt.

Autor: Sabine (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal aus, ob es von den geöffneten Webseiten liegt. Ich hatte mal 
das Problem, dass manche Seiten mit bestimmten Flash-Inhalten die CPU zu 
100% trieben. Lösung war ein Flashblockerplugin.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guru schrieb:
> Hast Du währenddessen die Chronik aufgehabt?
>
> Dabei beobachte ich auch sehr starke Verzögerungen.

Nein.

Zwischenzeitlich habe ich FF vollständig gelöscht und wieder neu 
installiert, allerdings das alte Profil weiterverwendet. Es hat nichts 
genutzt.

Da wird wohl irgendwo im Profil ein Haken sein. Ich werd ein neues 
anlegen.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
>> irgendwo in den Chrome-Skripten des FF
> Was hat den FF seit neuestem mit Crome zu tun? grübel

Die Skripte des FF heißen tatsächlich Chrome und tun das schon länger, 
als Google einen Browser herausgibt.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt auch ein AddOn, mit dem man sich das alles ansehen kann: 
https://addons.mozilla.org/en-US/firefox/addon/chrome-list/

Autor: Knilch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Uhu
Apropos AddOn
Es geht ja hier um FF unter Linux. Trotzdem wollte ich hier mal 
mitteilen, dass ich seit dem 7.03. einen weiteren Task unter XP im 
Taskmanager gefunden habe. Der Name ist "plugin-container.exe". Den Task 
hatte ich bis dato nicht. Eine Suche ergab, dass er zum Firefox 3.6.15 
gehört. Unter XP macht das bei mir allerdings keine Probleme - 
vielleicht aber unter Linux, was sich aber meiner Kenntnis entzieht.

Autor: -schumi- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In deinem Home-Verzeichnis befindet sich sich ein versteckter Ordner 
(Stgr+H) der ".mozilla" heist. Einfach mal in ".mozilla-alt" umbenennen. 
Dann sollte es schneller gehen, dafür musst du dein Profil neu erstellen 
:-D

Gruß
-schumi-

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt habe ich ein neues Profil angelegt und Bookmarks, Paßworte und 
Suchmaschinen aus dem alten kopiert - geholfen hats nicht.

Autor: -schumi- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann in der Adressleiste "about:config" eingeben und nach "ipv6" filtern 
lassen. Dann sollte ein Eintrag "network.dns.disableIPv6" kommen. Den 
mit einem Doppelklick den Wert auf "true" setzen

Autor: Uhu Uhuhu (uhu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich werde den Eindruck nicht los, daß das Problem nur bei 
http://www.mikrocontroller.net besteht.

Ich habe eben im Thread 
Beitrag "Pollin MOTOROLA VIP1710" unten 
den Link Threadliste gedrückt, dann war FF eine geschlagene Minute 
beschäftigt und ein Kern zu 100% ausgelastet.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-schumi- schrieb:
> Dann in der Adressleiste "about:config" eingeben und nach "ipv6" filtern
> lassen. Dann sollte ein Eintrag "network.dns.disableIPv6" kommen. Den
> mit einem Doppelklick den Wert auf "true" setzen

Das hab ich gemacht - leider ohne Effekt. Das Beispiel von eben war nur 
unwesentlich schneller.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht stark nach einem html-Fehler hier im Forum aus. Wenn ich 
diesen Thread hier in den Online-Validator eingebe, dann kommt eine 
Latte von Fehlern:

http://validator.w3.org/#validate_by_uri+with_options

Bei Threads, die den FF halb verhungern lassen, bricht er sogar die 
Validierung ab.

Autor: -schumi- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann kannst du noch das hier probieren:
http://wiki.ubuntuusers.de/tuning#IPv6-deaktivieren

Dann weis ich erst mal nicht mehr weiter..

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Latte von Fehlern
Naja... nun mal nicht übertreiben, allesamt "unkritische" Fehler...
Einmal 'obsolete', einmal 'missing' und einmal 'bad value', keine 
strukturellen Fehler, wenn dass Firefox in die Knie zwingt ist was 
anderes faul... validiere mal die Google Startseite...
Welche Firefox Version nutzt du den genau? Ich habe hier mit 3.5.16 
keine Probleme.
Du könntest alternativ mal FireBug installieren und im Netzwerkmodul 
schauen was da so lange "hängt" möglicherweise blockiert ein 
Werbebanner? Mal die JS Ausführung deaktiviert?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
3.6.15

Das Phänomen, daß FF bei syntaktisch falschen html-Seiten ins rotieren 
kommt, hatte ich schon ab und zu mal. Gerne bleiben die Übeltäter auch 
in diversen Caches hängen. Ich habe alle, die ich erreichen kann 
zurückgesetzt.

FF bleibt sogar hier im Eingabefenster zuweilen hängen - das sieht mir 
nach einem Problem mit der Speicherverwaltung aus. Das bekommt man mit 
kaputtem html hin...

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> keine strukturellen Fehler

Bei mir beschwert er sich über fehlende schließende spitze Klammern:
Line 282, Column 33: The name attribute is obsolete. Consider putting an id attribute on the nearest container instead.

          [a name="new" id="new" [/a]
                                ^

Spitze Klammern durch [ ] ersetzt!

> Du könntest alternativ mal FireBug installieren und im Netzwerkmodul
> schauen was da so lange "hängt" möglicherweise blockiert ein
> Werbebanner? Mal die JS Ausführung deaktiviert?

Läubi, ich habe FF komplett neu installiert, den Proxy-Cache gelöscht, 
ein neues Profil angelegt und nur Bookmarks, Paßworte und Suchmaschinen 
vom alten übernommen - gebessert hat sich nichts.

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Bei mir beschwert er sich über fehlende schließende spitze Klammern:

Da fehlt nichts, er beschwert sich nur dass das "name"-Attribut veraltet 
ist. Die sonstigen Warnungen/Fehler sind ebenfalls unkritisch und auf 
keinen Fall der Grund für dein Problem.

Uhu Uhuhu schrieb:
> Läubi, ich habe FF komplett neu installiert, ein neues Profil angelegt
> und nur Bookmarks, Paßworte und Suchmaschinen vom alten übernommen -
> gebessert hat sich nichts.

Aber den Vorschlag von ihm könntest du trotzdem mal ausprobieren.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Schwarz schrieb:
> Aber den Vorschlag von ihm könntest du trotzdem mal ausprobieren.

Hab ich gerade: 38 Errors, 2 warning(s) für http://www.google.de/

Unter Encoding und Doctype habe ich "detect automatically" eingestellt.

Was schließt man daraus?

JS disabeln hilft auch nichts.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Hab ich gerade: 38 Errors, 2 warning(s) für http://www.google.de/
Ich vermute Andreas meinte JS deaktivieren!

> Unter Encoding und Doctype habe ich "detect automatically" eingestellt.
> Was schließt man daraus?
Das selbst so kaputte Seite wie Google keine Probleme verursachen, wie 
Andreas schon sagte sind das kleinere Unschönheiten.
Was mir nur noch einfiele: Eventuell ist das HTML5 Modul von FireFox 3.6 
installier dir doch parrallel mal eine 3.5er Version zum Vergleich, ist 
eventuell auch noch ein anderer Webbrowser in Ubuntu drin? Debian kommt 
defaultmäßig noch mit 'Ephiany' als alternative, eventuell ist ein DNS 
auf deinem Weg etwas "ungnädig"?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> Du könntest alternativ mal FireBug installieren und im Netzwerkmodul
> schauen was da so lange "hängt" möglicherweise blockiert ein
> Werbebanner? Mal die JS Ausführung deaktiviert?

Der FireBug ist installiert, nur wie sehe ich wer der Übeltäter sein 
könnte? FireBug ist nämlich auch so lange tot, bis FF wieder aufgetaut 
ist.

> Eventuell ist das HTML5 Modul von FireFox 3.6
> installier dir doch parrallel mal eine 3.5er Version zum Vergleich, ist
> eventuell auch noch ein anderer Webbrowser in Ubuntu drin?

3.5 hab ich drauf, aber mit root-Rechten. Außerdem hab ich noch Opera 
da.

Ich seh mal nach, was Opera meint.

Nachtrag: Mit Opera scheint es keine Probleme zu geben. Mal sehen, ob es 
so bleibt.

JS zu deaktivieren, hat übrigens auch nichts gebracht.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> nur wie sehe ich wer der Übeltäter sein
> könnte?
Falls nicht zu sehen Firebug durch drücken auf den "Bug" am rechten Rand 
hervorholen, Reiter "Netzwerk", auf den kleinen Pfeil und das Modul 
aktivieren.
Wenn nun die Seite neu geladen wird, sollte er dir für jede Datei so 
Balken Zeigen wann er das laden begonne und wann es abgeschlossen wurde 
(siehe Anhang für Grafiken, Alle zeigt alle geladenen Daten an).

Autor: Uhu Uhuhu (uhu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der Trick ist gut - nur leider bringt er für den unteren 
Threadlisten-Link auf 
Beitrag "Pollin MOTOROLA VIP1710" keine 
Erkenntnis.

FF hat sich grau gestellt und hat knapp eine Minute vorsichhin 
gebaggert.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-Sind zufällig langsame Proxyeinträge im Spiel?
-Falls die Paketverwaltung zufällig große Updates gefunden hat sollte 
man die GLEICHE Seite später nochmals testen (Cache leeren) und 
vergleichen.
-Was sagen die FF-FAQ?

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> FF hat sich grau gestellt
Hm.. dann hab ich auch keine wirkliche Idee mehr, kannst du den derweil 
in anderen Tabs browsen oder "friert" alles ein?
Konntest du schon einene gegentest in FF3.5 machen?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oszi40 schrieb:
> -Sind zufällig langsame Proxyeinträge im Spiel?

Abschalten des Proxys hat keine Auswirkungen. Den Squid-Cache habe ich 
auch schon geleert und reparieren lassen - kein Effekt.

Läubi .. schrieb:
> in anderen Tabs browsen oder "friert" alles ein?

FF 3.6 friert komplett ein und das Komische ist, daß nur 
mikrocontroller.net betroffen ist und das vor allem bei langen Threads.

> Konntest du schon einene gegentest in FF3.5 machen?

FF 3.5.9 hat keine Probleme.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ist irgendwo der Oberwurm drin - jetzt kann man deaktivierte AddOns 
nicht mehr aktivieren, weil FF 3.6 offenbar nicht mehr mitbekommt, daß 
AddOns freigeschaltet wurden. FF 3.5 funktioniert dagegen klaglos.

Damit die Schaltfläche für ein AddOn springt auch erst mit dem zweiten 
Klick von Enable nach Disable.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, jetzt bin ich auf Ubuntu 10.10 ausgewichen mit FF 3.6.11 und die 
Probleme sind weg.

Mal sehen, was passiert, wenn FF aktualisiert ist...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.