Forum: Analoge Elektronik und Schaltungstechnik MOSFET wird 150 Grad heiß


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Hi,
ich habe eine Phasenabschnittsdimmerschaltung gebaut, bei der zwei in 
Reihe geschaltete HEXFETs (IRFP460) den Verbraucher an die 
Stromversorgung schalten (im 100Hz Takt).

Wenn ich jetzt einen 200W Verbraucher dranhänge und die MOSFET 
durchgehend schalten lasse, werden die ca. 140 Grad heiß. Das liegt noch 
unter den Maximum ratings im Datenblatt, trotzdem wollte ich mal fragen, 
ob das ok so ist und ob man das vllt besser hinbekommt...

Philipp

: Verschoben durch Admin
von Albert .. (albert-k)


Lesenswert?

Ich würde mal schätzen das die beiden HEXFET zu langsam geschalten 
werden, also der Umladungsstrom für die Gates zu niedrig ist. Dadurch 
bewegen sie sich zu lange im linearen Bereich. Und durch das Periodische 
schalten und denn sehr trägen Wärmeabbau werden sie dann eben Heiß. 
Gatetreiber verwenden um die beiden gates schneller umzuladen wäre eine 
möglichkeit

von Εrnst B. (ernst)


Lesenswert?

Albert ... schrieb:
> Ich würde mal schätzen das die beiden HEXFET zu langsam geschalten

Er erreicht die 140° ja schon im "Dauer-an-Betrieb". Schaltverluste 
können es also nicht sein.

Wie hoch ist "V+" / wieviel Gate-Spannung gönnst du den FETs?
5V wären jedenfalls zu wenig. Eher 10 … 15V nehmen.

von Falk B. (falk)


Lesenswert?

@  Philipp F. (nerdture)

>ich habe eine Phasenabschnittsdimmerschaltung gebaut, bei der zwei in
>Reihe geschaltete HEXFETs (IRFP460) den Verbraucher an die
>Stromversorgung schalten (im 100Hz Takt).

Ich sehen keinen MOSFET-Treiber. Die Steuerung ist unbrauchbar. Mit 
einem normalen Optokoppler kann man einen MOSFET nicht schnell genug 
schalten, er bleibt dann lange im linearen Bereich und verheizt viel 
zuviel Energie.
Und wenn mann schon einen Brückengleichrichter nutzt, braucht man auch 
nur einen MOSFET, nicht zwei.

MFG
Falk

von Albert .. (albert-k)


Lesenswert?

Εrnst B✶ schrieb:
> Er erreicht die 140° ja schon im "Dauer-an-Betrieb". Schaltverluste
> können es also nicht sein.
Nicht im Dauer-An sondern wenn er ständig schaltet
Philipp F. schrieb:
> und die MOSFET
> durchgehend schalten lasse, werden die ca. 140 Grad heiß

von MaWin (Gast)


Lesenswert?

Welchen Sinn soll J1 haben ?
Wenn man den wegmacht, geht was kaputt.

Was meinst du ist an einer 1N4007 besser als an der eingebauten Diode im 
MOSFET ? Wenn überhaupt, baut man dort schnelle Dioden hinzu, das ist 
aber bei 50Hz nicht notwendig. Lege also AGND fest an die Verbindung 
beider MOSFETs und entferne D3 und D4.

Was soll der 47k Gatewiderstand vor den MOSFETs ? Vielleicht ist es 
damit nicht zu langsam, aber es kann ein deutlicher Anteil an deiner 
Erwärmung sein. Macht den mal komplett weg (0 Ohm). Die 10k als R2 sind 
auch recht hochohmig. Ich verstehe, daß du aus dem kapazitiven Netzteil 
Strom sparen willst und nur 100uA spendierst, um die MOSFET-Gates 
umzuladen. Das sollte bei 50Hz auch noch reichen. Aber wenn es nicht 
funktioniert, wäre das mal die erste Stelle an der ich mehr Strom 
vorlegen würde, zumindest 1k für 1mA, das schaltet der Optokoppler noch 
problemlos.

Warum baust du umgekehrte Logic, LED im Optokoppler eingeschaltet heisst 
MOSFETs aus ? Das verbessert nicht das Verständnis.

Q3 an V+ ist eine ähnliche Konstruktion, schaltet den Optokoppler durch, 
wenn keine Spannung anliegt. Leider R6 R8 R9 = 66k an 9V = 130uA um 
damit 10mA zu schalten ? Hmm, recht hochohmig, 10k Summe wären besser, 
aber nicht 230V kompatibel.

Also: R2=1k R3=0 Ohm, die Geschichte um Q3 ganz umbauen, 10k nzur 
Verbindung von D5 und RR5, 10k PullDown von der Basis nach AGND.

D5 könnte übrigens auch weg, denn V+ ist schon über Dioden vor negativer 
Spannung geschützt, wenn nicht mein Umbau dem dazwischenkäme, der 
braucht D5 wieder.

von Philipp F. (nerdture)


Lesenswert?

Sorry ich meinte damit tatsächlich 'dauerhaft durchgeschaltet/an'.
Wobei das eigtl auch nicht ganz stimmt. Habe es getestet, indem ich an 
die Dimmerschaltung (siehe Schaltplan oben) kein Steuersignal 
angeschlossen habe, dann lädt sich der Kondensator bis 10V (Zenerdiode) 
auf und schaltet die MOSFETs, entlädt sich dann aber wieder, weil die 
ladespannung weg ist usw...

Aber jetzt teste ich gerade mit einer normal gesteuerten 
Abschnittsdimmung die ständig rauf und runter dimmt. Ich bin immer noch 
bei 115°C...

von NoPoP (Gast)


Lesenswert?

Bei Deiner Gateansteuerung fehlt irgendwie der Rückweg für die 
Gateströme. Der Gate-Kreis hängt nur mit einer Leitung an der 
Ansteuerung.

von Falk B. (falk)


Lesenswert?

@  NoPoP (Gast)

>Bei Deiner Gateansteuerung fehlt irgendwie der Rückweg für die
>Gateströme. Der Gate-Kreis hängt nur mit einer Leitung an der
>Ansteuerung.

Nö. AGND.

von Philipp F. (nerdture)


Lesenswert?

Wegen AGND brauche ich auch D3 und D4!
Ich richte ja die Wechselspannung gleich um damit die Nulldurchgänge 
über Q3 zu bestimmen...

Ich werde aber mal versuchen den 47k wegzulassen und den anderen durch 
1k zu ersetzen

von NoPoP (Gast)


Lesenswert?

Falk Brunner schrieb:
> Nö. AGND.

Sorry, ich nehme Alles zurück. Habe den AGND übersehen.

von Εrnst B. (ernst)


Lesenswert?

Philipp F. schrieb:
> Wegen AGND brauche ich auch D3 und D4!
> Ich richte ja die Wechselspannung gleich um damit die Nulldurchgänge
> über Q3 zu bestimmen...

Genau die Dioden sind schon in den Mosfets "integriert", sogar bei 
deinem Schaltplansymbol mit eingezeichnet.

von Philipp F. (nerdture)


Lesenswert?

Habe die Widerstände ersetzt, aber jetzt tut's gar nicht mehr.
Kann mir gerade auch nicht erklären warum

von Jörg S. (joerg-s)


Lesenswert?

Philipp F. schrieb:
> Sorry ich meinte damit tatsächlich 'dauerhaft durchgeschaltet/an'.
> Wobei das eigtl auch nicht ganz stimmt. Habe es getestet, indem ich an
> die Dimmerschaltung (siehe Schaltplan oben) kein Steuersignal
> angeschlossen habe, dann lädt sich der Kondensator bis 10V (Zenerdiode)
> auf und schaltet die MOSFETs, entlädt sich dann aber wieder, weil die
> ladespannung weg ist usw...
Das ist aber kein "Schwingkreis"! D.h. der MOSFET schaltet so viel bzw. 
wenig durch das er noch ein wenig Spannung zum leiten bekommt. Die 
Spannung am Gate erreicht also einen recht geringen Wert. Ich schätze 
mal so um die 5-10V. Der MOSFET ist somit STÄNDIG nur teilweise 
durchgeschaltet und verbrät Leistung ohne Ende.

von Philipp F. (nerdture)


Lesenswert?

Ok, also ich habe nun den 47k Ohm ganz raus aber den 10k drin gelassen.
Ich vermute der Optokoppler konnte den 1k pull-up nicht auf 0V 
runterziehen, aber mit 10k geht es.

Aber dadurch dass der 47k nun weg ist wird er schon viel weniger warm! 
Vielen Dank für den Tipp mit der Schaltzeit! Ich bin jetzt bei 75 Grad 
statt 120

von Jörg S. (joerg-s)


Lesenswert?

>Ich bin jetzt bei 75 Grad statt 120
Wenn du tatsächlich mit 10V am Gate 100% schaltest, was ich nicht 
glaube, ist das viel zu viel! Die Verlusstleistung in dem Fall müsste 
gegen Null gehen. Selbst bei 50% PWM dürfte der MOSFET bei 200W nur 
handwarm werden. Jedenfalls ist das bei meiner MOSFET Dimmerschaltung 
so.

von Philipp F. (nerdture)


Lesenswert?

Kannst du deinen Schaltplan hochladen? Wie hast du es gelöst?

Übrigens, wenn ich nun die Steuerung ausschalte und er sich im linearen 
Bereich wie von dir beschrieben einpendelt, wird er jetzt extremst heiß, 
sodass ich den Stecker ziehen musste.
Aber ich will nicht, dass nur weil die Elektronik ausfällt ich mir 
sorgen machen muss dass die Schaltung abfackelt, wie kann ich das lösen?

von Yalu X. (yalu) (Moderator)


Lesenswert?

C1 wird nur dann geladen, wenn die Mosfets sperren. Um die Mosfets zu
sperren, muss der Optokoppler leiten. Wenn der Optokoppler leitet, wird
C1 entladen. Und das umso schneller je kleiner R2 ist. Damit steht keine
ausreichende Steuerspannung für die Mosfets zur Verfügung, was diese
warm werden lässt.

Da steckt also noch ein Fehler im Konzept.

Besser wäre es, den Optokoppler andersherum zu benutzen (OK und R2
tauschen). Aber nicht zur Verbesserung des Verständnisses (s. Beitrag
MaWin), sondern zur Verbesserung der Funktion.

von Philipp F. (nerdture)


Lesenswert?

Die Idee, die Steuerspannung so zu beziehen habe ich hierher übernommen:

http://www.elv-downloads.de/Assets/Produkte/8/858/85829/Downloads/85829_DI200AB_KM_UM.pdf

Der Rest der Schaltung wurde vor einem Jahr mit viel Hilfe aus diesem 
Forum aufgebaut, aber ganz offensichtlich ist es noch nicht perfekt...

von Falk B. (falk)


Lesenswert?

@  Yalu X. (yalu) (Moderator)

>Da steckt also noch ein Fehler im Konzept.

Nicht nur einer . . .

Wenn der Optokoppler sperrt, müssen auch die MOSFETs sperren. Aber 10K 
ist immer noch viel zu hochohmig. Das ist kein Jim Beam, ähhh, 
MOSFET-Treiber. Das ist Murks.
Man braucht wenigstens ein Paar BC337/BC327 asl Treiber, oder man 
nimmt gleich was vollintegriertes ala HCPL3020. Dann wird ein Schuh 
draus.

MfG
Falk

von Jörg S. (joerg-s)


Lesenswert?

>Kannst du deinen Schaltplan hochladen? Wie hast du es gelöst?

Mein Projekt siehe:
http://www.see-solutions.de/projekte/projekte.htm#2007_02_SPS-LightControl

Ist auch aus dem DI300/200 von ELV entstanden :)

von Philipp F. (nerdture)


Lesenswert?

Jörg S. schrieb:
> Mein Projekt siehe:
> http://www.see-solutions.de/projekte/projekte.htm#...

Ach du bist das :) Ja das Projekt kenne ich schon ;)
Aber du verbaust noch einen DC/DC Wandler auf den ich sehr gerne 
verzichten würde...

von Simon K. (simon) Benutzerseite


Lesenswert?

Die Schaltung sieht, alleine wie sie schon gezeichnet ist, sehr 
merkwürdig aus. Was wirdn das (nicht)?

von Philipp F. (nerdture)


Lesenswert?

Danke für diesen helfenden Kommentar ;)
Bin eben kein E-Techniker, sondern mache das hobbymäßig.

von Florian V. (Gast)


Lesenswert?

Philipp F. schrieb:
> ..., dann lädt sich der Kondensator bis 10V (Zenerdiode)
> auf und schaltet die MOSFETs, entlädt sich dann aber wieder, weil die
> ladespannung weg ist usw...

Damit hast Du das Problem doch eigentlich schon erkannt:
Sobald die MOSFETs einschalten, steht keine Spannung mehr über den 
Eingangsklemmen an und die Dimmerschaltung hat keine Betriebsspannung 
mehr.

Dementsprechend kannst Du die Betriebsspannung nicht so wie realisiert 
aus den Eingangsklemmen gewinnen. Du brauchst eine vom Schaltzustand 
unabhängige Quelle. Z.B. in dem sowohl L als auch N an die Schaltung 
geführt wird.

So wie es momentan ist, schwingt das entweder oder die Spannung über den 
MOSFETs stellt sich irgendwo bei Uth + ? ein, so dass sie ständig im 
linearen Betrieb sind und mächtig Leistung verheizen.

Die ELV Grundschaltung nutzt wahrscheinlich einen Trick, um diesem 
Dilemma zu entgehen: Sie schaltet die Last nie zu 100% ein, sondern sie 
bleibt immer für kurze Zeit je Halbwelle aus. So kann noch genug 
Betriebsspannung abgezweigt werden.

von Jörg S. (joerg-s)


Lesenswert?

Falk Brunner schrieb:
> Wenn der Optokoppler sperrt, müssen auch die MOSFETs sperren. Aber 10K
> ist immer noch viel zu hochohmig. Das ist kein Jim Beam, ähhh,
> MOSFET-Treiber. Das ist Murks.
> Man braucht wenigstens ein Paar BC337/BC327 asl Treiber, oder man
> nimmt gleich was vollintegriertes ala HCPL3020. Dann wird ein Schuh
> draus.
Auch bei den Wald und Wiesen Dimmern die es zu kaufen gibt, gibt's keine 
MOSFET Treiber. Da sind auch Vorwiderstände im 10k Bereich am Gate.

von Philipp F. (nerdture)


Lesenswert?

@Florian: Klar, ich gehe auch nicht auf 100 prozent im normalen Betrieb, 
aber trotzdem wird es eben sehr heiß..

von Jörg S. (joerg-s)


Lesenswert?

Florian V. schrieb:
> Dementsprechend kannst Du die Betriebsspannung nicht so wie realisiert
> aus den Eingangsklemmen gewinnen. Du brauchst eine vom Schaltzustand
> unabhängige Quelle. Z.B. in dem sowohl L als auch N an die Schaltung
> geführt wird.
Kann man schon machen (macht ja so gut wie jeder Dimmer so) nur muss man 
halt verhindern das man 100% durchschaltet.

von Falk B. (falk)


Lesenswert?

@  Jörg S. (joerg-s)

>Auch bei den Wald und Wiesen Dimmern die es zu kaufen gibt, gibt's keine
>MOSFET Treiber. Da sind auch Vorwiderstände im 10k Bereich am Gate.

Dann ist es Wald- und Wiesen Murks!!! 47K Gatewiderstand, ich glaube ich 
spinne!

von Jörg S. (joerg-s)


Lesenswert?

Falk Brunner schrieb:
> Dann ist es Wald- und Wiesen Murks!!! 47K Gatewiderstand, ich glaube ich
> spinne!
Tja, es funktioniert millionenfach...

von Εrnst B. (ernst)


Lesenswert?

> 47K Gatewiderstand, ich glaube ich spinne!

Muss ja nicht sonderlich schnell sein. Im Gegenteil: Langsames Schalten 
des FETs macht die EMV-Prüfung einfacher...

Aber ein "echter" Mosfettreiber hätte nen Vorteil: Die gibts mit 
Under-Voltage-Lockout, d.H. wenn C1 zuwenig Saft hat, wird halt mal ein 
wenig pausiert, um ihn wieder zu füllen...

von Yalu X. (yalu) (Moderator)


Lesenswert?

Falk Brunner schrieb:
> Das ist kein Jim Beam, ähhh, MOSFET-Treiber. Das ist Murks.

Bei der niedrigen Schaltfrequenz darf man den Mosfet-Treiber auch
mal weglassen. Aber die Steuerspannung sollte auf jeden Fall die
vorgesehenen 10V erreichen, sonst wird das nichts.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

@  Philipp F. (nerdture)

>@Florian: Klar, ich gehe auch nicht auf 100 prozent im normalen Betrieb,
>aber trotzdem wird es eben sehr heiß..

Besser so, siehe Anhang.

MfG
Falk

von mhh (Gast)


Lesenswert?

Falk Brunner schrieb:
> 47K Gatewiderstand, ich glaube ich
> spinne!

Er wird nur übersehen haben, daß im Wald und auf der Wiese Triacs drin 
sind...

von Falk B. (falk)


Lesenswert?

@  Yalu X. (yalu) (Moderator)

>> Das ist kein Jim Beam, ähhh, MOSFET-Treiber. Das ist Murks.

>Bei der niedrigen Schaltfrequenz darf man den Mosfet-Treiber auch
>mal weglassen.

Irrtum. Und schon gar nicht bei so einem MONSTER-MOSFET. Schau dir mal 
das oben angehängt Datenblatt an!
Ein 500V/20A Klopper im TO247 Gehäuse. Mit satten 4nF Gatekapazität. 
Dazu vielleicht noch 20nF Millerkapazität und wir sind bei ~25nF, macht 
bei 47K+10K Ladewiderstand ~1,4ms Zeitkonstante.

Hust

MfG
Falk

von Harald Wilhelms (Gast)


Lesenswert?

Jörg S. schrieb:
> Falk Brunner schrieb:
>> Dann ist es Wald- und Wiesen Murks!!! 47K Gatewiderstand, ich glaube ich
>> spinne!
> Tja, es funktioniert millionenfach...

Millionen von Fliegen können nicht irren. Scheiße schmeckt köstlich!
Gruss
Harald

von Jörg S. (joerg-s)


Lesenswert?

mhh schrieb:
> Falk Brunner schrieb:
>> 47K Gatewiderstand, ich glaube ich
>> spinne!
> Er wird nur übersehen haben, daß im Wald und auf der Wiese Triacs drin
> sind...
Nein, ich rede von doppel MOSFET Dimmern.

von Jörg S. (joerg-s)


Lesenswert?

Harald Wilhelms schrieb:
> Millionen von Fliegen können nicht irren. Scheiße schmeckt köstlich!
Stimmt, die Funktion ist ja nebensächlich, hauptsache ein MOSFET 
Treiber.
Hinter den Treiber kann man dann ja einen Widerstand und Kondensator 
schalten damit es wieder funktioniert ;)

von mhh (Gast)


Lesenswert?

Jörg S. schrieb:
> Nein, ich rede von doppel MOSFET Dimmern.

Gib dem Mosfet mal bitte ein Gesicht.

von MaWin (Gast)


Lesenswert?

> Ich vermute der Optokoppler konnte den 1k pull-up nicht auf 0V
> runterziehen

Das sollten sie laut Datenblatt aber schaffen.
Hast du das Datenblatt gelesen ?

> C1 wird nur dann geladen, wenn die Mosfets sperren. Um die Mosfets zu
> sperren, muss der Optokoppler leiten. Wenn der Optokoppler leitet, wird
> C1 entladen. Und das umso schneller je kleiner R2 ist. Damit steht keine
> ausreichende Steuerspannung für die Mosfets zur Verfügung, was diese
> warm werden lässt. Da steckt also noch ein Fehler im Konzept.

Autsch, du hast Recht, kaum schaltet die Schaltung ein, nimmt sie sich 
selbst die Betriebsspannung, denn Last und 230V-Quelle liegen wohl 
ausserhalb des Plans, dort wo Last drangeschrieben wurde.

Natürlich muß die Betriebsspannung vor der Last gewonnen werden.

Dann könnte/sollte sie aber mit reduzierten Widerstandswerte wie von mir 
beschrieben funktionieren, der MOSFET wäre auch ohne Amperestarken 
MOSFET-Treiber schnell genug umzuladen.

von Yalu X. (yalu) (Moderator)


Angehängte Dateien:

Lesenswert?

Falk Brunner schrieb:
>>Bei der niedrigen Schaltfrequenz darf man den Mosfet-Treiber auch
>>mal weglassen.
>
> Irrtum. Und schon gar nicht bei so einem MONSTER-MOSFET. Schau dir mal
> das oben angehängt Datenblatt an!

Hab's mal simuliert.

So schlecht ist die Schaltung gar nicht. Auch das Einbrechen der
10V-Steuerspannung spielt erst bei einer Einschaltdauer von über 86%
eine Rolle, die Kondensatorspannung beträgt dann noch 8,3V. Lediglich
der Gate-Widerstand von 47kΩ ist unsinnig hoch gewählt.

Statt des IRFPC40 (600V, 1,2Ω, 6,8A) habe ich den SPA11N60C3 (650V,
0,38Ω, 11A) genommen, der von den Mofets in LTspice dem IRFPC40 in
Philipps Schaltung am nächsten kommt.

Die 47kΩ habe ich durch 680Ω ersetzt. Damit ist der Gate-Spitzenstrom
beim Ausschalten 15mA, was der Optokoppler noch schaffen sollte. Die
Ausschaltzeit beträgt dann maximal 18µs (wenn genau im Scheitelpunkt
geschaltet wird), die Schaltverluste für jeden Mosfet 7,6mJ je Aus-
schaltvorgang oder 0,38W im Mittel. Das macht die Mosfets warm, aber
nicht heiß.

Nimmt man einen Optokopppler, der auch 30mA schafft, kann man die 680Ω
auf 330Ω verkleinern. Die Ausschaltzeit beträgt dann nur noch 9µs, die
Schaltverluste 3,8mJ bzw. 0,19W.

Man könnte für R2 auch 47kΩ nehmen, dann bleibt die Steuerspannung auch
bei 94% Einschaltdauer noch über 8V. Das verlängert zwar die Einschalt-
zeit, was aber nichts ausmacht, da im Nullpunkt geschaltet wird.

von Falk B. (falk)


Lesenswert?

Und das alles, weil zwei kleine Transitoren für je 5 Cent zuviel 
verlangt sind. OMG!

von Philipp F. (nerdture)


Lesenswert?

Ich hab die Transistorenschaltung ausprobiert. Mit der Temperatur stimmt 
dann alles (45Grad). Im mittleren Dimmbereich ist alles ok (nachdem ich 
natürlich die logik invertiert hatte).
Aber im unteren und oberen Bereich flackert es wie wild... Ich bekomme 
mein DSO gerade nicht zum laufen und kann daher nicht nachforschen 
warum...

von Yalu X. (yalu) (Moderator)


Lesenswert?

Falk Brunner schrieb:
> Und das alles, weil zwei kleine Transitoren für je 5 Cent zuviel
> verlangt sind. OMG!

Du hast noch nie in der Massenproduktindustrie gearbeitet. Ich auch
nicht. Ich bekomme aber öfters einen Einblick, wie es da zu geht. Es ist
machmal wirklich haarsträubend, wie oft da jeder Cent umgedreht wird.

Die zwei Transistörchen im Dimmer machen immerhin ein paar Promille der
Herstellkosten aus, und der Endkunde merkt nichts davon, wenn man sie
einspart. Bei ein paar Millionen Stück kann sich der Chef aus den Er-
sparnissen ein neues Auto kaufen. Das kann ich noch nachvollziehen.

Ich kenne aber einige Fälle, wo um Einsparungen im 0,0x-Promillebereich
gefeilscht wird, und wo der durch die Einsparungen bedingte Qualitäts-
verlust vom Endkunden durchaus festgestellt werden kann. Das verstehe
ich dann nicht mehr.

Ok, Philipp macht das wohl eher hobbymäßig. Aber dort passiert es eban
manchmal, dass man eine Platine schon fertiggelötet hat und möchte zur
Optimierung am liebsten nur noch Bauteile ändern, aber keine neuen mehr
hinzufügen.

von Philipp F. (nerdture)


Lesenswert?

@Yalu: Ich habe eben nochmal deine oben vorgeschlagene Variante 
versucht, R2 und den Opto zu vertauschen, sodass man mit Schalten des 
Optokopplers die 10V an das Gate legt. Prinzipiell funktioniert auch 
alles noch, nur bekomm ich die Lampe nicht mehr dunkel. Sobald ich den 
FET auch nur ganz kurz an und aus schalte in jedem Halbzyklus, ist die 
Lampe eigtl schon zu hell für die dunkelste Stufe...
Andersherum konnte man das Gate wahrscheinlich mit dem Opto schön 
schnell leersaugen..

Noch ne Frage: Warum haben ELV und Jörg eine 15V Zener Diode direkt am 
MOSFET Gate? Da sollten doch sowieso maximal 10 bzw 12 volt sein...

von Yalu X. (yalu) (Moderator)


Lesenswert?

Philipp F. schrieb:
> @Yalu: Ich habe eben nochmal deine oben vorgeschlagene Variante
> versucht, R2 und den Opto zu vertauschen, sodass man mit Schalten des
> Optokopplers die 10V an das Gate legt.

Mist. Ich wollte in meinem letzten Beitrag noch schreiben, dass ich
diesen Vorschlag wieder zurücknehme, hab's aber vergessen :)

Diese Varaiante hätte zwar den prinzipiellen Vorteil, dass der Kondensa-
tor die Steuerspannung besser aufrechterhalten kann. Aber das, so hat
sich herausgestellt, ist gar kein so großes Problem, wenn man mit der
Einschaltdauer nicht zu sehr an die obere Grenze geht (s. mein letzter
Beitrag).

Das Vertauschen von Optokoppler und R2 hat aber den Nachteil, dass die
Ausschaltzeiten deutlich länger werden. Da das Ausschalten (im Gegensatz
zum Einschalten) aber unter Strom geschieht, erhöht das die Schaltver-
luste. Außerdem führt schnelles Ein- und langsames Ausschalten hierzu:

> nur bekomm ich die Lampe nicht mehr dunkel.

von Philipp F. (nerdture)


Lesenswert?

Jetzt beim zweiten Nachdenken verstehe ich aber nicht warum ich die 
Lampe mit meiner ursprünglichen Schaltung mit den 47k dunkel bekommen 
habe...
Und die Schaltung von Jörg hat ja auch diesen 47k Widerstand und scheint 
ja prima zu funktionieren.

Ich bin ein bisschen verzweifelt, was ist denn nun der optimale 
Schaltungsaufbau für einen Phasenabschnittsdimmer? Gibt es da keinen 
bewährten Standard? Was mir bei meiner bzw von dir simulierten Schaltung 
noch Sorgen bereitet ist eben, dass wenn die Steuerung ausfällt, der 
MOSFET sich wahrscheinlich irgendwo im linearen Bereich einpendelt und 
super heiß wird...

von Abdul K. (ehydra) Benutzerseite


Lesenswert?

Bevor ich mich wiederhole... der Thread hier ist ganz ergiebig:
Beitrag "Re: Dimmer mit FET realisieren"

AN518 und AN524 von STM sind auch nett.

von MaWin (Gast)


Lesenswert?

> Und das alles, weil zwei kleine Transitoren für je 5 Cent zuviel
> verlangt sind. OMG!

Nee,
das alles (Simulation, ein halbes Dutzend Beiträge) um darzulegen, daß 
deine Einwände fachlich unbegründet sind und du nur sinnloserweise die 
Hunde heiss machst.

Bei 1MHz Schaltfrequenz sind gute MOSFET-Treiber sinnvoll, aber bei 50Hz 
reicht 1mA Umladestrom locker aus (deine Schaltung käme übrigens auch 
nur auf 10mA, hfe=100 angesetzt).

von Jörg S. (joerg-s)


Lesenswert?

Philipp F. schrieb:
> Was mir bei meiner bzw von dir simulierten Schaltung
> noch Sorgen bereitet ist eben, dass wenn die Steuerung ausfällt, der
> MOSFET sich wahrscheinlich irgendwo im linearen Bereich einpendelt und
> super heiß wird...
Bei der Entwicklung meiner Schaltung hatte ich auch mal einen Aufbau wo 
der Optokoppler in Reihe zum Gate lag. D.h. Emitter vom O.K. an Gate, 
Kollektor an 10V Elko. Mit einem passendem Pull-Down am Gate hat das 
funktioniert. Wenn dann die Steuerung ausfällt, bleibt's dunkel.

von Jörg S. (joerg-s)


Lesenswert?

mhh schrieb:
> Jörg S. schrieb:
>> Nein, ich rede von doppel MOSFET Dimmern.
> Gib dem Mosfet mal bitte ein Gesicht.
Z.B.:
http://www.see-solutions.de/sonstiges/BJ-Dimmer.pdf

von Philipp F. (nerdture)


Lesenswert?

@Yalu:
Ich habe mal deine Simulation nachgebaut und R4 immer größer gewählt, 
damit sich auch bei langer Einschaltzeit der Kondensator nicht so 
schnell entlädt.
Dass der Mosfet im Nullpunkt dann nur langsam anschaltet ist ja nicht so 
schlimm.
Komischerweise musste ich feststellen, dass egal wie hoch ich den 
Widerstand wähle, das keinen Einfluss auf die Simulation hat, selbst 
wenn ich ihn komplett entferne, warum?! Das würde ja heißen, der Mosfet 
schaltet standardmäßig immer durch...

von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Ich habe mal die obige Schaltung mit Gate-Treiber simuliert. (SIM2 ist 
das korrekte)
In LTSpice funktioniert es wunderbar, so wie ich es mir vorstelle, also 
der Kondensator entlädt sich nicht, auch bei 90% einschaltdauer und die 
Flanken sind steil etc.

Ich habe das auch in echt so gebaut, aber es will nicht funktionieren. 
Wenn ich die Spannung am Kondensator messe liegt die bei ca 4 Volt.
Schalte ich die Steuerung aus, geht sie auf 10V, wo sie eigentlich die 
ganze Zeit sein sollte.

von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Hier das richtige Bild

von mhh (Gast)


Lesenswert?

Jörg S. schrieb:
> mhh schrieb:
>> Jörg S. schrieb:
>>> Nein, ich rede von doppel MOSFET Dimmern.
>> Gib dem Mosfet mal bitte ein Gesicht.
> Z.B.:
> http://www.see-solutions.de/sonstiges/BJ-Dimmer.pdf

Danke.

Es sind aber schon gewaltige, und entscheidende Unterschiede zur obigen 
Schaltung.

Der Mosfet in Deiner Schaltung hat nur ein Drittel der 
Eingangskapazität, einschalten erfolgt über 11 kOhm und ausschalten per 
Kurzschluß über einen Transistor ohne extra Widerstand. Damit wird der 
Linearbetrieb stark verkürzt, was meiner Meinung nach das Problem obiger 
Schaltung ist.

von Falk B. (falk)


Lesenswert?

@  Philipp F. (nerdture)

>In LTSpice funktioniert es wunderbar, so wie ich es mir vorstelle,

Ist immer noch eine komische Schaltung. Ausserdem ist ein Optokopler 
weit von einer idealen Pulsquelle entfernt ;-)
Und irgendwie hast du einen Gatewiderstandfetisch (was für ein Wort!).
Was soll das? Das ist total daneben! Dein "Treiber" hat so schon nicht 
viel Dampf, da muss man den nicht noch extra ausbremsen.

>Ich habe das auch in echt so gebaut, aber es will nicht funktionieren.
>Wenn ich die Spannung am Kondensator messe liegt die bei ca 4 Volt.
>Schalte ich die Steuerung aus, geht sie auf 10V, wo sie eigentlich die
>ganze Zeit sein sollte.

Tja, da stimmt was nicht.

MfG
Falk

von Jörg S. (joerg-s)


Lesenswert?

mhh schrieb:
> ...und ausschalten per Kurzschluß über einen Transistor ohne extra
> Widerstand.
1k Ohm sind immer da.

> Damit wird der Linearbetrieb stark verkürzt, was meiner Meinung nach das
> Problem obiger Schaltung ist.
Die DI300 Dimmer-Schaltung von ELV hat am Gate extra noch einen 
Kondensator um den Linearbetrieb noch zusätzlich zu verstärken. Wie oben 
schon steht ist es das Ziel dadurch die Störungen zu minimieren. Extrem 
steile Flanken will man bei den Dimmern überhaupt nicht.

von Philipp F. (nerdture)


Lesenswert?

Ich frage mich eben, warum bei mir in echt keine 10V zu Stande kommen, 
sondern nur 4V
Ich glaube da liegt das Problem

von Jörg S. (joerg-s)


Lesenswert?

Philipp F. schrieb:
> Ich habe das auch in echt so gebaut, aber es will nicht funktionieren.
> Wenn ich die Spannung am Kondensator messe liegt die bei ca 4 Volt.
> Schalte ich die Steuerung aus, geht sie auf 10V, wo sie eigentlich die
> ganze Zeit sein sollte.
Dein DSO läuft immer noch nicht? Ohne würde ich erst mal nicht weiter 
machen. Wäre schon sehr wichtig zu sehen wie es am Gate tatsächlich 
aussieht.

von mhh (Gast)


Lesenswert?

Jörg S. schrieb:
> Die DI300 Dimmer-Schaltung von ELV hat am Gate extra noch einen
> Kondensator um den Linearbetrieb noch zusätzlich zu verstärken. Wie oben
> schon steht ist es das Ziel dadurch die Störungen zu minimieren. Extrem
> steile Flanken will man bei den Dimmern überhaupt nicht.

Auf die schnelle fand ich nur den Schaltplan zum DI200. C3 - 470pF - 
nicht bestückt. Wobei die Widerstände wieder zu oben passen.

Jedenfalls bleibe ich bei meiner Meinung mit der zu langen Zeit beim 
Umschalten als Grund für die Überhitzung. Virtuell können wir beide 
schlecht auf Fehlersuche am Objekt gehen.

Eventuell ebenfalls ein Kühlblech nehmen wie ELV? Keine Ahnung...

von Jörg S. (joerg-s)


Lesenswert?

mhh schrieb:
> Auf die schnelle fand ich nur den Schaltplan zum DI200. C3 - 470pF -
> nicht bestückt.
http://www.mikrocontroller.net/attachment/71509/37378-DI300.pdf

> Jedenfalls bleibe ich bei meiner Meinung mit der zu langen Zeit beim
> Umschalten als Grund für die Überhitzung.
Glaube ich nicht. Das bekommt man mit dem bisschen Kapazität nicht hin.

von mhh (Gast)


Lesenswert?

Wir werden eine Oszimessung abwarten müssen.

von Philipp F. (nerdture)


Lesenswert?

Ich besitze das Voltcraft DSO-2100 USB, mit dem nur 32bit Treiber 
geliefert werden, daher geht es mit all meinen aktuellen PCs nicht... :(

von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Ich habe nun doch einen geeignete Laptop gefunden.

Aber das Ergebnis meiner Messung ist einfach ein noch größeres 
Fragezeichen über meinem Kopf...

Das erste Bild:
Lila: Spannung zwischen AGND und MOSFET-Gates
Weiß: Spannung Optokoppler (emitter) vor dem Gate treiber

Das zweite Bild zeigt einfach nochmal den Puls der in den Optokoppler 
rein geht (50/50 Dimmung)

von MaWin (Gast)


Lesenswert?

> Fragezeichen über meinem Kopf...

Welche von dem halben Dutzend Schaltungen
hast du denn nun nachgebaut ?

Deine Originalschaltung ohne Änderungen ?

Wenn ja, dann sieht man wohl zweierlei:

Der MOSFET wird schnell genug eingeschaltet,
aber zu langsam ausgeschaltet, sogar 5ms
reichen dafür nicht.

Nach 3 eingeschalteten Halbwellen in denen
die MOSFETs die Spannung durchschalten und
damit auf 0 reduzieren bricht die
Versorgungsspannung der Schaltung zusammen,
weil du wohl immer noch nicht die Spannung
von VOR der Last ziehst, sondern aus V+.


Hättest du die Schaltung wie vorgeschlagen
aufgebaut, hätte sie sicher funtioniert:

  +------+--|>|--+--68k--+----+--+
  |      |       |       |    |  |
  |     Last     |     ZD10 Elko 1k
  |      |       |       |    |  |
  o      I|--+---)-------)----)--+
230V~   S|   |   |       |    |  >| Optokoppler
  o      +---)---)-------+----+--+E
  |     S|   |   |
  |      I|--+   |
  |      |       |
  +------+--|>|--+

von Philipp F. (nerdture)


Lesenswert?

Ich habe die Schaltung mit dem Gate Treiber (siehe mein Text) 
nachgebaut.
Also die die ich zuvor simuliert habe...

edit: Sehe ich das richtig, dass du was ganz neues vorschlägst, wo ich 
zwischen Last und 230V noch abgreife um die 10V zu generieren?
Klingt sinnvoll, dann nimmt sich die schaltung die nicht selbst weg, 
aber ich muss ja auch den lastabhängigen Nulldurchgang bestimmen.. hm 
:/

PS: Man beachte in den Oszi-Messungen oben auch, dass die Gate-Spannung 
bei 3,5 Volt liegt statt 10...

von Abdul K. (ehydra) Benutzerseite


Lesenswert?

Philipp F. schrieb:
> Ich habe nun doch einen geeignete Laptop gefunden.
>
> Aber das Ergebnis meiner Messung ist einfach ein noch größeres
> Fragezeichen über meinem Kopf...
>
> Das erste Bild:
> Lila: Spannung zwischen AGND und MOSFET-Gates
> Weiß: Spannung Optokoppler (emitter) vor dem Gate treiber
>

Und was macht die Versorgungsspannung des Gate-Treibers?

von Philipp F. (nerdture)


Lesenswert?

Habe gerade mal gemessen, Die Versorgungsspannung bewegt sich zwischen 3 
und 4 Volt.

Übrigens, wenn ich den Oszikopf an das Gate hänge verändert sich das 
Verhalten der Schaltung, die flackert dann noch stärker..

von Holm T. (Gast)


Lesenswert?

Frage an Phillip:

Gab es die IRFP460 evtl. preiswert bei Ebay?

..wollte nur wissen was aus meinen FETs so wird..

Gruß,

Holm (tsht_de)

von Abdul K. (ehydra) Benutzerseite


Lesenswert?

Philipp F. schrieb:
> Habe gerade mal gemessen, Die Versorgungsspannung bewegt sich zwischen 3
> und 4 Volt.

Was heißt 'bewegt'? Doch nicht etwas mit dem Multimeter?


>
> Übrigens, wenn ich den Oszikopf an das Gate hänge verändert sich das
> Verhalten der Schaltung, die flackert dann noch stärker..

Wo ist die Masse deines Scopes?

Das Gate muß eh recht kräftig gehalten werden, sonst schaltet dir ein 
Eingangstransient auf den 230V den MOSFET zu 'irgendwas' ein. Was auch 
der Fall ist, wenn es generell zu hochohmig zugeht.

von Frank X. (flt)


Lesenswert?

Holm Tiffe schrieb:
> Frage an Phillip:
>
> Gab es die IRFP460 evtl. preiswert bei Ebay?
>
> ..wollte nur wissen was aus meinen FETs so wird..
>
> Gruß,
>
> Holm (tsht_de)

Wenn Du welche loswerden willst frag mich mal...

mfg

von Holm T. (Gast)


Lesenswert?

Guck doch mal auf Ebay, ich habe mehrere Tausend Stück die ich loswerden 
will.


Gruß,

Holm

von Eddy C. (chrisi)


Lesenswert?

Abdul K. schrieb:
> Das Gate muß eh recht kräftig gehalten werden, sonst schaltet dir ein
> Eingangstransient auf den 230V den MOSFET zu 'irgendwas' ein. Was auch
> der Fall ist, wenn es generell zu hochohmig zugeht.

Apropos hochohmig: Bei nicht leitendem MODFET bilden seine Gate/Source- 
und Drain/Gate-Kapazitäten einen Spannungsteiler, welcher das Gate 
ungewollt durch die am Drain anliegende Wechselspannung aufsteuern kann. 
Das könnte die oben beobachteten Effekte produzieren.

Daher ist es bei eh schon hochohmiger Ansteuerung des Gate die bessere 
Idee, mit dem Optokoppler das Gate gegen Masse zu ziehen. Leitend wird 
der MOSFET wie gehabt und irgendwie durch den Schlabberpullup gegen 10V. 
Das sollte jetzt nur eine Begründung für den Optokoppler sein, welcher 
laut ursprünglicher Schaltung gegen Masse arbeitet.

von Philipp F. (nerdture)


Lesenswert?

Also: Ich habe mich nun entschieden einen DC/DC Wandler auf die Platine 
zu setzen, der mir konstante 9V liefert, auch wenn die MOSFETs die ganze 
Zeit durchschalten.

Ich habe dies mit dem Labornetzteil getestet und es klappt wunderbar.
Die Schaltzeiten waren also nicht das Problem, es geht mit Gate-Treiber 
genauso gut wie ohne mit 47k Widerständen (die MOSFETs werden max 40Grad 
warm).

Danke nochmal an alle für eure Hilfe.

von Ben _. (burning_silicon)


Lesenswert?

IRFP460 brauch ich nicht von Schrottbay, die kann ich zu tausenden 
selbst irgendwo ausbauen. Die gibts wie Sand am Meer.

von Holm T. (Gast)


Lesenswert?

@Ben irgendwas:

Ich verkaufe dort Fets mit maschinell abgewinkelten Beinen aus der IRF 
Originalverpackung. Die kannst Du sicher nicht irgendwo auslöten, Du 
Held.
Wenn Du Schrottbay nicht magst, dann kaufe die selben Dinger doch in 
meinem Onlineshop. Kennst Du nicht? So'n Mist aber auch...



Gruß,

Holm

von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Also so sieht der Dimmer jetzt aus ;)

Und er tuts, wenn auch mit DC/DC Wandler leider ca 5 Euro teurer pro 
Stück...

von Jörg S. (joerg-s)


Lesenswert?

Sehr schön. Und gleich so viele :)

Kannst du noch den Schaltplan posten?

von Philipp F. (nerdture)


Angehängte Dateien:

Lesenswert?

Hi,
hier noch der Schaltplan.

Dazu aber noch eine Frage.. Die 15V Zener Diode D4 als 
Überspannungsschutz, habe ich leider in der aktuellen nicht drin. Wie 
kritisch ist es mit den Überspannungen am Gate? Was kann passieren?

von Abdul K. (ehydra) Benutzerseite


Lesenswert?

Prinzipiell könnte ein Netztransient einen der MOSFETs einschalten: Gate 
wird von Drain mit hochgerissen, da der Gate-Widerstand entkoppelt.

Statistisch muß man mit einigen 5KV Impulen pro Jahr rechnen.

von MaWin (Gast)


Lesenswert?

> Die 15V Zener Diode D4 als Überspannungsschutz, habe ich
> leider in der aktuellen nicht drin. Wie kritisch ist es
> mit den Überspannungen am Gate? Was kann passieren

Ich vermisse vor allem einen 275V VDR um die MOSFETs vor'm
Ableben durch Überspannung zu schützen.

Kommen ganz schnelle Impulse über's Netz, kann die DG-Kapazität
zu einer Injektion ins Gate führen, die über 20V beträgt. Da das
Gate über 11k an einer Spannung liegt, kann man ausrechnen,
wie hoch und steil der Impuls sein muss, bevor das Gate -20V
UNTERschreitet (zu hoch kann die Spannung nicht werden weil
dann ja die MOSFETs leiten würden). Solche Impulse kommen z.B.
vom Starter einer Leuchtstofflampe mit ihrer Drossel bei der
der Funkentstörkondenstaor kaputt ist, oder durch induzierte
Blitze, oder durch aufmodulierte Hochfreqeunz (PowerLine Modems).

von Hauspapa (Gast)


Lesenswert?

Die Zenerdiode sollte sich in Vorwärtsrichtung wie eine normale Diode 
Verhalten und daher negative Gatespannungen ebenfalls ableiten.

Aus dem Rest halte ich mich raus.

schönen Abend
Hauspapa

von Jörg W. (dl8dtl) (Moderator) Benutzerseite


Lesenswert?

Philipp F. schrieb:
> Wie
> kritisch ist es mit den Überspannungen am Gate?

Ich mach dann mal den Paul Baumann:

"Ist das Gateoxid erst weg,
schimpft der Kunde: 'Was für'n Dreck!'"

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.