Forum: Analoge Elektronik und Schaltungstechnik INA105 Invertierungsproblem


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Alfons M. (axan)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe in meiner Schaltung den INA105KP von Texas Instruments 
verwendet, um ein Signal zu invertieren. Im beigefügten Schaltplan geht 
es dabei um den mittleren INA105 in der rechten Spalte. Wenn ich am 
Eingangspin 2 eine Spannung von 10 V gegenüber dem Pin 1 anlege, bekomme 
ich am Ausgangspin 6 eine Spannung von 3.76 V gegenüber dem Pin 1. Auch 
ein Austausch des ICs brachte keine signifikante Verbesserung. Ebenso 
habe ich versucht, statt einer Versorgungsspannung von 28 V eine 
symmetrische Versorgungsspannung von ±14 V anzulegen, was ebenfalls 
nicht wirklich geholfen hat.

Laut dem Datenblatt vom INA105 ist auf Seite 7 in Figure 6 es möglich, 
die Eingangsspannung V2 recht präzise zu invertieren auf -V0. Daher 
stellt sich mir die Frage: Was ist da falsch gelaufen? Alle ICs wurden 
übrigens unter ständigem ESD Schutz eingebaut und gehandhabt.

: Verschoben durch Moderator
von Achim S. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Alfons M. schrieb:
> Laut dem Datenblatt vom INA105 ist auf Seite 7 in Figure 6 es möglich,
> die Eingangsspannung V2 recht präzise zu invertieren auf -V0

ja, sicher

Alfons M. schrieb:
> Daher
> stellt sich mir die Frage: Was ist da falsch gelaufen?

Schwer zu sagen, weil schwer durchzublicken ist, welche Spannungen im 
Bezug worauf bei dir tatsächlich anliegen.

Du könntest für mehr Klarheit sorgen, indem du in der zweiten 
Versorgungsvariante (mit +-14V) alle Pins des betreffenden Bausteins 
relativ zu seinem Vref-Anschluss misst und die Ergebnisse hier 
berichtest. (Bitte nicht vergessen auch die Versorgungspins mit zu 
messen).

von Alfons M. (axan)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Achim, vielen Dank für die Antwort.

Gemäß dem schwarzen Pfeil in der angehängten Zeichnung habe ich mein 
Multimeter COM Anschluss mit einer Messspitze an Pin 3 vom INA103 
angeschlossen und so mein Bezugspotential gewählt. Mit der zweiten 
Messspitze habe ich dann die Spannung zu allen anderen Pins gemessen.

Zu Pin 1: 0 V (logisch, weil gebrückt.)
Zu Pin 2: + 10.00 V (die gewünschte Eingangsspannung)
Zu Pin 4: - 10.30 V (Versorgungsspannung V-)
Zu Pin 5: - 9.060 V (Ausgangsspannung, erwartet waren hier - 10 V)
Zu Pin 6: - 9.060 V (wie Pin 5, weil gebrückt)
Zu Pin 7: + 11.16 V (Versorgungsspannung V+)
Zu Pin 8: 0 V (Pin ist nicht angeschlossen)

Die Versorgungsspannung von ±14 V habe ich mit Hilfe eines EL302D Dual 
Power Supply hergestellt.

V+ Ausgang 1 des Power Supply mit Platine verbunden.
V- Ausgang 1 des Power Supply mit V+ Ausgang 2 des Power Supply 
verbunden.
V- Ausgang 2 des Power Supply mit Platine verbunden.

Beide Power Supplys hatten jeweils 14 V eingestellt, sodass durch die 
Reihenschaltung insgesamt wieder 28 V Versorgungsspannung vorhanden 
waren.

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Der INA105 hat einen deutlich eingeschränkten Ausgangsspanungshub, was 
man auch leicht anhand des Datenblatt feststellen kann. Schon auf Seite 
2 wird "OUTPUT => Rated voltage" mit minimal 10V, typisch 12V angegeben, 
und zwar bei einer Versorgungsspannung von +/-15V. Dies bedeutet, dass 
die maximale Ausgangsspannung um 3V bis 5V von der Versorgungsspannung 
entfernt bleibt.

Auf Seite 4 befinden sich dann noch Diagramme (Maximum Vout vs. Iout) 
für negative und positive Ausgangsspannungen (negative swing, positive 
swing), und zwar in Abhängigkeit von Versorgungsspannung und 
Ausgangsstrom. Dort sieht man z.B., dass man bei Vs=+/12V nur bis auf 
ca. -10,5V und +9V kommt. Bei Deiner Versorgung mit -10,3V sind also -9V 
Ausgangsspannung durchaus plausibel. für positive Ausgangsspannungen 
sähe das ganze noch übler aus. Hier beträgt die Differenz tatsächlich 
3V.

Schaut man sich die (vereinfachten) Schaltbilder typischer älterer OPs 
an, kann man den recht kleinen Ausgangsspannungshub und die Asymmetrie 
sehr einfach erklären. Das ist eben der Nachteil von Emitterfolgern. Die 
Asymmetrie erfolgt dadurch, dass vermutlich eine mittels PNP-Transistor 
aufgebaute Treiberstufe mit Emitterwiderstand verwendet wird.

von Achim S. (Gast)


Bewertung
1 lesenswert
nicht lesenswert
Alfons M. schrieb:
> Die Versorgungsspannung von ±14 V habe ich mit Hilfe eines EL302D Dual
> Power Supply hergestellt.

Ne, hast du nicht :-)

Laut deiner Messung ist die Versorgungsspannung +11,6V und -10,3V. Damit 
schafft es der INA natürlich nicht, die gewünschten 10V am Ausgang zu 
treiben.

Wahrscheinlich hast du tatsächlich wieder nur in Summe 28V eingestellt, 
aber keinen Bezug von deren Mittelspannung zur Masse deiner Signale 
hergestellt. Die driften gegeneinander, daher verschieben sich auch beim 
Messen der Versorgung jeweils deren Werte.

Alfons M. schrieb:
> V+ Ausgang 1 des Power Supply mit Platine verbunden.
> V- Ausgang 1 des Power Supply mit V+ Ausgang 2 des Power Supply
> verbunden.
> V- Ausgang 2 des Power Supply mit Platine verbunden.

Es fehlt eine Verbindung des "mittleren" Anschluss (also V- von 1 bzw. 
V+ von 2) auf den GND deiner Signale.

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
1 lesenswert
nicht lesenswert
Achim S. schrieb:
> Wahrscheinlich hast du tatsächlich wieder nur in Summe 28V eingestellt,
> aber keinen Bezug von deren Mittelspannung zur Masse deiner Signale
> hergestellt. Die driften gegeneinander, daher verschieben sich auch beim
> Messen der Versorgung jeweils deren Werte.

Stimmt, jetzt fällt es mir auch auf, dass da offenbar gar keine 
Verbindung des Bezugspotentials besteht...

von Alfons M. (axan)


Bewertung
0 lesenswert
nicht lesenswert
Tatsächlich. Es funktioniert tadellos, wenn man die Bezugspotentiale von 
der Versorgungsspannung und den Signalen zusammenschließt. Wenn man 
einfach den Wald vor lauter Bäumen nicht mehr sieht, dann kommen genau 
so "dämliche" Fehler dabei raus.

Insofern: Vielen Dank an euch beide, das war eine gute und schnelle 
Hilfe.

Schönes Wochenende. :)

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.