Forum: HF, Funk und Felder Frequenzgenerator: ständiges MOSFET-sterben?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Willy (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!!

Nachdem mein "alter" Frequenzgenerator ja einige Macken hatte, baute ich 
diesen nun komplett neu auf (vgl. Bilder!), mit der Hoffnung auf 
"beseitigung" der Probleme. Hier der Link zu meinem letzten Eintrag: 
Beitrag "Re: "Frequenzgenerator" für HF/HV-Trafo wird viel zu heiß?!"

Nun, das Problem mit den heißen Transistoren und dem zu großen 
Stromfluss hat sich zumindest teilweise verringert - die Transistoren 
werden zwar schon noch heiß, aber es dauert zumindest einige Zeit und es 
ist nicht mehr so extrem. Der Stromfluss pendelt sich bei ca. 20V auf 
ca. 6-7A ein (bei ca. 30kHz) - nicht mehr 20A.

Leider gibts jetzt ein neues Problem: Die beiden Transistoren gehen 
einfach kaputt? Es hat angefangen, nachdem ich ein bisschen an der 
Frequenz herumgedreht hatte, jetzt liegt die Frequenz bei ca. 70kHz und 
sobald ich die Schaltung mit Spannung versorge, dauert es ca. 5sec, dann 
sind die beiden Transistoren im Himmel. Sie werden aber nicht wirklich 
heiß, so kann es an der Temperatur nicht liegen. Kein einziges Bauteil 
an der Schaltung wird heiß! Ich habe jetzt schon 3 Transistoren 
verloren, deswegen frage ich mal hier nach, an was es liege könnte?

Zur Schaltung: die Eingangsspannung kann zwischen 15-100V liegen, die 
Frequenz ist einstellbar bis ca. 120kHz über 2 Potis und über einen 
extra Poti kann man noch die Pulsweite einstellen. vgl. Bilder im 
Anhang.

Zum Trafo: Ferritkern aus Zeilentrafo mit prim. 2x9 Windungen + 
Mittelabgriff mit HF-Litze / sek. 1800 Windungen, 0,22mm / > KEIN 
LUFTSPALT <

Bitte um Ideen, an was es liegen könnte!!

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
> sobald ich die Schaltung mit Spannung versorge, dauert es ca. 5sec...

Wie hoch ist da die Spannung?

Willy schrieb:
> die Eingangsspannung kann zwischen 15-100V liegen,

Die Transistoren müssen aber mindestens das Doppelte der 
Betriebsspannung sperren können.
Hat die Platine auch eine Unterseite?
Hast Du wirklich (noch) kein Oszilloskop?

von Willy (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Zum testen sind es immer 20-25 Volt, die ich verwende!

Bild der unterseite im Anhang!

Leider, das Oszi fehlt noch :(

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
> Hallo!!
>
> Nachdem mein "alter" Frequenzgenerator ja einige Macken hatte, baute ich
> diesen nun komplett neu auf (vgl. Bilder!), mit der Hoffnung auf
> "beseitigung" der Probleme. Hier der Link zu meinem letzten Eintrag:
> Beitrag "Re: "Frequenzgenerator" für HF/HV-Trafo wird viel zu heiß?!"
>
> Nun, das Problem mit den heißen Transistoren und dem zu großen
> Stromfluss hat sich zumindest teilweise verringert - die Transistoren
> werden zwar schon noch heiß, aber es dauert zumindest einige Zeit und es
> ist nicht mehr so extrem. Der Stromfluss pendelt sich bei ca. 20V auf
> ca. 6-7A ein (bei ca. 30kHz) - nicht mehr 20A.
>
> Leider gibts jetzt ein neues Problem: Die beiden Transistoren gehen
> einfach kaputt? Es hat angefangen, nachdem ich ein bisschen an der
> Frequenz herumgedreht hatte, jetzt liegt die Frequenz bei ca. 70kHz und
> sobald ich die Schaltung mit Spannung versorge, dauert es ca. 5sec, dann
> sind die beiden Transistoren im Himmel. Sie werden aber nicht wirklich
> heiß, so kann es an der Temperatur nicht liegen. Kein einziges Bauteil
> an der Schaltung wird heiß! Ich habe jetzt schon 3 Transistoren
> verloren, deswegen frage ich mal hier nach, an was es liege könnte?
>
> Zur Schaltung: die Eingangsspannung kann zwischen 15-100V liegen, die
> Frequenz ist einstellbar bis ca. 120kHz über 2 Potis und über einen
> extra Poti kann man noch die Pulsweite einstellen. vgl. Bilder im
> Anhang.
>
> Zum Trafo: Ferritkern aus Zeilentrafo mit prim. 2x9 Windungen +
> Mittelabgriff mit HF-Litze / sek. 1800 Windungen, 0,22mm / > KEIN
> LUFTSPALT <
>
> Bitte um Ideen, an was es liegen könnte!!

für 100V Eingangsspannung ist das der falsche FET.

für diese Ansteuerung ist das der falsche IC.

und ohne Oszi bist Du blind, also was soll man dir da helfen?

Hol Dir ein Oszi, schau dir die Drainspannungen an (obacht, können hoch 
sein) messe den Strom durch den Trafo, verwende vernünftige Gatetreiber 
mit den paar 100mA macht der Fet nur ein müdes Gesicht), veranstalte ein 
sauberes Layout, verwende ausreichend robuste FETs die auch den Strom 
aushalten wenn Dein Kern in Sättigung geht... mit anderen Worten: fang 
von vorne an, da drinnen herumzudoktoren ist vergeudete Zeit.

MiWi

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der IRFB4019 hat schon recht wenig Gate-Kapazität.
Den muß der 3525 locker schalten können.

von der schreckliche Sven (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Rot: Verbindung trennen.
Gelb: Neue Verbindung.

von DCDC (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo,

auch wenn es schwer ist den Fehler ohne Bilder zu sehen. Vermutlich hast 
ganz leicht unsymmetrische Ansteuersignale bei Deinem 
spannungsgespeisten Push-Pull? Converter. Dann kann der Transformator in 
die Sättigung gehen, das kann etwas dauern (wenn die Symmetrie gut aber 
nicht perfekt ist) und dann nimmt der Strom rasant zu, da die 
Induktivität sehr klein wird. Das kann dazu führen, dass intern die 
maximale Temperatur zu groß wird, ohne das der Transistor "warm" wird 
(zumindest aussen am Kühlkörper).

Stichworte: SOA, thermischer Widerstand.

Lösung für das Problem wäre eine Strommessung und Strombegrenzung im 
Sinne einer Cycle-by-Cycle Stromabschaltung.

Ob das richtig ist oder nicht kann ich nicht sagen, da meine Glaskugel 
nicht so gut funktioniert, aber es wäre ein Mechanismus. Rausfinden 
könnte man das mit einem Oszi und einer Stromzange.

Gruß DC/DC

von Mark S. (voltwide)


Bewertung
0 lesenswert
nicht lesenswert
Eine (von vielen) in Fragen kommenden Möglichkeiten ist thermischer Tod 
infolge primärer Überspannung (Avalanche Effekt). In den Pulspausen 
entstehen Überspannungen, die in den MOSFETs verbraten werden. Es liegt 
auf der Hand, dass bei höheren Frequenzen, also mehr 
Impulsen/zeiteinheit, dies immer kritischer wird.
Wie gesagt ist das nur eine von vielen denkbaren Möglichkeiten.
Ohne Oszi wird das nix.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Es fehlt noch ein Stützkondensator von Mittelanzapfung
des Trafos nach Masse. Das nächste Problem ist, im
Leerlauf fließt ein Strom durch die internen Dioden
im FET, der Blindstrom will ja irgendwo hin. Ich weiß
jetzt aber nicht wieviel die vertragen, du könntest
vielleicht von außen noch zusätzlich ein paar kräftige
dazuschalten. Und dann meß doch mal im Leerlauf den
Strom, der in die Mittelanzapfung des Trafos fließt,
er sollte nicht hoch sein. Wenn doch, ist es ein
Zeichen das der Kern in die Sättigung getrieben wird.
Dann muß die Induktivität erhöht werden, also die
Primärwicklung braucht dann mehr Windungen. Und dann
mußt du mal prüfen, ob die FETs auch wirklich richtig
durchschalten, also die Spannung dann nahe Null ist.
Das geht aber nur mit einem Oszillograf.

von der schreckliche Sven (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Noch ein Hinweis zum Layout.
Die MOSFETs müssen nebeneinander montiert sein.
Die graue Fläche auf meinem Schaltplan ist im Idealfall ein Punkt, 
möglichst nahe an den Source-Anschlüssen.
Der Betriebsspannungskondensator muß(!) sich nahe bei den MOSFETs 
befinden.
Schalte dem Elko noch einen Foko mit ~1µF parallel.
Die R-C Glieder über den MOSFETs müssen sich wirklich da befinden, und 
nicht die steilen Schaltflanken irgendwo an anderer Stelle einkoppeln.

Der Laststrom darf auf keinen Fall über Signalleitungen fließen. So wie 
Du das gemacht hast, gibt es vermutlich an den Gates der MOSFETs 
tödliche Spannungsspitzen.

Und die Verbindung zwischen Platine und Trafo scheint auch schon wieder 
ziemlich lang zu sein. Da ist eigentlich jeder Zentimeter zu viel.

(Ich weiß, so ein großräumiger Aufbau ist oft anzutreffen, besonders in 
Endstufen für Car-HiFi. Aber da sterben die MOSFETs ja auch wie die 
Fliegen).

Es gibt leider keine bessere Nachricht: Du mußt das Ganze neu aufbauen.

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
der schreckliche Sven schrieb:
> Der IRFB4019 hat schon recht wenig Gate-Kapazität.
> Den muß der 3525 locker schalten können.

Nein, der 3525 muß das nicht können.

Der unter abs. max. Rating angegebene Gatestrom beträgt 500mA. Wenn nun 
nur 1Ohm Gatewiderstand da sind und Vcc 12V beträgt wird also bei jedem 
Umschalten des Gates dieser Wert massivst überschritten. Das kann der 
3525 mitmachen, er muß es aber nicht können. Nominal sollten max. 400mA 
ins oder aus dem Gate kommen. Das ist durch geeignete Gatewiderstände 
oder entsprechend dazwischengeschaltete Treiber einzuhalten, auch wenn 
es nur uS sind, die diese Ströme fließen.

Auch deutet der schnelle Tod bei 25V darauf hin, das der FET das nicht 
lange kann. Denn die Überspannung wird bei dem gemächlichen Abschalten 
des FETs nicht so drastisch sein das sie 150V erreicht, das Foto des 
Trafos deutet aber auf ziemlich wenig L, also baldige Sättigung hin, 
also viel Ptot nicht nur beim (Ab)Schalten...

das die Widerstände des Snubbers viel zu hochohmig und auch ziemlich 
L-behaftet sind (Bauform) verschlechtert das Spannungspitzenhandling 
zusätzlich.


doch der TO reitet die selbe Sau durch unterschiedliche Dörfer wie man 
im verlinkten Thread sehen kann... daher - der soll endlich das tun was 
im zuhauf in anderen Beiträgen schon gesagt wurde...

siehe dazu auch
Beitrag "Re: "Frequenzgenerator" für HF/HV-Trafo wird viel zu heiß?!"

Und ohne Oszi (und dem Wissen, wie man in solchen Schaltungen damit 
umgeht) wird das sowieso nix. Solche Schaltungen lassen sich - gerade 
bei Fehlfunktionen - nur sehr schlecht durch mentalen Fokus (auch 
Glaskugel genannt) debuggen.

MiWi

von Willy (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo & DANKE wiedermal für die vielen Infos!!

Gleich vorgweg:

MiWi schrieb:
> doch der TO reitet die selbe Sau durch unterschiedliche Dörfer wie man
> im verlinkten Thread sehen kann... daher - der soll endlich das tun was
> im zuhauf in anderen Beiträgen schon gesagt wurde...

... bitte, das mache ich doch?? Hab die Schaltung komplett neu 
aufgebaut, hab ne Totzeit eingebaut, andere Gatewiderstände, die Drossel 
entfernt, RC-Dämpfung eingebaut, dickere Leiterbahnen verwendet und für 
mich eingentlich schon sehr kompakt aufgebaut - noch mehr zusammenrücken 
kann ich das ja nicht mehr? Außerdem brauchen die Kühlkörper auch ihren 
Platz.

So, jetzt zu allem anderen:

MiWi schrieb:
> Nominal sollten max. 400mA
> ins oder aus dem Gate kommen. Das ist durch geeignete Gatewiderstände
> oder entsprechend dazwischengeschaltete Treiber einzuhalten, auch wenn
> es nur uS sind, die diese Ströme fließen.

... manche sagten, ich soll die Gatewiderstände komplett weglassen, 
andere meinten 27 Ohm reicht maximal aus? Was ist also dein Vorschlag?

MiWi schrieb:
> das die Widerstände des Snubbers viel zu hochohmig und auch ziemlich
> L-behaftet sind (Bauform) verschlechtert das Spannungspitzenhandling
> zusätzlich.

... ok, wie viel Ohm sollten sie denn haben?

der schreckliche Sven schrieb:
> Die MOSFETs müssen nebeneinander montiert sein.
> Der Betriebsspannungskondensator muß(!) sich nahe bei den MOSFETs befinden. 
Schalte dem Elko noch einen Foko mit ~1µF parallel. Die R-C Glieder über den 
MOSFETs müssen sich wirklich da befinden, und nicht die steilen Schaltflanken 
irgendwo an anderer Stelle einkoppeln. Der Laststrom darf auf keinen Fall über 
Signalleitungen fließen. So wie du das gemacht hast, gibt es vermutlich an den 
Gates der MOSFETs tödliche Spannungsspitzen.

...ok, habe jetzt einiges an der Schaltung verändert - vgl.Bild (blau = 
kommt dazu / rot= kommt weg). Der Elko ist näher an den MOSFETs + Foko 
dazu und der Laststrom läuft nun nicht mehr über die Signalleitungen. 
Wie ich die Mosfets und die RC-Glieder noch näher zusammenrücken kann, 
weis ich nicht - noch kompakter gehts doch nicht mehr, oder?

Natürlich kann ich auch neu aufbauen, nur das wird dann auch wieder so 
ähnlich aussehen, weil noch kompakter wird schwer...?


Mark S. schrieb:
> Eine (von vielen) in Fragen kommenden Möglichkeiten ist thermischer Tod
> infolge primärer Überspannung (Avalanche Effekt). In den Pulspausen
> entstehen Überspannungen, die in den MOSFETs verbraten werden.

Kann man generell etwas gegen die Überspannung tun oder müssen das die 
MOSFETS einfach aushalten?

Abgesehen davon finde ich, sollten die MOSFETs es doch auch aushalten, 
wenn der Kern mal in die Sättigung geht, weil das ganze sowieso zum 
experimentieren gedacht ist, vielleicht sollte ich MOSFETs verbauen, die 
auch eine Sättigung und andere "Fehler" aushalten.

z.B experimentiere ich seit Jahren mit einem Royer-Converter herum - mit 
einem sehr fliegenden, schlechten Aufbau (wurde mir oft gesagt), der hat 
2 "IRFP260N" drinnen und die leben immer noch. Möchte nicht sagen, was 
ich damit schon alles gemach habe ;), aber die sind irgendwie fast 
unzerstörbar.

Dann habe ich noch 2 "FDH44N50" und "IRFB4227" herumliegen. Was sagt ihr 
zu den 3 - kann ich welche davon für diese Schaltung verwenden?

DCDC schrieb:
> Rausfinden
> könnte man das mit einem Oszi und einer Stromzange.

... Stromzange habe ich, das Oszi besorgt mir ein Bekannter, der ist 
eine Art HF-Techniker. Aber das dauert sicher noch eine längere Zeit, 
bis der das organisiert hat - der bekommt die "Tektronix" Oszis von 
seiner Firma und da kann er eines "abzweigen" ;)


... Bitte das Bild ansehen und mir Rückmelden ob das so "besser" ist?

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
> Hallo & DANKE wiedermal für die vielen Infos!!
>
> Gleich vorgweg:
>
> MiWi schrieb:
>> doch der TO reitet die selbe Sau durch unterschiedliche Dörfer wie man
>> im verlinkten Thread sehen kann... daher - der soll endlich das tun was
>> im zuhauf in anderen Beiträgen schon gesagt wurde...
>
> ... bitte, das mache ich doch?? Hab die Schaltung komplett neu
> aufgebaut, hab ne Totzeit eingebaut, andere Gatewiderstände, die Drossel
> entfernt, RC-Dämpfung eingebaut, dickere Leiterbahnen verwendet und für
> mich eingentlich schon sehr kompakt aufgebaut - noch mehr zusammenrücken
> kann ich das ja nicht mehr? Außerdem brauchen die Kühlkörper auch ihren
> Platz.

aber immer noch nicht mit dem Oszi über die Schaltung hergefallen. Auf 
die Idee sowas ohne Oszi zu machen käme ich nicht einmal in meinen 
verwegensten Träumen.

> So, jetzt zu allem anderen:
>
> MiWi schrieb:
>> Nominal sollten max. 400mA
>> ins oder aus dem Gate kommen. Das ist durch geeignete Gatewiderstände
>> oder entsprechend dazwischengeschaltete Treiber einzuhalten, auch wenn
>> es nur uS sind, die diese Ströme fließen.
>
> ... manche sagten, ich soll die Gatewiderstände komplett weglassen,
> andere meinten 27 Ohm reicht maximal aus? Was ist also dein Vorschlag?

Weißt... was manche sagen muß deswegen noch nicht richtig sein. Und auch 
Dir bleibt das lesen und strikte (!!) Einhalten von absolut maximum 
Ratings (denn darum heißen die so) nicht erspart.

Meinen Vorschlag kennst Du bereits seit dem 4. Beitrag: Gatetreiber, die 
Gates schnell und zackig laden und entladen können. Such Dir einen aus, 
erkläre warum Du den nimmst und dann reden wir weiter, ich sag Dir nicht 
welchen Du nehmen sollst.

> MiWi schrieb:
>> das die Widerstände des Snubbers viel zu hochohmig und auch ziemlich
>> L-behaftet sind (Bauform) verschlechtert das Spannungspitzenhandling
>> zusätzlich.
>
> ... ok, wie viel Ohm sollten sie denn haben?
>

Ohne Oszibilder, ohne L des Trafos und ohne irgendwas mach ich mich 
nicht zu dem "Du hast aber gesagt" Deppen. Es gibt viel Fachliteratur zu 
dem Thema, suche sie, lese sie und komme wieder.


> der schreckliche Sven schrieb:
>> Die MOSFETs müssen nebeneinander montiert sein.
>> Der Betriebsspannungskondensator muß(!) sich nahe bei den MOSFETs befinden.
> Schalte dem Elko noch einen Foko mit ~1µF parallel. Die R-C Glieder über den
> MOSFETs müssen sich wirklich da befinden, und nicht die steilen Schaltflanken
> irgendwo an anderer Stelle einkoppeln. Der Laststrom darf auf keinen Fall über
> Signalleitungen fließen. So wie du das gemacht hast, gibt es vermutlich an den
> Gates der MOSFETs tödliche Spannungsspitzen.
>
> ...ok, habe jetzt einiges an der Schaltung verändert - vgl.Bild (blau =
> kommt dazu / rot= kommt weg). Der Elko ist näher an den MOSFETs + Foko
> dazu und der Laststrom läuft nun nicht mehr über die Signalleitungen.
> Wie ich die Mosfets und die RC-Glieder noch näher zusammenrücken kann,
> weis ich nicht - noch kompakter gehts doch nicht mehr, oder?
>
> Natürlich kann ich auch neu aufbauen, nur das wird dann auch wieder so
> ähnlich aussehen, weil noch kompakter wird schwer...?
>
>
> Mark S. schrieb:
>> Eine (von vielen) in Fragen kommenden Möglichkeiten ist thermischer Tod
>> infolge primärer Überspannung (Avalanche Effekt). In den Pulspausen
>> entstehen Überspannungen, die in den MOSFETs verbraten werden.
>
> Kann man generell etwas gegen die Überspannung tun

Ja. Generell kann man, nennt sich Snubber (in dem Fall wäre ein 
D-R//C-snubber sinnvoll), wird zwingend aber nicht nur - bei 
Flyback-Netzteilen verwendet. Mach Dich schlau, das ist keine 
Raketenwissenschaft.

> oder müssen das die MOSFETS einfach aushalten?

Nein.

> Abgesehen davon finde ich, sollten die MOSFETs es doch auch aushalten,
> wenn der Kern mal in die Sättigung geht, weil das ganze sowieso zum
> experimentieren gedacht ist, vielleicht sollte ich MOSFETs verbauen, die
> auch eine Sättigung und andere "Fehler" aushalten.
>
> z.B experimentiere ich seit Jahren mit einem Royer-Converter herum - mit
> einem sehr fliegenden, schlechten Aufbau (wurde mir oft gesagt), der hat
> 2 "IRFP260N" drinnen und die leben immer noch. Möchte nicht sagen, was
> ich damit schon alles gemach habe ;), aber die sind irgendwie fast
> unzerstörbar.

Nun, warum nimmst Du nicht die?

>
> Dann habe ich noch 2 "FDH44N50" und "IRFB4227" herumliegen. Was sagt ihr
> zu den 3 - kann ich welche davon für diese Schaltung verwenden?

Datenblatt lesen hilft. Und wenn Du da was nicht verstehst - frage 
konkret was Du nicht verstehst. Einfach nur Bauteile in den Raum werfen 
und dann "macht mal bitte" sagen ist ein bissi wenig.

>
> DCDC schrieb:
>> Rausfinden
>> könnte man das mit einem Oszi und einer Stromzange.
>
> ... Stromzange habe ich, das Oszi besorgt mir ein Bekannter, der ist
> eine Art HF-Techniker. Aber das dauert sicher noch eine längere Zeit,
> bis der das organisiert hat - der bekommt die "Tektronix" Oszis von
> seiner Firma und da kann er eines "abzweigen" ;)

Nur so ein kleiner Vorschlag:
https://www.willhaben.at/iad/kaufen-und-verkaufen/d/tektronix-2445-oszilloskop-150mhz-4-kanal-260727361/

die billigeren Hamegs habe ich Nicht vorgeschlagen, da gibts welche ab 
100€  einfach immer wieder einmal hineinschauen hilft...

>
> ... Bitte das Bild ansehen und mir Rückmelden ob das so "besser" ist?

kA.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
>Abgesehen davon finde ich, sollten die MOSFETs es doch auch aushalten,
>wenn der Kern mal in die Sättigung geht,

Während der Sättigung steigt der Strom extrem an, und es kann
in der Zeit keine Energie übertragen werden, also konstruiert
man die Schaltung so daß dies nicht passieren kann.
Also bitte mal den Strom im Leerlauf, wenn die Sekundärwicklung
nicht belastet wird, messen. Der Strom sollte dann gering sein,
vieleicht so um die 50mA. Noch mal zu den internen Dioden
des FETs, im Datenblatt bei Maximal Ratings, findet man leider
nichts wieviel Strom da maximal zugelassen ist, vielleicht
weiß jemand anderes mehr darüber.

 MiWi schrieb:
>das Foto des
>Trafos deutet aber auf ziemlich wenig L, also baldige Sättigung hin,
>also viel Ptot nicht nur beim (Ab)Schalten...

Den Verdacht habe ich auch.

von MiWi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Günter Lenz schrieb:
 Noch mal zu den internen Dioden
> des FETs, im Datenblatt bei Maximal Ratings, findet man leider
> nichts wieviel Strom da maximal zugelassen ist, vielleicht
> weiß jemand anderes mehr darüber.
>

Diese Dioden sind aufbaubedingt vorhanden. Insofern gelten für sie die 
gleichen Parameter wie für den FET.

die "nutzbaren" und für den normalen Anwender zulässigen Parameter 
finden sich für den IRFB4019 auf Seite 2 im Datenblatt unten. Wenn es 
knackiger sei muß spezifiziert man die Frage und redet mit dem 
Hersteller.

Wenn die Angaben fehlen (und das tun sie fast nie) und man auf diese 
Dioden angewiesen ist (und das ist in dieser Schaltung nicht der 
Fall)... dann anderen FET suchen, es gibt genug Auswahl.

MiWi

von Willy (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Stromfluss am Eingang der Schaltung im Leerlauf, also mit 
angeschlossenem Trafo, aber ohne die Sekundärseite zu belasten beträgt 
0,65A bei 20V Eingangsspannung und bei (mit dem Multimeter gemessenen) 
21kHz. Dabei macht der Trafo laute Piepsgeräusche. Erhöhe ich die 
Frequenz wird das Piepsen lauter aber feiner, verringere ich sie, wird 
es leiser aber geht mehr ins Rauschen.

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
> 0,65A bei 20V Eingangsspannung und bei (mit dem Multimeter gemessenen)
> 21kHz. Dabei macht der Trafo laute Piepsgeräusche. Erhöhe ich die
> Frequenz wird das Piepsen lauter aber feiner, verringere ich sie, wird
> es leiser aber geht mehr ins Rauschen.

Der Stromverbrauch scheint akzeptabel. Ob das besser geht mit der 
Monster-Sekundärwicklung ist fraglich.
Die Frequenzmessung kann nicht stimmen. Vielleicht kannst Du 21KHz noch 
hören, mehr aber nicht. Und von einer nicht vorhandenen Regelung kann 
das Piepsen nicht kommen. An welchem Punkt misst Du?

Mit dem SG3525 habe ich etwas Erfahrung. Der kann noch viieel dickere 
MOSFETs problemlos schalten. Weil nämlich seine Treiberausgänge relativ 
langsam sind. Würdest Du aber die möglichen Schaltzeiten Deiner MOSFETs 
wirklich nutzen, hättest Du wieder neue Probleme.

Der Aufbau geht auch mit Hobbymitteln noch viieel kompakter.
Es erfordert halt etwas Kopfzerbrechen.

So ganz nebenbei: Dieser Tread gehört eigentlich ins Analog-Forum.

von Günter Lenz (Gast)


Bewertung
0 lesenswert
nicht lesenswert
MiWi schrieb:
>man auf diese
>Dioden angewiesen ist (und das ist in dieser Schaltung nicht der
>Fall)...

Im Leerlauf schon, da fließt im Moment der Umschaltung, der
Strom erst mal invers durch diese Diode, die Spule gibt
dadurch ihre gespeicherte Energie an die Batterie wieder
ab. Danach kehrt sich die Sache wieder um, und der Strom
fließt wieder in die richtige Richtung. Die Spule nimmt
wieder Energie auf. Ein Wechselspannung an eine Spule
erzeugt einen Blindstrom. Das Hin- und Herschalten der
Transistoren ist ja im Prinzip eine Wechselspannung.

 Willy schrieb:
>aber ohne die Sekundärseite zu belasten beträgt
>0,65A bei 20V

Ich würde mal sagen, etwas zuviel. Aber du brauchst
ein Oszillograf, da siehst du es dann genauer.
Es muß dann eine gute Rechteckspannung zu sehen sein.

von Willy (Gast)


Bewertung
0 lesenswert
nicht lesenswert
der schreckliche Sven schrieb:
> Die Frequenzmessung kann nicht stimmen. Vielleicht kannst Du 21KHz noch
> hören, mehr aber nicht. Und von einer nicht vorhandenen Regelung kann
> das Piepsen nicht kommen. An welchem Punkt misst Du?


Naja, ich hab um den Kern ein paar zusätzliche Windungen gewickelt und 
dort das Multimeter angeschlossen. Ich glaube auch nicht, dass es 
stimmt, das Multimeter zeigt wahrscheinlich irgend etwas an - k.a. ob 
das diese Rechteckigen-Impulse überhaupt messen kann?

Noch etwas: wenn ich an dem Poti für die Pulsweiteneinstellung rumdrehe 
(bei fixer Frequenz), varriert der Stromverbrauch im Lerrlauf auch von 
ca. 0,05A bis 6A(!) alles immer bei 20V am Eingang.

Es ist die Sekundärwicklung, die diese Geräusche macht!?


Günter Lenz schrieb:
> Ich würde mal sagen, etwas zuviel. Aber du brauchst
> ein Oszillograf, da siehst du es dann genauer.
> Es muß dann eine gute Rechteckspannung zu sehen sein.

OK, ich hab ein bisschen herumtelefoniert - wenn es gut geht, bekomme 
ich vielleicht schon am Ende der Woche das Oszi, mal sehen.

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:
> Naja, ich hab um den Kern ein paar zusätzliche Windungen gewickelt und
> dort das Multimeter angeschlossen.

Schalte mal ei R-C Glied (1K + 1-10nF) dazwischen. Die angezeigte 
Frequenz sollte irgendwie zum Pfeifton passen.

Kannst Du die Sekundärwicklung entfernen? Wenn ja, mach das mal!

von Willy (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok, hab nun wieder einen MOSFET zerstört. Es dürfte doch an der 
Temperatur liegen! Ich habe einen alten AC-Zeilentrafo gefunden und den 
an die Schaltung angeschlossen mit primär 2x 6 Windungen. Dabei habe ich 
an der Frequenz un der Pulsweite herumgedreht und auch Spannungen von 
20-30Volt ausgetestet.

Grundsätzlich: sobald der Poti für die Pulsweite mehr als 1/4 
"aufgedreht" wird, werden die MOSFETS wieder sehr schnell sehr heiß und 
es fließen große Ströme von 5A aufwärts - mit erhöhung der Frequenz kann 
ich diese großen Ströme zwar wieder reduzieren, aber das ändert nix an 
der radikalen Erwärmung der MOSFETS. Ich denke, als ich den 
Pulsweiten-Poti ca. bis zur Hälfte "aufgedreht" hatte und die Spannung 
auf ca. 28Volt hochdrehte, wurde mindestens 1 MOSFET so schnell so heiß, 
dass er kaputt ging und diese Erwärmung dürfte auch so rasch gehen, dass 
man dies nicht gleich an den Kühlkörpern bemerkt. So denke ich, passiert 
es.

BEDEUTET: jetzt werden die MOSFETs eigentlich noch schneller heißer, als 
bei meiner "alten" Schaltung :( und fahren anstatt nach ca. 30 Sekunden 
schon nach 5 Sekunden in den Himmel. Und dem Trafo gebe ich immer 
weniger die Schuld, denn diesen habe ich schon mit verschiedenen 
primären Windungen getestet und zu guter Letzt auch einen "fertigen" 
AC-Zeilentrafo angeschlossen und das Ergebnis ist immer das Selbe - die 
MOSFETS "verdampfen".

WAS ICH JETZT MACHE: 1. Die Schaltung nochmal neu aufbauen, noch 
kompakter + ein besseres Layout auch mit der Möglichkeit die MOSFETs 
"einfacher" zu tauschen. 2. Ein Oszi anschließen und alles messen und 
dann poste ich die Bilder hier rein!

von U. B. (pasewalker)


Bewertung
1 lesenswert
nicht lesenswert
Haben die defekten FET eine Gate-Drain-Schluss?  =>

Die Gatewiderstande sind eher klein.
Womöglich ist daher die Schaltgeschwindigkeit zu gross, sodass die
max. Gatespannung (20V ?) transient überschritten wird?

von Willy (Gast)


Bewertung
0 lesenswert
nicht lesenswert
U. B. schrieb:
> Haben die defekten FET eine Gate-Drain-Schluss?  =>

Zwischen Gate-Drains messe ich 320 Ohm bei den defekten, bei den 
nicht-defekten zeigt das Messgerät über mehrere MegaOhm an.

von Thomas O. (kosmos)


Bewertung
1 lesenswert
nicht lesenswert
Ich erkläre es mal kurz am Beispiel einer Zündspule aus dem Kfz- 
Bereich.

14V Bordspannung Zündspule mit einem primär Widerstand von 0,6 Ohm.
14V/0,6 Ohm = 23,3A.

Der Zündtransistor ist aber laut Datenblatt nur für 10 A ausgelegt. Wie 
kann das sein?

Die Spule ist ja eine Induktivität die den Stromanstieg bis Sie voll 
gesättigt ist begrenzt nach der Sättigung geht der induktive Widerstand 
gegen Null zurück und es kommt nur noch der ohmsche Widerstand zum 
tragen wodurch der Strom dann sehr schnell auf die 23A ansteigt.

Man darf die Spule dann eben nur so lange laden bis kurz vor ihrer 
Sättigung meist wenige mSek lang. Oder man ermittelt mit einem Oszi ab 
welcher Zeit nach Ladebeginn der Strom weiter stark ansteigt.
(Differenzmessung mit 2 Kanaloszi über Messwiderstand).

In Kurzfassung: Ladezeit kurz und konstant halten und die Frequenz 
mittels der Pausen dazwischen regeln. Pausenzeit nicht kürzer als 
Ladezeit.

von Soul E. (souleye) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Willy schrieb:

> Grundsätzlich: sobald der Poti für die Pulsweite mehr als 1/4
> "aufgedreht" wird, werden die MOSFETS wieder sehr schnell sehr heiß und
> es fließen große Ströme von 5A aufwärts - mit erhöhung der Frequenz kann
> ich diese großen Ströme zwar wieder reduzieren, aber das ändert nix an
> der radikalen Erwärmung der MOSFETS.

Das sieht aus als ginge Deine Induktivität in Sättigung. Häng mal die 
Stromzange rein und guck Dir den Stromverlauf auf dem Oszi an. Bei einer 
Spule an konstanter Spannung steigt der Strom linear mit der Zeit an. 
Wenn die Kurve plötzlich steil nach oben knickt ist der Kern gesättigt 
und die Induktivität nimmt ab.

Google hat dazu dieses Bild gefunden: 
https://cdn.weka-fachmedien.de/thumbs/media_uploads/images/1474358911-273-worzmkqbp.jpg.950x534.jpg

Wenn Du in den steilen Bereich gerätst geht der Transistor kaputt und 
der Trafo überträgt auch keine zusätzliche Energie mehr (er ist 
gesättigt).

von der schreckliche Sven (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Da wird nichts mit der Sättigung.
Willy hat schon wieder einen Zeilentrafo MIT LUFTSPALT !
Die Platine ist Müll.
Der ENT-Magnetisierungsstrom geht durch die Transistoren, weil da der 
Weg kürzer ist!
Daß in dieser Schaltung ein hoher Blindstrom fließt, scheint 
unvermeidbar. Wenn der Aufbau dafür geeignet wäre, würden sich auch die 
Verluste in erträglichen Grenzen halten.

von Willy (Gast)


Bewertung
0 lesenswert
nicht lesenswert
der schreckliche Sven schrieb:
> Willy hat schon wieder einen Zeilentrafo MIT LUFTSPALT !


... ja zum testen, aber wie gesagt - gleiches Ergebnis wie mit dem 
selbstgebastelten trafo OHNE Luftspalt, keine Unterschiede merkbar.

Jedenfalls warte ich mal auf das Oszi und dann gehe ich das Ganze anders 
an - inzwischen baue ich die Schaltung besser auf:

-)MOSFETS + RC-Glieder + Elko direkt nebeneinander.
-)Laststrom fließt über eigene Leitung, Steuersignale andere Leitungen.
-)Gatewiderstände werde ich vielleicht auf 10 Ohm erhöhen, da das fast 
alle anderen Schaltungen mit dem 3525er auch so haben.
-)FDH44N50 oder IRFP260N werden die neuen MOSFETS.

Ich habe mir andere Schaltungen angesehen, wobei ein 3525er zwei oder 
mehr MOSFETS steuert und die sehen eigentlich alle fast so aus wie meine 
- also vom PRINZIP kann man da nicht mehr viel anders machen, halt eben 
nur von der Konstrukion besser aufbauen wahrscheinlich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.