mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LTSpice Model für den MCP6001 funktioniert nicht


Autor: Simon K. (yo-gurt)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte einen zweistufigen Filter mit dem MCP6001 simulieren. Im 
Anhang befindet sich die .asc Datei, sowie das dazugehörige Model.

Bei der AC Analyse kommt als Fehlermeldung "failed to find dc operating 
point for ac analysis".
Die Transientenanalyse funktioniert auch nicht: "Analysis: Time step too 
small; initial timepoint: trouble with node u3:21".

Ich habe bereits die Optionen aus diesem Beitrag 
"Beitrag "MCP6001 - LTSpice Model hinzufügen"; von Jens G. getestet.
Dann funktioniert zwar die simulation, doch die Dämpfung ist viel zu 
hoch.

Ich kenne mich mit LTSpice leider nicht gut aus, ich hoffe mir kann hier 
jemand helfen.

Gruß Simon

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier läuft das ohne Probleme.

Autor: Simon K. (yo-gurt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir an der Hochschule lief es auch problemlos, doch zu dem PC habe 
ich momentan keinen Zugang. Ich habe es bereits an mehreren PC's 
probiert, doch da ging es auch nicht.
Kann es vielleicht an der LTSpice Version liegen? Ich habe mir von hier
(http://www.analog.com/en/design-center/design-tools-and-calculators/ltspice-simulator.html 
)
die aktuellste Version runtergeladen.

Könntest du mir vielleicht deine LTSpice Version über den Anhang geben?

Autor: Simon K. (yo-gurt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe mir gerade LTSpice IV runtergeladen dann funktioniert 
alles. Vorher hatte ich LTSpice XVIII.

Trotzdem nochmal Danke!

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simon K. schrieb:

> Könntest du mir vielleicht deine LTSpice Version über den Anhang geben?

Das wären 37MB, etwas viel dafür.

Ich hab noch die LTS17 vom Sept 2016.

Autor: Bordodynov (Gast)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Ich habe gezeigt, wie ich aus der schwierigen Situation herauskommen 
kann, sowie mein Modell dieses Operationsverstärkers.

Autor: Bordodynov (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Entschuldigung, ich bin auf Deutsch Null.

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Hier mein Vorschlag.
Beachte die eingekreisten Änderungen.
In der Modelldatei hat jemand Kapazitäten wegen Konvergenzproblemen für 
LTspice hinzugefügt. Diese Kapazitäten habe ich auf 1/10 reduziert damit 
die Bandbreite(GBW) des Opamp näher bei 1MHz ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.