mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LTSpice Simulation wird nicht fertig


Autor: Info (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anbei eine recht einfache Schaltung aus einem billigen Toaster, die ich 
zu verstehen versuche.
Im Normalfall ist die Versorgung Wechselspannung, abgegriffen an den 
Heizdrähten. Die wird Einweg-gleichgerichtet.
Um die Zusammenhänge / Schaltschwellen ohne Ripple besser erkennen zu 
können, habe ich die Versorgung auf DC gestellt.

LTSpice kommt jedoch vor dem entscheidenden Moment nicht weiter.
Ich habe es auch schon mit dem Alternate Solver versucht (im Control 
Panel unter SPICE).

Soweit meine Annahme zur Funktion:

Einschalten:
- C2 ist entladen
- Q3 sperrt
- Q2 Basisstrom über R7 und R4 (+Poti)
- Q2 schaltet und zieht die Basis von Q1 über R3 und R4 (+Poti) runter, 
so dass Q1 schaltet und Strom durch den Elektromagnet fließt

Ausschalten:
- C2 lädt sich über den NTC-Spannungsteiler auf, bis seine Spannung 
einen PN-Übergang über der Emitterspannung von Q2 und Q3 liegt
- Q3 schaltet und zieht die Basis von Q2 runter
- Q2 sperrt
- Q1 sperrt (Toaster schaltet ab)
- C2 entlädt sich auch über D2 via R1 etc.

Der NTC soll wohl beim vorgewärmten Toaster die Zeit verkürzen (C2 lädt 
schneller).
Das Poti zur Zeiteinstellung erhöht die Schwellspannung.

Der Toaster tut es nicht mehr, d.h. er bleibt nicht eingeschaltet. Der 
NTC ist i.O.

Der Elektromagnet ist eigentlich krümelfrei. Nur die Schalterkontakte 
haben  in den letzten 11 Jahren einseitig ordentlich Abbrand erhalten... 
Ich muss mal messen, was da so passiert. Elko ausgetrocknet?

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elkos sind OK.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nimm für die Transistoren "richtige" Modelle z. B.

Q1: 2N3906

Q2, Q3: 2N3904

Damit läuft die Simulation bis zum Ende durch.

: Bearbeitet durch User
Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich probier's mal. Vielen Dank und ggf. gute Nacht.

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das funktioniert, wie du sagtest - leider sind der Ablauf und die 
Schwellspannungen für mich nicht ohne Weiteres abzulesen, da das 
Umschalten im ps-Bereich abläuft.
Was mir aber aufgefallen ist: im Abschaltmoment gibt es kurzzeitig einen 
negativen Basisstrom von Q2, obwohl die Basis-Emitter-Spannung auch dann 
positiv ist (Set > Q2).

Aber auch diese vermeintlichen Erkenntnisse über die Funktion der 
Schaltung lösen mein praktisches Problem leider noch nicht, denn auch 
der Verdacht, dass der Glättungskondensator doch einen Schaden hat, und 
daher nicht genug Energie für den Magneten zur Verfügung steht, hat sich 
bislang nicht bestätigt: 36 Vpp bzw. 12.4 Veff werden zu mittleren 11.6 
V, und das entspricht den 12VAC des Bestückungsdruckes.
Der "Transistortester" sagt 440 uF und ein ESR von 1.2 Ohm.

Der Magnet zieht auch an, aber er schafft es nicht mehr. Was kann sonst 
noch die Ursache sein?
Strom reicht nicht: Windungsschluss? Transistor schafft es nicht? 
Basisstrom zu klein? Spannung zu niedrig (Heizdrähte hochohmiger)?

Oder ich gebe endlich auf und spendiere einfach 15 Euro für einen neuen 
Toaster...

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was mir aber aufgefallen ist: im Abschaltmoment gibt es kurzzeitig einen
negativen Basisstrom von Q2, obwohl die Basis-Emitter-Spannung auch dann
positiv ist (Set > Q2).

Der kurzzeitig negative Basisstrom im Umschaltmoment kommt von den 
Kapazitäten Ccb und Cbe des Transistors.

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Helmut, ich muss dringend mein Transistor-Halbwissen 
auffrischen...

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Info schrieb:
> Der "Transistortester" sagt 440 uF und ein ESR von 1.2 Ohm.

Das ist selbst für einen FWW 470µF/25V Elko arg viel ESR.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Info schrieb:
>> Der "Transistortester" sagt 440 uF und ein ESR von 1.2 Ohm.
>
> Das ist selbst für einen FWW 470µF/25V Elko arg viel ESR.

Da der Spulenstrom nur ca. 100mA beträgt, stört der ESR von 1,2Ohm 
nicht.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> hinz schrieb:
>> Info schrieb:
>>> Der "Transistortester" sagt 440 uF und ein ESR von 1.2 Ohm.
>>
>> Das ist selbst für einen FWW 470µF/25V Elko arg viel ESR.
>
> Da der Spulenstrom nur ca. 100mA beträgt, stört der ESR von 1,2Ohm
> nicht.

Das ist richtig, aber der hohe ESR deutet auf baldiges Ableben hin.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Helmut S. schrieb:
>> hinz schrieb:
>>> Info schrieb:
>>>> Der "Transistortester" sagt 440 uF und ein ESR von 1.2 Ohm.
>>>
>>> Das ist selbst für einen FWW 470µF/25V Elko arg viel ESR.
>>
>> Da der Spulenstrom nur ca. 100mA beträgt, stört der ESR von 1,2Ohm
>> nicht.
>
> Das ist richtig, aber der hohe ESR deutet auf baldiges Ableben hin.

Dre ESR von 1,2Ohm passt. Der Elko ist "gesund".
Du hast ja nur einen billigen normalen Elko genommen und keinen 
"low"-ESR Elko für Schaltnetzteile.

Die Frage ist natürlich ob generell die 10V und 8V für das 12V-Relay 
hoch genug bzw. niederig genug sind.

: Bearbeitet durch User
Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Dre ESR von 1,2Ohm passt. Der Elko ist "gesund".
> Du hast ja nur einen billigen normalen Elko genommen und keinen
> "low"-ESR Elko für Schaltnetzteile.

1,2 Ohm sind für einen solchen Elko dennoch deutlich zu viel.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Helmut S. schrieb:
>> Dre ESR von 1,2Ohm passt. Der Elko ist "gesund".
>> Du hast ja nur einen billigen normalen Elko genommen und keinen
>> "low"-ESR Elko für Schaltnetzteile.
>
> 1,2 Ohm sind für einen solchen Elko dennoch deutlich zu viel.

War ja auch schon öfter Thema:

Beitrag "Re: ab welchen widerstand Elko lieber tauschen ?"

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum Elko-ESR: ich weiß nicht, wie genau der "Transistortester" den 
bestimmen kann. Aber: ein ungebrauchter 470uF, 25V, 85°C Elko von 
Jamicon hat den gleichen Wert.

Ich habe übrigens einen neuen Thread aufgemacht, da die Fragestellung 
hier ja eher LTSpice betrifft:

Beitrag "Toaster defekt (bleibt nicht unten, Magnetkraft reicht nicht aus)"


> Im Betrieb fallen am Magneten 13.75 VDC (laut Multimeter, die Spannung hat aber 
ordentlich Ripple) ab, es reichen aber bereits 120 mA bei 9.5 V (DC Netzteil).
> Ein zusätzlicher Glättungskondensator hat nicht nennenswert etwas gebracht, 
Versuche, den Magnet besser auszurichten, auch nicht.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Info schrieb:
> Zum Elko-ESR: ich weiß nicht, wie genau der "Transistortester" den
> bestimmen kann. Aber: ein ungebrauchter 470uF, 25V, 85°C Elko von
> Jamicon hat den gleichen Wert.

Einfach mal einen 1 Ohm Widerstand in Reihe schalten und nochmal messen, 
dann zeigt sich schnell ob das Messgerät richtig arbeitet.

Autor: MM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Info schrieb:
> Aber: ein ungebrauchter 470uF, 25V, 85°C Elko von
> Jamicon hat den gleichen Wert.

Finde den Fehler. (Tip: beginnt mit J und endet mit amicon)

Alt, gebraucht, Rubicon 470 µF/ 16 V/ 85 °C: 0,18 Ohm.

Autor: hinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MM schrieb:
> Info schrieb:
>> Aber: ein ungebrauchter 470uF, 25V, 85°C Elko von
>> Jamicon hat den gleichen Wert.
>
> Finde den Fehler. (Tip: beginnt mit J und endet mit amicon)
>
> Alt, gebraucht, Rubicon 470 µF/ 16 V/ 85 °C: 0,18 Ohm.

Auch die Jamicon SK sind normalerweise nicht schlechter.

Autor: MM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hinz schrieb:
> Auch die Jamicon SK sind normalerweise nicht schlechter.

Zugegebenermaßen bin ich durch mehrere Reinfälle mit Jamicon nicht mehr 
sehr motiviert funktionierende Serien herauszupicken. Die Objektivität 
ging bei mir zu diesem Hersteller unwiederbringlich verloren...

Autor: Info (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schaltung als Bild im Anhang.

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(die Induktivität des E-Magnets habe ich nicht bestimmt, die 100uH in 
der Schaltung sind willkürlich gewählt)

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(PNP: "S8550", NPN: "S9014")

Autor: Info (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, vorerst letzter Post:
Bei ca. 20°C Raumtemperatur läuft er auf niedrigster Einstellung 2,5 
Minuten.
Die Temperatur vom NTC ist hier die Variable (Typ, "Anbindung" im 
Toaster).
Wer es kürzer haben möchte kann den 330k Serienwiderstand reduzieren (C 
lädt schneller) oder evtl. den Mindest-Schwellwert reduzieren (1k in 
Serie mit dem Poti).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.