mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Class D Amp. / Knick im Ausgangssinus unter Last


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
Autor: Simi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich habe nun eine neue Version meines Class D Amps. vom 
Beitrag "Class D Amp. mit LTC6992" vor ein paar Wochen als 
Elektronik-WM Vorbereitung gestartet. Kein LTC6992 mehr, sondern mit 
OPVs aufgebaut (Schaltplan und PCB Files sind angehängt).

Verstärkung, Duty Cylce, PWM-Frequenz kann alles super eingestellt 
werden und auch die Musikqualität bei kleinerer Lautstärke passt super, 
leider wird sie bei steigender Amplitude schlechter.
Ein Oszilloskop-Bild verrät auch warum. In der "negativen" Halbwelle des 
Sinus ist ein deutlicher Knick zu sehen.
Ich versuche jetzt schon eine halbe Ewigkeit diesen Knick wegzubringen.

Note: In der Endstufe ist zur Zeit nur eine Halbbrücke verbaut.
Es wird eine JLC-PCB Platine benutzt. Also nicht Lochraster oder 
Steckbrett. Deshalb sollte außer Routing-Fehler der Aufbau nicht schuld 
sein.

Zum Knick selbst:
-) Er ist Last abhängig. Also bei 16R ist der Knick weiter unten als bei 
4R Last. Bei 100R ist der Knick unter Vollaussteuerung gar nicht mehr zu 
sehen. Ohne Last ist der Sinus optisch fast perfekt (siehe Bilder im 
Anhang).

-) Der Knick verschiebt sich ebenfalls, wenn man die einzelnen 
Betriebsspannungen 0V-20V oder 20V-40V verschiebt.

-) Der Knick ist bei einer PWM-Frequenz von 200kHz bis 1MHz vorhanden. 
Eine kleinere oder größere PWM-Frequenz wurde noch nicht probiert. Die 
PWM-Frequenz nach der Halbbrücke ist bis ca. 600kHz kaum verzerrt und 
hat fast kein Überschwingen (siehe Bild im Anhang).

Anfangs dachte ich, dass das LC-Filter am Ausgang schuld ist. 
Mittlerweile habe ich aber eine geschirmte 22uH Leistungsspule aus einem 
kaputten Class-D Verstärker ausgebaut und 2x220nF (parallel) MKP 22.5mm 
RM Kondensatoren eingebaut. In vielen Verstärkern sieht man ein solches 
"Premiumfilter" nicht einmal und alles funktioniert. Der Knick hat sich 
nicht verbessert. Lediglich die Restwelligkeit hat sich durch bessere 
und parallel geschaltete Kondensatoren verbessert (vermutlich durch den 
kleineren ESR). Ist das LC-Filter schuld?

Ich habe mit den Gate-Widerständen/Dioden herumprobiert. Kein Erfolg.

Ich habe den RT Widerstand vom LM5104 auf 5k (kleinster R laut DB) 
verringert, um die Totzeit zu verringern. Kein Erfolg.
Ein 47k RT für eine größere Totzeit bringt auch nichts.

Ich habe in meiner Schaltung zwei Rückkopplungsmöglichkeiten. Die eine 
geht vor dem LC-Filter zurück, die andere schon vor dem LM5104. Bei 
beiden passiert der Knick. Lediglich mit der Rückkopplung vor dem 
LC-Filter wird der Knick etwas geringer.
Hier wäre noch eine Idee nach dem Spannungsteiler von R26/R27 eine 
Buffer-Schaltung mit einem OPV einzubauen. Was hält ihr davon?

Wenn ich nach dem Komparator (vor dem LM5104) ein RC-Filter anschließe, 
ist das Rauschen und der Sinus perfekt, auch unter Last. Deshalb sollte 
der ganze analoge Teil funktionieren. Mit Betonung auf "Sollte".

Ein interessantes Phänomen ist, dass der Class D Verstärker unter Last 
in "Speisebetrieb" geht. Dieser wird vermutlich durch das LC-Filter 
verursacht. Man könnte also die 30V Versorgung abhängen, da die Endstufe 
ins Netzteil zurückspeist und die OPVs so am Leben hält. Dieses Phänomen 
ist aber bei Class D Amps. nichts neues wegen des LC-Filters und die UA 
hat dort auch keinen Knick.
Ich habe aber trotzdem mal den Filter gegen GND gezogen, weil ich alle 
Fehlerquellen ausschließen möchte. Hier passiert aber trotzdem der 
Knick.
Könnte das trotzdem der Fehler sein? Wie kann ich den "Speisebetrieb" 
verringern?

Sollte irgendwann dieser Knick behoben sein, ist das letzte Problem das 
Rauschen, welches im Lautsprecher deutlich hörbar ist und auch schon 
störend wirkt.


Warum das Rauschen und der Knick so stark vorhanden sind, ist mir 
mittlerweile ein Rätsel. Ich habe MOSFETs extra für Class-D Anwendungen 
verbaut. Ich habe ziemlich teure OPVs und Komparatoren verbaut, welche 
als "Low-Noise" gekennzeichnet sind.

Vielleicht habe ich ja Glück und einer von euch hatte schon das selbe 
Problem und auch eine Lösung dafür. Ich wäre euch wirklich sehr dankbar, 
weil ich mit meinem ABC langsam am Ende bin.

Bevor jetzt wieder einer mit "Kauf doch einfach einen Class-D IC von TI" 
antwortet: Nein, werde ich nicht. Ich möchte das Prinzip verstanden 
haben und möchte sagen können, das ich ein solches Ding konkret 
aufgebaut habe. Weil das eine wirklich herausfordernde, aber auch 
interessante Sache ist.
Außerdem möchte ich, falls dieser Amp. doch noch funktionieren sollte, 
größere Leistungen anstreben.

Danke für eure Antworten!

Simi

Autor: Carsten Sch. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht nach übernahmeverzerrung aus.

Autor: Stephan C. (stephan_c)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das LC-Filter bei Class-D-Verstärkern ist passend zum Lastbereich 
ausgelegt.
Für Lautsprecher typische Bereiche (4-8 Ohm) wird oft eine Kombination 
aus 22uH und 470nF verwendet.
Bei der Spule solltest du eine wählen, die sehr viel Strom ab kann.
Dazu auch immer die Kennlinie im Datenblatt berücksichtigen, die die 
Induktivität über den Strom darstellt.
Gerade bei Class-D-Verstärkern können im Schaltmoment sehr schnell mal 
sehr hohe Ströme fließen und eine Spule in Sättigung kann nicht richtig 
filtern.

Beim Kondensator solltest du auf einen PPS-Folienkondensator setzen.

Hast du auch mal versucht die Rückkopplung hinter das LC-Filter zu 
packen?

Könnte es vielleicht noch was bringen, wenn du die 60V mit noch mehr 
Kapazität stützt?
Hast du es auch mal mit jeweils nur einen MOSFET im pull-up- und im 
pull-down-Pfad ausprobiert?
Obwohl beide vorherigen Vorschläge kann man ausschließen, wenn das 
Rechtsignal sauber ist.
Allerdings könntest du auch einen HEMT anstelle von 2 MOSFETs nehmen!

Wenn ich es mir nochmal genau überlege, dann würde ich sagen, dass es 
wahrscheinlich dein LC-Filter oder deine Rückkopplung ist.

Hast du parallel zu C18 mal einen Widerstand eingelötet?

Autor: Sven S. (schrecklicher_sven)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht hilft ein Kondensator im Rückkopplungszweig (zwecks 
entkoppeln des Gleichspannungsanteils).
Also vor R26.

: Bearbeitet durch User
Autor: Stephan C. (stephan_c)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es bestünde noch die Möglichkeit, mit der Rückkopplung an den Knoten 
zwischen R6 und R8 zu gehen.

Autor: Sven S. (schrecklicher_sven)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach du meinen Güte, jetzt habe ich es erst entdeckt, R14 hat ja 0Ohm, 
damit ist "FB" ja wirkungslos.

Autor: MDK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Ein interessantes Phänomen ist, dass der Class D Verstärker unter Last
> in "Speisebetrieb" geht.

Jitter!

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, man kann mit dem 0R Jumper einstellen, welche Rückkopplung wirken 
soll.
Entweder vor dem LM5104 oder vor dem LC-Filter.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stephan C. schrieb:
> Es bestünde noch die Möglichkeit, mit der Rückkopplung an den
> Knoten zwischen R6 und R8 zu gehen.

Dafür müsste ich aber das Signal nachdem LC-Filter nehmen und den 
DC-Anteil mit einem Kondensator entkoppeln oder?

Weil eine Rückkopplung vom PWM-Signal in das Audio-Signal scheint mir 
komisch.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Sch. schrieb:
> Sieht nach übernahmeverzerrung aus.

Ja, hab ich mir auch gedacht. Aber die müsste ja im Nulldurchgang sein 
oder? Und wieso ist sie Last und Betriebsspannung abhängig?

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stephan C. schrieb:
> Für Lautsprecher typische Bereiche (4-8 Ohm) wird oft eine Kombination
> aus 22uH und 470nF verwendet. Bei der Spule solltest du eine wählen, die
> sehr viel Strom ab kann.
> Dazu auch immer die Kennlinie im Datenblatt berücksichtigen, die die
> Induktivität über den Strom darstellt.
> Gerade bei Class-D-Verstärkern können im Schaltmoment sehr schnell mal
> sehr hohe Ströme fließen und eine Spule in Sättigung kann nicht richtig
> filtern.
>
> Beim Kondensator solltest du auf einen PPS-Folienkondensator setzen.

Ich habe folgendes LC-Filter:

Spule:
https://www.mouser.at/ProductDetail/Coilcraft/ED0006-AL?qs=%2Fha2pyFadujI%2FYTVjhuiCd6gq4kvXk%252BqlwpeEpX1YGfWjmXRnEmarA%3D%3D

2xKap. parallel:
https://www.conrad.at/de/p/wima-mkp1j032205f00kssd-1-st-mkp-folienkondensator-radial-bedrahtet-0-22-f-630-v-dc-20-22-5-mm-l-x-b-x-h-26-5-x-8-459844.html

Im Internet steht, dass Kondensatoren mit Polypropylenfolie auch 
geeignet sind. Das sind diese MKP. Sollte also passen oder?


Stephan C. schrieb:
> Hast du es auch mal mit jeweils nur einen MOSFET im pull-up- und im
> pull-down-Pfad ausprobiert?

Nein, noch nicht. Denke aber, dass die Halbbrücke funktioniert und nicht 
das Problem ist.

Stephan C. schrieb:
> Hast du parallel zu C18 mal einen Widerstand eingelötet?

Nein, auch nocht nicht. Was soll der bewirken? Welcher Wert? Soll der 
eine Grundverstärkung einstellen?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergaentze mal R27 mit einem Elko in Reihe.

Autor: MDK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Vielleicht habe ich ja Glück und einer von euch hatte schon das selbe
> Problem und auch eine Lösung dafür.

Jitterbug!

Autor: MDK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Dieser wird vermutlich durch das LC-Filter verursacht. Man könnte also
> die 30V Versorgung abhängen, da die Endstufe ins Netzteil zurückspeist
> und die OPVs so am Leben hält. Dieses Phänomen ist aber bei Class D
> Amps. nichts neues wegen des LC-Filters und die UA hat dort auch keinen
> Knick.
> Ich habe aber trotzdem mal den Filter gegen GND gezogen, weil ich alle
> Fehlerquellen ausschließen möchte. Hier passiert aber trotzdem der
> Knick.
> Könnte das trotzdem der Fehler sein? Wie kann ich den "Speisebetrieb"
> verringern?

Flutter.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter schrieb:
> Ergaentze mal R27 mit einem Elko in Reihe.

Werde ich mal probieren, danke!

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MDK schrieb:
> Jitter!

MDK schrieb:
> Jitterbug!

MDK schrieb:
> Flutter.

Danke!

Gibt es auch einen Lösungsvorschlag dafür?

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stephan C. schrieb:
> Gerade bei Class-D-Verstärkern können im Schaltmoment sehr schnell mal
> sehr hohe Ströme fließen und eine Spule in Sättigung kann nicht richtig
> filtern.

Hi Stephan,

magst du das bitte mal näher erläutern? Inwiefern kann im Schaltmoment 
sehr schnell mal ein sehr hoher Strom in den Ausgang (durch die Spule 
des Filters) fließen? Der Strom in einer Spule kann sich nicht 
schlagartig ändern, erst recht nicht während des Schaltmoments des 
MOSFETs. Der sehr hohe Strom kann, wenn überhaupt, durch den reverser 
recovery Strom der Body Diode den abschaltenden MOSFETs sein, aber 
diesen Strompeak sieht nur der zu schaltende MOSFETs und kommt nicht in 
den Ausgang.


Zum eigentlichen Thema:
Ich würde ebenfalls im ersten Schritt versuchen, das eigentliche 
Ausgangssignal (X2-1) anstatt das Signal (FB) in die Rückkopplung zu 
geben. Ein Class-D Verstärker ist nichts anderes als ein Buck-Typ 
Konverter zwei FETs. Du hast ein LC Ausgangsfilter und verwendest eine 
klassische Spannungsregelung (Voltage-Mode Control). Ergo kann deine 
(simple) Reglerstruktur nicht die Gewünschte Leistung erbringen. Ein 
Type-3 Regler ist für diese Art Konverter Voraussetzung, benötigt aber 
auch ein paar mehr Komponenten.
Siehe auch:
http://www.ti.com/lit/an/slva662/slva662.pdf

https://www.ti.com/seclit/ml/slup340/slup340.pdf

https://www.infineon.com/dgdl/an-1162.pdf?fileId=5546d462533600a40153559a8e17111a

Der letzte Artikel sollte gut auf dein Problem zutreffend sein.

Des weiteren sehe ich nicht, dass du einen DC Block Kondensator in den 
Feedbackzwei packen musst, weil dein GND ja eigentlich -30V sind und 
deine 30V dein GND? Oder weshalb ist deine Last (X2-2) an 30V verbunden?

Ich muss gestehen, ich bin ein wenig verwirrt mit deiner Bezeichnung. 
Sind deine 60V Versorgung galv. isoliert?

Ist es üblich, in Serie zum eigentlichen Filter Kondensator einen 4.3Ohm 
Widerstand zu packen? Normalerweise setzt man einen dedizierten RC 
Snubber parallel zum Filterkondensator.

Zum Debuggen:
Wie sieht dein Dreiecksgenerator unter Last aus? Hast du mal alle 3 Pins 
vom U6G$1 gemessen?

Spannendes Projekt! Viel Erfolg.

Gruß,

Autor: Sven S. (schrecklicher_sven)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Ja, man kann mit dem 0R Jumper einstellen, welche Rückkopplung wirken
> soll.

Dieser Schaltungsteil ist einfach Schrott.
Wenn R14 anwesend ist, wird das Gegenkopplungssignal vom 
Komparatorausgang verschluckt.
Ist R14 nicht da, hast Du genau das:

Simi schrieb:
> Weil eine Rückkopplung vom PWM-Signal in das Audio-Signal scheint mir
> komisch.

Erschwerend kommt hinzu, daß die Spannung an "FB" nicht symmetrisch ist, 
sondern entweder 0V oder +60V.

Sechs, setzen.

Autor: Stephan C. (stephan_c)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wegen der Spule ist es schwer zu sagen. Die Kennlinie sieht ok aus, Irms 
ist aber recht niedrig.
Wird die Spule sehr heiß?
Die Kondensatoren müssten gehen.

Wegen C18, war es ein Denkfehler meinerseits.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Simi schrieb:
> Ja, man kann mit dem 0R Jumper einstellen, welche Rückkopplung wirken
> soll.
>
> Dieser Schaltungsteil ist einfach Schrott.
> Wenn R14 anwesend ist, wird das Gegenkopplungssignal vom
> Komparatorausgang verschluckt.
> Ist R14 nicht da, hast Du genau das:


Man hat ja nur die eine Gegenkopplung vor dem LC-Filter (R14 offen und 
R18 0R) oder die Gegenkopplung vor dem LM5104 (R14 0R und R18 offen). 
Beides geht nicht! Das ist mir klar.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stephan C. schrieb:
> Wegen der Spule ist es schwer zu sagen. Die Kennlinie sieht ok aus, Irms
> ist aber recht niedrig.
> Wird die Spule sehr heiß?

Nein, die Spule wird gar nicht heiß.

Autor: Stephan C. (stephan_c)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK.

Du könntest das Ausgangssignal auf das Eingangssignal aufsummieren.
Wenn du aber DC-mäßig zurückkoppelst, dann müsstest du deine OPs um +30V 
herum versorgen, weil der Ruhepegel am Ausgang +30V beträgt.

@Al3ko:

du hast natürlich recht, es fließt ein dreiecksförmiger Strom.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Ein Type-3 Regler ist für diese Art Konverter Voraussetzung, benötigt
> aber auch ein paar mehr Komponenten.
> Siehe auch:

Danke für die Links! Sieht vielversprechend aus.

Die neue Rückkopplung probiere ich dann am MO aus.




Al3ko -. schrieb:
> Ist es üblich, in Serie zum eigentlichen Filter Kondensator einen 4.3Ohm
> Widerstand zu packen? Normalerweise setzt man einen dedizierten RC
> Snubber parallel zum Filterkondensator.

Das Snubber Filter ist doch parallel zum LC-Filter-Kondensator? 4.3R und 
10uF sind für den Snubber. Die 2x 220nF sind für den LC-Filter.


Al3ko -. schrieb:
> Oder weshalb ist deine Last (X2-2) an 30V verbunden?
>
> Ich muss gestehen, ich bin ein wenig verwirrt mit deiner Bezeichnung.
> Sind deine 60V Versorgung galv. isoliert?

Die 30V habe ich, damit bei der Last kein DC-Offset ist und ich keinen 
großen Entkoppelkondensator brauche. Würde ich die Last auf GND ziehen, 
hätte ich 20V DC-Offset.

Was meinst mit galv. isoliert? Ich habe einfach zwei Netzteilquellen. 
Nichts ist galv. isoliert oder so.

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Was meinst mit galv. isoliert?

Meiner Erfahrung nach hat man ein galvanisch getrenntes Netzteil (oder 
zwei in Serie), so dass der Mittelpunkt (bei dir +30V) auf GND gelegt 
wird, und das in deinem Schaltplan entsprechende GND dann auf -30V 
liegt. Somit schaltest du entsprechend mit +-30V um dein gelegtes GND. 
Alle Kleinsignal Elektronik wird auf den Mittelpunkt GND (bei dir +30V) 
gelegt.

Wie gesagt, geht das nur, wenn deine Netzteile galvanisch isoliert sind.

Gruß,

: Bearbeitet durch User
Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Simi schrieb:
> Was meinst mit galv. isoliert?
>
> Meiner Erfahrung nach hat man ein galvanisch getrenntes Netzteil (oder
> zwei in Serie), so dass der Mittelpunkt (bei dir +30V) auf GND gelegt
> wird, und das in deinem Schaltplan entsprechende GND dann auf -30V
> liegt. Somit schaltest du entsprechend mit +-30V um dein gelegtes GND.
> Alle Kleinsignal Elektronik wird auf den Mittelpunkt GND (bei dir +30V)
> gelegt.
>
> Wie gesagt, geht das nur, wenn deine Netzteile galvanisch isoliert sind.
>
> Gruß,

Ja, so ist es bei mir eh der Fall. Nur halt nicht -30V-0V-30V sondern 
0V-30V-60. Aber das ist ja dann egal, wie man es schaltet.

Bei meiner AB-Endstufe (siehe hier: 
Beitrag "Veröffentlichung Class AB-Endstufe")
habe ich die andere Variante genommen.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat jemand noch Tips, wie ich das Rauschen verringern kann?

Autor: Forist (Gast)
Datum:
Angehängte Dateien:

Bewertung
1 lesenswert
nicht lesenswert
Simi schrieb:
> Class_D_Amplifier_with_OPV-PWM_Circuit.pdf

Warum muss man sämtliche Leute, die sich den Schaltplan ansehen wollten, 
erstmal damit verschrecken, dass das Ding verdreht daher kommt.

Wenn du hier Hilfe habe möchtest, könntest du dir gerne die Mühe machen, 
den Schaltplan vernünftig ausgerichtet hochzuladen :-(

Autor: Sven S. (schrecklicher_sven)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Simi schrieb:
> Tips, wie ich das Rauschen verringern kann?

Mit einer neuen Schaltung.

Autor: Sorgenfalten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> bei mir eh der Fall. Nur halt nicht -30V-0V-30V sondern
> 0V-30V-60. Aber das ist ja dann egal, wie man es schaltet.

Bist Du Dir da sicher? 0V-30V-60V bezeichnet nicht das gleiche.

GND eines Netzteil mit 60VDC verbunden mit GND eines 30VDC NTs
ergibt zwar GND-30V-60V, aber nicht(!) -30V-0V-30V.

Stromrichtung beachten.

Eine Halbbrücke (auch eine doppelt aufgebaute) braucht exakt
-V, GND, +V. Nur eine Vollbrücke bräuchte das nicht - dafür
reichte eine einzelne Rail (und daraus entsteht der doppelte
Spannungshub, durch das "Umpolvermögen" der Vollbrücke).

Und GND-Bezug beachten.

Wie genau ist Deine Versorgung nun aufgebaut? Beschreibe das
mal ganz ausführlich, nicht in (evtl. nur vermeintlich auch
wirklich zutreffender) Kurzform.

Autor: Peter D. (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würd mal sagen, die Speicherdrossel sättigt.

Ich hatte auch grad für einen Schaltregler eine falsche Drossel 
genommen, der hat dann schon weit vor dem gewünschten Strom 
abgeschaltet.
Die Drossel vom Eval-Board hats dann gebracht. Das ist ne Vishay 
IHLP5050FDER2R2M01 (22A/5MHz), der Schaltregler läuft mit 500kHz und 
soll 6A liefern.
Die falsche Drossel war nur für 10A und ohne Angabe der maximalen 
Arbeitsfrequenz. Bei 4A erfolgte die Überstromabschaltung. Schön heiß 
wurde sie auch.
Drosseln also besser reichlich dimensionieren.

: Bearbeitet durch User
Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter D. schrieb:
> Ich würd mal sagen, die Speicherdrossel sättigt.
>
> Ich hatte auch grad für einen Schaltregler eine falsche Drossel
> genommen, der hat dann schon weit vor dem gewünschten Strom
> abgeschaltet.
> Die Drossel vom Eval-Board hats dann gebracht. Das ist ne Vishay
> IHLP5050FDER2R2M01 (22A/5MHz), der Schaltregler läuft mit 500kHz und
> soll 6A liefern.
> Die falsche Drossel war nur für 10A und ohne Angabe der maximalen
> Arbeitsfrequenz. Bei 4A erfolgte die Überstromabschaltung. Schön heiß
> wurde sie auch.
> Drosseln also besser reichlich dimensionieren.

Meine Spule hat einen saturation current von 36A und max. DC current von 
7.2A und wird auch nicht heiß.

Sollte also passen oder?

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Simi schrieb:
> Tips, wie ich das Rauschen verringern kann?
>
> Mit einer neuen Schaltung.

Deine Anmerkungen in diesem Forum sind immer sehr hilfreich...

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorgenfalten schrieb:
> Wie genau ist Deine Versorgung nun aufgebaut? Beschreibe das
> mal ganz ausführlich, nicht in (evtl. nur vermeintlich auch
> wirklich zutreffender) Kurzform.

Ok, gerne!

Ich habe folgendes Netzteil:
https://www.komerci.de/shop/stromversorgung/qj3005eiii-labornetzgeraet-3-fach-2x30v-5a-regelbar-5v-3a-fest

Die zwei regelbaren 30V Quellen schalte ich mit dem Netzteilmodus 
"Series" intern in serie.

Bei der ersten 30V Quelle (Links) nehme ich "-" für GND und "+" für 30V. 
Bei der zweiten 30V Quelle (Rechts) nehme ich "+" für 60V.

Autor: Peter D. (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Meine Spule hat einen saturation current von 36A und max. DC current von
> 7.2A und wird auch nicht heiß.

Bei 60V und typischen Boxen von 4R komme ich auf 15A, da sind 7.2A weit 
jenseits von gut und böse. Der Arbeitsstrom ist wichtig, den 
Sättigungsstrom kannst Du in der Pfeife rauchen.
Und welche maximale Frequenz habe Deine Drosseln? Für 1MHz würde ich 
wenigstens 2MHz empfehlen.

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter D. schrieb:
> Ich würd mal sagen, die Speicherdrossel sättigt.

Wenn die Speicherdrossel sättigen würde, würde der Strom ansteigen, weil 
die Induktivität sinkt. Da eine Ohmsche Last angeschlossen ist, würde 
das ebenfalls bedeuten, dass die gemessene Spannung ansteigen würde.
u_L(t) = 1/L*(di_L(t)/dt)
Die beigefügten Bilder bestätigen dies aber nicht, weil die gemessene 
Spannung nicht zunimmt. Das erkennt man, wenn man sich die Steigung der 
Spannung anguckt.

Insofern würde ich eine gesättigte Drossel im ersten Moment 
ausschließen.

Ggf. könnte man sich mal die Rails-Spannung (60V in Bezug zu GND und 30V 
in Bezug zu GND) anschauen, ob die Zusammenbricht.

Ich tippe aber immer noch auf die Regelung.

Gruß,

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter D. schrieb:
> Und welche maximale Frequenz habe Deine Drosseln? Für 1MHz würde ich
> wenigstens 2MHz empfehlen.

Hier der Link zur Spule:
https://www.mouser.at/ProductDetail/Coilcraft/ED0006-AL?qs=%2Fha2pyFadujI%2FYTVjhuiCd6gq4kvXk%252BqlwpeEpX1YGfWjmXRnEmarA%3D%3D


Ich habe genau den selben starken Knick auch bei einer 0V-15V-30V 
Versorgung. Sollte der nicht weniger werden, wenn es wirklich von der 
Spule abhängt?

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Ich tippe aber immer noch auf die Regelung.

Du würdest das Signal nach dem LC-Filter abgreifen, DC-Entkoppeln, mit 
einem variablen Spannungsteiler kleiner machen und zwischen R6 und R8 
einkoppeln oder?

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Du würdest das Signal nach dem LC-Filter abgreifen, DC-Entkoppeln, mit
> einem variablen Spannungsteiler kleiner machen und zwischen R6 und R8
> einkoppeln oder?
Zwischen R6 und R8 koppelst du nichts ein. Du rückst einfach deinen 0Ohm 
Jumper an den Ausgang. Die Einkopplung geschieht nach wie vor in den 
Error Amplifier, wie man es von einer gewöhnlichen Regelung gewohnt ist.

Du has deine Schaltungspotentiale im Prinzip sehr ungünstig gewählt, 
weil sich deine Last (und damit die zu regelnde Größe) auf 30V bezieht, 
wohingegen deine ganze Kleinsignalelektronik auf GND bezogen ist. Du 
vergleichst in deiner Regelung ein wenig Äpfel mit Birnen.

Eleganter ist es, wenn deine Elektronik ebenfalls auf 30V bezogen ist.

Ich weiß unmittelbar nicht, ob und inwiefern eine DC Entkopplung im FB 
Pfad Einfluss auf deine Regelung hat, was die Lage der Pol- und 
Nullstellen angeht. Einfach mal versuchen.

Gruß,

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Eleganter ist es, wenn deine Elektronik ebenfalls auf 30V bezogen ist.

Oder die Halbbrücke mit 30V und -30V versorgen oder? Dann habe ich auch 
GND als Bezugspotential.

Werde testweise das LC-Filter und die Last auf GND ziehen. Muss ich halt 
mit einem Elko entkoppeln. Dann habe ich auch GND als Bezugspunkt.

Dann noch deine vorgeschlagene Rückkopplung.

Bin schon aufs Ergebnis gespannt. Ich präsentiere am MO die Resultate. 
Danke mal!

@Al3ko: Wie würdest du das Rauschen minimieren?

Autor: Sven S. (schrecklicher_sven)
Datum:

Bewertung
-1 lesenswert
nicht lesenswert
Simi schrieb:
> Deine Anmerkungen in diesem Forum sind immer sehr hilfreich...

Ich nehme einmal an, daß Du meine "Anmerkungen" einfach nicht verstehst.
Aber wie soll ich es denn erklären??

Simi schrieb:
> oder die Gegenkopplung vor dem LM5104 (R14 0R und R18 offen).

Meinst Du etwa "HS"?
Wenn Du diesen Anschluss am LM5104 mit einer Gegenkopplung verwechselst, 
kann ich Dir eigentlich nichts erklären.

Alle Anderen hier haben leider auch nicht viel Ahnung. Die 
Stromversorgung und die Speicherdrossel sind schon in Ordnung, der 
Leistungsteil Deiner Schaltung auch.
Der Wechsel der Bezugsleitung von 0Volt nach +30Volt ist total daneben.
Die Schaltung, die die PWM erzeugen soll, funktioniert so nicht, fertig.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Die Schaltung, die die PWM erzeugen soll, funktioniert so nicht, fertig

Die PWM-Erzeugung funktioniert doch super?
Außerdem wurde so eine ähnliche Schaltung von TI getestet und sogar ein 
Modul gebaut.

Sven S. schrieb:
> Meinst Du etwa "HS"?
> Wenn Du diesen Anschluss am LM5104 mit einer Gegenkopplung verwechselst,
> kann ich Dir eigentlich nichts erklären.

Mach ich nicht! Ich habe als Testzweck zwei Möglichkeiten zur 
Rückkopplung.

Eine vor dem LM5104: PWM Ausgang vom Komparator wird rückgekoppelt. 
Dafür musst du aber R18 offen lassen und nur R14 einbauen.

Als zweite Variante kann man das PWM-Signal nach der Halbbrücke über 
einen Spannungsteiler rückkoppeln. Dafür musst du aber R14 offen lassen 
und nur R18 einbauen!

Autor: mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Hast du das Dreiecksignal schon mal ohne und mit Last dir mit dem Oszi 
angeschaut? Wenn durch den von dir beschrieben Speisetrieb der Dreieck 
beeinflusst wird "verzerrt" sich inhaltlich das PWM Signal

lg
Mike

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven S. schrieb:
> Alle Anderen hier haben leider auch nicht viel Ahnung.
Das ist völlig unnötig und trägt zur Lösung des Problemes nichts bei. 
Bitte sachlich bleiben.

Sven S. schrieb:
> Der Wechsel der Bezugsleitung von 0Volt nach +30Volt ist total daneben.
Du meinst +30V, GND (0V) und -30V sind total daneben? Das sehe ich 
anders. Das zurückgeführte Signal ist auf 30V bezogen, die Elektronik 
und das Referenzsignal auf GND.

Simi schrieb:
> Al3ko -. schrieb:
>> Eleganter ist es, wenn deine Elektronik ebenfalls auf 30V bezogen ist.
>
> Oder die Halbbrücke mit 30V und -30V versorgen oder? Dann habe ich auch
> GND als Bezugspotential.

Das ist in meinen Augen das gleiche, wenn du deine jetzigen 30V als 
Bezugspotential verwendest, und dann die Spannung von GND nach 30V 
misst. Die Ausgänge deines Netzteils sind voneinander galvanisch 
getrennt, ergo kannst du dein Bezugspotential frei definieren. Und das 
setzt man üblicherweise an den Mittelpunkt, an dem du im Schaltplan 
jetzt 30V stehen hast.

Simi schrieb:
> @Al3ko: Wie würdest du das Rauschen minimieren?
Ich bin mir nicht sicher, ob unsere Definitionen von Rauschen 
übereinstimmen.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mike schrieb:
> Hi,
>
> Hast du das Dreiecksignal schon mal ohne und mit Last dir mit dem Oszi
> angeschaut? Wenn durch den von dir beschrieben Speisetrieb der Dreieck
> beeinflusst wird "verzerrt" sich inhaltlich das PWM Signal
>
> lg
> Mike

Ich bin mir nichtmehr ganz sicher. Ich glaube aber, dass das 
Dreiecksignal in Ordnung ist.

Weil wenn ich die Rückkopplung vor dem LM5104 verwende und das 
PWM-Signal am Komparatorausgang RC filtere, verändert sich der Sinus 
nicht, egal ob Last oder nicht.

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Das ist in meinen Augen das gleiche, wenn du deine jetzigen 30V als
> Bezugspotential verwendest

Naja, wenn ich -30V-GND-30V vom Netzteil ziehe, ist GND in der Mitte und 
ich kann die Halbbrücke mit 30V und -30V versorgen.
Also sollte das dann mit dem Bezugspotential der PWM-Elektronik passen.

Al3ko -. schrieb:
> Ich bin mir nicht sicher, ob unsere Definitionen von Rauschen
> übereinstimmen.

Wie würdest du das Rauschen definieren?
Ich will das Rauschen im Lautsprecher minimieren. Mit den RC-Gliedern 
parallel zu den MOSFETs habe ich das Rauschen im Lautsprecher bisschen 
verringert.

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Naja, wenn ich -30V-GND-30V vom Netzteil ziehe, ist GND in der Mitte und
> ich kann die Halbbrücke mit 30V und -30V versorgen.
> Also sollte das dann mit dem Bezugspotential der PWM-Elektronik passen.

Jap, oder du setzt die Referenz deiner PWM Elektronik auf 30V. Da deine 
Netzteile galv. isoliert sind, sind 60V, 30V und GND lediglich Namen in 
deinem Schaltplan.

Der Kern meiner Aussage und das Ergebnis ist somit gleich: Setz die 
Referenz deiner PWM-Elektronik an den Mittelpunkt deiner 
Spannungsversorgung. Wie du das nennst, ist elektrisch gesehen völlig 
egal.

Oder muss ich ernsthaft eine Skizze machen, um zu zeigen, dass es auf 
dasselbe hinaus läuft? :D

Wenn du mit Rauschen den hochfrequenten Rippel meinst (der gleich deiner 
Schaltfequenz ist), kannst du ihn lediglich verringern, indem du 
entweder die PWM Frequenz erhöhst, und/oder dein LC Filter vergrößerst.

Gruß,

Autor: Simi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Al3ko -. schrieb:
> Oder muss ich ernsthaft eine Skizze machen, um zu zeigen, dass es auf
> dasselbe hinaus läuft? :D

Nein, nein. Ich verstehe völlig was du meinst. Danke! Werde ich auch 
probieren.
Dafür muss ich halt den LM5104 auf -30V (nichtmehr GND) ziehen, wenn ich 
die Halbbrücke mit +-30V betreibe.

Al3ko -. schrieb:
> Wenn du mit Rauschen den hochfrequenten Rippel meinst (der gleich deiner
> Schaltfequenz ist), kannst du ihn lediglich verringern, indem du
> entweder die PWM Frequenz erhöhst, und/oder dein LC Filter vergrößerst.

Nein, das ist mir egal. Da kenne ich Endstufen, die 1 bis 2Vpp 
Restwelligkeit der PWM haben. Das hört man im Lautsprecher sowieso nicht 
mehr.
Ich möchte das hörbare Rauschen im Lautsprecher verringern.

Autor: Al3ko -. (al3ko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simi schrieb:
> Dafür muss ich halt den LM5104 auf -30V (nichtmehr GND) ziehen, wenn ich
> die Halbbrücke mit +-30V betreibe.

Ganz genau - und die Versorgung vom LM5104 muss ebenfalls auf -30V 
bezogen werden.

Zum Thema Rauschen kann ich nicht viel aus der Ferne helfen, weil 
Rauschen aus zig verschiedenen Ecken kommen kann. Ändere erstmal deine 
Schaltung entsprechend der Vorschläge, die hier gemacht wurden. Übers 
Rauschen kann man sich dann immer noch unterhalten, wenn es überhaupt 
noch vorhanden ist.

Gruß,

Beitrag #5973029 wurde von einem Moderator gelöscht.
Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normalerweise bezieht sich alles gegenueber der Mitte, dh U/2 als 
virtuelle Masse. Bei Dir ist das aber -30V, bzw. 0V. Bei Umrichter fuer 
Motoren ist so ein Knick, bzw. offset hub,  belanglos.
Zum Vergleich schau Dir auch die Mittelspannung,  30V, 0-30-60, genauer 
an. Damit es besser zu sehen ist, paralell U/2 ueber Widerstaende und 
Glaettung mit Elkos aufbauen und die Differenz dazu messen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.