Forum: HF, Funk und Felder SAW-Sender: Frequenzeinstellung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Hansi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe zwei Handsender, von denen der eine nach einer Reparatur 
(Beitrag "Reparatur Handsender") zuverlässig funktioniert. 
Der zweite sendet auf einer falschen Frequenz.

Da irgendwann auch der zweite Sender funktioniert hat, möchte ich ihn 
nun reparieren, d.h. die korrekte Sendefrequenz einstellen.

Die Frequenz prüfe ich mit einem Funkscanner. Der funktionierende Sender 
ist bei 433,925 MHz gut zu hören. Der zweite nicht funktionierende wurde 
bei 433,85 MHz gefunden.

Damit man sich ein Bild der Schaltung machen kann, habe ich den 
Schaltplan gezeichnet.

In der Hoffnung, dass der SAW-Resonator des zweiten Senders ein Problem 
hat, wurde der des ersten ausgelötet und im zweiten eingebaut. Die 
Frequenz ändert sich dadurch nicht. Es muss also etwas anderes sein.

Mir ist leider nicht klar, welche Bauteile sonst für die Sendefrequenz 
verantwortlich sind und wie ich die korrekten Bauteilwerte bestimmen 
kann, um die gewünschte Frequenz zu erhalten.

Vielleicht kennt hier jemand diese Art von Sender und kann mit den einen 
oder andern Tip geben.

Vielen Dank und Grüße
Hansi

von Ralph B. (rberres)


Bewertung
0 lesenswert
nicht lesenswert
SAW-Filter verhalten sich ähnlich wie Quarze.

In diesen Fall wird die Serienresonanzfrequenz  die Frequenz bestimmen.

Vielleicht ist der Kondensator C1 defekt.

Ralph Berres

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke. Hmm, wie kann ich das prüfen? Die Kondensatoren haben ja keine 
Werte aufgedruckt, so dass ich sie ersetzen könnte...

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Kondensator mit dem roten Fragezeichen als "Nummer" rechts an der 
Drossel (1R0) ist abgleichbar und bringt den gesamten 
1-Transistor-Oszillator auf die gewünschte Frequenz.
Der herausgezeichnete Plan stimmt so wohl nicht ganz. Ich bin mir 
eigentlich sicher, dass die Drossel direkt an den Kollektor des 
Transistors geht, sonst hätte der gar keine Betriebsspannung.

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Löten kannst Du wohl, hast ja schon die SAWs getauscht.
Löte mal parallel zum abgleichbaren C zwei
vielleicht 5cm lange Drahtstücke (isoliert) und verdrille die 
miteinander. Sie bilden dann einen "Drahtkondensator", dann prüfst Du 
mit dem Scanner, ob die Sendefrequenz damit einstellbar wird, durch mehr 
oder weniger Verdrillen oder Kürzen der Drähte.

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke, werde ich machen und berichten.

Das Bauteil mit dem "?" ist ein ???
Mit dem Durchgangsprüfer messe ich da ca. 0,5 Ohm und das bei beiden 
Sendern, dem funktionierenden und dem mit falscher Frequenz.

Den Schaltplan prüfe ich und berichtige geg.falls.

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Der Schaltplan stimmt an dieser Stelle, habe es nochmal mit der Lupe und 
dem Durchgrangsprüfer angeschaut:
Von der Batterie geht es über die Drossel (1R0) und das ominöse Bauteil 
mit dem Strich weiter über einen 10 Ohm Widerstand zum Kollektor.
Wie geschrieben, hat das Bauteil mit dem Strich keinen nennenswerten 
Widerstand.

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die Antenne bildet hier die Schwingkreisspule und der liegt das ominöse 
Bauteil womöglich direkt parallel. Das würde die 0,5 Ohm im eingelöteten 
Zustand erklären und die Abstimmung auf die "richtige" 
Resonanz=Sendefrequenz ermöglichen. Trenne doch mal die Antenne auf 
(reparabel) und miss erneut.

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Oder löte das ? aus und miss erneut.

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für die Erklärung. Das werde ich machen, aber erst morgen.
Jetzt ist Familienzeit dran.
Ist übrigens ein schöner Teilnehmername: Bin nämlich schon fast am 
verzweifeln mit diesem Ding...

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Musste das jetzt doch noch wissen:

Habe beide ?-Bauteile ausgelötet und messe daran in beide Richtungen 
einen ohmschen Widerstand von ca. 0,4 Ohm.

Wenn das Bauteil fehlt, besteht keine Verbindung mehr zwischen der 
Versorgungsspannung und dem Kollektor.

Hilft diese Info weiter?

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ja, bitte mal vorsichtig den Transistor auslöten, ich hätte gerne das 
Layout unter dem gesehen.

von Ralph B. (rberres)


Bewertung
0 lesenswert
nicht lesenswert
Nichtverzweifelter schrieb:
> Die Antenne bildet hier die Schwingkreisspule und der liegt das ominöse
> Bauteil womöglich direkt parallel. Das würde die 0,5 Ohm im eingelöteten
> Zustand erklären und die Abstimmung auf die "richtige"
> Resonanz=Sendefrequenz ermöglichen. Trenne doch mal die Antenne auf
> (reparabel) und miss erneut.

Ich glaube kaum das die Antenne die Frequenz des Senders bestimmen soll.

Dazu ist sie als Schwingkreis 1. zu breitbandig und 2. nicht 
frequenzstabil genug. Das frequenzbestimmende Element für den Sender ist 
das SAW.

Woher dieses doch sehr merkwürdiges Verhalten kommt kann ich allerdings 
nicht sagen.

Betreibe den Sender doch mal ohne SAW, und messe ob und auf welcher 
Frequenz er schwingt.

Ralph Berres

: Bearbeitet durch User
von Hansi (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das Bauteil mit dem "?" ist also eine Induktivität 
(Beitrag "Welches Bauteil ist das?"). Das habe ich im 
Schaltplan so eingetragen.
Das Bauteil mit dem Aufdruck 1R0 ist wahrscheinlich auch eine 
Induktivität.

Die Versorgung ist auf dem Foto eingezeichnet. Der Transistor wurde dazu 
aber nicht ausgelötet. Stattdessen wurde mit Lupe und Durchgangsprüfer 
die Verbindung verfolgt. Insbesondere geht die Leiterbahn unter dem 
Transistor nicht an dessen Anschlüsse.

Ich hatte ja gehofft, dass ich irgendwo einen kleinen Trimmkondensator 
einlöten kann, um damit die Frequenz abzugleichen.

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hahaaa, ich auch... ein Trimmer und hinziehen, das "darfst " Du 
natürlich trotzdem probieren.

Ja, "natürlich" sollte nur der SAW frequenzbestimmend sein, ist er aber 
nicht. So wie gezeichnet gäbe es keinerlei hochfrequente Anregung für 
den Filter, überhaupt zu schwingen.
Irgendwas an dem Plan stimmt einfach noch nicht (ehrlich: Bauchgefühl!).
Es müsste wenigstens aus dem Emitterkreis eine Rückkopplung auf den SAW 
geben.

von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Gut, dann muss ich den Schaltplan nochmal komplett prüfen.
Melde mich dann wieder.

von Ralph B. (rberres)


Bewertung
0 lesenswert
nicht lesenswert
Nichtverzweifelter schrieb:
> Es müsste wenigstens aus dem Emitterkreis eine Rückkopplung auf den SAW
> geben.

Die Rückkopplung erfolgt zwischen Collektor und Emitter.

Schwingen wird die Schaltung auf der Serienresonanz des SAWs. Dieser 
liegt vom Basis nach Masse. Das heist nur bei der Serienresonanz ist die 
Basis HF-mäßig auf Masse, sonst liegt sie hoch und die 
Rückkopplungsbedingung ist mangels Verstärkung nicht erfüllt. Der 
Schwingkreis am Kollektor kann wenn überhaupt die Frequenz nur ganz 
geringfügig verstimmen, auf Grund der Phasenverschiebung die er bewirkt. 
Aber keineswegs um 125KHz wie beim TO.

Der durch die Antenne gebildete Schwingkreis hat übrigens eine sehr 
geringe Güte und ist entsprechend breitbandig. Bei einer hohen Güte der 
Antenne , würde der Sender nur schwingen, wenn die Antenne exakt in 
Resonanz wäre.

Vielleicht ist der Kondensator in Reihe zum SAW defekt. ( Haarriss? ) 
Wenn er zu klein ist, könnte der den SAW eventuell etwas verstimmen.

Dem spricht allerdings die zu niedrige Frequenz des defekten Senders 
entgegen.

Ralph Berres

: Bearbeitet durch User
von Hansi (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Erklärung. Aber ehrlich gesagt, verstehe ich davon 
nicht viel. HF ist für mich immer Magie...

Den Kondensator muss ich mal prüfen, evtl. tauschen.

Eines ist mir eben noch aufgefallen:
Wenn ich die Antenne bei C5 berühre (auf dem Foto oben), sinkt die 
Frequenz etwas, so um 400 kHz. Das ganze ist aber nicht sehr gut 
reproduzierbar.

von Ralph B. (rberres)


Bewertung
0 lesenswert
nicht lesenswert
Hansi schrieb:
> enn ich die Antenne bei C5 berühre (auf dem Foto oben), sinkt die
> Frequenz etwas, so um 400 kHz. Das ganze ist aber nicht sehr gut
> reproduzierbar.

Das würde für mich bedeuten das der SAW einen Kurzschluss hat.

Ralph Berres

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Die SAWs hat er aber mal gegengetauscht, Fehler wandert nicht mit!

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hansi, Du hast doch den zweiten Handsender komplett nachgelötet, einfach 
Lötstelle für Lötstelle abgearbeitet, mit sofortigem vollen Erfolg. Er 
tut wieder, wie er soll.
Hast Du das bei diesem hier auch schon gemacht?
Nur mal so um "Dreckeffekte" auszuschliessen?
Wär ja schnell gemacht...

von Ralph B. (rberres)


Bewertung
0 lesenswert
nicht lesenswert
Nichtverzweifelter schrieb:
> Die SAWs hat er aber mal gegengetauscht, Fehler wandert nicht mit!

Der Kurzschluss kann ja auf der Platine sein.

Ralph Berres

von Nichtverzweifelter (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Eigentlich kommt nur noch C1 in Frage, den SAW derart zu verstimmen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.