Forum: Analoge Elektronik und Schaltungstechnik TP 4056 Solarregler


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von HitmanNL (Gast)


Lesenswert?

hallo zusammen
habe ein problem mit dem solarregler tp4056. Ich betreibe eine 
Wetterstation mit einem esp8266 der ueber eine 3,7V 18650 strom bekommt 
was auch funktioniert nu moechte ich das ganze ueber usb laden und hab 
da eine kleine platine gebaut auf der die anschluesse auf klemmen 
gefuehrt sind ich habe an den klemmen der batterie 3,7v am Ausgang zum 
ESP 8266 auch 3,7V und am eingang wo die solarzelle fran ist zwischen 
3,2V und 4,1V was gut ist leider zeigt der Laderegler nicht an ob die 
batterie voll ist oder geladen wird hab von den + der solarzelle eine in 
Flussrichtung geschaltete Diode 1N4007 drinne aber er zeigt nicht an 
also weis ich nicht was passiert was kann ich da tun.

Gebaut nach dieser Anleitung:
https://www.instructables.com/Solar-Powered-WiFi-Weather-Station/

: Verschoben durch Moderator
von Lothar M. (Firma: Titel) (lkmiller) (Moderator) Benutzerseite


Lesenswert?

HitmanNL schrieb:
> was kann ich da tun.
1. Füge Satzzeichen an sinnvollen Positionen in deinen Text ein.
2. Zeichne einen Schaltplan von deinem Aufbau.
3. Poste ein Foto von deinem Aufbau.
4. Beschreibe das Problem und stelle eine definierte Frage.

: Bearbeitet durch Moderator
von HitmanNL (Gast)


Angehängte Dateien:

Lesenswert?

Ok ich beschreibe alles.

Also ich habe einen Wemos D1 Mini pro der als Wetterstation arbeitet.
Der Wemos D1 Mini Pro wird über einen Akku 18650 3,7V mit Strom versorgt 
was auch funktioniert. Jetzt habe ich einen TP4056 Laderegler an den 
eine Solarzelle angeschlossen ist. An den Solarregler TP4056 ist auch 
der Akku und der Wemos D1 Mini pro angeschlossen. Was ich damit 
erreichen möchte ist, das die Solarzelle den Akku wieder aufladen soll 
und sich der Wemos D1 Mini Pro an bei dem Akku bedient. Der Laderegler 
TP4056 hat auch einen USB Anschluss ueber den ich den Akku auch aufladen 
kann was mir mit einer gruenen und roten LED angezeigt wird
(rot = Laden) (gruen = Voll). Hab ich alle Komponenten Angeschlossen, 
habe ich am Wemos D1 Mini Pro 4,1V und am Akku 4,1V. Die Solarzelle 
liefert auch Spannung zwischen 2,0V ubnd 4,1V (je nach 
Lichtverhaeltniss) Die zwei LED's die anzeigen ob dder Akku geladen wird 
oder voll ist zeigen keinen zustand an. Desweiteren ist eine Sperr-Diode 
1N4007 in der + Leitung von der Solarzelle verbaut um Rueckspannung zu 
vermeiden. An der diode ist ein faellt eine Spannung von 0,5V ab (bitte 
berichtigen falls ich nicht richtig liege).|
Leider kann ich so nicht feststellen ob der Akku geladen wird oder 
nicht.

Das ganze habe ich nach einer Anleitung gebaut siehe Link
https://www.instructables.com/Solar-Powered-WiFi-Weather-Station/

von HitmanNL (Gast)


Lesenswert?

Anhang hab ich vielleicht die Diode Falsch herum eingebaut.
Gruss HitmanNL

von Helge (Gast)


Lesenswert?

Eine 5,5V Solarzelle, der du 0,6V (Diode Flußspannung) klaust, liefert 
weniger als 5V bei voller Sonne. Wirf die Diode raus, der TP4056 schützt 
den Akku.
Die LED zur Ladeanzeige leuchtet nur, wenn genug Strom fließt. Das wird 
deine Solarzelle nicht schaffen.

von hinz (Gast)


Lesenswert?

Helge schrieb:
> Die LED zur Ladeanzeige leuchtet nur, wenn genug Strom fließt. Das wird
> deine Solarzelle nicht schaffen.

ACK, die erreicht nur unter allerbesten Lichtverhältnissen (klarer 
Sommertag, optimal ausgerichtet) die 150mA.

von HitmanNL (Gast)


Lesenswert?

ok Das war auch nur fuer den Sommer gedacht mit der Solarzelle der 
ESP8266 Arbeitet im Deep Sleep Modus das heist er wird alle 15 min wach 
sendet seine 3 werte per Mqtt an Raspberry pi und geht wieder schlafen 
und wird erst nach 15 min fuer kurze Zeit wach

Danke fuer die Antwort :-) baue ich gleich mal um

Gruss hitman

von Andreas B. (bitverdreher)


Lesenswert?

Und die 3.7V des Akkus könnte auch zu wenig für den 5V Eingang des Wemos 
sein. Es kommt jetzt darauf an, welcher Spannungsregler da verbaut ist.
Und das ganze USB Ladegerümpel würde ich sowieso rauswerfen. Das braucht 
zu viel Strom.
Kann man z.B. so machen:
Beitrag "Re: ESP8266 mit Solarstrom und Pufferbatterie"
Kannst Dir den Thread mal durchlesen. Da ist viel informatives dabei.

von HitmanNL (Gast)


Lesenswert?

Nein das klappt gut denn der Wemos kann zwischen 3,3V und 5V alles 
vertragen hatte den auch mit 3x AA 1,5V in betrieb das sind dann aich 
4,5V

Siehe hier:
https://robotfreak.de/elab-wiki/index.php?title=WeMos_D1_Mini#Stromversorgung

von Andreas B. (bitverdreher)


Lesenswert?

HitmanNL schrieb:
> Nein das klappt gut
Stimmt, der im Schaltplan angegebene RT9013 hat einen sehr niedrigen 
Dropout.

von HitmanNL (Gast)


Angehängte Dateien:

Lesenswert?

Hab die Diode Wie Helge sagt Rausgeworfen die LED zum laden geht an aber 
nur wenn ich das SolarPanal  direkt unter die Lampe halte denn das muss 
ja auch alles ins Gehaeuse passen

von Helge (Gast)


Lesenswert?

Die LED ist ja nur Gimmick. Geladen wird trotzdem, zumindest wenn die 
Solarspannung > Akkuspannung + ca.0,3V ist.

von Bernd L. (Gast)


Lesenswert?

Späte Antwort, aber ich habe prinzipiell den gleichen Aufbau.

Das Solarpanel (optisch gleich zu dem was der TE verbaut hat, 6V, 150mA) 
liefert auch bei indirektem Licht schon genug Strom, das die Lade-LED am 
TP4056 leuchtet, auch wenn da dann nichtmehr wirklich viel Strom 
rauskommt. Die Diode reduziert das ein klein wenig, verhindert aber 
nicht, das der Akku geladen wird.
Ich messe die Akkuspannung am Wemos am A0 mit (mit Spannungsteiler) und 
die Solarzelle hält den Akku bisher auch bei 3,8 bis 3,9V.

Wenn die Diode (bei mir ebenfalls 1N4007) falschrum eingebaut wird, 
fließt da natürlich kein Strom mehr. So wie im Schaltplan eingezeichnet 
sollte aber richtig rum sein (der silberne Ring an einem Ende von der 
Solarzelle wegzeigend). Im Zweifel mit einem Multimeter einfach mal die 
Richtung der Diode messen.
Vorher hatte ich eine andere Diode verbaut die 1V Drop hatte, aber auch 
damit hat der Akku geladen, nur halt eben im Grenzbereich schon früher 
abgeschaltet.

Die Diode soll ja afaik nur verhindern, das bei Dunkelheit die 
Solarzelle den Akku entlädt. Da das überall empfohlen wird, gehe ich mal 
davon aus, das es mehr bringt den Verlust durch die Diode hinzunehmen.

Ich benutze eine TP4056 Schaltung ohne Tiefentladeschutz. Eine Variante 
mit Tiefentladeschutz habe ich auch ausprobiert, allerdings zog mir da 
der Tiefentladeschutz permanent 12mA aus dem Akku. Viel zu viel für 
sinnvollen Akkubetrieb.

Ist das hier auch der Fall? Welche Platine ist das genau?

Der D1 läuft bei mir übrigens über den 5V-Pin bis der Akku auf ca. 3V 
runter ist. Also er läuft sogar noch mit weniger als 3,3V.
Wenn man den 3,3V Anschluss benutzt (natürlich mit entsprechender 
Stromquelle, z.B. LiFePo4 Akku mit 3,2V) und damit den Spannungsregler 
am 5V-Anschluss umgeht, soll er sogar mit nur 2,8V noch laufen.

Beitrag #6789342 wurde von einem Moderator gelöscht.
Beitrag #6789344 wurde von einem Moderator gelöscht.
von Stefan F. (Gast)


Lesenswert?

Ham kei Hirn! schrieb im Beitrag #6789344:
> Und noch eine Bemerkung zum Tiefentladeschutz: Den hat der TP4056
> INTEGRIERT!!

Nein, definitiv nicht.

Deswegen gibt es Platinen (wie die oben abgebildete), wo neben dem 
TP4056 ein zweiter IC sitzt.

Ham kei Hirn! schrieb im Beitrag #6789344:
> Kann nicht endlich mal jemand dss Knternet vom Markt wegschalten??
> Wir zahlen für solche Bullschitplatformen keinen Cent!

Keiner zwingt dich dazu mit zu machen. Im übrigen bezahlst du für 
Mikrocontroller.net wirklich nichts.

von Wolfgang (Gast)


Lesenswert?

Ham kei Hirn! schrieb im Beitrag #6789344:
> Und noch eine Bemerkung zum Tiefentladeschutz: Den hat der TP4056
> INTEGRIERT!!

Dann erklär mal, wie das funktionieren soll.
Der TP4056 ist ein Laderegler, der die Aufladung des Akkus steuert. Der 
Entladestrom fließt vom Akku direkt zum Verbraucher, d.h. den kann der 
TP4056 gar nicht kontrollieren.

von MaWin (Gast)


Lesenswert?

Wolfgang schrieb:
> Dann erklär mal, wie das funktionieren soll

Wie soll er, ohne Hirn.
Er hat bisher das Dümmste geschrieben, was in diesem thread zu lesen 
war.
Der allerdings schon in der Überschrift vom TP4056 als Solarladeregler 
spricht, obwohl der TP4056 kein Solarladeregler ist, also schon dumm 
begonnen hat.
Wie gut, dass die meisten LiIon Akkus mit Schutzschaltung ausgeliefert 
werden, sonst hätten viele der gnadenlos dummen Bastler schon ihre Bude 
abgefackelt.

von Wolfgang (Gast)


Lesenswert?

hinz schrieb:
> ACK, die erreicht nur unter allerbesten Lichtverhältnissen (klarer
> Sommertag, optimal ausgerichtet) die 150mA.

Wo auch immer du die 150mA her hast - die Datenblattangaben werden nicht 
bei "allerbesten Lichtverhältnissen ..." sondern normalerweise für 
standardisierten Testbedinungen (STC Einstrahlung 1000W/m², 
Sonnenspektrum, 25°C, senkrechter Lichteinfall) angegeben. Bei der 
Angabe zum Strom ist außerdem zu unterscheiden, ob es sich um den 
Kurzschlussstrom oder den Strom am MPP handelt.

Beitrag #6799771 wurde von einem Moderator gelöscht.
Beitrag #6800750 wurde von einem Moderator gelöscht.
Beitrag #6800757 wurde von einem Moderator gelöscht.
von AbRauch (Gast)


Lesenswert?

Typisch Fake -》
https://320volt.com/en/li-po-li-ion-battery-charge-mcp73831-tp4056-circuits/

Weil das, was da gezeigt wird, NIEMALS funktioniert, sondern SOFORT die 
Chips ABRAUCHEN!!

Man darf NIEMALS diese Module am OUTPUT PIN 5 (Akku-Plus!!) PARRALEL 
schalten!! WER SOLCHEN UNFUG POSTET, um sich wichtig zu machen, dem 
gehört eine Tracht Prügel!! SOVIEL BLÖDSINN, was der da postet, tut 
einfach nur weh!!! Was für ein Pfosten!!!!!!!

Das ist echt grausam sowas!! Voll die Verblödung und Verarsche!! Aber 
scheinbar hat der schon einen Schlag weg, der Typ, der sowas online 
stellt. Wäre ja kein Wunder, bei so vielen weiterrn Pfosten im Internet!

von AbRauch (Gast)


Angehängte Dateien:

Lesenswert?

noch so ein Internerfake: siehe Foto

von Domian (Gast)


Lesenswert?

AbRauch schrieb:
> Typisch Fake -》
> https://320volt.com/en/li-po-li-ion-battery-charge-mcp73831-tp4056-circuits/
>
> Weil das, was da gezeigt wird, NIEMALS funktioniert, sondern SOFORT die
> Chips ABRAUCHEN!!
>
> Man darf NIEMALS diese Module am OUTPUT PIN 5 (Akku-Plus!!) PARRALEL
> schalten!! WER SOLCHEN UNFUG POSTET, um sich wichtig zu machen, dem
> gehört eine Tracht Prügel!! SOVIEL BLÖDSINN, was der da postet, tut
> einfach nur weh!!! Was für ein Pfosten!!!!!!!
>
> Das ist echt grausam sowas!! Voll die Verblödung und Verarsche!! Aber
> scheinbar hat der schon einen Schlag weg, der Typ, der sowas online
> stellt. Wäre ja kein Wunder, bei so vielen weiterrn Pfosten im Internet!

An Deinem Beitrag fällt mir negativ auf:

1. Du schreist mit Großbuchstaben.
2. Du benutzt Ausrufungszeichen im Überfluss.
3. Du verwendest eine beleidigende Sprache.
4. Deine Argumentation" ist nicht technisch sachbezogen.
...

von MaWin (Gast)


Lesenswert?

Domian schrieb:
> An Deinem Beitrag fällt mir negativ auf:

So ist die Welt heute.

Hauptsache die Form stimmt, keine Rechtschreibfehler, everything 
politically correct.

Die Fakten interessieren in der Ära der fake news keinen mehr, 
Wahrheiten werden möglichst unterdrückt.

Also steck dir deinen dummen Beitrag sonstwohin.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.