Forum: PC Hard- und Software Netzteilspannungen innerhalb der Toleranzen aber trotzdem kein Power-Good-Signal


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Andrej (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe ein Problem mit meinem PC-Netzteil. Es handelt sich dabei um 
ein Be Quiet TFX2B-300W.
Ich habe alle Ausgangsspannungen mit einem Multimeter gemessen und sie 
sind alle innerhalb der Toleranzen (die 3,3V- und 5V-Leitungen sind 
leicht höher und die 12V-Leitung leicht unter dem Nominalwert). Trotzdem 
liegt an der Power-Good-Leitung nur 0,01 V an.
Woran könnte das liegen?

Vielen Dank im Voraus!
Andrej

von N. M. (mani)


Bewertung
0 lesenswert
nicht lesenswert
Evtl Open Collector Signal?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
N. M. schrieb:
> Evtl Open Collector Signal?

So isses. Wie heisst denn der Controller IC im Netzteil?

von Andrej (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Rückmeldungen.

N. M. schrieb:
> Evtl Open Collector Signal?

Matthias S. schrieb:
> Wie heisst denn der Controller IC im Netzteil?

Sorry, aber ich bin nicht vom Fach. Könntet ihr nochmal beschreiben was 
ihr genau meint?

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Das PowerGood Signal muss extern mit einem Widerstand gegen +5V (oder 
3,3V) hochgezogen werden, damit es wahr werden kann.

Im Netzteil sitzt nämlich ein Transistor, dessen Kollektor an die PG 
Leitung angeschlossen ist. Der Arbeitwiderstand für diesen Transistor 
wird extern hinzugefügt.
Schalte also an die PG Leitung einen z.B. 1kOhm - 4,7kOhm Widerstand 
gegen die +5V Leitung, dann kannst du daran messen, ob PG wahr wird.

von Andrej (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Matthias,
zum Hintergrund meiner Frage: Mit dem oben genannten Be-Quiet-Netzteil 
fährt mein Rechner nicht hoch und beim Messen ist mir als einziges das 
Power-Good-Signal aufgefallen, dass eine deutlich zu geringe Spannung 
aufweist.

Ich habe gerade mal an einem zweiten Netzteil gemessen, mit dem mein 
Rechner problemlos startet. Dort liegen an der Power-Good-Leitung 5,2V 
an. Deshalb gehe ich eigentlich davon aus, dass auch beim 
Be-Quiet-Netzteil eine Spannung um die 5V an der Power-Good-Leitung 
anliegen sollte.

von Andreas S. (Firma: Schweigstill IT) (schweigstill) Benutzerseite


Bewertung
0 lesenswert
nicht lesenswert
Dann ist offenbar das Netzteil doch defekt. Für jemanden ohne tiefe 
Elektronikkenntnisse wäre es lebensgefährlich, an einem PC-Netzteil 
herumzubasteln. Die Bauteile sind so dicht gedrängt, dass ein Laie ggf. 
nur schwer einschätzen kann, was zur Primär- und Sekundärseite gehört. 
Auch die in den primärseitigen Elkos gespeicherte Energie kann 
lebensgefährlich sein.

Und selbst wenn es Dir gelingen sollte, die Bastelei zu überleben, wäre 
damit der Fehler noch nicht gefunden. Offenbar scheitert es ja schon 
daran, den entsprechenden Controller zu identifizieren.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Diese BeQuiet Netzteile gehen anscheinend öfter mal kaputt - oder das 
ist eine Filterblase, weil sie oft verkauft werden.

Es ist klar, das man bei den Preisen für PC-Netzteile von einem 
Reparaturversuch Abstand nehmen sollte - höchstens, sofern vorhanden, 
die Gewährleistung in Anspruch nehmen.

von michael_ (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Andrej schrieb:
> Dort liegen an der Power-Good-Leitung 5,2V
> an. Deshalb gehe ich eigentlich davon aus, dass auch beim
> Be-Quiet-Netzteil eine Spannung um die 5V an der Power-Good-Leitung
> anliegen sollte.

Und was sagt die 9, violett Standby?
Die 8 grau Power-Good ist ein Eingang.

Andrej schrieb:
> Ich habe alle Ausgangsspannungen mit einem Multimeter gemessen und sie
> sind alle innerhalb der Toleranzen (die 3,3V- und 5V-Leitungen sind
> leicht höher und die 12V-Leitung leicht unter dem Nominalwert). Trotzdem
> liegt an der Power-Good-Leitung nur 0,01 V an.
> Woran könnte das liegen?

Wenn du die anderen Spannungen messen kannst, ist es richtig, wenn 
Power-Good auf Masse liegt.
Hast du im eingebauten Zustand gemessen?

von Andrej (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Andreas S. schrieb:
> Dann ist offenbar das Netzteil doch defekt. Für jemanden ohne tiefe
> Elektronikkenntnisse wäre es lebensgefährlich, an einem PC-Netzteil
> herumzubasteln. Die Bauteile sind so dicht gedrängt, dass ein Laie ggf.
> nur schwer einschätzen kann, was zur Primär- und Sekundärseite gehört.
> Auch die in den primärseitigen Elkos gespeicherte Energie kann
> lebensgefährlich sein.

Da bin ich schon vorsichtig. Einen defekten Elko austauschen, das hätte 
ich mir schon zugetraut. Aber die sehen alle noch gut aus. Und wie 
gesagt, die Spannungen sind auch alle in Ordnung, bis auf das 
Power-Good-Signal eben.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-2 lesenswert
nicht lesenswert
300W lohnt sich sowieso nicht zu reparieren. Allein das Aufschrauben 
kostet mehr Zeit als der Schrott wert ist.

Und nein, das ist keine Filterblase, bequiet-Netzteile hatte ich mehr 
als jede andere Marke auf dem Basteltisch, weil irgendwas da drin den 
Arsch hochgerissen hat. Vieles ging auf das Konto schlechter Elkos, aber 
die PFC-Stufe und das Standby-Netzteil sind auch eine wahre BWL-Freude.

Übrigens müssen die Netzteil die PG-Leitung selbst auf 3,3 oder 5V 
anheben. Wenn die bei 0V bleibt, stimmt etwas nicht. Da muß man sich 
jetzt das Datenblatt des Housekeeping-IC raussuchen und alles 
kontrollieren was der so kontrolliert. Da gibts sooo viele verschiedene 
Wege, auf denen diese ICs das Netzteil überwachen, da muß man wirklich 
spezifiziert rangehen. Bei einigen ICs muß das Netzteil mit allen 
Spannungen in einer bestimmten Zeit im Soll sein oder es darf keine 
Überschwinger geben etc... da hat man dann viel Spaß beim Suchen.

von Andrej (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
Die 9 ist bei 5V. Ich habe alle Spannungen mit ausgebautem Netzteil 
gemessen und das Einschaltsignal mit einem Kabel überbrückt, damit das 
Netzteil startet.
Beim zweiten Mal messen, hab ich eine 35W-Halogenglühbirne an die 
12V-CPU-Versorgung geklemmt. Das lieferte sehr ähnliche Spannungswerte.

von michael_ (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Andrej schrieb:
> Ich habe alle Spannungen mit ausgebautem Netzteil
> gemessen und das Einschaltsignal mit einem Kabel überbrückt, damit das
> Netzteil startet.

Wenn du das gebrückt hast, dann muß es doch 0 sein.
Oder meinst du irgendwas anderes?

von Andrej (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Ok danke, Ben. Wenn also kein Elko offensichtlich defekt aussieht, ist 
es wohl zu mühsam den tatsächlichen Fehler zu finden.
Dann bringt das Rumbasteln auch nichts mehr.. schade!

von Andrej (Gast)


Bewertung
-1 lesenswert
nicht lesenswert
michael_ schrieb:
> Wenn du das gebrückt hast, dann muß es doch 0 sein.
> Oder meinst du irgendwas anderes?

Ich meinte, dass ich PS_ON mit Masse verbunden habe, um das Netzteil im 
ausgebauten Zustand einzuschalten.
An Power_Good habe ich nichts überbrückt, sondern nur gemessen.

von michael_ (Gast)


Bewertung
-5 lesenswert
nicht lesenswert
Hab ich jetzt verwechselt.
Aber es hat mich in den ganzen Jahren auch nicht interessiert.
War nie eine Fehlerquelle.

von michael_ (Gast)


Angehängte Dateien:

Bewertung
-2 lesenswert
nicht lesenswert
So schlimm kann eine Fehlersuche nicht sein.
Hier such dir deine Variante heraus.

http://www.danyk.cz/s_atx_en.html

Im obigen .PDF sind auch paar Varianten.
Leider kenn ich die Quelle nicht mehr.

Beim LM339, LM393, usw. suchen.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
Das ist heute alles in einem Chip, externe Komparatoren sind so gut wie 
ausgestorben.
Die z.B. WT7514/7515 Chips sind häufig verbaut.

von 2aggressive (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Andrej schrieb:
> Dann bringt das Rumbasteln auch nichts mehr.. schade!
Wenn es wirklich schade um das NT wäre würden sicherlich mehr als genug 
Helferlein hier einspringen.

In diesen Fall: man muss auch mal etwas aufgeben können. Wäre Schade um 
die benötigte Zeit, und irgendein Risiko ist in diesem Fall nichts Wert. 
Wirklich Schade wäre es wenn ein später dranhängender Rechner gefraggt 
werden würde.

On Top: Tragisch wäre es, wenn dem Reperateur (=Andrej) ein Schaden 
zugefügt werden würde.

Meine Meinung: Mach das Teil unbrauchbar (DEFEKT-Markierung oder 
komplettes Widlarizing) oder zerlege und nutze es als Teilespender.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
-2 lesenswert
nicht lesenswert
Naja, dummen Elko tauschen kann jeder, der einen Lötkolben halbwegs 
gerade halten kann. Nur notorische Grobmotoriker können's trotzdem nicht 
weil die dabei die Platine demolieren.

Die Probleme fangen an wenn es eben nicht an sowas einfachem liegt. Dann 
braucht man jemanden, der sich damit auskennt (sonst gibts bis zu 420Vdc 
auf die Finger) und die nötige Messtechnik (Oszi und Trenntrafo).

Ich hab etliche PC-Netzteile mit höherer Leistung repariert, aber was 
zahlt man für ein gebrauchtes 300W-Netzteil eines mittelmäßigen 
Herstellers... Ist auch nur ein Bronze, mit komischer Bauform... Lohnt 
sich nicht bzw. wäre ein rein sportliches Vergnügen.

Mach doch mal ein Foto von der Platine, vor allem von den ICs auf der 
Niederspannungsseite.

von Joachim B. (jar)


Bewertung
1 lesenswert
nicht lesenswert
Ben B. schrieb:
> Naja, dummen Elko tauschen kann jeder, der einen Lötkolben halbwegs
> gerade halten kann

nur hilft das nicht immer auch wenn es Standardfehler sind, der Aufwand 
Teilebeschaffung und Kosten steht oft nicht dem Erfolg oder Nutzwert 
gegenüber, bzw. selbst wenn die Reparatur erfolgreich war kann die 
Restnutzungsdauer kurz sein weil das Netzteil(oder Gerät) einen anderen 
Fehler bekommt oder weil es nicht mehr nutzbar ist wegen anderer 
Umstände z.B. Umstieg auf andere PC -> Laptop, NUC, Tablett.

Wenn ich bedenke was ich für den Elkotausch eines alten Löwe TV mit CRT 
ausgegeben hatte. Schaltbild beschaffen kostenpflichtig, Elkos 
beschaffen, im Dreck alles tauschen für eine alte Röhrenglotze die kurz 
danach eh durch LCD ersetzt wurde. Da darf man mal hinterfragen ob sich 
das lohnt.

von Baku M. (baku)


Bewertung
0 lesenswert
nicht lesenswert
[OT]
2aggressive schrieb:
> Meine Meinung: Mach das Teil unbrauchbar (DEFEKT-Markierung oder
> komplettes Widlarizing) oder zerlege und nutze es als Teilespender.

Schön, daß man immer noch was lernen kann. Den Begriff "Widlarizing" 
kannte ich noch garnicht, obwohl ich diese Methode seit Jahrzehnten 
gerne praktiziere, insbesondere mit Festplatten mit Daten drauf.

Besten Dank!
sagt Baku

Zum Thema: Ein PC-Netzteil zu reparieren lohnt sich wohl nur dann, wenn 
man es 'der Sache selbst wegen' macht, also aus technischem Ehrgeiz oder 
zum angenehmen Zeitvertreib. Dazu sind allerdings gute Fachkenntnise von 
Nöten, ansonsten es zu gefährlich ist.

von Andrej (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ben B. schrieb:
> Mach doch mal ein Foto von der Platine, vor allem von den ICs auf der
> Niederspannungsseite.

Hier kommen ein paar Bilder..

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
-1 lesenswert
nicht lesenswert
Ahh, Sonderlocke mit abgeschliffenem Controller, diese Idioten. Wenn du 
ein Oszilloskop hast, könntest du mal die Welligkeit der 
Ausgangsspannungen messen, es könnte sein, das einer der Elkos 
aufgegeben hat und die Welligkeit so ansteigen lässt, das der Controller 
es nicht 'Good' findet.

Aber alle Hinweise oben gelten nach wie vor - gerade der gedrängte 
Aufbau macht es schwer, primär und sekundär zu trennen und damit die 
Sicherheit des Benutzers zu gewährleisten.
Ohne Oszi und Trenntrafo tust du am besten nichts, ausser das Netzteil 
durch ein neues zu ersetzen.

von michael_ (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Ja schwierig.
Und sehe ich da recht an dem Chip, wo die gn und gr Drähte hinführen, 
dass da zwei Einstellwiderstände sind?
Vielleicht hat da nur jemand "die Schrauben festdrehen" wollen.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Angehängte Dateien:

Bewertung
-3 lesenswert
nicht lesenswert
An den Einstellwiderständen nicht einfach so rumdrehen, das ist idR 
nicht zielführend.

Kannst Du lesen was das für ein IC ist? Auf dem Foto leider gar nichts 
zu erkennen. Ich hab mal markiert was meiner Meinung nach primär (not 
good) und sekundär ist - aus rechtlichen Gründen aber ohne Gewähr, muß 
jeder selber wissen was er tut wenn er sowas aufschraubt.

von michael_ (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Andrej schrieb:
> Hallo Matthias,
> zum Hintergrund meiner Frage: Mit dem oben genannten Be-Quiet-Netzteil
> fährt mein Rechner nicht hoch und beim Messen ist mir als einziges das
> Power-Good-Signal aufgefallen, dass eine deutlich zu geringe Spannung
> aufweist.

Ist es eigentlich das Original-NT?
Und ging es plötzlich nicht mehr.

Oder von einer Resterampe und du willst es nur testen.

von Andrej (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Wenn du ein Oszilloskop hast, könntest du mal die Welligkeit der
> Ausgangsspannungen messen, es könnte sein, das einer der Elkos
> aufgegeben hat und die Welligkeit so ansteigen lässt, das der Controller
> es nicht 'Good' findet.

Ein Oszilloskop habe ich leider nicht.

Ben B. schrieb:
> Kannst Du lesen was das für ein IC ist?

Sehr schwierig zu sehen was da drauf steht und erst recht zu 
fotografieren. Ich hab's aber mal probiert..

michael_ schrieb:
> Ist es eigentlich das Original-NT?
> Und ging es plötzlich nicht mehr.
> Oder von einer Resterampe und du willst es nur testen.

Ich hatte das NT über EBay Kleinanzeigen gekauft. Als sich 
herausgestellt hat, dass es nicht mehr funktioniert, hat mir der 
Verkäufer das Geld wieder zurück überwiesen. Jetzt wollte ich einfach 
mal spaßeshalber dran rumbasteln und gucken ob da vielleicht doch noch 
was geht. Aber ich denke das kann ich vergessen.

Vielen Dank euch allen für eure Hilfe!

von mkn (Gast)


Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Im obigen .PDF sind auch paar Varianten.

Schaltbilder aus den 80ern werden bei einem aktuellen 80 Plus Platinum 
Netzteil eher nicht weiterhelfen.

Neues Netzteil kaufen.

von Ben B. (Firma: Funkenflug Industries) (stromkraft)


Bewertung
0 lesenswert
nicht lesenswert
Naja dann: https://datasheetspdf.com/pdf-file/623995/Weltrend/WT7527/1

Los gehts - wenn Du es Dir zutraust. Mich würde vor allem die Spannung 
an Pin 3 interessieren, muß man nachsehen ob da ein PullUp-Widerstand 
verbaut wurde oder nicht. Wenn das Netzteil den Pin nicht nutzt, wird 
der wegrationalisiert sein und dann müsste man ihn hinzufügen um da ein 
brauchbares Signal zu bekommen. Multimeter reicht zum Messen aus.

von michael_ (Gast)


Bewertung
-2 lesenswert
nicht lesenswert
Pin-3, das ist doch nur die LED.

Nachsehen, ob die Trimmpot was mit diesen IC zu tun haben.
Vielleicht sind die nur verantwortlich.

Und bei PGO die Diode und die zwei R überprüfen.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
-1 lesenswert
nicht lesenswert
Ist also wirklich ein WT75XX wie oben vermutet. Es gilt nach wie vor - 
nichts tun, Netzteil abhaken und ersetzen. Ohne Oszi, Trenntrafo und 
Kenntnisse keine Experimente mit PC-Netzteilen versuchen.

von michael_ (Gast)


Bewertung
-4 lesenswert
nicht lesenswert
Matthias S. schrieb:
> Ist also wirklich ein WT75XX wie oben vermutet.

Was hast du wo und wann vermutet?
Solche Leute wie dich habe ich am liebsten.
Die schon am Anfang wissen, wie es nicht geht.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Bewertung
0 lesenswert
nicht lesenswert
michael_ schrieb:
> Was hast du wo und wann vermutet?

Nach deiner falschen Vermutung von wegen LM339 usw:

michael_ schrieb:
> Beim LM339, LM393, usw. suchen.

Matthias S. schrieb:
> Das ist heute alles in einem Chip, externe Komparatoren sind so gut wie
> ausgestorben.
> Die z.B. WT7514/7515 Chips sind häufig verbaut.

Also lesen und nicht pöbeln. Das geht auch im Internet.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.