Forum: Analoge Elektronik und Schaltungstechnik Batterieladegerät mit LM317


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Ralf W. (tubefreak)



Lesenswert?

Hallo,

nachdem mein Roller Winterschlaf gehalten hat und die Batterie wohl 
nicht mehr sooo frisch ist wollte ich Sie Laden.
Habe im Internet ein Video und eine Schaltung entdeckt die das REGELN 
sollte. Die Frage ist kann das so Funktionieren?

Ich weiß, es gibt jede menge andere Schaltungen mit L200 und PB137 usw 
die das besser können, hab ich aber nicht in meiner Bastelkiste.

Es gibt ein Video dazu, welches wegen meiner geringen Englisch Kentnisse 
für mich nicht sehr hilfreich ist. Habe nur entdeckt das es sich wie im 
Schaltplan vorgegeben wohl eher nicht um einen BD139 handeln dürfte 
sondern um einen Kleinsignaltransistor: 
https://www.youtube.com/watch?v=RAZiNM-HzEo

Kann mir jemand die Schaltung erklären? insbesondere wie die grüne LED 
erlöschen soll?

von HildeK (Gast)


Lesenswert?

Ralf W. schrieb:
> insbesondere wie die grüne LED erlöschen soll?
Die wird nicht erlöschen solange das Ladegerät versorgt wird.
'Charging' ist die falsche Bezeichnung, das ist einfach nur eine 
Anzeige, dass die Schaltung über den Trafo versorgt wird.

So lange die Batteriespannung (bzw. die Spannung vor R5) weniger als 
Uz+U_Led+0.7V hat, wird geladen, R5 begrenzt aber den Ladestrom 
deutlich. Wird diese Spannung erreicht, so wird über Q1 die 
Ausgangsspannung des LM317 begrenzt.
Und richtig: Q1 muss kein BD139 sein, auch die Z-Diode ist mit 1W 
überdimensioniert, genau so wie R2 mit 0.5W, der verheizt höchsten 
einstellige mW.

von tnzs (Gast)


Lesenswert?

Es gibt einen ST PB317 genau für den Zweck...

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Die Schaltung ist nicht so optimal. Die soll sicherstellen, das der Akku 
geladen wird, sobald der Akku unter 12,0...11,7V fällt und hört an 
dieser Schwelle auch wieder auf. Volladen also Fehlanzeige.

Wird der Akku durch die Lichtmaschine geladen, liegen dort 13...14V an. 
Q1 wird dann leitend und am Ausgang von U2 liegen rund nur noch 1,4V an 
und das ist für die grüne LED zu wenig.

von Ralf W. (tubefreak)


Lesenswert?

HildeK schrieb:
> Ralf W. schrieb:
>> insbesondere wie die grüne LED erlöschen soll?
> Die wird nicht erlöschen solange das Ladegerät versorgt wird.
Bitte mal Video anschauen, dort geht die LED eindeutig aus....kann aber 
auch sein das es ein Fake Vieo ist.....

von MaWin (Gast)


Lesenswert?

Ralf W. schrieb:
> Habe im Internet ein Video und eine Schaltung entdeckt

Oje, 100 Ohm als strombegrenzender Widerstand in Reihe und eine extrem 
ungenaue und nicht justierbare Z-Diode als Spannungsgrenze.

Vergiss die Schaltung.

Wenn du einen 2 x 1A Netztrafo hast, ist dein erstes Problem eine 
Strombegrenzung auf unter 1.2A= damit der Trafo nicht überhitzt.

Wenn du einen 15V~ Trafo hast, darf dich die Strombegrenzung nicht mehr 
als ( 0.9x15x1.4-1 = 18  ) - 13.8 = 4.2V kosten, Ripple durch Siebelko 
ignorieren wir mal weil es eine Maximalbegenzung sein darf.

Hier sind mehrere Schaltungen mit LM317 und TL431 oder auch mal nur 
Transistoren die das können 
https://dse-faq.elektronik-kompendium.de/dse-faq.htm#F.21.2

Interessant ist halt eine Schaltung die auch bei Netzstromausfall den 
Akku nicht entlädt. Notfalls in dem ein Relais den Akku sbklemmt.

von Helge (Gast)


Lesenswert?

Die Umschaltung rot-grün wird nie ganz funktionieren. Sobald der 
Ladestrom wegen der Steuerung des 317 geringer wird, fällt die 
Akkuspannung ab.

Zweiter Mangel: Z-Dioden leiten auch etwas unterhalb der Z-Spannung 
etwas. Das abschalten läßt sich nicht einstellen und dürfte stark 
temperaturabhängig sein.

von Ralf W. (tubefreak)


Lesenswert?

tnzs schrieb:
> Es gibt einen ST PB317 genau für den Zweck...

Wie meinen? es gibt einen UMC / LM oder wie immer sein Vorname sein mag 
317 oder meintest du den PB 137 den ich oben schon zusammen mit dem L200 
erwähnt habe, aber nicht in meiner Bastelkiste vorrätig habe. Und nein 
ich werde bestimmt nicht für 4€ einen regler bestellen und dann nochmal 
5€ porto bezahlen + mindermengenzuschlag......

von Erich (Gast)


Lesenswert?

Ralf W. schrieb:
> aber nicht in meiner Bastelkiste vorrätig habe.

Dann baue es doch wie du willst,
mit deinem Grusch,
und frage nicht mehr.

von Ratgeber (Gast)


Lesenswert?

Wenn die Akkuspannung über 11,6 Volt angestiegemn ist (Z-Diode+Ube des 
Transistors) beginnt der zu leiten, schaltet die rote LED und zieht den 
Sapnnungsteiler am LM317 runter, so daß die Ladespannung abgeschaltet 
wird.
daraufhin geht die grüne LED aus, weil sie nun weder über den LM317 noch 
aus dem Akku gespeist werden kann, denn dazwischen sitzt ja die Diode.

HTH

von Ratgeber (Gast)


Lesenswert?

Korrektur: Abschaltspannung ist die Z-Spannung+Ube+die Flußspannung dere 
roten LED

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Was gibt Deine Bastelkiste denn her?

Trafos, Netzteile, sonstige Spannungsregler, ZD, LED, Dioden, 
Transistoren, ...

Mit Letzteren lässt sich immer etwas sehr Einfaches bauen.
LED, Dioden, od. ggf. ZD , Transistoren,

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Dieter D. schrieb:
> Q1 wird dann leitend und am Ausgang von U2 liegen rund nur noch 1,4V an
> und das ist für die grüne LED zu wenig.

Korrektur, es sind bei dieser Schaltung 2,8...3.0V. Mit dem 
Vorwiderstand von 2.2k leuchtet die LED dann nur noch sehr schwach im 
Vergleich zu 12V.

In der originalen Schaltung sind aber die LED in Reihe zu den 
Widerständen R2, bzw. R3. Und da sind es dann die beschriebenen rund 
1,4V.

von HildeK (Gast)


Lesenswert?

Ralf W. schrieb:
> Es gibt ein Video dazu, welches wegen meiner geringen Englisch Kentnisse
> für mich nicht sehr hilfreich ist.

Das hat nichts mit schlechten Englischkenntnissen zu tun: scheint eine 
Inderin zu sein, da tut man sich immer schwer ....

Dem Gehäuse nach wurde für Q1 auch kein BD139 verwendet, BC547 schätze 
ich mal ...

Ich habe das Video inzwischen angeschaut. Das mit der grünen LED kann 
nicht sein - in der Schaltung ...

Ratgeber schrieb:
> Wenn die Akkuspannung über 11,6 Volt angestiegemn ist (Z-Diode+Ube des
> Transistors) beginnt der zu leiten, schaltet die rote LED und zieht den
> Sapnnungsteiler am LM317 runter, so daß die Ladespannung abgeschaltet
> wird.
> daraufhin geht die grüne LED aus, weil sie nun weder über den LM317 noch
> aus dem Akku gespeist werden kann, denn dazwischen sitzt ja die Diode.
Nein, tut sie nicht. Die geht erst aus, wenn man den Trafo abschaltet. 
Und die 11.6V stimmen auch nicht: 1.8V (LED) + 11V (Z-Diode) + 0.6V 
(UBE) = 13.4V - solange die Z-Diode auch 11V bei dem kleinen Strom hat.
Und auch die rote LED geht erst aus, wenn die Akkuspannung größer ist 
als die vom Längsregler (minus U_D5) - und woher soll das kommen?

von Udo S. (urschmitt)


Lesenswert?

Ralf W. schrieb:
> nachdem mein Roller Winterschlaf gehalten hat und die Batterie wohl
> nicht mehr sooo frisch ist wollte ich Sie Laden.

Wahrscheinlich zu spät.
Akku ist sulfatiert und zumindest dauerhaft geschädigt.

Vor dem nächsten Winter (neuen) Akku ausbauen und an ein kleines 
Erhaltungsladungsgerät anschliessen. Das könnte auch mit einer 
Solarzelle versorgt werden.

von Ralph S. (jjflash)


Lesenswert?

grundsätzlich würde ich sagen, dass die Schaltung ohne angeschlossenen 
Akku stark zum Schwingen neigt:

Ausgang des LM317 überschreitet (je nach Einstellung von RV1) addition 
der Spannungswerte von D5, D6 und R4 => Transistor Q1 wird leitend.

Spannung an R2 sind immer 1,25V, somit ergibt sich (bei leitendem 
Transistor Q1) eine Ausgangsspannung von 1,25V + Uf_LED_rot was so in 
etwa 2.8V bis 3V sein dürfte.

Somit wird die Schwellspannung der Z-Diode nicht mehr erreicht und 
Transistor Q1 sperrt wieder, Ausgangsspannung steigt wieder an ==> 
schwingt.

Eine Dimensioniertung mit RV1 = 10k Ohm ist absoluter Quatsch, weil die 
Ausgangsspannung schlecht eingestellt werden kann. Die Kombination von 
R2, RV1, R1 würde, wenn es eine genügend hohe Spannung des Trafos geben 
würde und es die Maximum-Ratings des Reglers zulassen würde, einen 
Stellbereich der Ausgangsspannung von 59.092V ergeben.

-------------------------------

Mit angeschlossenem Akku:

Die Spannung am Akku übersteigt den Spannungsfall von D6, R4 und U_be => 
Transistor ist leitend. Wie oben beschrieben wird die Ausgangsspannung 
des Reglers auf ca. 2.8V bis 3V begrenzt (1,25 U_ref des Regles + 
Uf_LED_rot).

So, warum geht nun die grüne LED aus?

Das ist hier etwas "doof" realisiert. Geht man davon aus, dass grüne 
LEDs typische Flussspannungen von 2.0V bis 2.5V haben fallen bei 
"geschickter" LED-Wahl am Widerstand R3 nur eine Spannung von 0.3V ab. 
Der Strom durch die grüne LED wäre dann nur 0.13 mA was zum Leuchten 
nicht reichen würde und sie ist aus.

Hat man hier jedoch eine rote LED mit hoher Flussspannung (sagen wir mal 
2V) und eine grüne LED mit geringer Flussspannung (sagen wir wieder mal 
2V), dann hätten wir eine Ua des Reglers von 3.25V. Am R3 wären dann 
1,25V was einen Strom von 0,56 mA zur Folge hätte. Bei Ultra-Low-Current 
LEDs würde das reichen, um die grüne Leuchtdiode zumindest schwach 
leuchten zu lassen.

Ob die grüne Leuchtdiode ausgeht (oder nicht) hängt also stark von den 
Leuchtdiodentypen ab !

von Ralph S. (jjflash)


Lesenswert?

Ralph S. schrieb:
> Spannungsfall von D6, R4 und U_be

muß heißen:

D6, U_R4, U_be, Uf_LED_rot

von Ralf W. (tubefreak)


Lesenswert?

> Ob die grüne Leuchtdiode ausgeht (oder nicht) hängt also stark von den
> Leuchtdiodentypen ab !

Also ich entnehme, das die Schaltung grundsätzlich funktiomiert, zwar 
suboptimal, aber funktioniert.......

ob die Grüne LED ausgeht oder nicht ist auch nicht so tragisch, evtl 
anderen Typ nehmen.

von Roland E. (roland0815)


Lesenswert?

Wenn schon ein LM317 da ist, warum dann so kompliziert?  Schaltung Seite 
1 TI-Datenblatt. LM + 6 passive Bauteile + Trafo und fertig.

: Bearbeitet durch User
von Udo S. (urschmitt)


Lesenswert?

Ralf W. schrieb:
> Also ich entnehme, das die Schaltung grundsätzlich funktiomiert, zwar
> suboptimal, aber funktioniert.......

Wieder ein typisches Beispiel dass ein Threadersteller solange auf 
Antworten wartet bis eine kommt der genau das aussagt was er hören will.
Alle anderen Argumente werden ignoriert

Vor allem fundierte wie die:

MaWin schrieb:
> Vergiss die Schaltung.
>
> Wenn du einen 2 x 1A Netztrafo hast, ist dein erstes Problem eine
> Strombegrenzung auf unter 1.2A= damit der Trafo nicht überhitzt.
>
> Wenn du einen 15V~ Trafo hast, darf dich die Strombegrenzung nicht mehr
> als ( 0.9x15x1.4-1 = 18  ) - 13.8 = 4.2V kosten, Ripple durch Siebelko
> ignorieren wir mal weil es eine Maximalbegenzung sein darf.
>
> Hier sind mehrere Schaltungen mit LM317 und TL431 oder auch mal nur
> Transistoren die das können
> https://dse-faq.elektronik-kompendium.de/dse-faq.htm#F.21.2
>
> Interessant ist halt eine Schaltung die auch bei Netzstromausfall den
> Akku nicht entlädt. Notfalls in dem ein Relais den Akku sbklemmt.

Ralf, dann baue es halt. Viel kaputtmachen kannst du an dem zumindest 
teilgeschädigten Akku sowiso nicht mehr.
Viel Erfolg.

von MaWin (Gast)


Lesenswert?

Ralph S. schrieb:
> Die Spannung am Akku übersteigt den Spannungsfall von D6, R4 und U_be =>
> Transistor ist leitend.

Nö, dazu kommt die Flussspannung der roten LED D3.

Dieter D. schrieb:
> sobald der Akku unter 12,0...11,7V fällt und hört an dieser Schwelle
> auch wieder auf. Volladen also Fehlanzeige.

Unsinn, D3+UBE(Q1)+D6=2+0.8+11=13.8V wenn 'ideal' ausgewählte Bauteile 
verwendet werden.

Aber 100 Ohm an 13.8V  führt selbst bei 12V also leerem Akku nur zu 18mA 
Ladestrom.

Blöderweise misdt der Trottel der den Schaltungsmist gezeichnet hat die 
Akkuspannung aber vor den 100 Ohm, also nur die Netzteilspannung und die 
erreicht, bei passender Einstellung von RV1, immer 13.8V also leuchtet 
rot immer, wie auch grün, egal wie leer dr Akku ist.

Ralf W. schrieb:
> Also ich entnehme, das die Schaltung grundsätzlich funktiomiert

Nein. Nichtmal an Sonntagen die auf Gründonnerstag fallen.

von Helge (Gast)


Angehängte Dateien:

Lesenswert?

vielleicht enthält deine bastelkiste diese bauteile?

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

MaWin schrieb:
> Unsinn, D3+UBE(Q1)+D6=2+0.8+11=13.8V wenn 'ideal' ausgewählte Bauteile
> verwendet werden.

Hier hatte ich die LED im Emitterkreis vergessen. Es gibt diese 
Schaltung auch mit LED im Kollektorkreis.

Ralf W. schrieb:
> ob die Grüne LED ausgeht oder nicht ist auch nicht so tragisch, evtl
> anderen Typ nehmen.

Einfach zwei grüne LED in Reihe geschaltet verwenden als Lösung.

von HildeK (Gast)


Angehängte Dateien:

Lesenswert?

Ralf W. schrieb:
> Also ich entnehme, das die Schaltung grundsätzlich funktiomiert, zwar
> suboptimal, aber funktioniert.......

Die geht schon für ein paar 10mA Ladestrom - wegen R5.

Nur die LEDs tun nicht, was ihnen angedichtet wird.
Solange der Regler am Eingang versorgt wird - so mit >16V - solange wird 
die rote und die grüne LED leuchten.

Ralph S. schrieb:
> Eine Dimensioniertung mit RV1 = 10k Ohm ist absoluter Quatsch, weil die
> Ausgangsspannung schlecht eingestellt werden kann.

Für RV1 ist es fast egal, welchen Wert er hat, solange er groß genug 
ist, um ca. 14-15V am Ausgang zu produzieren. Den Rest macht nämlich der 
Transistor und die LED parallel zu RV1. Die halten die Ausgangsspannung 
nach D5 weitgehend konstant. Genau so gut hätte man die nur mit dem 
richtigen RV1 einstellen können - ganz ohne den Transistor. Die 
Strombegrenzung macht eh der R5.

Kannst ja mal mit dem angehängten File simulieren - ist mit dem LT1086 
statt LM317. Und den Widerstand verändern, bei Werten oberhalb von rund 
2.5k tut sich fast nichts mehr ...

von Ratgeber (Gast)


Lesenswert?

HildeK schrieb:

> Ratgeber schrieb:
>> Wenn die Akkuspannung über 11,6 Volt angestiegemn ist (Z-Diode+Ube des
>> Transistors) beginnt der zu leiten, schaltet die rote LED und zieht den
>> Sapnnungsteiler am LM317 runter, so daß die Ladespannung abgeschaltet
>> wird.
>> daraufhin geht die grüne LED aus, weil sie nun weder über den LM317 noch
>> aus dem Akku gespeist werden kann, denn dazwischen sitzt ja die Diode.

> Nein, tut sie nicht. Die geht erst aus, wenn man den Trafo abschaltet.
> Und die 11.6V stimmen auch nicht: 1.8V (LED) + 11V (Z-Diode) + 0.6V
> (UBE) = 13.4V - solange die Z-Diode auch 11V bei dem kleinen Strom hat.
> Und auch die rote LED geht erst aus, wenn die Akkuspannung größer ist
> als die vom Längsregler (minus U_D5) - und woher soll das kommen?

Wie Du sehen konntest, habe ich meinen Beitrag Sekunden später 
dahingehend korrigiert.

Ich habe beschrieben, wie es funktioniert und davon gehe ich nicht ab.

von Ralf W. (tubefreak)


Lesenswert?

> Wieder ein typisches Beispiel dass ein Threadersteller solange auf
> Antworten wartet bis eine kommt der genau das aussagt was er hören will.
> Alle anderen Argumente werden ignoriert
>
> Ralf, dann baue es halt. Viel kaputtmachen kannst du an dem zumindest
> teilgeschädigten Akku sowiso nicht mehr.
> Viel Erfolg.

Ich werde die Schaltung nicht nachbauen, zumindest nicht nach diesem 
Schaltplan und mit 100Ohm Reihenwiderling....
Es war nur die Frage ob die Schaltung überhaupt funktioniert oder ob die 
abraucht....und die Arbeitsweises ser grünen LED hatte mich 
interessiert.

Dafür allen die etwas dazu beigetragen haben bielen Dank.

von Ralf W. (tubefreak)


Lesenswert?

Helge schrieb:
> vielleicht enthält deine bastelkiste diese bauteile?

den TL431 hab ich definitiv nicht.....

von HildeK (Gast)


Lesenswert?

Ratgeber schrieb:
> Wie Du sehen konntest, habe ich meinen Beitrag Sekunden später
> dahingehend korrigiert.
Hab ich zu spät gesehen.

> Ich habe beschrieben, wie es funktioniert und davon gehe ich nicht ab.
Darfst du gerne.
Trotzdem: so funktioniert sie eben nicht. Dazu müsste der Akku von einer 
weiteren Quelle weiterhin geladen werden und seine Spannung steigen. 
Erst dann versucht der Transistor die Ausgangsspannung des LM317 immer 
weiter zu reduzieren.
Es wird einfach so sein, dass die Schaltung dauerhaft mit kleinem Strom 
lädt um den Selbstentladungsteil des Akkus auszugleichen. Mehr ist nicht 
und mehr kann sie nicht - nicht mal richtig laden (Bleiakku laden mit 
max. 10...15mA? Selbst wenn man den Ausgang kurzschließt, es fließen 
max. 130mA).

Die Kombination aus Z-Diode, T und LED ist nichts anderes als eine 
(schlechte) Spannungsregelung. Die hat der 317 bereits viel besser 
eingebaut.

von Helge (Gast)


Angehängte Dateien:

Lesenswert?

hatte (vernachlässigbar kleinen) Fehler. V1 ist billiger 12V-Trafo.

von Helge (Gast)


Lesenswert?

Ralf W. schrieb:
> den TL431 hab ich definitiv nicht.....

Es tut ja irgendeine Referenzspannung. Z-Diode, 7805, irgendwas.

von Ralf W. (tubefreak)


Lesenswert?

Dieter D. schrieb:
> Was gibt Deine Bastelkiste denn her?
>
> Trafos, Netzteile, sonstige Spannungsregler, ZD, LED, Dioden,
> Transistoren, ...
>
> Mit Letzteren lässt sich immer etwas sehr Einfaches bauen.
> LED, Dioden, od. ggf. ZD , Transistoren,

Trafo/ Steckernetzteil 12V 500mA 12V 800mA 12V 1A (Steckernetzteile 
nicht Gleichgerichtet)
Trafo 2x12V je 1,6A
diverse 12V Schaltnetzteile mit 5und 12V (mit Trimmpoti)(T40B) 5V3A 
12V(+)2A  12V(-)0,5A
LM350 LM317 78XX LM724(im Transistorgehäuse)
LM386 LM311 TL81 TL062
Diverse kleinsignaltransistoren BC5xx NPN un PNP BD140 BD139 2N3055 und 
so
Dioden 1n40007 1n4148 diverse Z-dioden 1/2W

von Erich (Gast)


Lesenswert?

HildeK schrieb:
> Kannst ja mal mit dem angehängten File simulieren

Can't find definition of model "LED_RED"

von Ralf W. (tubefreak)


Lesenswert?

Helge schrieb:
> Ralf W. schrieb:
>> den TL431 hab ich definitiv nicht.....
>
> Es tut ja irgendeine Referenzspannung. Z-Diode, 7805, irgendwas.
Hab ich 7805 oder eine 5.1V Z-diode ,

von Helge (Gast)


Angehängte Dateien:

Lesenswert?

ganz billige Referenz 2.5V. Ist natürlich schlechter als ein 
referenz-IC, reicht aber hier aus.

von Ralf W. (tubefreak)


Lesenswert?

Helge schrieb:
> ganz billige Referenz 2.5V. Ist natürlich schlechter als ein
> referenz-IC, reicht aber hier aus.
Danke , Q3 soll was sein? BD140?

von 2aggressive (Gast)


Lesenswert?

Ralf W. schrieb:
> Bitte mal Video anschauen, dort geht die LED eindeutig aus....kann aber
> auch sein das es ein Fake Vieo ist.....
Vielleicht(!) der Grund:
Ein "Problem" mit dem Breadboard, siehe Anhang. Sobald durch den Akku 
erstmals ein kleinerer Strom fliesst fällt am parasitären Widerstand 
weniger Spannung ab; dadurch "kippt" die Schaltung.
Manch Schrottschaltungen funktionieren nur aufgrund eines schrottigen 
Layouts :D

von 2aggressive (Gast)



Lesenswert?

Anhang vergessen :-(

von HildeK (Gast)


Lesenswert?

Erich schrieb:
> Can't find definition of model "LED_RED"

Wähle halt eine andere aus oder nimm zwei, drei Si-Dioden in Reihe. Es 
leuchten ja sowieso nicht in der Simulation 😀.
Sorry, ich hatte mal einige gefunden und mit abgelegt.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)



Lesenswert?

Ralf W. schrieb:
> Trafo/ Steckernetzteil 12V 500mA 12V 800mA 12V 1A (Steckernetzteile
> nicht Gleichgerichtet)

Nach dem Gleichrichter als Leerlaufspannung sind das 12V*1,4 - 1,4V, 
15.4V.

Mal als Idee eine einfache Schaltung angehängt.
Einige Dioden sind in der Skizze verkehrt herum.

: Bearbeitet durch User
von Ralf W. (tubefreak)


Lesenswert?

>>> den TL431 hab ich definitiv nicht.....
>>
>> Es tut ja irgendeine Referenzspannung. Z-Diode, 7805, irgendwas.
> Hab ich 7805 oder eine 5.1V Z-diode ,

Sage niemals nie, hab doch 2 TL431 gefunden,- Was ist mit dem PNP, 
welcher Typ, da fliest ja der ganze Ladestrom drüber ?

von Helge (Gast)


Angehängte Dateien:

Lesenswert?

Ralf W. schrieb:
> Q3 soll was sein? BD140?
irgendein pnp, der mindestens 5W kann. Der BD140 ist gut geeignet.

Da du einen 500mA Steckertrafo hast, könntest du bei Bedarf auch eine 
echte ca. 200-250mA Strombegrenzung bauen. Das wäre beim nachladen eines 
größeren Akkus sinnvoll, aber dann braucht der pnp bessere Kühlung.

von Ralf W. (tubefreak)


Lesenswert?

Helge schrieb:

> Da du einen 500mA Steckertrafo hast, könntest du bei Bedarf auch eine
> echte ca. 200-250mA Strombegrenzung bauen. Das wäre beim nachladen eines
> größeren Akkus sinnvoll, aber dann braucht der pnp bessere Kühlung.

Hallo Helge,
Welche Schaltung nehme ich jetzt, die erste die du gepostet hast mit ref 
5V
oder die 2te mit ref 2,5V?
was machen die beiden 1n4148 am Q3 auf Basis? (limiter)
Deine guten NSCW100 Nichia hab ich leider auch nicht zur Verfügung.
Was wird am Poti eingestellt ? Ladeschlussspannung?
Erkläre mir doch bitte wie deine Schaltung funktioniert.

von Stromberg B. (Gast)


Lesenswert?

Ralf W. schrieb:
> Welche Schaltung nehme ich jetzt, die erste die du gepostet hast mit ref
> 5V
> oder die 2te mit ref 2,5V?

Du kannst beides nutzen, oder hier mal was ganz anderes:

Beitrag "Re: Strombegrenzung für Akku laden"

...oder doch lieber den LM317 für die Ladeendspannung nutzen und durch 
den Einsatz eines zusätzlichen NPN-Transistors und eines 
Shuntwiderstandes in der GND-Leitung, eine Strombegrenzung dazu bauen.

von Helge (Gast)


Angehängte Dateien:

Lesenswert?

"5V" war falsch beschriftet. Bei der letzten Idee passiert folgendes: 
Die Dioden begrenzen die Spannung zwischen Versorgung und Basis auf 
höchstens ca. 1,3V. Im Leistungspfad fallen zwischen Basis und Emitter 
etwa 0,7V ab. Dadurch wird der Widerstand am Emitteranschluß 
strombestimmend, denn an ihm fallen ca. 0,5-0,7V ab.
Für einen 500mA-Trafo sind die bei 2,2 Ohm fließenden ca. 200-250mA 
dauerhaft gut verträglich.
Ich häng den Plan mit TL431 und Strombegrenzung an.

(RL + CL stellt der ltspice Simulation sowas ähnliches wie einen Akku 
bereit, damit man sieht, was beim aufladen passiert. Braucht natürlich 
nicht dazugebaut werden bei dir)

von Stromberg B. (Gast)


Angehängte Dateien:

Lesenswert?

Stromberg B. schrieb:
> ..oder doch lieber den LM317 für die Ladeendspannung nutzen und mit 
Strombegrenzung...

R1 = 220R

R2 = 2R2

R3 = 240R

R4 = 5k Trimmer

C3 = 220nF

T1 = BC337-25

Die Schaltung war in den 90ern in der Elektor. Die Strombegrenzung liegt 
jetzt etwa bei 250mA. Durch Verändern von R2, ändert sich auch die 
Stromgrenze.

von Helge (Gast)


Lesenswert?

Ralf W. schrieb:
> NSCW100 Nichia
vergessen: irgendwelche 20mA LED. Sorte, Farbe egal.

von Ralf W. (tubefreak)


Angehängte Dateien:

Lesenswert?

Stromberg B. schrieb:
> Stromberg B. schrieb:
>> ..oder doch lieber den LM317 für die Ladeendspannung nutzen und mit
> Strombegrenzung...
>
>Die Schaltung kenne ich mit LED im Kollektorkreis. Danke für die Mühe.

Mal gucken wie lange es noch Kalt ist und regnet,- dann werden es evtl 2 
Schaltungen.
Mit sicherheit einmal die von Helge
und dann die mit LM317, aber mit LED...

von Ralf W. (tubefreak)


Lesenswert?

Helge schrieb:
> Ralf W. schrieb:
>> NSCW100 Nichia
> vergessen: irgendwelche 20mA LED. Sorte, Farbe egal.
Danke nochmals für die Schaltung und die Erklärung.
Das Poti ist dann für die Ladespannung?

von Mani W. (e-doc)


Lesenswert?

Ralf W. schrieb:
> Das Poti ist dann für die Ladespannung?

Blöde Frage!

Wozu soll es sonst dienen...

von HildeK (Gast)


Lesenswert?

Mani W. schrieb:
> Ralf W. schrieb:
>> Das Poti ist dann für die Ladespannung?
>
> Blöde Frage!
>
> Wozu soll es sonst dienen...

Es ist für die Ladeschlussspannung!
Die Ladespannung wird während des Ladens über den Transistor soweit 
zurückgenommen, dass max. der eingestellte Strom fließt (hier ca. 
700mA).

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Ralf W. schrieb:
> Das Poti ist dann für die Ladespannung?

HildeK schrieb:
> Es ist für die Ladeschlussspannung!

Zur Einstellung der Ladeschlussspannung benötigst Du den 100 
Ohmwiderstand als Last in Reihe mit dem Akku, oder einen etwas höheren 
Widerstand alleine.

: Bearbeitet durch User
Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.