Forum: Analoge Elektronik und Schaltungstechnik Wien -Brückengenerator von Siemens schwingt nicht - LT SPICE


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Christian (Gast)


Angehängte Dateien:

Lesenswert?

Moin Leute,

Ich habe ein Problem mit LT-Spice. Ich soll eine vorgegebene Schaltung 
von Siemens so simulieren. Die Schaltung wurde auf einem Steckbrett 
aufgebaut und gemessen dort hat sie auch wunderbar Funktioniert.

Aber ich kann in LT-Spice machen was ich will, sie schwingt nicht an.
Auf dem Steckbrett wurden BC141 Transistoren verwendet, in LT-Spice habe 
ich BC-547 genommen, sollte eigentlich für diese Anwendung keinen 
Unterschied machen, oder?

ich habe bereits versucht mit Startwerten zu arbeiten, habe den 
Kondensatoren einen IC von 3 gegeben und die Schaltung mit uic 
simuliert.

Habt ihr noch irgendwelche Ideen, wie ich diese Schaltung zum Schwingen 
bekomme?

Viele Grüße
Christian

von Christian S. (roehrenvorheizer)


Lesenswert?

Christian schrieb:
> Habt ihr noch irgendwelche Ideen, wie ich diese Schaltung zum Schwingen
> bekomme?

Die Schaltung kann ich leider nicht sehen, aber die Schwingung facht 
sich üblicherweise durch Rauschen an UND die Verstärkung muß genügend 
groß sein in der Mitkopplung. Vielleicht kannst Du den Spannungsteiler 
der Mitkopplung noch etwas nachjustieren in Richtung mehr Verstärkung.

mfg

von Lutz V. (lvw)


Lesenswert?

Christian schrieb:
> Habt ihr noch irgendwelche Ideen, wie ich diese Schaltung zum Schwingen
> bekomme?

Eigentlich sollte es mit UIC gehen.
Sichere Möglichkeit: Bei der TRAN-Analyse auch die (mindestens eine) 
Spannungsversorgung bei t=0 mit einschalten.
Das mit dem Rauschen funktioniert nur in Realität - nicht bei der 
Simulation.
Zur Sicherheit solltest Du aber den Schaltungsaufbau (Simulation) noch 
mal kontrollieren - auch die Bauteilwerte (gefährlich: M und F).
Und - natürlich hier auch zeigen!


Christian S. schrieb:
> Vielleicht kannst Du den Spannungsteiler
> der Mitkopplung noch etwas nachjustieren in Richtung mehr Verstärkung.

Hier ist wohl der Spannungsteiler der GEGENKOPPLUNGg gemeint

: Bearbeitet durch User
von Andrew T. (marsufant)


Lesenswert?

Christian schrieb:
> Habt ihr noch irgendwelche Ideen, wie ich diese Schaltung zum Schwingen
> bekomme?

Du hast die Schaltung in LT nicht so gezeichnet, wie sie von Siemens 
gebaut wurde.

Also erstmal die Spice-Plan-Fehler korrigieren, dann tut das auch.

von H. H. (hhinz)


Lesenswert?

Christian schrieb:
> Habt ihr noch irgendwelche Ideen, wie ich diese Schaltung zum Schwingen
> bekomme?

Einfach die Fehler im Schaltplan beheben.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Christian schrieb:
> Aber ich kann in LT-Spice machen was ich will, sie schwingt nicht an.
> Auf dem Steckbrett wurden BC141 Transistoren verwendet, in LT-Spice habe
> ich BC-547 genommen, sollte eigentlich für diese Anwendung keinen
> Unterschied machen, oder?

Warum zeichnest du eine Versorgungsspannung maximal schief?
Wenn du sie gescheit und übersichtlich zeichnen würdest, könnte dir 
auffallen, daß sie verpolt ist!

von H. H. (hhinz)


Lesenswert?

Falk B. schrieb:
> verpolt ist!

Es sind noch mehr Fehler.

von Lutz V. (lvw)


Lesenswert?

H. H. schrieb:
> Falk B. schrieb:
>> verpolt ist!
>
> Es sind noch mehr Fehler.

Ja - ich sehe gar keine Mitkopplung.

von Christian S. (roehrenvorheizer)


Lesenswert?

Lutz V. schrieb:
> Hier ist wohl der Spannungsteiler der GEGENKOPPLUNGg gemeint

Richtig.

von Christian (Gast)


Angehängte Dateien:

Lesenswert?

Schon einmal danke für eure zahlreichen Antworten!

Ich habe die Schaltung Korrigiert, ich stelle sie als Vergleich mal 
nebeneinander. Leider schwingt die Schaltung noch nicht an.

Den Poti habe ich zerlegt in einen 10K Festwiderstand (zwischen E und A)
und einmal einen Widerstand 5K zwischen Betriebsspannung und S weil er 
im Versuch auf Mittelstellung stand.

von H. H. (hhinz)


Lesenswert?

Christian schrieb:
> Ich habe die Schaltung Korrigiert,

Immer noch falsch.

von Lutz V. (lvw)


Lesenswert?

Immer noch keine Mitkopplung....schau mal, wo Du R7 angeschlossenhast.

von Christian (Gast)


Lesenswert?

Lutz V. schrieb:
> Immer noch keine Mitkopplung....schau mal, wo Du R7
> angeschlossenhast.

Naja moment, der R7 als Poti stellt mit den Anschlüssen E und A ja einen 
Festwiderstand von 10k in Reihe zu dem R1 dar...
Und der Schleifer auf Mittelstellung stellt einen Widerstand von 5K 
(R11) dar der an den Kollektor von V2 angeschlossen ist dar. Sehe ich 
das falsch?
Entschuldigt meine Betriebsblindheit...

von H. H. (hhinz)


Lesenswert?

Christian schrieb:
> Sehe ich
> das falsch?

Ja.

von Andrew T. (marsufant)


Lesenswert?

Christian schrieb:
> ehe ich
> das falsch?

Schau mal wo R11 im LT und
wo der schleifer des Poti im original Plan ansetzt.

Da ist einer der Fehler.

von Christian (Gast)


Angehängte Dateien:

Lesenswert?

Oha!
Ich bin einfach davon ausgegangen, dass der Schleifer zwischen der 
Versorgungsspannung und dem Ausgang liegt. Ich habe die Schaltung noch 
einmal geändert. Diesmal den Poti anders aufgesplittet und dann in der 
Mitte "abgegriffen". Jetzt Schwingts!

Das war mir eine Lehre!

Vielen Dank an alle!

von Lutz V. (lvw)


Lesenswert?

Christian schrieb:
> Entschuldigt meine Betriebsblindheit...

Du weißt aber schon, dass ein Oszillator einen geschlossenen und 
frequenzabhängigen Rückkopplungszweig benötigt (also Ausgang muss auf 
Eingang rückgeführt werden)?

von Andrew T. (marsufant)


Lesenswert?

Christian schrieb:
> Diesmal den Poti anders aufgesplittet und dann in der
> Mitte "abgegriffen". Jetzt Schwingts!

Und weil's so schön ist ersetzt Du nun die beiden 5k durch ein echtes 
10k Poti )in der Simulation) das dann durch alle Schleiferpeostionen von 
0...270 Grad durchläuft.

Dann siehst Du wo die Schwingung einsetzt. (also in welcher Poti 
position)

Enjoy!

von Christian (Gast)


Lesenswert?

Tatsächlich nicht. Diese Versuchsreihe ist mein erster Berührungspunkt 
wenn es um Oszillierer geht. Bei meiner Onlinerecherche verwenden auch 
viele einen OPV. Die Unterlagen hier sind vermutlich auch schon etwas 
älter.

von Falk B. (falk)


Angehängte Dateien:

Lesenswert?

Siehe Anhang. Er schwingt, aber nicht sinusförmig. Die Arbeitspunkte 
stimmen nicht sonderlich.

von Christian (Gast)


Lesenswert?

Andrew T. schrieb:
> Christian schrieb:
>> Diesmal den Poti anders aufgesplittet und dann in der
>> Mitte "abgegriffen". Jetzt Schwingts!
>
> Und weil's so schön ist ersetzt Du nun die beiden 5k durch ein echtes
> 10k Poti )in der Simulation) das dann durch alle Schleiferpeostionen von
> 0...270 Grad durchläuft.
>
> Dann siehst Du wo die Schwingung einsetzt. (also in welcher Poti
> position)
>
> Enjoy!

Gibt es für LT-Spice ein Potimodel? Sonst würde ich einfach mit dem 
.step befehl arbeiten.

von Lutz V. (lvw)


Lesenswert?

Christian schrieb:
>
> Gibt es für LT-Spice ein Potimodel? Sonst würde ich einfach mit dem
> .step befehl arbeiten.

Warum willst Du denn ein Poti in der Simulation einsetzen?
Versuche doch - wie erwähnt - per .step den besten Verstärkungswert zu 
finden...

von Dietrich L. (dietrichl)


Lesenswert?

Falk B. schrieb:
> Er schwingt, aber nicht sinusförmig. Die Arbeitspunkte
> stimmen nicht sonderlich.

Und wirklich sinusförmig wird es erst, wenn man eine amplitudenabhängige 
Regelung der Rückkopplung einbaut, damit nichts übersteuert.

von ths (Gast)


Angehängte Dateien:

Lesenswert?

Der Wien von Siemens ist vielleicht nicht mehr erste Wahl. Probier mal 
die Schaltung im Anhang.

von Mohandes H. (Firma: مهندس) (mohandes)


Lesenswert?

Dietrich L. schrieb:
> amplitudenabhängige Regelung der Rückkopplung

Am besten mit einem FET, oder einer Glühlampe wie im Klassiker HP-200A:

https://en.wikipedia.org/wiki/HP_200A

Der HP-200A war Ende der 1930er Jahre der erste kommerzielle 
Wienbrückengenerator und hatte, dank der Amplitudenreglung mit einer 
Glühbirne, für damalige Verhältnisse sagenhafte Klirrwerte. Schaltplan 
und Erläuterungen unter:

https://www.hpmemoryproject.org/wa_pages/wall_a_page_01.htm

von Christian S. (roehrenvorheizer)


Lesenswert?

Christian schrieb:
> Diesmal den Poti anders aufgesplittet und dann in der
> Mitte "abgegriffen". Jetzt Schwingts!
Was ein trivialer Fehler sich da doch einschleichen konnte.

Christian schrieb:
> mein erster Berührungspunkt
> wenn es um Oszillierer geht

Bitte auch die OszilliererInnen nicht vergessen :-)

mfg

von Carlo (Gast)


Lesenswert?

ths schrieb:
> Der Wien von Siemens ist vielleicht nicht mehr erste Wahl. Probier mal
> die Schaltung im Anhang.

...danach plot Bild anklicken,
rechte Maus-Taste drücken,
view  auswählen,
FFT   auswählen ,
ok
und Ausgabe mit der vorhergehenden Schaltung vergleichen :-)

von Carlo (Gast)


Lesenswert?


von ths (Gast)


Lesenswert?

Empfehle auch die gute AN43 von Jim Williams. Ab Seite 27

https://www.analog.com/en/search.html?q=an43

von geschädigter (Gast)


Angehängte Dateien:

Lesenswert?

ths schrieb:
> sinus.asc (2,37 KB)

Man kann ja über die Art eine Schaltung zu zeichnen durchaus
unterschiedlicher Meinung sein, aber ich bekomme von dieser
Version Augenkrebs.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.