Forum: PC Hard- und Software Notebook schaltet sich ab


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Franko P. (sgssn)


Lesenswert?

Hallo
arbeite gerade an einem kleinen Elektronikprojekt. Dabei ist der Laptop 
mit der Elektronik (mit einem PIC18F1220) über ein PicKit4 und über den 
UART und nem UART/USB-Wandler verbunden. Die Elektronik wird über ein 
Labornetzgerät versorgt. Die 5-Volt-Spannung liegt auch am PICKIT4 an 
und am UART-USB-Wandler. Während ich die Ausgabe von Messwerten am 
Notebook (Terminal-programm) beobachtet habe, stieg plötzlich die 
Stromaufnahme der Elektronik vom Labornetzgerät an, es hat dann nach 
Elektronik gerochen, dann hat sich das Notebook einfach abgeschaltet. 
Gleich im Anschluss, nach abstecken aller Anschlüsse am Notebook hat 
sich dieses nicht mehr einschalten lassen. Nach etwa einer Minute liess 
es sich zwar einschalten, hat sich aber gleich wieder abgeschaltet, nach 
weiteren ca 3 Minuten, liess es sich wieder starten, und zeigt keine 
Defekte. Nun bin ich etwas ratlos. Weiss ja, dass keiner ne Glaskugel 
hat, aber was kann das Abschalten verursacht haben. Inspektion der 
Elektonik hat 2 Defekte gezeigt: Der 7805 ist defekt, liefert nur noch 
2,5V und möglicherweise ist der Ausfall von ner kalten Lötstelle direkt 
am Masseanschluss des 7805 verursacht worden. Der 7805 wird mit 20Volt 
versorgt, Sromaufnahme "normalerweise" 40mA. Alle anderen Teile haben 
den Ausfall überlebt, auch das PICKit4 und der UART/USB-Wandler. Frage 
also primär: was kann dern Absturz/das Abschalten des Notebooks 
verursacht haben? Überspannugen am USB-Anschluss?

Gruß

: Bearbeitet durch User
von dummschwaetzer (Gast)


Lesenswert?

Wohl ehr Strom und eine rückstellende Sicherung

von Franko P. (sgssn)


Lesenswert?

Ja, das zeitversetzte Wiedereinschalten spricht auf jeden Fall dafür. 
Gottsei Dank, ist eines meiner besten Notebooks (:-) )

von Peter D. (peda)


Lesenswert?

Franko P. schrieb:
> Der 7805 wird mit 20Volt
> versorgt

Das ist sehr viel, wird er ausreichend gekühlt?
Ist es ein echter 8705, die LDO-Typen vertragen oft nur max 16V.

Bei mehr als 6V Differenz leitet im 8705 die D2 über R13. Bei geringer 
Last bedeutet das, die Spannung kann hochlaufen auf deutlich über 5V.
Z.B. wenn  man den MC in Power-Down setzt.

Ich setze an Testschaltungen immer einen USB-Trenner ein:
https://www.reichelt.de/usb-isolator-galvanische-trennung-host-geraet-usb-care01-p116460.html?PROVID=2788

: Bearbeitet durch User
von Franko P. (sgssn)


Lesenswert?

Nein, der 7805 hat keinen Kühlkörper. Bei 40mA sollte das auch so noch 
reichen. Ist TO220-Typ, der sollte eigentlich 1Watt ohne Kühlkörper 
packen. Ist ok, ich spendier ihm einen. Die Ursache für den defekt liegt 
abr woanders. Und der USB-Isolator ist ne gute Idee. Nicht gerade billig 
das Teil, aber billiger als das Notenbook allemal.
Danke für die Tipps und Hinweise.

Gruß

von Max M. (Gast)


Lesenswert?

Franko P. schrieb:
> Dabei ist der Laptop
> mit der Elektronik (mit einem PIC18F1220) über ein PicKit4 und über den
> UART und nem UART/USB-Wandler verbunden.
Sind auch die 5V USB mit den 5V PIC verbunden?

Franko P. schrieb:
> Der 7805 ist defekt, liefert nur noch
> 2,5V und möglicherweise ist der Ausfall von ner kalten Lötstelle direkt
> am Masseanschluss des 7805 verursacht worden.
Damit hat der 7805 volle Eingangsspannung rausgegeben, weil sein 
Bezugsgnd fehlte.
Bei 5V Verbindung USB / Elektronik, hat das Labornetzgerät dann volle 
Spannung zurück in den Laptop gespeist, die komplette 5V Versorgung 
angehoben und Du kannst nur drei Kreuze machen WENN das alle Komponenten 
dauerhaft überlebt haben.
Das ist nämlich keinesfalls sicher das die jetzt noch lange halten.

Immer vorrausgesetzt die angenommenen Bedingungen treffen zu.

Der 7805 wirklich defekt, oder zieht nur einer der 5V Bausteine die 
Spannung runter?
Mal direkt mit 5V einspeisen an der Stelle und auf Strom / Hotspots 
achten.

von Franko P. (sgssn)


Lesenswert?

Ja, die 5 Volt sind überall hin verbunden. Beim UART-USB-Wandler weiss 
ich das aber nicht genau. Ist das Billigteil, das auch über Amazon 
vertrieben wird.

Den 7805 hab ich schon getauscht, und jetzt geht das auch wieder. 
Trotzdem wäre es mir lieber, die Ursache oder besser den Wirkmechanismus 
zu kennen, den das Notebook übelgenommen hat. Wie oben schon erwähnt, 
scheint da ne Temperatursicherung angesprochen zu haben. Aber welche? Wo 
sitzt da sowas? USB ist da möglicherweise abgesichert. Bin da kein 
Profi.

von HP (Gast)


Lesenswert?

> Bin da kein Profi.

Nur ein D.A.U. schliesst seine "Versuchsschaltungen"
direkt an den USB-Port seines Rechners an.
Schon Anfaenger benutzen einen USB-Hub dafuer.
Profis einen USB-Isolator.

Vermutlich bist du auch "ahnungslos", ob dein Programmieradapter
sein Target auch mit Strom versorgen will.

Als 7805 wuerde ich auch die Mitarbeit verweigern, wenn 0.6 W
ohne Kuehlkoerperunterstuetzung abzublasen waeren.

Ich hoffe mal das du das nicht beruflich machst.
Da wirst du dann naemlich nicht alt werden.

von Max M. (Gast)


Lesenswert?

Franko P. schrieb:
> Ja, die 5 Volt sind überall hin verbunden.

Glückwunsch.
Dann haben zwei Quellen gespeist.
Die 5V USB und das Labornetzteil.
Und durch den Lötfehler am 7805 hat ALLES am Notebook das 5V sieht die 
volle Packung vom Labornetzteil bekommen.

Hoffe auf das beste, sichere Deine Daten regelmäßig und versorge beim 
nächsten mal nur ext. und am besten über einen USB Isolator.

von Franko P. (sgssn)


Lesenswert?

Ja den Isolator habe ich schon mal bestellt. Danke.
Denke aber nicht, dass ich der einzige Gutgläubige bin. Oft denkt man 
über deartiges erst nach, wenns mal gekracht hat. (Und bisher ist ja 
auch immer alles gut gegangen....:-|   )

Bei meinen Lochraster-Platinen messe ich auch immer alles erst mal 
durch. Die 5V Versorgung hat ja funktioniert - nur durch die kalte 
Löststelle leider nicht auf Dauer....

: Bearbeitet durch User
von Peter D. (peda)


Lesenswert?

Franko P. schrieb:
> Die Elektronik wird über ein
> Labornetzgerät versorgt. Die 5-Volt-Spannung liegt auch am PICKIT4 an
> und am UART-USB-Wandler.

Das würde ich auf keinen Fall machen.
Entweder die Schaltung wird nur über USB versorgt, dann gehen die USB-5V 
auf die Schaltung.
Oder die Schaltung hat ein eigenes Netzteil, dann werden die USB-5V 
gekappt und gehen ausschließlich auf den USB-RS232 Umsetzer. Zur 
Schaltung gehen GND, TXD und RXD.

Von den Atmel Programmern kenne ich es so, daß VCC nur ein Eingang ist 
für die Pegelkonverter. Er speist nicht die Testschaltung, also auch 
nicht rückwärts den USB.

von Franko P. (sgssn)


Lesenswert?

Ich meine gelesen zu haben, dass das PICKIT4 über die Versorgung des PIC 
versorgt werden muss. ich weiss nicht wie der PK4 aufgebuat ist und ob 
da Strom über das PK4 zum Notebook fliessen kann. Denke aber, dass ich 
nur die Verbindung am UART trennen kann. Auf dem UART-PIC-Wandler ist 
ein Jumper für Auswahl der Versorgung 3.3/5Volt. Den Jumper kann ich 
ganz öffnen, dann sollte da die Verbindung offen sien, werd ich aber mal 
nachmessen.

Danke an alle...
Gruß

von Manfred (Gast)


Lesenswert?

Franko P. schrieb:
> Ich meine gelesen zu haben, dass das PICKIT4 über die Versorgung des PIC
> versorgt werden muss.

Ich hatte so die Idee, dass Du rückwärts in den USB-Port des PCs 
einspeist, was eindeutig verboten ist. Wenn der Aufbau eine eigene 
Versorgung hat, sollte man die Leitung abklemmen können:
Beitrag "Re: Klone-ARDUINO und externe 5V-Versorgung"

Eine andere Variante, sicher zu sein, ist die komplette Trennung:
Beitrag "Re: Benötigt man für µC Boards (Arduino, Launchpad, Raspberry Pi) eine galvanische Trennung für USB?"

Wenn die Pegel unterschiedlich sind oder ..., kann man den USB-Wandler 
auch gerne aus dem PC versorgen und Rx / Tx der seriellen Schnittstelle 
trennen:
Beitrag "Re: Arduino ProMini galvanisch getrennt"

Nun rate mal, warum ich das alles habe ...

von Schlaumaier (Gast)


Lesenswert?

Franko P. schrieb:
> Nach etwa einer Minute liess
> es sich zwar einschalten, hat sich aber gleich wieder abgeschaltet, nach
> weiteren ca 3 Minuten, liess es sich wieder starten, und zeigt keine
> Defekte.

Klingt für mich nach "Notabschaltung wegen Überhitzung".

Habe ich einige Male erlebt. Seit ich ein Bekannten gesagt habe er soll 
sein Teil im Bett nur noch mit Schutzständer betreiben, steigt seins 
auch nicht mehr aus. ;)

I.d.R. tritt so was aber auf wenn die Lüfter zu sind. Bloß bei dir 
scheint es der Meinung zu sein es müsste schneller aussteigen. Normal 
piepst es, und fährt das System sauber runter. Genau wie bei Akku-Leer.

von Fromarschdibrie (Gast)


Lesenswert?

Serielle Dü? Für sowas nehme ich lieber einen ESP mit BLE oder WLAN und 
Websockets. Den kann ich schlafen schicken um Strom zu sparen und 
vermeide komplett die Probleme einer galvanischen Kopplung. Dann kann 
ich auch den Läppi noch woanders verwenden und muss in nicht auf´m Tisch 
stehen lassen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.