Forum: Digitale Signalverarbeitung / DSP / Machine Learning Step-Down-Wandler pfeift sehr laut, was tun?


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von tomtailor (Gast)



Lesenswert?

Hi,

Habe eine eigene Platine zum Betrieb meines Raspberry Compute Module 4 
entworfen. Ich bringe 24VDC auf das system und Wandle es dann auf 5,15V 
mittels einem Step-Down namens "AP63300WU-7". Leider pfeift der 
Step-Down sehr laut und es ist nahezu unaushaltbar, im Umkreis von 
3metern an der Platine zu stehen, da der Lärm so penetrant ist.

Meine Platzverhältnisse auf der Platine sind eher eng, weswegen ich auf 
den oben gennannten Step-Down zurückgegriffen habe, da dieser im 
gegensatz zu einem LM2596 o.ä. schneller taktet und ich somit weniger 
Platz für die LC-Filterung benötige.

Nun zu meinem Problem:
Was könnte dazu führen, dass mein Step-Down so laut pfeift? Gemäss 
Datenblatt ist er für 3A konzipiert, habe aber nur das nackte Compute 
Module und ein kleines Touchscreen welches ca. 0,75W aufnimmt. Wäre es 
denkbar, dass durch die tiefe Belastung der Step-Down zu pfeifen 
beginnt? Oder müsste ich die Ein- oder Ausgangsspannung noch mit 
zusätzlichen KeKo's filtern? Habe versucht, die Designregeln des Step 
downs gemäss Datenblatt zu beachten und wenn ich mit dem Oszilloskop die 
Spannung ansehe, dann ist diese relativ stabil bei 5,15V.

Im Anhang befinden sich Datenblatt und Bilder meiner Schaltung, bin froh 
um eure Hilfe, da ich mich nur begrenzt in diesem Thema auskenne.

Danke im Vorraus

von -gb- (Gast)


Lesenswert?

Deine beiden Layouts unterscheiden sich. Welches verwendest du denn? Die 
Anbindung von Masse sieht im Datenblatt deutlich besser aus.
Welche Schaltfrequenz, welche Spule und welche Kondensatoren verwendest 
du? Die Spule muss den Strom können und die Kondensatoren müssen auch 
bei der Spannung noch die Kapazität haben. Thermals würde ich vermeiden.
Und sonst mal messen mit dem Oszi. Wie sieht die Ausgangsspannung aus? 
Bricht die Eingangsspannung ein?
Ist der LDO dahinter bestückt? Der kann auch schwingen.

von -gb- (Gast)


Lesenswert?

Und wenn das Eagle ist dann lade das mal hoch. Dann mache ich dir einen 
Layoutvorschlag.

von tomtailor (Gast)


Angehängte Dateien:

Lesenswert?

-gb- schrieb:
> Deine beiden Layouts unterscheiden sich. Welches verwendest du
> denn? Die
Sorry, ist dieses mit GND-Plane. Wollte nur das GND-Plane ausblenden für 
bessere Sichtbarkeit meiner Schaltung.

> Anbindung von Masse sieht im Datenblatt deutlich besser aus.
Was genau meinst du damit? Wo hätte diese bei mir besser sein sollen?

> Welche Schaltfrequenz, welche Spule und welche Kondensatoren verwendest
> du? Die Spule muss den Strom können und die Kondensatoren müssen auch
C4,C5,C10 = CL10A226MQ8NRNC(Samsung) = 22uF = 6.3V max. (eher knapp...)
C3 = CL31A107MQHNNNE(Samsung) = 100uF = 6.3V max. (eher knapp...)
C2 = 0402CG470J500NT(FH(风华)) = 47pF = 50V max.
C1 = CL05B104KB54PNC(Samsung) = 100nF = 50V max.
C7-1,C7-3,C7-4,C7-5,C7-6(Samsung) = CL31A106KBHNNNE = 10uF = 50V max.
L2 = 5.6uH = MHCI06030-5R6M-R8(Chilisin Elec) = 5.5A (auch eher knapp 
wegen starken derating?) Im Anhang das Datenblatt


> bei der Spannung noch die Kapazität haben. Thermals würde ich vermeiden.
Was meinst du mit Thermals? meinst du die Vias? sorry für mein Fehlende 
Fachkundigkeit

> Und sonst mal messen mit dem Oszi. Wie sieht die Ausgangsspannung aus?
> Bricht die Eingangsspannung ein?
Werde ich messen.

> Ist der LDO dahinter bestückt? Der kann auch schwingen.
Ist kein LDO sondern eine elektronischer Überstromschutz, damit ich den 
Strom auf ca. 2,5A begrenzt habe.

von tomtailor (Gast)


Lesenswert?

-gb- schrieb:
> Und wenn das Eagle ist dann lade das mal hoch. Dann mache ich dir
> einen
> Layoutvorschlag.

Ne sorry, kein Eagle...

von -gb- (Gast)


Lesenswert?

Keramikkondensatoren mit 6.3V max haben bei 5V nur noch einen eher 
kleinen Teil ihrer Kapazität.
Als Faustregel empfehle ich welche mit mindestens der doppelten Spannung 
zu nehmen. Hier sollten laut Datenblatt am Ausgang 2 x 22uF reichen. 
Aber dann eben mit 16 V Nennspannung.

tomtailor schrieb:
> Was genau meinst du damit? Wo hätte diese bei mir besser sein sollen?

Naja im Datenblatt sind deutlich mehr Vias gezeichnet. Und dann fließt 
ja immer der Strom auf der Masse zurück. Da sollten also beide 
Versorgungsleitungen schön zur Last gehen.
Und dann zu den Ausgangskondensatoren:
Die sollten im Strompfad liegen damit der Strom an den Anschlüssen der 
Kondensatoren vorbei muss, also über deren Pads fließt. Hier fließt der 
Strom vom Switchpin durch die Spule nach oben im Bild zur Last. Die 
Filterkondensatoren sind aber unten im Bild und so wenig effektiv.

tomtailor schrieb:
> Was meinst du mit Thermals? meinst du die Vias? sorry für mein Fehlende
> Fachkundigkeit

Macht nichts. Thermals ist die Anbindung von Pads über mehrere dünne 
Leitungen. Das lässt sich dann besser löten. Aber wenn man mit Heißluft 
lötet dann kann man Thermals weglassen und die Pads schön flächig 
anbinden.

von Dieter (Gast)


Lesenswert?

-gb- schrieb:
> Keramikkondensatoren mit 6.3V max haben bei 5V nur noch einen eher
> kleinen Teil ihrer Kapazität.

Nicht nur, sondern biegen sich stärker durch als welche mit 50V. Es 
entsteht dabei ein Mix an allen möglichen Oberwellen und vielen 
Seitenbändern, auch hörbaren.

Als Drossel empfiehlt sich mehr an Induktivität zu wählen, weil bei 
Tastverhältnissen von rund 25% oder weniger  (5,2V/24V=21,x%) läuft die 
Regelung schmutzloser. Sowas wie, MHCC10040-8R2M-R7 um bei Deiner pdf zu 
bleiben.

von tomtailor (Gast)


Lesenswert?

Danke für die Antworten. Welche Step-Downs hast du denn jeweils so 
verwendet? Möchte auf eine relativ exakte Spannung wandeln und mein 
verwendeter Step-Down hat 1% toleranz und ca. 0.1V spannungseinbruch von 
0...2A.

Das Problem tritt interessantweise viel Stärker in meiner Schule auf, 
zuhause hingegen viel weniger. Kann es sein, dass die Störungen vom 
Netz/Netzteil kommen? Die Schule ist ein altes Industriegebäude. Habe 
dort auch ein leicht anderes Netzteil zum testen genommen

von -gb- (Gast)


Lesenswert?

Ja das mit der mechanischen Verfolgung stimmt.
Vielleicht auch die Lötstellen nochmal angucken ob die auch schön 
flächig festgelötet sind. Bei SMD wird manchmal nur der Rand gelötet 
wenn man nicht lange genug heiß macht oder zu wenig Flussmittel 
verwendet. Dann ist das Zinn eher wie Fugensilikon nur am Rand aussen 
rum aber nicht drunter geflossen. Ob da gut gelötet war sieht man wenn 
man das Bauteil abreißt. Aber das will man vermutlich nicht tun beim 
Einzelstück.

Bei der Induktivität würde ich am Datenblatt bleiben.

von -gb- (Gast)


Lesenswert?

Liefert dein Netzteil genug Strom? Bricht die Eingangsspannung ein? Ist 
auf der Eingangsspannung ein großer Ripple? Kannst du messen.

Ja ich verwende schon auch Schaltregler aber eigentlich muss ich immer 
von 5 V runter auf 1.0 V oder 1.8 V oder so. Ich tendiere zu hohen 
Schaltfrequenzen und kleinen Bauteilen. Da bekommt man die Stromschleife 
schön kompakt gelayoutet. Und ich halte mich möglichst 1:1 ans Layout 
und die Bauteile im Datenblatt/Evalboard. Bin damit bisher gut gefahren.

von Interessierter (Gast)


Lesenswert?

Wozu dient denn R2?

von -gb- (Gast)


Lesenswert?

Stimmt, der kann weg (aber nicht auslöten sondern brücken) aber ich 
glaube nicht, dass der stört.

von tomtailor (Gast)


Lesenswert?

Habe eine neue Erkenntnis erlangt:
Dimme mit meiner Platine ein LED-Band, welches an der 24V 
versorgungsspannung hängt. Dies ist der Grund, weshalb das pfeifen in 
meinem Testaufbau in meiner Schule viel stärker war als zuhause, da ich 
dort auch mehr LED-Band verwendet habe. Denke also, dass die Störungen 
vom 24VDC-Netz kommen. Werde mal ein wenig rummessen und wäre dann froh 
um mögliche Behebung für das Problem. Habe mal von Gleich- und 
Gegentaktstörungen gehört, passt eines dieser Stichworte zu meinem 
genannten Problem?
Danke

von -gb- (Gast)


Lesenswert?

Moment, das LEDBand will 24 V und du gibst dem dann 5 V? Sind das denn 
LEDs die man so dimmen kann?

Naja erstmal messen mit dem Oszi, gerne auch hier Bilder posten so mit 
Skala von Oszi. Und dann gucken wir was das Problem ist. Die 
Eingangsspannung sollte schön glatt sein.

von tomtailor (Gast)


Lesenswert?

-gb- schrieb:
> Moment, das LEDBand will 24 V und du gibst dem dann 5 V? Sind das
> denn
> LEDs die man so dimmen kann?
>
> Naja erstmal messen mit dem Oszi, gerne auch hier Bilder posten so mit
> Skala von Oszi. Und dann gucken wir was das Problem ist. Die
> Eingangsspannung sollte schön glatt sein.

Nein, betreibe das LED-Band mit 24V, steuere es über meinen Raspberry 
mittels PWM-Signal an. Der Step-Down pfeift bei ca. 50% dutycycle am 
stärksten. Wenn ich das LED-Band zuschalte und dimme, dann ist die 
welligkeit der 24V deutlich stärker. Habe zwei Fotos angehängt: 1x mit 
dimmen und 1x ohne.

P.S. habe den 0-Punkt des Oszilloskop unter den sichtbaren bereich 
geschoben damit ich bei den 24V weiter reinzoomen kann. Habe an den 
Kondensatoren C7-1,C7-3,C7-4,C7-5,C7-6 gemessen.

von tomtailor (Gast)


Angehängte Dateien:

Lesenswert?

Hier die Bilder vom 24V

von Dieter (Gast)


Lesenswert?

500us ein Kaestchen oder der Bildschirm?

von -gb- (Gast)


Lesenswert?

tomtailor schrieb:
> Nein, betreibe das LED-Band mit 24V, steuere es über meinen Raspberry
> mittels PWM-Signal an. Der Step-Down pfeift bei ca. 50% dutycycle am
> stärksten.

Was hängt dann am Stepdown wenn es nicht die LEDs sind?

von tomtailor (Gast)


Lesenswert?

tomtailor schrieb:
> Hier die Bilder vom 24V

Habe aus Jux mal einen 100uF @63V Supercap vor den Spannungswandler 
gesetzt. Das pfeifen ist nahezu verschwunden:) Ist das die "saubere" 
art, das Problem zu beheben? also einen grösseren Kondensator 
davorzusetzen? Oder muss ich da was spezielles beachten?

von -gb- (Gast)


Lesenswert?

Ok, also 24 V gehen zu den LEDs und zum Stepdown und vom Stepdown geht 
das zum Raspberry Modul. Und von dort geht etwas zu den LEDs?
Und wie ist die Masse von dem Raspberry und die (Minuspol) von den LEDs 
angeschlossen? Fließt da vielleicht ein Strom zwischen Raspberry Modul 
und LEDs?

von Gustl B. (gustl_b)


Lesenswert?

tomtailor schrieb:
> Habe aus Jux mal einen 100uF @63V Supercap vor den Spannungswandler
> gesetzt.

Naja für einen Supercap ist das eher klein. Aber ja das passt schon so. 
Vor allem hat ein Elko eine höhere ESR, das kann da vorteilhaft sein. 
Kannst auch noch einen zweiten dazutun. Der Ripple auf dem 24 V sollte 
dadurch auch deutlich kleiner geworden sein.

von Mark S. (voltwide)


Lesenswert?

Interessierter schrieb:
> Wozu dient denn R2?

Begrenzung der Ladestromspitzen des Bootstrap caps, würde ich drin 
lassen für störungsarmen Betrieb. Musste ich schon mal in einen step 
down nachträglich ein designen - in der Appnote gabs den nicht. 
Ansonsten, wenn der Regler hörbar pfeift, ist die Regelung instabil und 
Du findest die Pfeiffrequenz als ripple hinter der Speicherdrossel 
wieder.

: Bearbeitet durch User
von Dieter (Gast)


Lesenswert?

tomtailor schrieb:
> Der Step-Down pfeift bei ca. 50% dutycycle am stärksten.

Bei 24 auf 5V duerfte das Taktverhaeltnis nur bei grossen 
Lastleistungsspruengen im us-Bereich auftreten.
22% waere normal und 5% mehr wuerden unter 1ms ein Stromdelta von 2A 
nachregeln.

von tomtailor (Gast)


Lesenswert?

Gustl B. schrieb:
> tomtailor schrieb:
>> Habe aus Jux mal einen 100uF @63V Supercap vor den Spannungswandler
>> gesetzt.
>
> Naja für einen Supercap ist das eher klein. Aber ja das passt schon so.
> Vor allem hat ein Elko eine höhere ESR, das kann da vorteilhaft sein.
> Kannst auch noch einen zweiten dazutun. Der Ripple auf dem 24 V sollte
> dadurch auch deutlich kleiner geworden sein.

Bedeutet besseres ESR = tieferer Innenwiderstand in meinem Fall? Möchte 
den Supercap nur ungern drin lassen, da dieser RIESIG ist. Gehen auch 
10x weitere 10uF KeKo's, von welchen ich schon 5stk. vor dem Step-Down 
verschaltet habe? Oder müssen es ElKo's sein? Oder hat es auch mit der 
Frequenz meiner "rauschenden" eingangsspannung zu tun?

von Dieter (Gast)


Lesenswert?

tomtailor schrieb:
> Oder hat es auch mit der Frequenz meiner "rauschenden" eingangsspannung
> zu tun?

Der Step-Down schwingt dadurch. Die Keramik 4xidentisch schwingt und 
bringt Piezzoeffekte mit ein.

47uF Low ESR sollte auch gehen.

von tomtailor (Gast)


Lesenswert?

Dieter schrieb:
> tomtailor schrieb:
>> Oder hat es auch mit der Frequenz meiner "rauschenden" eingangsspannung
>> zu tun?
>
> Der Step-Down schwingt dadurch. Die Keramik 4xidentisch schwingt und
> bringt Piezzoeffekte mit ein.
>
> 47uF Low ESR sollte auch gehen.

Also meinst du, die Kondensatoren C7-1,C7-3,C7-4,C7-5,C7-6 am Eingang 
vollständig wegzulassen und anstelle ca. 4-5x 47uF Low-ESR nehmen? Oder 
wie genau meinst dus?

von Dieter (Gast)


Lesenswert?

tomtailor schrieb:
> Oder wie genau meinst dus?

Schmeiss mal einen Keramik c7-5 raus und setze einen 47uF Low ESR Elko 
rein.

von tomtailor (Gast)


Lesenswert?

Dieter schrieb:
> tomtailor schrieb:
>> Oder wie genau meinst dus?
>
> Schmeiss mal einen Keramik c7-5 raus und setze einen 47uF Low ESR Elko
> rein.

Werde ich morgen mal machen, werde dann berichten. Wäre es gescheiht, 
auch Ausgangsseitig noch besser zu Filtern? Auch mit ESR-Kondensatoren 
oder anderen?

von Volker (Gast)


Lesenswert?

Du holst die Spannung zum FB an der falschen Stelle, die muss am 
Ausgangs Kondensator abgegriffen werden und nicht an der Spule. Wie 
wurde C2 berechnet?

von Volker (Gast)


Lesenswert?

Am Eingang könnte auch eine Spule gute Dienste  leisten, also C-L-C

von Volker (Gast)


Lesenswert?

Warum nimmst Du für die 5V ganz andere Werte der Feedback Widerstände, 
R3 hat hier 12k  im Datenblatt nehmen die 158k, dasselbe gilt für deinen 
R1. Dein Spannungsteiler ist also viel niederohmiger, somit passt der 
47p Kondensator  natürlich nicht mehr.

von tomtailor (Gast)


Angehängte Dateien:

Lesenswert?

Konnte noch keinen LOW-ESR-Kondensator draufpacken, aber hab mal einen 
220uF ElKo draufgetan und das pfeifen war auch schon deutlich besser. 
Hab noch einen Test mit mehr LED-Bändern gemacht, folglich bricht die 
Spannung um bis zu 1V ein!! Wie kann ich errechnen, wie ich meine 
Kondensatoren dimensionieren muss, damit ich dieses Spannungsloch nahezu 
lückenlos überbrücken kann?

Und wäre es auch Sinnvoll, direkt vor den MOSFET's meiner LED-Strips 
noch 2-3 low ESR-Kondensatoren hinzupacken? War ja jetzt jeweils nur die 
Rede von "direkt vor dem Step-Down", aber die Ursache liegt ja beim 
LED-Band.

von Joachim L. (nixiefan)


Lesenswert?

Probiere mal die frequenzbestimmenden Teile etwas zu verändern. Das 
Pfeifen entsteht durch Resonanzen und aus diesem resonierenden 
Frequenzbereich muss du irgendwie raus.

von Pjotr Phi (Gast)


Lesenswert?

Falls du mit Pfeifenden Wandler die Problematik hinter "Coil whining" 
meinst, du würde hier schon mehr als einmal durchgekaut:

Beitrag "Wieso schreit meine Induktivität bei 500kHz?"
Beitrag "Fiepende Spule im NAS - Mit Kerzenwachs abdichten?"
Beitrag "Spulenfiepen bei neuer Grafikkarte"
...

Wenn da was pfeift, dann schwingt da was mechanisch. Das könnte man auch 
sehen, wenn man scharfe Augen hat.

Dieses 'mechanische' problem würde ich mit 'mechanischen' Massnahmen 
angehen. Vielleicht geht ja das PCB in Resonanz, also nimm andere 
Coil-pads oder versetze die um 90 grad. Vielleicht hilft es den 
Pfeifgenerator mechanisch freizustellen, alsoVias, aussparungen um 
diesen. Kühlkörper drauf verschiebt auch die Resonanzgüte, Frequenz ...

von Old (old_newcomer)


Lesenswert?

Die akustische Quelle des pfeifenden Tones kann man mit einem Stethoskop 
oder statt dessen hilfsweise auch mit einem Stück passendem 
Isolierschlauch im Ohr (nicht das Trommelfell durchbohren) genau 
lokalisieren.

von Scyte R. (scyte)


Lesenswert?

Ich schmeiße noch Mal einen anderen Ansatz in den Raum:
Wenn ich es richtig sehe sind deine Einbrüche in der Spannung ca. 500us 
auseinander.
1/500us=2kHz ist das deine PWM-Frequenz?
Dann ist es kein Wunder, dass es pfeift. Das liegt mitten im Hörbereich.

Also PWM Frequenz erhöhen auf >20khz o.ä. könnten u.U. helfen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.