www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR IO NET Fertigmodul


Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI ertsmal ,
So hab vor ner Woche mir das AVR NET IO Fertigmodul von pollin gekauft. 
Gleich mal angeschlossen um zu schauen ob es geht. Drücke auf connect 
dan läd es so ca 20 sec dan kommt "no connection to AVR IO NET" warum? 
Firmwarupdate hat wunderbar geklappt auch die MAC konnte ich 
schreiben.Wäre echt dankbar wen ihr mir helfen könntet

LG Jürgen

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richtige IP angegeben, kontrolle über Seriell?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hubert G. schrieb:
> Richtige IP angegeben, kontrolle über Seriell?
>
>
>
>
>
>     Beitrag melden | Bearbeiten | Löschen |

die IP von dem ding war schon voreingestellt mit dem Seriellen kabel 
kann ich das firmwareupdate übertragen abe mehr auch nicht

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner sonst ne Antwort bin am verzewifeln.

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal hier vorbei:

http://www.mikrocontroller.net/articles/AVR_Net-IO...

Ich denke die Fuses sind nicht richtig.

Autor: kiar (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
moin,

die IP anpassen an dein Netzwerk.

raik

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kiar schrieb:
> moin,
>
> die IP anpassen an dein Netzwerk.
>
> raik

HI raik danke genau die ip hab ich auch bei dem Prog muss ich die bei 
meinen pc seinen Netztwerk einstellungen auch einragen sry in totaler 
noob

Autor: Martin P....... (billx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin, den jumper zum umstellen zwischen programmiermodus / betrieb hast 
du aber schon richtig gesetzt?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dennis schrieb:
> Schau mal hier vorbei:
>
> http://www.mikrocontroller.net/articles/AVR_Net-IO...
>
> Ich denke die Fuses sind nicht richtig.
>
>
>
>
>
>     Beitrag melden | Bearbeiten | Löschen |

HI Dennis kannst du mir erklären wie ich das mach mit den Fuses da steht 
iwas von nem programm aber welches? Dannke

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin P....... schrieb:
> moin, den jumper zum umstellen zwischen programmiermodus / betrieb hast
> du aber schon richtig gesetzt?

ja also wen ich das firmwareupdate mach muss iches auf progr machen dan 
wieder normal oder ?

Autor: kiar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin Jürgen

wie verbindest Du dein Modul mit deinem Rechner, über Netzwerk oder 
direkt?

wenn Netzwerk dann musst Du Dein Modul an das Netzwerk anpassen, also 
wenn dein Netzwerk 192.168.2.xxx ist musst du dein Modul auch so eine IP 
verpassen, wobei xxx ein freier Platz sein sollte. Wenn direkt, dann 
deine Netzkarte anpassen und ein Crossoverkabel benutzen.

Raik

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kiar schrieb:
> Moin Jürgen
>
> wie verbindest Du dein Modul mit deinem Rechner, über Netzwerk oder
> direkt?
>
> wenn Netzwerk dann musst Du Dein Modul an das Netzwerk anpassen, also
> wenn dein Netzwerk 192.168.2.xxx ist musst du dein Modul auch so eine IP
> verpassen, wobei xxx ein freier Platz sein sollte. Wenn direkt, dann
> deine Netzkarte anpassen und ein Crossoverkabel benutzen.
>
> Raik

 HI Ich betreibe es über Netztwerk wobei ich kein Crossoverkabel habe 
aber eigentlich sollte es auch mit einem seriellenkabel gehen oder ?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So hab mal meine netzwekeinstellungen durchsucht  habe 192.168.2.xx

Autor: kiar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie lautet die IP Adresse des Routers?

Autor: kiar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann ändere deine AVR IP in 192.168.2.90

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kiar schrieb:
> Dann ändere deine AVR IP in 192.168.2.90

dan kommt IP ungültig muss ich den jumper auf prog. machen ?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habs jetzt nomal versucht kein erfolg mann so ein dreck :(

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Jumper auf 'normal' lassen
- Terminalprogramm für serielle Schnittstelle starten
- mit 'getip' aktuelle IP anzeigen lassen
- mit 'setip 192.168.2.90' die IP setzen
Im Netserver Programm kann man die IP nur ändern wenn man schon eine 
Verbindung hat, das ist etwas unschön.
Wenn du XP nutzt solltest du Hyperterminal haben, bei Win7 ist das nicht 
mehr dabei. Es gibt aber jede Menge bessere Alternativen.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> Terminalprogramm für serielle Schnittstelle starten
> - mit 'getip' aktuelle IP anzeigen lassen
> - mit 'setip 192.168.2.90' die IP setzen

?????? WAS FÜR EIN TERMINALPROGRAM

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen schrieb:
> - Jumper auf 'normal' lassen
> - Terminalprogramm für serielle Schnittstelle starten
> - mit 'getip' aktuelle IP anzeigen lassen
> - mit 'setip 192.168.2.90' die IP setzen
> Im Netserver Programm kann man die IP nur ändern wenn man schon eine
> Verbindung hat, das ist etwas unschön.
> Wenn du XP nutzt solltest du Hyperterminal haben, bei Win7 ist das nicht
> mehr dabei. Es gibt aber jede Menge bessere Alternativen.
>
>
>
>
>
>     Beitrag melden | Bearbeiten | Löschen |

ok ich versuch es mal ;D

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MHH iwie klappt des nicht

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beitrag "http://bray.velenje.cx/avr/terminal ist tot - mirror?"
da gibts ein einfaches Terminalprogramm. Richtigen COM Port auswählen, 
Connect Button drücken. Auf 9600 Baud, 8 Data bits, none Parity, 1 Stop, 
none Handshaking einstellen.
Dann unten in das dunkelgraue Eingabefeld klicken und getip und Enter 
eingeben, jetzt muss im mittleren Fenster die Antwort kommen. Wenn das 
klappt die richtige IP mit setip x.x.x.x eingeben.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> Beitrag "http://bray.velenje.cx/avr/terminal ist tot - mirror?"
> da gibts ein einfaches Terminalprogramm. Richtigen COM Port auswählen,
> Connect Button drücken. Auf 9600 Baud, 8 Data bits, none Parity, 1 Stop,
> none Handshaking einstellen.
> Dann unten in das dunkelgraue Eingabefeld klicken und getip und Enter
> eingeben, jetzt muss im mittleren Fenster die Antwort kommen. Wenn das
> klappt die richtige IP mit setip x.x.x.x eingeben.

ok danke bete das es geht :)

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So getip hat geklappt dan hab ich setip 192.168.2.90 eingegeben dan auf 
enter dan kommt NAK COMMAND ist das richtig ?

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nö, NAK heisst 'not acknowledge', nicht verstanden. Nochmal probieren. 
Nach dem setzen der IP muss man den AVR NET IO einmal kurz aus- und 
wieder einschalten damit die neue IP aktiv wird. Aber setip muss erstmal 
mit ACK quittiert werden. Und kontrolliere mit 'getmask' das Subnetz, 
sollte 255.255.255.0 sein. Mit 'setmask' setzen. Siehe Seite 14/15 in 
der Anleitung.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> nö, NAK heisst 'not acknowledge', nicht verstanden. Nochmal probieren.
> Nach dem setzen der IP muss man den AVR NET IO einmal kurz aus- und
> wieder einschalten damit die neue IP aktiv wird. Aber setip muss erstmal
> mit ACK quittiert werden. Und kontrolliere mit 'getmask' das Subnetz,
> sollte 255.255.255.0 sein. Mit 'setmask' setzen. Siehe Seite 14/15 in
> der Anleitung.


MH so ein scheiß da kommt immer das gleich vill liegt es daran das ich 
ein Crossover kabel verwende.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach shceiße was laber ich da des geht ja über COM1

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trotzdem kommt immer NAK COMMAND.

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn die Kommunikation über die serielle schon klappt sieht das doch 
schon gut aus. Hast du zwischen setip und x.x.x.x auch ein Leerzeichen 
eingegeben?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> wenn die Kommunikation über die serielle schon klappt sieht das doch
> schon gut aus. Hast du zwischen setip und x.x.x.x auch ein Leerzeichen
> eingegeben?

JA hab ich ich hab noch ein ATmega644 rumliegen könnte ich die evt 
tauschen ?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen schrieb:
>> wenn die Kommunikation über die serielle schon klappt sieht das doch
>> schon gut aus. Hast du zwischen setip und x.x.x.x auch ein Leerzeichen
>> eingegeben?

es geht !!!!!!!!!!!!!!!!!!!!!! hab einfach ne ip nummer über 100 gemacht 
also

192.268.109
jetzt steht da ACK

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was muss ich jetzt machen?

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was soll das ändern?
welche Antwort kriegst du auf das Kommando 'version' ? Ich habe hier die 
1.03 drin (Auslieferungszustand).
liefert ein 'getadc 1' einen AD-Wert?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> was soll das ändern?
> welche Antwort kriegst du auf das Kommando 'version' ? Ich habe hier die
> 1.03 drin (Auslieferungszustand).
> liefert ein 'getadc 1' einen AD-Wert?
>
>
>
>
>
>     Beitrag melden | Bearbeiten | Löschen |



hab jetzt einfach die ip verwändet 192.168.2.109 jetzt kommt ACK was 
muss ich dan amchen ?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> was soll das ändern?
> welche Antwort kriegst du auf das Kommando 'version' ? Ich habe hier die
> 1.03 drin (Auslieferungszustand).
> liefert ein 'getadc 1' einen AD-Wert?
>
>
>
>
>
>     Beitrag melden | Bearbeiten | Löschen |

ja liefert er 556 kommt dan :D

Autor: JojoS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das mitgelieferte Netserver Programm starten, den länglichen Button am 
rechten Fensterrand drücken damit die Erweiterten Einstellungen 
aufgehen, oben die IP 192.168.2.109 eingeben und den connect Button 
drücken. Dann sollte unter dem Button grün connected erscheinen und die 
AD Werte leben. Dann das Ding wieder einpacken und sich freuen das es 
funktioniert.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JojoS schrieb:
> das mitgelieferte Netserver Programm starten, den länglichen Button am
> rechten Fensterrand drücken damit die Erweiterten Einstellungen
> aufgehen, oben die IP 192.168.2.109 eingeben und den connect Button
> drücken. Dann sollte unter dem Button grün connected erscheinen und die
> AD Werte leben. Dann das Ding wieder einpacken und sich freuen das es
> funktioniert.

DANKE du warst mir echt net große hilfe "LOB" :)

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Ursachen oder Möglichkeiten hat man noch, wenn man mit dem 
Terminalprogramm term20041226.zip nicht mehr auf das Board kommt.
Zum Hintergrund , ein fertig bestücktes und anfangs auch voll 
funktionierendes Net-IO läßt sich nicht mehr ansprechen, weder über LAN 
noch seriell.
Der NW-Chip wird mäßig warm, die Kontoll-LED an der NW-Bu von vorn 
rechts leuchtet (grün), aber kein Zugriff auf das Teil mehr möglich.
Ohne einen ersichtl. Grund, von heute auf morgen, praktisch über Nacht.
Weder dabei an der SV gelassen noch elektrostatisch gefährdet, auch ein 
Wechsel des NW-Chips brachte nichts.
Man hätte noch die Möglichkeit den AVR zu wechseln, aus einem Bausatz, 
nur ob das Sinn macht unter diesen Umständen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.